none
Remote Desktop Connection Fails After Fall Creators Update Installed

    Question

  • I just installed the Fall Creators Update on Windows 10/64 bit, and now Remote Desktop  Connection crashes every time I try to connect to another PC running Windows 10 64 bit (which I haven't updated yet). Moreover, my Surface 3, running Windows 10 (but also not yet updated) can successfully connect to the same target PC.

    To be clear, the connection goes through. But, invariably, within 30 seconds the Remote Desktop Connection app crashes on the machine running the Fall Creators Update.

    Here's the info from event log:

    Faulting application name: mstsc.exe, version: 10.0.16299.15, time stamp: 0x3a40081f
    Faulting module name: ntdll.dll, version: 10.0.16299.15, time stamp: 0x493793ea
    Exception code: 0xc0000409
    Fault offset: 0x0000000000090d5f
    Faulting process id: 0x3748
    Faulting application start time: 0x01d3482264e415dd
    Faulting application path: C:\WINDOWS\system32\mstsc.exe
    Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
    Report Id: dcac4007-90d1-4964-9c64-b33765bfffee
    Faulting package full name: 
    Faulting package-relative application ID: 

    Any workarounds or solutions?

    Wednesday, October 18, 2017 3:10 PM

Answers

  • My workaround is to disable printer redirection in the RDP settings. At least in my case it "solved" the crash problem.
    • Proposed as answer by jphughan Thursday, October 19, 2017 3:17 PM
    • Marked as answer by ChairmanMAO Thursday, October 19, 2017 3:19 PM
    Thursday, October 19, 2017 1:32 PM

All replies

  • I can confirm this behavior on every device in my office with Version 1709 Build 16299.19.

    The Insider Version 1709 Build 17017.1000 does not crash, so we will probably need to wait for that to hit the pipeline.

    To resolve this problem for my clients I used the Recovery options in windows settings to go back to an earlier build of windows.

    Another work around is installing Remote Desktop from the Microsoft Windows App Store. Note that some terminal services like TSPrint won't work with this app.

    • Edited by GCMC IT Wednesday, October 18, 2017 5:14 PM
    Wednesday, October 18, 2017 5:13 PM
  • Thanx for the confirmation. Gotta love it when Microsoft software causes Microsoft software to crash. Makes you wonder how thorough the testing regime is. Or maybe no one in Redmond uses Remote Desktop :)
    Wednesday, October 18, 2017 5:27 PM
  • I am having a similar problem, but with the virtual machine connection.  After 15 - 30 seconds, get message that the virtual machine connection has stopped working.

    Occurs on all computers.


    Jeff Childers

    Wednesday, October 18, 2017 9:25 PM
  • I can confirm this behavior on every device in my office with Version 1709 Build 16299.19.

    The Insider Version 1709 Build 17017.1000 does not crash, so we will probably need to wait for that to hit the pipeline.

    To resolve this problem for my clients I used the Recovery options in windows settings to go back to an earlier build of windows.

    Another work around is installing Remote Desktop from the Microsoft Windows App Store. Note that some terminal services like TSPrint won't work with this app.


    Win10 17017 is Redstone 4, which will be the next major release not due until March, not a future update for Win10 1709.  If it releases on time, it'll be Win10 1803.

    Anyhow, I have this exact issue with VMConnect and RDP, but in the latter case, only when I try to RDP to my VMs, which I tried in the hopes of working around VMConnect being broken.  When I RDP to an actual remote host running Windows Server 2016, RDP is fine -- even though I have a VM running Win10 1607 (same code base) that breaks RDP and VMConnect.

    My thread about this is here: https://social.technet.microsoft.com/Forums/ie/en-US/4a976da1-eb41-49f4-89ff-a12fe3825a45/hyperv-enhanced-sessions-constantly-crash-on-win10-1709-fall-creators-rtm?forum=win10itprovirt

    • Edited by jphughan Wednesday, October 18, 2017 10:39 PM
    Wednesday, October 18, 2017 10:38 PM
  • I am having a similar problem, but with the Application hosting connection.  After 15 - 30 seconds, get message that there is a program default so the connection has stopped working.

    Worked fine before update :(

    Wednesday, October 18, 2017 11:00 PM
  • My workaround is to disable printer redirection in the RDP settings. At least in my case it "solved" the crash problem.
    • Proposed as answer by jphughan Thursday, October 19, 2017 3:17 PM
    • Marked as answer by ChairmanMAO Thursday, October 19, 2017 3:19 PM
    Thursday, October 19, 2017 1:32 PM
  • Same issue in connecting to my server running Server 2012 R2. Will try some of the workarounds listed tomorrow as out of town today. Thanks for your input everyone!
    Thursday, October 19, 2017 2:24 PM
  • My issue with build 1709 is that I cannot log into my servers using the built-in WIndows 10 Remote Desktop app. When I log in it just says that I username and password didn't work. I can log in fine using mstsc.exe.

    Anyone else experiencing this?

    Thursday, October 19, 2017 2:31 PM
  • This worked for me also
    Thursday, October 19, 2017 2:53 PM
  • My issue with build 1709 is that I cannot log into my servers using the built-in WIndows 10 Remote Desktop app. When I log in it just says that I username and password didn't work. I can log in fine using mstsc.exe.

    Anyone else experiencing this?


    MSTSC.exe is the built-in Remote Desktop app.  If you launch the built-in app and start Task Manager, right-click it, and select "Go to details", you'll see the process name listed as MSTSC.  Or have you discovered a behavioral difference based on how the application is launched, e.g. Start menu vs Run command?

    • Edited by jphughan Thursday, October 19, 2017 3:20 PM
    Thursday, October 19, 2017 3:10 PM
  • My workaround is to disable printer redirection in the RDP settings. At least in my case it "solved" the crash problem.

    THANK YOU!  That solved it for me as well, and I never need that anyway.  I wish there were a way to default that to off without having to save all of the other settings for an RDP/VMConnect session, since sometimes I want different display configurations and/or audio redirection settings, but I never ever need printer redirection.  Cheers! :)
    Thursday, October 19, 2017 3:16 PM
  • My workaround is to disable printer redirection in the RDP settings. At least in my case it "solved" the crash problem.
    This worked for me, too. Thanx for sharing, and here's hoping Microsoft gets this fixed soon.
    Thursday, October 19, 2017 3:18 PM
  • My workaround is to disable printer redirection in the RDP settings. At least in my case it "solved" the crash problem.
    Hmm, and that's the most important feature we use. I've got a support request open, we'll see where that goes...

    DG

    Thursday, October 19, 2017 3:57 PM
  • This workaround resolved my issue as well with RDP crashing.
    Thursday, October 19, 2017 4:13 PM
  • For us, we manage and enable RDP and client firewall rules via group policy and the spring/fall creators update "broke" it. I fixed my machine by going in the Windows Defender Firewall with Advanced Security and enabling the three newer Remote Desktop firewall rules:

    Remote Desktop - Shadow (TCP - In)

    Remote Desktop - User Mode (TCP - In)

    Remote Desktop - User Mode (UDP - In)

    Enabling those three on top of the main Remote Desktop (TCP - In) that is always enabled when you turn on RDP fixed it for me.



    Gary Adkins


    • Edited by gdadkins Thursday, October 19, 2017 6:53 PM
    • Proposed as answer by jcarafa Wednesday, October 25, 2017 1:39 AM
    Thursday, October 19, 2017 6:53 PM
  • My workaround is to disable printer redirection in the RDP settings. At least in my case it "solved" the crash problem.

    Hmm, and that's the most important feature we use. I've got a support request open, we'll see where that goes...

    DG


    I figured print redirection would be critical for people in Terminal Server/VDI-type scenarios.  Please update this thread with whatever you hear!
    Thursday, October 19, 2017 6:57 PM
  • For us, we manage and enable RDP and client firewall rules via group policy and the spring/fall creators update "broke" it. I fixed my machine by going in the Windows Defender Firewall with Advanced Security and enabling the three newer Remote Desktop firewall rules:

    Remote Desktop - Shadow (TCP - In)

    Remote Desktop - User Mode (TCP - In)

    Remote Desktop - User Mode (UDP - In)

    Enabling those three on top of the main Remote Desktop (TCP - In) that is always enabled when you turn on RDP fixed it for me.



    Gary Adkins


    Those rules have been there since at least Win10 Anniversary since I see them on my work system that's still running that version, but inability to connect to a system via RDP is a completely separate topic.  This is about the RDP session crashing on the client shortly after connecting to the host.
    Thursday, October 19, 2017 6:59 PM
  • Ok, anyone up for trying to narrow this down further by looking at the printers in use, or more specifically the print drivers in use?  On my system, in addition to the standard Fax, Microsoft Print to PDF, and Microsoft XPS Document Writer printers, I have the following drivers (found under Printer Properties > Advanced):

    Amyuni Document Converter 400 (for a Quicken PDF printer)
    HP LaserJet Pro MFP M225-M226 PCL6
    Adobe PDF Converter (for the Adobe PDF printer built into Acrobat)

    Thursday, October 19, 2017 7:06 PM
  • My workaround is to disable printer redirection in the RDP settings. At least in my case it "solved" the crash problem.

     Worked like a charm, thank you.  I sorta found an odd workaround earlier as well, after many a google.

    I downloaded and installed Microsoft Remote Desktop Connection Manager 2.7. (never heard of it before this morning)

    https://www.microsoft.com/en-ca/download/details.aspx?id=44989

    Setup my remote desktop connections in there, and i could connect no problem(couldn't get the full screen to work properly though, glad i kept this post open)

    Thanks again.

    Thursday, October 19, 2017 10:52 PM
  • Opened a support case

    [REG:117101916518777] RDP with rdgateway broken in Windows 10 1709

    Friday, October 20, 2017 1:29 AM
  • I have the same issue.  I unchecked the Printer resources and I was able to get it to work.

    This is not the only bug; after the installation of 1709 all of a sudden Outlook 2016 does not open any of the links in the emails I receive.  I have run repair of the office and I have run Office Configuration Analyzer Tool 2.2 to no avail.

    Why am I not surprised!? This is absolutely ridiculous and totally absurd.



    Alcompco


    • Edited by AlcompCo Friday, October 20, 2017 1:33 AM
    • Proposed as answer by AlcompCo Friday, October 20, 2017 1:34 AM
    Friday, October 20, 2017 1:32 AM
  • Ok, anyone up for trying to narrow this down further by looking at the printers in use, or more specifically the print drivers in use?  On my system, in addition to the standard Fax, Microsoft Print to PDF, and Microsoft XPS Document Writer printers, I have the following drivers (found under Printer Properties > Advanced):

    Amyuni Document Converter 400 (for a Quicken PDF printer)
    HP LaserJet Pro MFP M225-M226 PCL6
    Adobe PDF Converter (for the Adobe PDF printer built into Acrobat)

    In my clients environment, they have 2 HP printers:

    HP LaserJet 1320
    HP M476

    In my environment where I have no issues, I have only a Xerox. If I was a betting man, my money would be on something to do with the HP drivers... 


    DG

    Friday, October 20, 2017 1:53 AM
  • In my clients environment, they have 2 HP printers:

    HP LaserJet 1320
    HP M476

    In my environment where I have no issues, I have only a Xerox. If I was a betting man, my money would be on something to do with the HP drivers... 


    DG

    Are those printers set up to run the device-specific drivers or the HP Universal Print driver?  If the latter, is it PCL5, PCL6, or PS?
    Friday, October 20, 2017 2:54 AM
  • My issue with build 1709 is that I cannot log into my servers using the built-in WIndows 10 Remote Desktop app. When I log in it just says that I username and password didn't work. I can log in fine using mstsc.exe.

    Anyone else experiencing this?


    MSTSC.exe is the built-in Remote Desktop app.  If you launch the built-in app and start Task Manager, right-click it, and select "Go to details", you'll see the process name listed as MSTSC.  Or have you discovered a behavioral difference based on how the application is launched, e.g. Start menu vs Run command?

    I'm having this problem as well with the Remote Desktop Windows Store app after I upgraded to the Fall Creators Update. Couldn't connect to either another Windows 10 Fall Creators machine or a Windows 8.1 machine, it always says the username or password is wrong. I could connect to a Win 7 machine though. It does work when I use the mstsc.exe app, just not the store app for some reason. I always used to use MachineName\UserName as the format for the username and I've tried a million other combos/variants suggested elsewhere, but nothing works


    • Edited by McChen Friday, October 20, 2017 3:22 AM
    Friday, October 20, 2017 3:20 AM
  • I'm having this problem as well with the Remote Desktop Windows Store app after I upgraded to the Fall Creators Update. Couldn't connect to either another Windows 10 Fall Creators machine or a Windows 8.1 machine, it always says the username or password is wrong. I could connect to a Win 7 machine though. It does work when I use the mstsc.exe app, just not the store app for some reason. I always used to use MachineName\UserName as the format for the username and I've tried a million other combos/variants suggested elsewhere, but nothing works


    Ah ok, I didn't even realize there WAS a "Modern/Metro" version of the RDP app available in the Store.
    Friday, October 20, 2017 3:43 AM
  • I have the same issue with my 1709 build, using the win store RD client, trying to connect to Server 12 R2. It keeps stating that the password or login is incorrect, thus locking my account out of AD after while.

    Friday, October 20, 2017 3:58 PM
  • While I can reproduce both the broken RDP client and the fix, I have tested fully patched Outlook 2016 on multiple Windows 10 Pro build 1709 systems and links in e-mails work fine.  Depending on the system I've had both Edge and Chrome as the default browser and links work just fine.

    That 1709 went to market with this RDP issue is beyond unacceptable.  Anyone taking bets on how long it takes Microsoft to 1) admit it, and 2) issue a fix?  Me, personally and maybe I've just become a skeptic, but I wouldn't count on a Christmas present for this.  Maybe for the spring 2018 update.  Microsoft seems more intent on adding consumer fluff (useless People bar that doesn't support Skype for Business, 3D Paint, VR, unwanted Candy Crush installs, etc...) to Windows Pro rather than enhancing business-class functionality (the ability to remove the Store again, etc...).  It's a shame Windows has turned into a consumer-grade game OS rather than a business tool.


    Sincerely,<br/> Brian Bergin<br/> Terabyte Computers, Inc.<br/> <br/> Information posted by me in these forums is provided &quot;As-Is&quot; with no warranties or rights conferred. Use at your own discretion/risk.<br/>

    Friday, October 20, 2017 4:56 PM
  • Has anyone tested whether this also applies to the closely-related RemoteApp feature?  If so, in that case, printers can be disallowed in the server configuration, to presumably work around it.
    Friday, October 20, 2017 5:19 PM
  • Yes, the 1709 release breaks the RemoteApp Feature as well.  Same ntdll.dll faulting module.

    - We have found that on a couple of machines it is the Quicken PDF Printer (Quicken Deluxe 2014).  If we don't transfer that printer, remote printing still works.

    • Edited by ndonhauser Friday, October 20, 2017 6:43 PM
    Friday, October 20, 2017 6:15 PM
  • I have tested this with a few machines running 1709 16299.19 for me it was defiantly a print driver issue. I removed the offending driver and remote desktop and remoteapp now function correctly without crashing. You must remove the printer then go to administrative tools and then print management. Remove the driver package for the printer and poof all if fine.

    • Edited by Mike Tremmel Saturday, October 21, 2017 12:14 AM
    Friday, October 20, 2017 11:57 PM
  • I have tested this with a few machines running 1709.19 It is defiantly a print driver issue. I removed the offending driver and remote desktop and remoteapp now function correctly without crashing. You must remove the printer then go to administrative tools and then print management. Remove the driver package for the printer and poof all if fine.

    If you reinstall does the issue return?

    DG

    Saturday, October 21, 2017 12:00 AM
  • Can you tell us which driver(s) you are removing?  I'm seeing this with a ton of different remote connections so the issue must be prevalent across many different vendors' printer drivers.

    Sincerely,<br/> Brian Bergin<br/> Terabyte Computers, Inc.<br/> <br/> Information posted by me in these forums is provided &quot;As-Is&quot; with no warranties or rights conferred. Use at your own discretion/risk.<br/>

    Saturday, October 21, 2017 12:02 AM
  • So I have a Xerox and a Brother (Both network printers) on two different Windows 10 Pro computers, and I have no issues. I just added an HP LaserJet M4345 MFP PCL6 driver to my computer on a generic TCP/IP port, it didn't cause a problem, and it did map to the remote server when I connected.

    I'm trying a driver from HP's website (M476) that match the drivers my client is using that has had this issue, the drivers are old, from 2016.. but I cannot recreate the issue. When I install them on my computer, my RDP continues to function normally. I was really hoping for a smoking gun... Definitely now want to know if uninstalling/reinstalling the printer driver resumes the issue or is a fix...


    DG


    Saturday, October 21, 2017 12:28 AM
  • The Print drivers that I have been removing that have been causing the issue were PDF Printers. All of my other devices IE Lexmark C543dn, HP envy and HP officejet 8600's along with multiple savin/ricoh MFP devices have not caused me any issues. It seems to be older drivers that are posing the problem. I haven't had the need to reinstall the drivers that have been causing the issue so I cannot tell you if the problem would return or not. The PDF printer that was causing my issue was ABS PDF Driver v400. I think this is the QuickBooks PDF printer


    • Edited by Mike Tremmel Saturday, October 21, 2017 12:51 AM
    • Proposed as answer by Derek Gabriel Saturday, October 21, 2017 3:12 AM
    Saturday, October 21, 2017 12:40 AM
  • Hmm, I have both Adobe PDF (Acrobat Pro DC, 2017 Release, 2017.012.20098) and Microsoft Print to PDF installed. I also realized I've been logging into the remote system as domain admin, so I tried both a regular domain user account as well as a local machine user account, neither had an issue. I'm a little perturbed I can't recreate the problem. :/

    AHHHHAA my client DOES have QuickBooks Enterprise installed on their machines, so that is very likely the difference here... I will see if I can get them to re-upgrade the machine they downgraded and try removing that driver... 


    DG


    Saturday, October 21, 2017 12:56 AM
  • Just an FYI when I removed the ABS Print Driver QuickBooks no longer was able to send the invoices to outlook. when you have an invoice open and click email invoice if they have QB set to send the pdf to outlook I got an error that said outlook is not responding try opening outlook and try again. I did a repair install of office 2013 and it corrected the problem without having to reinstall the bad driver. QuickBooks Enterprise is installed on our servers and it does indeed install the ABS PDF Printer v400

    • Edited by Mike Tremmel Saturday, October 21, 2017 1:28 AM
    • Proposed as answer by Derek Gabriel Saturday, October 21, 2017 3:12 AM
    Saturday, October 21, 2017 1:17 AM
  • Ding! That's it for my client as well, they have the ABS Print Driver and that's the only difference between our environment. Effin QuickBooks, if I had a dollar for every time they caused a problem.

    DG

    Saturday, October 21, 2017 3:10 AM
  • Intuit's PDF driver is definitely NOT the only driver that's the problem.  Connecting to a Server 2016 box with Microsoft Print to PDF, Microsoft XPS Document Writer, and Send to OneNote 16 as the ONLY printers there it crashes.

    Sincerely,<br/> Brian Bergin<br/> Terabyte Computers, Inc.<br/> <br/> Information posted by me in these forums is provided &quot;As-Is&quot; with no warranties or rights conferred. Use at your own discretion/risk.<br/>

    Saturday, October 21, 2017 3:19 AM
  • Right, that's way too obscure to be the central figure.

    Just to add to the confusion, connecting to Server 2016 with these redirecting: CutePDF Writer, Microsoft Print to PDF, Microsoft XPS Document Writer, and Xerox Phaser 6180MFP-D PS (which is the default).

    And it doesn't crash.

    Saturday, October 21, 2017 3:30 AM
  • Excuse me for not being a pro but I just want to add to the thread to report the related problem.

    My wife's laptop was running 1703 build of Windows 10 HOME. My wife uses the laptop for connecting to her company's network / VM (she works for RBS and uses their my.rbs.com gateway to connect). The connector is a bit obscure piece of software (and I do not really care what this RBS Anywhere 2 thing is) but some of the system prompts suggest it is running on RDP of some sort. After 1709 upgrade the connection fails. I spent last 3 days trying to resolve the problem.

    I have tried the suggested trick with disabling Printer Redirection for RDP. I managed to implement that after messing around in the Windows registry. That trick did NOT help (unless I did not do it in correct way). In the meantime I rolled back 1709 twice. I was going ballistic. In desperation we upgraded to PRO version and finally I managed to defer this update via Group Policy. We are back to 1703 build, the connection works again and 1709 will be deferred for some time (Business Rollout / 365 days). Fingers crossed the correct patch will be released sooner or later.

    Now, a bit off topic, all I did requires some reasonable PC knowledge while, I imagine, many average users may face exactly the same problem while connecting from homes to their employers' VMs. Some have macs, some have old Windows 7 but there will be some of these poor guys with Windows 10 Home who will get stuck in next few days to come without any way out in sight.

    Sunday, October 22, 2017 2:19 PM
  • QuickBooks 2017 abs print driver was the culprit here also. Removed the driver - RDP connection still has printer redirecting enabled and seems to work so far

    Monday, October 23, 2017 2:00 AM
  • I have tried the suggested trick with disabling Printer Redirection for RDP. I managed to implement that after messing around in the Windows registry. That trick did NOT help (unless I did not do it in correct way). In the meantime I rolled back 1709 twice. I was going ballistic. In desperation we upgraded to PRO version and finally I managed to defer this update via Group Policy. We are back to 1703 build, the connection works again and 1709 will be deferred for some time (Business Rollout / 365 days). Fingers crossed the correct patch will be released sooner or later.

    Now, a bit off topic, all I did requires some reasonable PC knowledge while, I imagine, many average users may face exactly the same problem while connecting from homes to their employers' VMs. Some have macs, some have old Windows 7 but there will be some of these poor guys with Windows 10 Home who will get stuck in next few days to come without any way out in sight.

    What registry setting did you change to disable printer redirection?  One other thing you can try is editing the Default.rdp file that is stored in the user's Documents folder (and hidden by default, so enable "Show hidden files").  If you open that file in Notepad, look for the line "redirectprinters:i:1" and change that 1 to a 0.  That will cause RDP sessions NOT launched by starting a saved RDP file to have printer redirection disabled by default, but since I don't know how your wife's solution works, I don't know if that will apply there.

    I agree that not being able to defer updates on Win10 Home is hugely annoying.  Fyi though, after you're on Pro, you don't need to use Group Policy to configure that.  You can just go to Settings > Update & security > Windows Update > Advanced options.  I use Group Policy to block driver installation via Windows Update though, since there's a hugely annoying bug in the current Intel graphics drivers that affects systems that have the HD Graphics 4600 GPU and have Hyper-V installed.  Intel has known about it for a long time and even claims to have fixed internally, but months later they hasn't released a beta build yet -- but that's a whole other story.

    And hey, seeing as you've paid for Pro anyway, you may want to enable BitLocker.
    • Edited by jphughan Monday, October 23, 2017 4:09 AM
    Monday, October 23, 2017 4:06 AM
  • The issue seems to be tied to the RDP Easy Print driver, and how it is handling 3rd party PDF printers.
    So one work around is to disable printer redirection - simply by using the Local Resources panel on the RDP connection settings and unchecking "Printers". But that eliminates redirected printers.

    If you need those printers, here is another workaround:

    First, you need to tell the RDP host not to try to use the Easy Print driver by default. You can do that one of two ways -

    Using gpedit.msc, expand to Computer Configuration - Administrative Templates - Windows Components - Remote Desktop Services - Remote Desktop Session Host - Printer Redirection, then set the policy for "Use remote desktop easy print printer driver first" to DISABLE

    Or you can directly create a value in the registry,

    HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services

    "UseUniversalPrinterDriverFirst" with a reg_dword value 4

    This tells RDP to try to use a locally installed driver first, with the EasyPrint driver being the fallback, rather than the first choice.

    Next, you'll need to add the PDF printer driver to the host. For Quickbooks, you can find that by extracting the installer exe (the full installer), and browsing to the 3rd Party\ABS folder. Run the EXE that is there to install the ABS PDF Driver.

    If you still get the crash, look at the other 3rd party PDF printers installed on the RDP client, and install those on the host. As long as the host as a native driver for them, you won't get the crash.

    (side note, this is the same procedure I've been using to get certain HP Officejet printers to function correctly over RDP)

    • Proposed as answer by Derek Gabriel Monday, October 23, 2017 5:45 PM
    Monday, October 23, 2017 2:35 PM
  • Thank you - we have a true workaround now. :)

    DG

    Monday, October 23, 2017 5:45 PM
  • I had the same issue after installing update 1709 using RDP has become impossible. We have tested several machines with Pro and Home version of Win 10 and it has the same issue.

    when you intend to connect to the remote computer it says connecting but once the window opens in RDP displays this:

    Remote Desktop Connection has stopped working; Hang on while Windows reports the problem to Microsoft...and then it shows a new screen to CLOSE the program.

    As a fix the users now are using RDP app from Windows store but we cant copy and paste from the remote computer to the user's machine. 

    This is the fix that worked for me on both Win 10 Pro and Win 10 Home:

    In the Remote Desktop Connection main screen before you log in to the remote computer click on Show Options/ select Local Resources tab/ Under Local devices and resources I unchecked Printers, I still have Clipboard checked. After this change I was able to connect to the remote computer and stay connected with no issue.

    Monday, October 23, 2017 5:51 PM
  • This worked for me as well
    Monday, October 23, 2017 7:26 PM
  • This worked. Thanks so much Mike and Derek
    Monday, October 23, 2017 7:27 PM
  • What registry setting did you change to disable printer redirection?  One other thing you can try is editing the Default.rdp file that is stored in the user's Documents folder (and hidden by default, so enable "Show hidden files").  If you open that file in Notepad, look for the line "redirectprinters:i:1" and change that 1 to a 0.  That will cause RDP sessions NOT launched by starting a saved RDP file to have printer redirection disabled by default, but since I don't know how your wife's solution works, I don't know if that will apply there.

    Since I managed to defer the upgrade the urgency has passed. But since I posted here I feel I need to reply to your kind response.

    I would not jump to deal with RDP if not forced to do so by the problem we faced. So in state on near panic I searched the web for means of disabling this printer redirection (as other commentators missed to state how to do that possibly assuming it is pretty obvious for the audience). I found some information about adding the registry key that would achieve exactly that.

    I added the key :

    DisablePrinterRedirection

    set to :

    1

    to :

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Terminal Server Client

    The effect of doing that is that when RDP is explicitely launched, the dialog box has printer redirection unticked and greyed out. I honestly believed that was the possible way of "disabling printer redirection". And as I wrote before that fix did NOT work for me as the problem persisted. Though luck. Only then I decided to upgrade to PRO in order to defer the 1709 update.

    PS

    For completness, we have the following printers and scanners installed on the laptop :

    Brother HL-4150CDN series Printer

    Fax

    Microsoft Print to PDF

    Microsoft XPS Document Writer

    Send To OneNote 2013

    • Edited by August Gustaw Monday, October 23, 2017 7:56 PM to add further details
    Monday, October 23, 2017 7:35 PM
  • Workarounds are great, but let's all remember this worked PERFECTLY and WITHOUT issue until 1709 so while removing one or more print drivers may fix it, it also cripples apps that need the driver (QuickBooks must have their own PDF driver to e-mail invoices, statements, quotes, etc...).  We all need to continue the pressure on Microsoft to issue a fix for this ASAP.  Not weeks or months, but days.  

    There's simply no excuse that 1709's RDP wasn't properly vetted against some of the most popular applications and printer drivers out there.



    Sincerely,<br/> Brian Bergin<br/> Terabyte Computers, Inc.<br/> <br/> Information posted by me in these forums is provided &quot;As-Is&quot; with no warranties or rights conferred. Use at your own discretion/risk.<br/>

    Tuesday, October 24, 2017 4:00 PM
  • The "fix" worked for me on 2 computers with 1709 upgraded in the last week... mstsc.exe worked before 1709 without issue. Thanks! It sounds like no one uses MSTSC.exe at microsoft - hopefully it gets fixed soon... 

    I wish the UWP app would be updated to support multi window and other functions of the built in app... I would switch then... 

    • Edited by MicroSest Tuesday, October 24, 2017 6:23 PM
    Tuesday, October 24, 2017 6:22 PM
  • For us, we manage and enable RDP and client firewall rules via group policy and the spring/fall creators update "broke" it. I fixed my machine by going in the Windows Defender Firewall with Advanced Security and enabling the three newer Remote Desktop firewall rules:

    Remote Desktop - Shadow (TCP - In)

    Remote Desktop - User Mode (TCP - In)

    Remote Desktop - User Mode (UDP - In)

    Enabling those three on top of the main Remote Desktop (TCP - In) that is always enabled when you turn on RDP fixed it for me.



    Gary Adkins



    This worked for me, thanks! I also noticed the update cleared the IP Scope Settings I had in Windows Firewall as well.
    Wednesday, October 25, 2017 1:42 AM
  • I'm having this problem as well with the Remote Desktop Windows Store app after I upgraded to the Fall Creators Update. Couldn't connect to either another Windows 10 Fall Creators machine or a Windows 8.1 machine, it always says the username or password is wrong. I could connect to a Win 7 machine though. It does work when I use the mstsc.exe app, just not the store app for some reason. I always used to use MachineName\UserName as the format for the username and I've tried a million other combos/variants suggested elsewhere, but nothing works


    Ah ok, I didn't even realize there WAS a "Modern/Metro" version of the RDP app available in the Store.
    if anyone is having this issue, Microsoft has found the problem and is working on a fix. There is a workaround for it for now. The problem is with using the enter key to connect after inputting the username/password. That will always generate a wrong username/password message. The workaround is to use the mouse to click the connect button instead. This only affects the UWP app, the classic mstsc.exe app is not affected.
    Thursday, October 26, 2017 8:08 AM
  • I'm having this problem as well with the Remote Desktop Windows Store app after I upgraded to the Fall Creators Update. Couldn't connect to either another Windows 10 Fall Creators machine or a Windows 8.1 machine, it always says the username or password is wrong. I could connect to a Win 7 machine though. It does work when I use the mstsc.exe app, just not the store app for some reason. I always used to use MachineName\UserName as the format for the username and I've tried a million other combos/variants suggested elsewhere, but nothing works

    if anyone is having this issue, Microsoft has found the problem and is working on a fix. There is a workaround for it for now. The problem is with using the enter key to connect after inputting the username/password. That will always generate a wrong username/password message. The workaround is to use the mouse to click the connect button instead. This only affects the UWP app, the classic mstsc.exe app is not affected.
    Glad that a fix is coming for that UWP app issue and all, but I really don't even know where to begin with the fact that pressing the Enter key rather than clicking Connect results in different and problematic behavior, and that this too made it into a final release unnoticed.

    This issue and the original topic of this thread are incidentally emblematic of a concern I've had for a while, namely that the relative ease of deploying patches these days has led developers not to bother getting it right in the first place.  That's true across multiple industries, but the fact that Microsoft has now officially moved to a planned 6-month cadence for major Windows 10 releases only amplifies this concern, since I really worry that the norm will be that issues "will be fixed as part of the next release, which is only a few months away" rather than being fixed the current release promptly, or ever.  But since new releases are always going to have new features as well, and the bugs that come with them, I think we may well end up in a state of affairs where NO release ever really works the way it's supposed to.  Bugs will creep in, they won't get fixed until the next release (if then), but that release turns out to introduce several NEW frustrations, so rather than ever having a properly stable platform, you'll just constantly be trading one set of aggravations for another.

    I hope you prove me wrong, Microsoft...

    • Edited by jphughan Thursday, October 26, 2017 6:52 PM
    Thursday, October 26, 2017 6:34 PM
  • I was able to fix my issue with the remote desktop connection failure by deleting the ABS PDF Driver on the affected computer that had QuickBooks on it.  I own a HP pagewide 377 MPF printer and tried to uninstall and reinstall the printer drivers, but the problem continued.  Obviously that was not the problem driver.  With the removal of the ABS PDF driver, remote desktop worked as before the fall creators update.  By the way further investigation about this  ABS PDF driver I found numerous issues with it, especially with the earlier versions of quickbooks.  It may not be needed as quickbooks would use the Microsoft PDF drivers instead if the ABS PDF driver was not available.  This was tested by others, not me, so something to keep in mind.  Thanks to all for your help!    
    Sunday, October 29, 2017 11:47 PM
  • I had the same issue, disabling print forwarding resolved it for me too. 
    Wednesday, November 1, 2017 5:06 PM
  • Thanks for finding that.
    Wednesday, November 1, 2017 5:06 PM
  • Uninstalling the ABS driver fixed it for a friend that I helped. Thanks SSBR!

    How did you figure that out?



    • Edited by Yisroel Tech Thursday, November 2, 2017 10:50 PM
    Thursday, November 2, 2017 10:48 PM
  • Working with a client we discovered changing version settings of the ABS PDF driver from 400 to 450 solves the problem.

    FWIW, according to this article, the ABS driver is no longer used directly by QuickBooks after 2013. It remains for only the Business Plan Tool subcomponent, and kept for legacy compatibility. It should be safe to remove the ABS driver and still get PDF output from QuickBooks.


    DG

    Thursday, November 2, 2017 11:16 PM
  • I have the same issue, I cannot stay connected to my Windows 8.1 Virtual machine (I need it to access PhotoDraw 2.0 files, no Program other than PhotoDraw can access them!) and I am trying to figure out how to fix it. The VM keeps running, it's just the VM Connection that fails in about 10 to 25 seconds or so. Everything worked fine BEFORE the update. Sigh.

    I see that "disabling Printer Redirection" solves it ... just haven't found out how to do that yet.

    I run Windows 10, with a VM Windows 8.1. Thanks for the help!

    Friday, November 3, 2017 6:53 PM
  • ok, finally found the instructions below on using qpedit.msc, and it worked great! Thank you very much!
    Friday, November 3, 2017 7:04 PM
  • disabling the printer worked for me also

    thank you

    Sunday, November 5, 2017 3:10 PM
  • A thread that you are following on Microsoft Partner Support Community has received a reply from Tommy Xing.

    Reply:

    Hi Brian,

     

    According to the message I get from the product team, the fix will be release on 11D, which should be around the end of November. At the same time, we are pushing product team to see if it can be released earlier.

    Sunday, November 5, 2017 11:51 PM
  • All of our 1709 builds have issues with drive redirection as well. Disabling isn't an option in our environment as most of our remote employees use RDS and print or save locally. I've found creating a mstsc.exe /admin shortcut with the RDS information pre-populated works but is a pain.
    Wednesday, November 8, 2017 5:47 PM
  • Disabling printers worked for me, but I can't do that for the bulk of the users, postponing 1709 at least until the next round of updates. Have to wait and see if Microsoft has gotten the message that they demolished a perfectly fine feature part of the daily business process with no apparent concern. 
    Thursday, November 9, 2017 6:57 PM
  • Remote Desktop crashes after upgrade to Windows 10 Fall Creators Update version 1709 (OS Build 16299.19), Disable printer redirection in the RDP setting didn't work but update graphics card driver fixed the issue for me.

    Tuesday, November 14, 2017 12:23 PM
  • Just installed the monthly update, bringing my Windows 1709 build to 16299.64, and this problem persists....
    Tuesday, November 14, 2017 8:50 PM
  • Yup, wasn't fixed.
    Tuesday, November 14, 2017 8:58 PM
  • For us, we manage and enable RDP and client firewall rules via group policy and the spring/fall creators update "broke" it. I fixed my machine by going in the Windows Defender Firewall with Advanced Security and enabling the three newer Remote Desktop firewall rules:

    Remote Desktop - Shadow (TCP - In)

    Remote Desktop - User Mode (TCP - In)

    Remote Desktop - User Mode (UDP - In)

    Enabling those three on top of the main Remote Desktop (TCP - In) that is always enabled when you turn on RDP fixed it for me.



    Gary Adkins


    Thanks!  Had some new Windows 10 machines that I was inexplicably unable to RDP into from another local PC.  Your tip fixed that for me.

    FYI I only needed to do one of those - "Remote Desktop - User Mode (TCP-In)" - and I set it to "Domain" and "Private" only (not "Public").  That worked in my case.  Thanks!  :-)

    Thursday, November 16, 2017 4:16 PM
  • You've got be kidding me. First, thank you, you saved me some time, disabling printer redirection worked.

    That's a great statement... "when Microsoft updates its software and breaks its software..." Wow.

    First, had a few minutes to login this morning, get on our RD server to do deposits in QuickBooks, and get to the bank before it closed. Login to PC, greeted by Microsoft “we’ve got some updates for your PC.” Nice, thank you. “This is gonna take a while.” Love the honesty. Well, after a while I get in. Fire up RDP to connect, login, BANG “Remote Desktop Connection has stopped working.” Rub my eyes, try again, same thing – seriously? Three times a charm… now I know there’s a problem and a quick Google search gives me comfort knowing I’m not alone after reading this thread.

    Great, no idea how I’ll print checks until Microsoft fixes their crap.

    For the love of… something else non-Microsoft, when will someone with a crap ton of money step up and sue them? Is it worth complaining to the consumer protection agencies? The FTC? I mean, as an IT service provider we deal with update related issues now on a weekly basis. It is costing businesses money to have pay to fix them, and it is diminishing productivity. For our clients on a service agreement, it costs us money to dealing with this crap.  Collectively that has to be a large enough price tag to get someone’s attention.

    Saturday, November 18, 2017 4:26 PM
  • It works most of the time here,
    but it takes atleast 30 seconds to connect,
    it took less than 1 second before fall creators update.

    Sunday, November 19, 2017 9:17 PM
  • I had ths same error. and your workarround has solved it!
    Tuesday, November 28, 2017 1:45 PM
  • Thank you - that option worked for me too!

    Kudos :-)

    Tuesday, November 28, 2017 7:46 PM
  • Have the exact same issue with a user that upgraded to Windows 10 version 1709 (from version 1703) this morning.  We run a Remote Desktop Web App site (on two servers, running Sever 2012 and Server 2012 R2), and this user mostly runs Dynamics GP in through the Remote App site.  After the update, it would crash within a few seconds of running Dynamics GP (same exact error message that ChairmanMAO posted, minus the process id, start time, and report id values, which I'm sure would vary for each error instance).

    Rolling back to version 1703 fixed this issue for us.  I didn't get to try to other suggested solutions here first.  I guess I can if we have the same issue after upgrading again - specifically removing the Windows Store version of the Remote Desktop app, as perhaps this is what is causing the issue.  Interestingly, we have another laptop with 1709 installed on it, and it does not present with this issue.

    The recommendation to disable printer redirection does not work in this method, because users are launching the apps via the Remote App website, so they do not have the opportunity to select what is and isn't mapped to the remote server.

    Thursday, November 30, 2017 5:49 PM
  • I am happy to report that KB4051963 fixed our rdt remote printing problem on a win10 system we set up 2 weeks ago, we had it at 1709(16299.64) and could not use it in the field because of that.  

    It is now at 1709 16299.98 and remote printing works


    Eric

    Friday, December 1, 2017 6:50 PM
  • Removing the ABS PDF driver fixed it for my client's W10 Fall update computers connecting to the their Server 2012 R2. All remote users use QB Enterprise and can still print remotely and send invoices via email.
    Friday, December 8, 2017 1:21 AM
  • running windows 10 enterprise and after 2017 upgrade i could not connect to RDP on a non-default port which worked before. none of the comments above help. including some morons method to just "disable printer redirection"

    fix:

    control panel (old style) -> window firewall -> disable or add the remote desktop rules in for default or set for port being used. I have symantec endpoint, so i have no idea why this crappy windows firewall would trump that after this upgrade.

    Thursday, December 21, 2017 11:29 PM
  • I agree, re: printer redirection, it is a critical component for my users.  We are down the road a bit, and in build 1803 - the remote desktop (mstscax) was working just fine until the Cumulative Update which installed on my users on 6/12/18, at which point the built in rdp app quit working, just gave an error that the activex control didn't match the client shell.

    I tried using the Microsoft store app but since it doesn't support tsprint, it was kind of useless.  

    I ended up uninstalling the security update KB4284835, and this resolved the problem.  Unfortunately, I don't know how long I can suppress it, and it also didn't break on one of the machines that had the update.

    Ironically, I am running rdp on these machines because of another horrendous Microsoft screwup of RDWEB Access, another result of an untested Windows 10 update.  Seems like every time I try to fix one of Microsoft's screwups, they break something else.

    Thursday, June 14, 2018 8:38 PM
  • how in gods name do you idiots mange to screw up windows rdp? its 2018 and you cant keep shit working thats been in windows how long?
    Sunday, June 17, 2018 11:29 PM
  • My workaround was to disable forwarding remote sound to local (do not play).  Seems one of my third-party sound drivers is causing a problem.  Found this solution here: http://www.fixedbyvonnie.com/2014/12/fixed-remote-desktop-connection-stopped-working-error-windows-8-1/
    Thursday, September 13, 2018 1:50 PM