none
Printer cannot communicate

    Question

  • I have a Lexmark X7550 which has the capabilities of running hardwired or wireless. I had it successfully running with Vista32 Ultimate on both hardwired & wirelesss network. recently I installed W-7 and since the printer installs, appears to have no errors nor issues after running troubleshooting, but in fact when trying to print it pops up with system cannot communicate with printer. This has happened in either wirelesss or hardwired setup. I have attempted several times to ensure that the wiring, settings, protocols, etc are all working and correct but still nothing. even tried multiple resets of both pc and printer with clean installs and still the same. I have searched several forums and Lexmark site for driver concerns and nothing appears to stand out. Any ideas?
    Tuesday, June 02, 2009 5:07 AM

Answers

  • It seems that the latest Lexmark X7550 driver that is for Windows Vista is not compatible with Windows 7 RC. Let's see if X7550 other users have this problem. If so, we may need to wait for Lexmark to release new driver.
    Arthur Xie - MSFT
    Wednesday, June 03, 2009 9:03 AM
    Moderator

All replies

  • I am experiencing almost the exact same problem with the Lexmark x7675.    My computer sees the printer on the connection and even loads the drivers, but when I go to print I get the same error as you (that essentially the printer cannot be found).    I have a MAC laptop sitting right next to my Win 7 and it sees and prints to the printer wirelessly with no problem so it is not a networking issue.
    Ron P. CISA, CISSP, CISM, CGEIT
    Tuesday, June 02, 2009 6:28 AM
  • It seems that the latest Lexmark X7550 driver that is for Windows Vista is not compatible with Windows 7 RC. Let's see if X7550 other users have this problem. If so, we may need to wait for Lexmark to release new driver.
    Arthur Xie - MSFT
    Wednesday, June 03, 2009 9:03 AM
    Moderator
  • Has there been any fix on this issue, I just bought a lexmark x7675, and the error I am getting is "need .NET Framework version 2.0", etc. etc., but when I have attempted 17,000 ways and times I have not been able to fix this issue, either i will get "this program is installed as part of the operating system" or "not compatible with this version of windows"

    Please help in any way,  Thank you..........
    Thursday, July 23, 2009 12:24 AM
  • Has there been any fix on this issue, I just bought a lexmark x7675, and the error I am getting is "need .NET Framework version 2.0", etc. etc., but when I have attempted 17,000 ways and times I have not been able to fix this issue, either i will get "this program is installed as part of the operating system" or "not compatible with this version of windows"

    Please help in any way,  Thank you..........
    Thursday, July 23, 2009 12:24 AM
  • I had the same problem but I have a dell. I did get my dell 968w all in one going after about two hours . (The reason I will have you restart windows every time you change setting  is it seem that windows 7 will use the same setting when you try to reinstall software or reconnect devices if not rebooted.

    This how I fix it,

    1. Downloaded Vista drivers or Windows 7 (64) or (32) for your OS from the manufacture .

    2. Turn off printer and disconnect USB port from your computer .

    3. restart Windows 7.

    4.  Go to  uninstall a programs and uninstall all printer software and if you were like me, fax and scanner software  and  restart Windows.

    6. Set up  devices and printers link  (you can set this up by right click on task bar then properties then start menu then customize,  go thru the list and check it) then it will show up on the right below control panel link)

    7.  After clicking on devices and printers it will open a folder all you printer and devices.  right chick on your printer icon and remove device do this for all your printer and fax's and  restart Windows

    8. Check and make sure all software and devices are uninstall.

    9.  Turn on printer

    10. Reconnect USB port for printer (one at a time) let windows find printer and install drivers on my computer after windows was completed loading drivers  a message box popup and said that I could load additional software from manufacture if needed.  Then I checked to see if printer was working  and it did so I rebooted again  then load my fax and scanner software I  download from manufacture.

    I hope this works for you Dude58

    Friday, July 24, 2009 2:08 AM
  • Hi,

    Even I was facing this issue, after the motherboard was replaced on Dell Insp D530, while using the Dell Printer V313, this error message started to come up.

    After I followed the above mentioned steps, I was able to resolve the issue and got my printer to work again!

    Thank You

    Sam G

    Monday, June 13, 2011 10:37 PM
  • The model number Lexmark X7550 does not seem to be correct.

    Method 1:
    You may refer to the below links and use the troubleshooters. Check if it lists and helps resolve any issues: Open the Printer troubleshooter:
    http://support.lexmark.com

    Method 2:
    You may check if you have the latest drivers installed for the device. You may refer to the below link for getting the latest drivers and check
    Lexmark X7550 Driver

    Good Luck.

    Thursday, March 01, 2012 7:27 AM