none
.net framework 3.5 installation fails w/ error code: 0x800F0954 RRS feed

  • Question

  • Title. Downloads for about 2 seconds then fails. Tried the DISM command

    Dism /online /enable-feature /featurename:NetFX3 /All /Source:D:\sources\sxs

    Get the same error code.

    Windows 10 1709


    • Edited by CFFraser Friday, December 8, 2017 8:16 PM
    Friday, December 8, 2017 8:15 PM

Answers

  • Title. Downloads for about 2 seconds then fails. Tried the DISM command

    Dism /online /enable-feature /featurename:NetFX3 /All /Source:D:\sources\sxs

    Get the same error code.

    Windows 10 1709


    Used the powershell command

    Add-WindowsCapability –Online -Name NetFx3~~~~ –Source D:\sources\sxs
    which worked.

    • Marked as answer by CFFraser Friday, December 8, 2017 8:37 PM
    Friday, December 8, 2017 8:37 PM

All replies

  • Title. Downloads for about 2 seconds then fails. Tried the DISM command

    Dism /online /enable-feature /featurename:NetFX3 /All /Source:D:\sources\sxs

    Get the same error code.

    Windows 10 1709


    Used the powershell command

    Add-WindowsCapability –Online -Name NetFx3~~~~ –Source D:\sources\sxs
    which worked.

    • Marked as answer by CFFraser Friday, December 8, 2017 8:37 PM
    Friday, December 8, 2017 8:37 PM
  • Hi CFFraser,

    Adding features (including .NET 3.5) to Windows 10

    DISM.EXE /Online /Get-Capabilities

    Get-WindowsCapability -Online

    https://blogs.technet.microsoft.com/mniehaus/2015/08/31/adding-features-including-net-3-5-to-windows-10/

    Glad to hear that you have solved it and thank you for sharing it here, it will be helpful to other community members who have same questions.

    Regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Eric0502 Thursday, December 14, 2017 12:40 PM
    Monday, December 11, 2017 6:57 AM
    Moderator
  • I get the same error in the Powershell window (running as admin):

    PS C:\Windows\system32> Add-WindowsCapability –Online -Name NetFx3~~~~ –Source D:\sources\sxs
    Add-WindowsCapability : Add-WindowsCapability failed. Error code = 0x800f0954
    At line:1 char:1
    + Add-WindowsCapability –Online -Name NetFx3~~~~ –Source D:\sources\sxs
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Add-WindowsCapability], COMException
        + FullyQualifiedErrorId : Microsoft.Dism.Commands.AddWindowsCapabilityCommand

    I also tried inserting the original Windows 10 DVD, which is the R: drive, and changed the D: to R: in the command above. Same result.

    Any further suggestions?


    Colin


    • Edited by GraniteStateColin Friday, January 19, 2018 1:16 PM added info about also trying from DVD
    • Proposed as answer by Joaquin H Monday, January 22, 2018 6:06 PM
    Friday, January 19, 2018 1:11 PM
  • For me, the solution was to use the full name of the source file, instead of just the path. Not sure why that was needed, but I had found a post that suggested it (don't recall where now, sorry), tried it, and sure enough it solved my problem with very similar symptoms:

    Instead of using this (which did not work for me): Dism /online /enable-feature /featurename:NetFX3 /All /Source:R:\sources\sxs

    I used this, which did work for me: dism /online /add-package /packagepath:R:\sources\sxs\microsoft-windows-netfx3-ondemand-package.cab

    Where R is the drive letter for my Blu-Ray/DVD-ROM drive. Prior to finding the solution, I had tried many variants on the command, which all failed, because Windows couldn't find the source file. I believe the key difference is inclusion of the filename, not the other differences from the command above.


    Colin



    Monday, January 22, 2018 7:41 PM
  • Is the source correct?

    DISM /Online /Enable-Feature /FeatureName:NetFx3 /All /LimitAccess /Source:"d:\sources\sxs"

    • Edited by JoseEspitia Monday, January 22, 2018 7:55 PM
    Monday, January 22, 2018 7:54 PM
  • The "Add-WindowsCapability" command worked for me.

    Thank you :-)


    Stephane

    Monday, February 5, 2018 12:24 AM
  • Hi,

    I got an answer that worked from another post

    Dism.exe /online /enable-feature /featurename:NetFX3 /source:C:\ /LimitAccess

    Copy first the CAB files from media locally to the root of C:\ drive and 100% success!

    Wednesday, February 14, 2018 5:17 PM
  • You may receive this error when trying to install DotNet (.net) on Windows 10 and you are using a WSUS server. This error may occur of the .net installer is not approved in WSUS.

    As a temporary workaround, change the registry key “UseWUServer” to 0. It is located at:

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU

    After the registry change, restart the Windows Update service. You should be able to install .net at this time. Once done you should change this key back to its original value (or wait and allow Group Policy to do it for you.)

    Source => https://www.westechs.com/error-0x800f0954-when-installing-dot-net-on-windows-10/

    • Proposed as answer by DGooose Monday, March 19, 2018 8:04 PM
    Thursday, February 15, 2018 10:02 AM
  • I solve the problem this way. Thank you.

    Thanks

    Thursday, February 22, 2018 7:38 AM
  • You sir have saved me.

    Ive been having this problem for wel over a year.

    i salute you

    Monday, February 26, 2018 8:29 AM
  • You Sir, are a life saver. This is definitely the perfect fix for me.

    Thank you.

    Tuesday, March 6, 2018 8:05 PM
  • great thanks a lot....
    Wednesday, March 7, 2018 4:26 PM
  • Here's what worked for me. I saw something about CBS in the dism log so I cleaned up CBS logs.

    net stop trustedinstaller

    Delete all files from C:\Windows\Logs\CBS

    net start trustedinstaller

    Then I ran Dism.exe /online /enable-feature /featurename:NetFX3 /source:C:\

    I had already copied the sxs files to the root of C: based on someone else's post here, but it probably would work with the source in other locations.

    Thanks everyone.

    • Proposed as answer by Jamieweeman Tuesday, October 16, 2018 8:13 AM
    Friday, March 9, 2018 3:32 PM
  • That registry worked for me too! Thanks for the fix.

    Thanks,

    Joe B

    Monday, March 12, 2018 3:03 PM
  • This combined with the PS command worked for me :)
    Thursday, March 15, 2018 4:56 PM
  • Thank you so much!!!  This solved the issue for me! 
    Friday, March 16, 2018 4:36 PM
  • You may receive this error when trying to install DotNet (.net) on Windows 10 and you are using a WSUS server. This error may occur of the .net installer is not approved in WSUS.

    As a temporary workaround, change the registry key “UseWUServer” to 0. It is located at:

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU

    After the registry change, restart the Windows Update service. You should be able to install .net at this time. Once done you should change this key back to its original value (or wait and allow Group Policy to do it for you.)

    Source => https://www.westechs.com/error-0x800f0954-when-installing-dot-net-on-windows-10/

    this works for me to turn on .net framework 2&3 on Windows10 64bit, thanks.
    • Proposed as answer by goonerwhelan Wednesday, May 9, 2018 2:22 PM
    Thursday, March 29, 2018 5:32 AM
  • Perfect. thanks. worked
    Thursday, March 29, 2018 9:32 AM
  • Thanks.

    <snip

    Here's what worked for me. I saw something about CBS in the dism log so I cleaned up CBS logs.

    net stop trustedinstaller

    Delete all files from C:\Windows\Logs\CBS

    net start trustedinstaller

    Then I ran Dism.exe /online /enable-feature /featurename:NetFX3 /source:C:\

    I had already copied the sxs files to the root of C: based on someone else's post here, but it probably would work with the source in other locations.

    </snip>

    This worked for me as well.


    Tuesday, April 3, 2018 5:23 AM
  • Hi,

    I got an answer that worked from another post

    Dism.exe /online /enable-feature /featurename:NetFX3 /source:C:\ /LimitAccess

    Copy first the CAB files from media locally to the root of C:\ drive and 100% success!

    i had to copy it to c:/temp or any other folder, because trying to access c: directly was giving me an error, even running cmd as administrator. 
    Wednesday, April 4, 2018 7:57 PM
  • You may receive this error when trying to install DotNet (.net) on Windows 10 and you are using a WSUS server. This error may occur of the .net installer is not approved in WSUS.

    As a temporary workaround, change the registry key “UseWUServer” to 0. It is located at:

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU

    After the registry change, restart the Windows Update service. You should be able to install .net at this time. Once done you should change this key back to its original value (or wait and allow Group Policy to do it for you.)

    Source => https://www.westechs.com/error-0x800f0954-when-installing-dot-net-on-windows-10/

    I tried everything above, and this finally fixed my issue!

    Thanks.

    Friday, May 4, 2018 12:11 PM
  • You may receive this error when trying to install DotNet (.net) on Windows 10 and you are using a WSUS server. This error may occur of the .net installer is not approved in WSUS.

    As a temporary workaround, change the registry key “UseWUServer” to 0. It is located at:

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU

    After the registry change, restart the Windows Update service. You should be able to install .net at this time. Once done you should change this key back to its original value (or wait and allow Group Policy to do it for you.)

    Source => https://www.westechs.com/error-0x800f0954-when-installing-dot-net-on-windows-10/

    Good job!
    Thankssssssssssssssssssssssssssssssss
    Tuesday, May 8, 2018 10:30 AM
  • Like other people trying to get this resolved, I tried the registry change and it worked - THANKYOU!
    Wednesday, May 9, 2018 2:23 PM
  • Thanks Sir... this works for me and my team mates... Windows10 64bit, 
    Thursday, May 10, 2018 4:34 PM
  • One thing I have noticed - If you have the window open that says installation failed when trying to add it through "Turn Windows features on and off" and you try to run the scripts, they will still give the 0x800f0954 error. Closing that window and then rerunning the script worked fine. Guessing it was locking a file that was needed.
    Saturday, May 26, 2018 11:26 AM
  • Thank you @GranteStateColin for this! I kept running the PowerShell commands above and it kept erroring out for me, so I finally came across your fix with using the full name of the source file and it worked! Yaaaaay!  If only I could get those 4 hours of my life back.

    -Jessica


    Thursday, June 21, 2018 6:35 PM
  • Absolutely perfect, had tried everything else but only this worked for me.

    Thanks

    Thursday, July 5, 2018 12:41 PM
  • This solution solve my problem. Thanks a lot!
    Wednesday, July 11, 2018 3:40 PM
  • Your powershell command worked for me too.

    Thanks

    Wednesday, July 18, 2018 7:14 PM
  • Thanks so much. This and the PowerShell combined worked for me!
    Wednesday, July 25, 2018 9:32 PM
  • You may receive this error when trying to install DotNet (.net) on Windows 10 and you are using a WSUS server. This error may occur of the .net installer is not approved in WSUS.

    As a temporary workaround, change the registry key “UseWUServer” to 0. It is located at:

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU

    After the registry change, restart the Windows Update service. You should be able to install .net at this time. Once done you should change this key back to its original value (or wait and allow Group Policy to do it for you.)

    Source => https://www.westechs.com/error-0x800f0954-when-installing-dot-net-on-windows-10/


    worked, thanks.
    Friday, August 17, 2018 9:24 AM
  • Thank you!! Works 100%
    Friday, August 17, 2018 1:38 PM
  • Thank you.
    Thursday, August 23, 2018 8:21 AM
  • Thank you Flavio!

    Great solution!

    Wednesday, September 5, 2018 8:38 AM
  • MS, why do you have to make this so difficult?
    Friday, September 21, 2018 7:52 PM
  • Thanks a million.

    Worked for me. Disabling WSUS update policy allowed me to download the .net 3.5 software.


    A Wright

    Thursday, September 27, 2018 8:21 AM
  • I got the same problem when I tried to add .NET 3.5 by go to "Turn Windows features on or off", got Error code 0x800F0954. Tried run 

    DISM.EXE /Online /Add-Capability /CapabilityName:NetFx3~~~~

    Still the same error, now it is possible to read error log in C:\Windows\Logs\DISM\dism.log:

    xxxx, Info                  DISM   DISM Package Manager: PID=12956 TID=12296 Further logs for online package and feature related operations can be found at %WINDIR%\logs\CBS\cbs.log - CPackageManagerCLIHandler::ExecuteCmdLine
    xxxx, Error                 DISM   DISM.EXE: DISM Package Manager processed the command line but failed. HRESULT=800F0954

    Go to C:\Windows\Logs\CBS\CBS.log, found 

    xxxx, Info                  CBS    DWLD:Failed to do Windows update search [HRESULT = 0x800f0954 - CBS_E_INVALID_WINDOWS_UPDATE_COUNT_WSUS]
    xxxx, Info                  CBS    FC:   WindowsUpdateDownloadFromUUP returns. [0x800F0954]
    Now search for "CBS_E_INVALID_WINDOWS_UPDATE_COUNT_WSUS" will lead to solution that change  "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU the key UseWUServer to 0".

    Thursday, September 27, 2018 2:07 PM
  • Brilliant, this worked for me. Thanks.
    Tuesday, October 9, 2018 10:40 PM
  • Perfect! Thank you I solve the problem.
    Thursday, October 11, 2018 2:28 PM
  • This worked for me.
    Tuesday, October 16, 2018 8:13 AM
  • Worked Well for me ! Thanks !
    Wednesday, October 17, 2018 12:21 PM
  • I had the same problem, but with optional feature on Windows 10 1809

    Add-WindowsCapability -Online Rsat.ActiveDirectory.DS-LDS.Tools~~~~0.0.1.0

    the reg key and WU service restart helped.

    Thanks !!

    Friday, October 19, 2018 7:00 PM
  • Muchas gracias... sirvió... 
    Tuesday, October 23, 2018 4:36 PM
  • Really works. Thanks.
    Tuesday, October 23, 2018 5:03 PM
  • For me, the solution was to use the full name of the source file, instead of just the path. Not sure why that was needed, but I had found a post that suggested it (don't recall where now, sorry), tried it, and sure enough it solved my problem with very similar symptoms:

    Instead of using this (which did not work for me): Dism /online /enable-feature /featurename:NetFX3 /All /Source:R:\sources\sxs

    I used this, which did work for me: dism /online /add-package /packagepath:R:\sources\sxs\microsoft-windows-netfx3-ondemand-package.cab

    Where R is the drive letter for my Blu-Ray/DVD-ROM drive. Prior to finding the solution, I had tried many variants on the command, which all failed, because Windows couldn't find the source file. I believe the key difference is inclusion of the filename, not the other differences from the command above.


    Colin



    Using the full path and filename also worked for me.
    Wednesday, November 14, 2018 8:32 PM
  • Thanks. the changing of registry solved my issue.
    Friday, December 7, 2018 4:57 PM
  • Thanks for the workaround by disabling WSUS. I've inherited a legacy environment and I'm building myself a Windows 10 VM so I don't have to touch their existing systems. Wondered why I couldn't install .NET v3.5 which I need for vSphere. Saved me a lot of hassle!
    Wednesday, December 19, 2018 2:05 PM
  • thank you a lot, it's the only one working for my so far.
    Friday, December 28, 2018 10:24 AM
  • Worked perfectly for me Thank you so much for help.
    Thursday, January 3, 2019 9:33 AM
  • Worked for me. Thanks
    Friday, January 4, 2019 3:54 AM
  • This worked for me, thank you very much :)
    Tuesday, January 8, 2019 3:35 PM
  • I salute you too. This worked. Months trying to figure it out. The error is very misleading. It was in fact WSUS. THANK YOU
    Thursday, January 10, 2019 5:05 PM
  • You may receive this error when trying to install DotNet (.net) on Windows 10 and you are using a WSUS server. This error may occur of the .net installer is not approved in WSUS.

    As a temporary workaround, change the registry key “UseWUServer” to 0. It is located at:

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU

    After the registry change, restart the Windows Update service. You should be able to install .net at this time. Once done you should change this key back to its original value (or wait and allow Group Policy to do it for you.)

    Source => https://www.westechs.com/error-0x800f0954-when-installing-dot-net-on-windows-10/

    This worked, thanks so much!
    Wednesday, January 16, 2019 4:41 PM
  • You may receive this error when trying to install DotNet (.net) on Windows 10 and you are using a WSUS server. This error may occur of the .net installer is not approved in WSUS.

    As a temporary workaround, change the registry key “UseWUServer” to 0. It is located at:

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU

    After the registry change, restart the Windows Update service. You should be able to install .net at this time. Once done you should change this key back to its original value (or wait and allow Group Policy to do it for you.)

    Source => https://www.westechs.com/error-0x800f0954-when-installing-dot-net-on-windows-10/

    Helped me too!! Yipee!!
    Saturday, January 19, 2019 3:31 PM
  • worked for me
    Monday, January 21, 2019 12:17 PM
  • Yes, also worked for me. Thank you.
    Friday, January 25, 2019 10:08 AM
  • I found another solution that may be easier for some (a GUI solution, rather than a PS solution) and works for installing all Windows components, not just the .NET Framework: IF you run into this on a computer getting updates through WSUS, instead of directly from MS, then:

    change the registry key “UseWUServer” to 0

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU

    This will let you install any of the Windows Optional features from the GUI.

    After you're done, be sure to run gpupdate /force or manually restore that key to 1 after you have finished your installs so you can resume getting updates from the WSUS server.


    Colin

    Friday, January 25, 2019 3:52 PM
  • Thanks so much!  This worked for me.  I'm running W10 1809 x64.
    Monday, January 28, 2019 3:35 PM
  • Thank you, this worked for me!!!

    Monday, February 25, 2019 10:39 PM
  • Legend!!! That worked, I can now do my job!!
    Monday, March 4, 2019 12:51 AM
  • I am trying to install Skylight by Sierra Wireless on a new Dell Rugged Extreme Tablet with M$ Win 10, so I can use the WWAN card & SIM I installed, but I cannot get it to work. I read through other posts about this error, but I cannot get their resolutions to work. I've changed the Registry Key for UseWUServer to "0". Where can I get the necessary .NET 3.5 setup files without the DISM (I don't have access to it)?
    Wednesday, March 20, 2019 3:44 PM
  • Ok, I'm a newbie here. I just read that I could try running...

    I deleted all files in C:\Windows\Logs\CBS

    I ran Windows PowerShell as admin

    PS C:\Users\JD_S>net start trustedinstaller

    PS C:\Users\JD_S>Dism.exe /online /enable-feature /featurename:NetFX /source:C:\

    The response was...

    Deployment Image Servicing and Management tool

    Version: 10.0.17763.1

    Image Version: 10.0.17763.379

    Enabling feature(s)

    [==================100.0%===============]

    Error: 0x800f0950

    DISM failed. No operation was performed.

    For more information, review the log file.

    The DISM log file can be found at C:\WINDOWS\Logs\DISM\dism.log

    So, apparently, I have access to DISM, but I do not have access to the CAB files referred to above. I guess I should have asked that instead. Anyone know where I can find and download them to drop onto my C:\ root drive? 

    Wednesday, March 20, 2019 4:23 PM
  • This was it, even with it in the allowed list on the WSUS server it still would not work had to bypass it.
    Friday, March 22, 2019 6:21 PM
  • This worked for me after many other methods failed. Thanks!

    Friday, March 22, 2019 6:25 PM
  • Thank you!!   Thank you!!   Thank you!!

    Such a simple, intuitive solution. This should win an award.

    Trashed a computer trying to add .netFramework3.5 back after a user removed this feature. Tried all of the other DISM BS, which worked for previous builds, but not 1809. Wish I would have found this a lot sooner. Now the trick is to remember it for the next time:)

    Friday, March 29, 2019 1:42 PM
  • Thank you sir!
    Tuesday, April 9, 2019 6:04 PM
  • This did the trick for me. Thanks!
    Thursday, April 18, 2019 12:31 PM
  • This was it. Worked like a charm. Many thanks!!
    Wednesday, May 1, 2019 8:56 PM
  • This solution worked for me as well - thanks for this
    Friday, May 3, 2019 10:12 AM
  • Thank you changing the registry as you advised I was able to install it using the PowerShell command

    Add-WindowsCapability –Online -Name NetFx3~~~~ –Source D:\sources\sxs

    Friday, May 3, 2019 6:57 PM
  • Reg hack worked on my brand new Dell lappy..thanks much!
    Monday, May 6, 2019 4:56 PM
  • man, you saved my life.
    Wednesday, May 29, 2019 7:30 PM
  • Legend

    This solved my issue

    Wednesday, July 17, 2019 6:45 AM
  • Thank you, Flafio!

    That's the perfect solution for me and my friends.

    In addition, it solved some other problems with updates.

    Tuesday, August 6, 2019 9:25 AM
  • Even after more than 1 year, the Flavio's suggestion saved me! THX
    • Edited by MCosta68 Tuesday, August 6, 2019 11:07 AM
    Tuesday, August 6, 2019 11:04 AM
  • This solved my problem installing .Net 2.0
    Tuesday, August 6, 2019 2:48 PM