none
Windows 7 x64, ADI Soundmax Integrated digital audio, no 5.1 available!

    Question

  • I have an IBM Intellistation Z Pro 6223 ATU, and the ADI SoundMax Integrated digital audio used to support 5.1 surround in vista but in windows 7 it doesnt have that option... any fixes or work-a-rounds?

    Thursday, November 05, 2009 4:08 PM

Answers

  • Hi,

     

    As we know, to make a device work properly, a proper driver is needed.

     

    Regarding this, please go to IBM or ADI site to see if there is a Windows 7 driver for this sound card. If so, please install it and see how it works.

     

    If there is no driver for Windows 7 available, alternatively, please try to install install the driver for Windows Vista x64 with Compatibility Mode.

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    Friday, November 06, 2009 10:09 AM
    Moderator

All replies

  • Hi,

     

    As we know, to make a device work properly, a proper driver is needed.

     

    Regarding this, please go to IBM or ADI site to see if there is a Windows 7 driver for this sound card. If so, please install it and see how it works.

     

    If there is no driver for Windows 7 available, alternatively, please try to install install the driver for Windows Vista x64 with Compatibility Mode.

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    Friday, November 06, 2009 10:09 AM
    Moderator
  • I have the IBM 9228's and they use the ADI1981HD chipset.   If you install the XP drivers from IBM's site you will get audio from the device but no special options like 5.1

    Ibm has refused to make a driver.  Will not accept a Spore Request on the intellistation as they have closed that division and migrated it completely to Lenovo and Lenovo does not care either. 

    Before you go an blame IBM. HP and Dell have this same Intel chip on their boards and they have yet to make a windows 7 driver.

    If Microsoft doesn't make the driver then you can give up.  Intel has no desire to make a reference driver because they don't use that chip anymore from what I understand. 

    Don't know what else to do.
    Wednesday, December 02, 2009 8:45 PM

  • Same problem with the 9228.  I tried the drivers from HP but they didn't work.  I do have audio and the standard mixer.  I'm also running the 64 bit Version of "7".
    In the end I'll find a sound card that will work and has the right driver set.  It is really a mess.  The ONE good thing is that any vendor that states that a product works with "7" has to certify with both the 32 bit and 64 bit versions.  Sometimes you just have to use a MAC!

    Phil
    Wolcott, CT
    Sunday, December 06, 2009 7:34 AM
  • Problem solved.  Disable the IBM driver, install Soundblaster (pick any one from the windows 7 compatabilty list).
    Viola everything works like a charm.
    Only one issue, the bios does not have a power control section and Windows 7 does not pick up the driver what to do when you hit the power button.
    Other than that I've run into one software issue with a 12 year old program that runs but the video is a little quirky so I be converting that database to One Note over time.
    I was able to import my outlook express local folders on my OTHER machine my mapping a drive to to the OUTLOOK folder and doing an import.
    Windows Live Mail SUCKS but there are so many issues with the outlook connector I went the WLM route.  It will do it is just a bit more painful to file messages.

    So, give up on the Sound Max.  Spend the $40-$99 and get better audio and have everything work.

    Phil
    Friday, December 11, 2009 10:17 AM
  • people use realtek driver for windows 7 on ADI soundmax card will work GUARANTEED!! 

    Friday, December 18, 2009 5:59 AM
  • thank you..the ADI soundmax card driver for windows vista 64 bit...worked like a champ!!!! thanks
    Tuesday, June 01, 2010 3:27 PM
  • http://support.lenovo.com/en_US/downloads/detail.page?&LegacyDocID=MIGR-62634 worked great for my ThinkCentre
    Monday, August 15, 2011 7:03 PM