none
"Your current security settings put your computer at risk. Click here..."

    Question

  • While a appreciate the message. I want to turn it off.

    Like UAC, and turning it off, it isn't that I don't care for what it's telling me. I'd rather say oops and reimage if anything, for the first time in years, gets by me and somehow cripples my system.

    Mostly my computer is only being used as a glorified media center machine. There isn't a single possible way for malicious software to get in that I'm not closely monitoring. 

    I want to turn this message off without turning off the information bar. That only because it's likely some other automatically blocked event will require turning on the information bar, force enabling something to do what I want it to, but was blocked by IE's built in security.


    Context:

    -Launch Applications and unsafe files (set to enable) to avoid the prompt.

    I wanted Windows to stop prompting me when I want to open shortcuts as links and save things from the internet. Which is only because I set up the links toolbar to replace the quick launch bar. So I checked enable instead of prompt for downloading and opening files. Now the information bar is permanently open. 
    Tuesday, May 05, 2009 3:50 AM

Answers

  • Hi,

     

    In order to let us know the detail of the issue, please capture a screenshot when the notification is received and submit it in the SkyDrive of your Live Space.  


    Arthur Xie - MSFT


    http://cid-2126f0a7617f33d3.skydrive.live.com/browse.aspx/.Public

    1.1 The message always appears when a new page is opened or refreshed.
    2.1 Here too (blue banner). How do I get rid of these notifications?
    3.1 All I want is this red option to be on so, as you can see, I can have a quick launch bar again without wasting gobs of room on useless Pinned items.

    Notice Links on the taskbar. This is the fake quick launch bar. These items are packed more tightly and don't have contextual stuff so I don't need them to be pinned. I mean that was the point of the quick launch menu wasn't it? See how nice the fake quick launch menu and pinned items play together? Besides that Pinned items take up more room which will only mean more items will be added to the Links bar before being considered Pin worthy.

    4.1 Change Action Center Settings. Everything save troubleshooting notifications is off. It remains on only because at times a notification pops up for a software update I can try which sometimes resolves issues. So the notification may be more than the one mentioned in 3.1.
    5.1 Even when I say Default Level, the notification remains. What does Default Level change? (I put User Authentication back to login with credentials.)


    When I tried to post from IE8 it failed with - Unexpected Error.

    6.1 This is the first page that IE8 displays. No browsing for you before jumping through this hoop. Why? Just to force it to NOT harrass me about downloads and logging into familiar websites?


    But after researching this "issue" online.. yeah wow.. 3 years and the problem is worse than ever. Ah.

    Nevermind. It isn't worth the headache I'll stick with Maxthon.

    • Marked as answer by lzim Friday, May 08, 2009 1:12 AM
    Thursday, May 07, 2009 12:02 AM

All replies

  • Control Panel | Action Center | AC Settings
    Remove tick by Antivirus. Done
    • Proposed as answer by Jens Peter Karlsen Tuesday, May 05, 2009 5:00 PM
    • Unproposed as answer by lzim Tuesday, May 05, 2009 10:27 PM
    Tuesday, May 05, 2009 4:59 PM
  • Control Panel | Action Center | AC Settings
    Remove tick by Antivirus. Done

    This was one of many notifications that I turned off along with UAC.

    Still has the security message in IE8 when any new page is opened or refresehd.

    As Per information bar instructions:

    1. Click to open Internet Explorer.

    2. Click the Tools button, and then click Internet Options.

    3. Click the Security tab, and then click Custom level.

    4. Do one or both of the following:

      • To turn off the Information bar for ActiveX controls, scroll to the ActiveX controls and plug-ins section of the list, and then, under Automatic prompting for ActiveX controls, click Enable.

      • To turn off the Information bar for file downloads, scroll to the Downloads section of the list, and then, under Automatic prompting for file downloads, click Enable.

    5. Click OK, click Yes to confirm that you want to make the change, and then click OK again.

      The one in bold is the one I did.

    Tuesday, May 05, 2009 10:37 PM
  • Hi,

     

    In order to let us know the detail of the issue, please capture a screenshot when the notification is received and submit it in the SkyDrive of your Live Space.  


    Arthur Xie - MSFT
    Wednesday, May 06, 2009 7:39 AM
  • Hi,

     

    In order to let us know the detail of the issue, please capture a screenshot when the notification is received and submit it in the SkyDrive of your Live Space.  


    Arthur Xie - MSFT


    http://cid-2126f0a7617f33d3.skydrive.live.com/browse.aspx/.Public

    1.1 The message always appears when a new page is opened or refreshed.
    2.1 Here too (blue banner). How do I get rid of these notifications?
    3.1 All I want is this red option to be on so, as you can see, I can have a quick launch bar again without wasting gobs of room on useless Pinned items.

    Notice Links on the taskbar. This is the fake quick launch bar. These items are packed more tightly and don't have contextual stuff so I don't need them to be pinned. I mean that was the point of the quick launch menu wasn't it? See how nice the fake quick launch menu and pinned items play together? Besides that Pinned items take up more room which will only mean more items will be added to the Links bar before being considered Pin worthy.

    4.1 Change Action Center Settings. Everything save troubleshooting notifications is off. It remains on only because at times a notification pops up for a software update I can try which sometimes resolves issues. So the notification may be more than the one mentioned in 3.1.
    5.1 Even when I say Default Level, the notification remains. What does Default Level change? (I put User Authentication back to login with credentials.)


    When I tried to post from IE8 it failed with - Unexpected Error.

    6.1 This is the first page that IE8 displays. No browsing for you before jumping through this hoop. Why? Just to force it to NOT harrass me about downloads and logging into familiar websites?


    But after researching this "issue" online.. yeah wow.. 3 years and the problem is worse than ever. Ah.

    Nevermind. It isn't worth the headache I'll stick with Maxthon.

    • Marked as answer by lzim Friday, May 08, 2009 1:12 AM
    Thursday, May 07, 2009 12:02 AM
  • To disable "security settings" warning in IE8:
     
    Open registry editor
     
    In
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Security
     
    Create a new DWORD value named:   DisableSecuritySettingsCheck
    with a value of "1"
     
    This will disable the security settings check.
     
    In IE7:
     
    Same as for IE8, but the location is:
     
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Security
    Monday, May 11, 2009 11:07 PM
  • I did the following...

    open Registry Editor, navigate to key below (step 1):

    1) [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_SECURITYBAND]

    2) Add or ensure the following keys have these values
        2.1)  (Reserved)"=dword:00000000
        2.2)  "explorer.exe"=dword:00000000
        2.3)  "wmplayer.exe"=dword:00000000
        2.4)  "iexplore.exe"=dword:00000000

    3)  Close IE8, and reopen it, navigate to a page, and no info bar about the Security Risk.

    I used this for IE8, running on Windows Server 2003 EE.


    Donnie Wishard
    Thursday, May 14, 2009 3:16 PM
  • Correction to IE7
    The location is:
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Security

    The rest is good. Thanks.
    Wednesday, March 17, 2010 6:15 PM
  • This works, but the better method (since you should always recommend against directly editing the registry) is to go into Local Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Internet Explorer and enable "Turn off the Security Settings Check feature."

    Incidentally, for IE8 this sets the value at HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Security, which you listed for IE7.

    • Proposed as answer by Blinks Wednesday, June 22, 2011 1:24 PM
    Saturday, June 19, 2010 5:49 PM
  • I did the following...

    open Registry Editor, navigate to key below (step 1):

    1) [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_SECURITYBAND]

    2) Add or ensure the following keys have these values
        2.1)  (Reserved)"=dword:00000000
        2.2)  "explorer.exe"=dword:00000000
        2.3)  "wmplayer.exe"=dword:00000000
        2.4)  "iexplore.exe"=dword:00000000

    3)  Close IE8, and reopen it, navigate to a page, and no info bar about the Security Risk.

    I used this for IE8, running on Windows Server 2003 EE.


    Donnie Wishard

    Thank you very much, that indeed got rid of the ever annoying "Your current security settings put your computer at risk. Click here..." message I was getting in IE8.
    Thursday, August 05, 2010 4:08 PM
  • Hey, Ok now can you explain this in english for me please. How do  I create a new DWORD value?

    All I see in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Security

    is 4 folders.. DPA, MSN, NEGOTIATE, NTLM

    and a fine called (default). Can you break down what my next steps are?

     

    Thursday, January 13, 2011 3:23 PM
  • Hey, Ok now can you explain this in english for me please. How do  I create a new DWORD value?

    All I see in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Security

    is 4 folders.. DPA, MSN, NEGOTIATE, NTLM

    and a fine called (default). Can you break down what my next steps are?

     

    You are in the wrong location for the creation of key values

    above refer Donnie Wishard

    lavigate to;
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_SECURITYBAND

    Then right click within,

    New, then DWORD Value, then type name

    iexplorer.exe.

    A new entry will appear named iexplorer with a value of 0x00000000.

     

    Tuesday, February 01, 2011 6:45 PM
  • Question:

    When some group decided to prompt every user about their IE settings not being secure, what goal did they have in mind? 

    Was it to force admins to adjust settings immediately while fending off the belief that we messed up... or was it that they wanted us to dump IE?

    Friday, April 15, 2011 11:22 AM
  • Yes, this is totally ridiculous, for a few days now, every time I launch IE9 or open a new tab, I get the security warning message which offers to "Fix settings for me". Thank you very much, I don't need the settings fix, how the hell do I turn this annoying feature off??? Sometimes I wonder who has these brilliant ideas and why do they need to fix something if it's not broken???
    Tuesday, August 23, 2011 4:02 PM
  • Had no effect.
    Wednesday, September 07, 2011 5:00 PM
  • I gave up and decided to click the "Fix settings for me" button. I'm happy now, no idea what IE9 did for me and if it would ever affect some websites, so far everything seems alright...
    Friday, September 09, 2011 8:17 PM
  • I am using Windows 7 Home Premium which is anything but "premium".  Premium doesn't have GPEDIT.MSC so it's harder to fix these problems.  I have IE8 and it took me over an hour to solve this problem.  The other places where I created "DisableSecuritySettingsCheck" didn't work.  I almost gave up.  Microsoft really needs to get its act together. BTW, NO, I CANNOT SET THE INTERNET SECURITY SETTINGS TO "DEFAULT" BECAUSE AN APPLICATION I USE NEEDS THEM "CUSTOM."  The solution can be found here:


    "Open registry editor by typing regedit in the run box.

    Open
    HKEY_LOCAL_MACHINE ->SOFTWARE ->POLICIES ->MICROSOFT
    Here, create a key [looks like a folder] named Internet Explorer (if not there)
    Create a sub key [looks like a folder] named Security

    In Security, add a DWORD value named DisableSecuritySettingsCheck and assign it a value of 1

    Close registry editor and restart internet explorer. That annoying information bar should be gone now."

     

    Or, if you wish, you can simply copy and paste the text between the ===== lines below and save it as a file named DisableSecuritySettingsCheck.reg in NotePad.  Do NOT include the ===== lines:

    ====================

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Internet Explorer\Security]
    "DisableSecuritySettingsCheck"=dword:00000001

    ====================

    In Explorer, double-click on the file and click "Yes".  That should add what you need and it should work.

     


    • Edited by Cypherdude Sunday, October 23, 2011 6:12 PM
    • Proposed as answer by Florin F Micle Thursday, November 10, 2011 5:09 PM
    Sunday, October 23, 2011 6:07 PM
  • Had someone tried to think that the option might be in user configuration.

    Run local group policy editor (gpedit.msc)

    User Configuration > Administerative Templates > Windows Components > Internet Explorer
    Enable "Turn of the Security Settings Check feature"

    Monday, March 19, 2012 3:37 AM