How to set default browser with group policy? RRS feed

  • Question

  • Hi all,

    the task is: Make firefox the default browser for all users in the domain when using our terminalservers.

    I created a default application association file, put it in %logonserver%\netlogon\DefaultApps_v1.xml. The content:

    <?xml version="1.0"?>
    <Association ApplicationName="Firefox" ProgId="FirefoxHTML" Identifier=".htm"/>
    <Association ApplicationName="Firefox" ProgId="FirefoxHTML" Identifier=".html"/>
    <Association ApplicationName="Firefox" ProgId="FirefoxHTML" Identifier=".shtml"/>
    <Association ApplicationName="Firefox" ProgId="FirefoxHTML" Identifier=".xht"/>
    <Association ApplicationName="Firefox" ProgId="FirefoxHTML" Identifier=".xhtml"/>
    <Association ApplicationName="Firefox" ProgId="FirefoxURL" Identifier="ftp"/>
    <Association ApplicationName="Firefox" ProgId="FirefoxURL" Identifier="http"/>
    <Association ApplicationName="Firefox" ProgId="FirefoxURL" Identifier="https"/>

    I made a gpp changing Computer Configuration / Admin Templates / Windows Components / File Explorer / Configuration file ... to point to the file above.

    The terminal servers using this gpp - checked.

    The terminal server set this policy - checked.

    But the file is not taking effect.

    Even if i make

    dism /online /import-defaultappassociations:"DefaultApps_v1.xml" (no error)

    and check with

    dism /online /export-defaultappassociations:"test.xml"

    the settings are not there. Still edge ist present for html ...

    I struggling for hours, no idea any more...

    Any help is very appreciated. There must be something basic missing, because making a piece of software default couldn't be THIS complicated, right?

    With kind regards,


    Wednesday, January 22, 2020 10:13 AM

All replies

  • Hi Alex, 

    Does the issue occur when configure other application as default?

    Try to check if the share folder is accessible. Please make sure it could be access by every one with read and write priviledge, then reproduce your action again.

    What's the existing system version?

    Try to update system to the latest build through Settings\Update & Security\Windows update.

    Try to change default browser through registry key below to check. 



    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact

    Thursday, January 23, 2020 4:10 AM
  • Hi Alex,

    Haven't received your message a few days, was your issue resolved? 
    I am proposing previous helpful replies as "Answered". Please feel free to try it and let me know the result. If the reply is helpful, please remember to mark it as answer which can help other community members who have same questions and find the helpful reply quickly.


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact

    Monday, February 10, 2020 4:16 PM