Windows 10 Fall Creators Update: Remote Desktop Crashes


  • After the Fall Creators Update on Windows 10/64 bit, Remote Desktop  Connection crashes every time I connect to another PC running Windows 10 64 bit.  The connection goes through. But, invariably, within 30 seconds the Remote Desktop Connection app crashes.  Both systems are on Windows 10 Pro Fall Creators Update.  Methinks something didn't get tested before the update was rolled out.  Any workarounds or solutions?

    Wednesday, October 18, 2017 4:35 PM

All replies

  • I can confirm this behavior on every device with Version 1709 Build 16299.19.

    The Insider Version 1709 Build 17017.1000 does not crash, so we will probably need to wait for that to hit the pipeline.

    To resolve this problem for my clients I used the Recovery options in windows settings to go back to an earlier build of windows.

    Another work around is installing Remote Desktop from the Microsoft Windows App Store. Note that some terminal services like TSPrint won't work with this app.

    • Edited by GCMC IT Wednesday, October 18, 2017 5:14 PM
    Wednesday, October 18, 2017 4:59 PM
  • Thanks for the update.  I guess will wait for the Inside Version 1709 Build 17017.1000 to come up in Windows Automatic update and fix this issue.  I don't want to mess up the system by going back to earlier build of Windows.
    Wednesday, October 18, 2017 8:35 PM
  • After the Windows 10 Fall Creators Update, print driver host for applications crashes everytime I try to print a file to PDF in Adobe Acrobat XI Pro.

    Faulting Application Path: C:\Windows\splwow64.exe

    Problem signature
    Problem Event Name: BEX64
    Application Name: splwow64.exe
    Application Version: 10.0.16299.15
    Application Timestamp: 7403b6eb
    Fault Module Name: ntdll.dll
    Fault Module Version: 10.0.16299.15
    Fault Module Timestamp: 493793ea
    Exception Offset: 0000000000090d5f
    Exception Code: c0000409
    Exception Data: 000000000000000a
    OS Version: 10.0.16299.
    Locale ID: 1033
    Additional Information 1: 275f
    Additional Information 2: 275f0f44c060eb151c5662542ef60619
    Additional Information 3: a9c8
    Additional Information 4: a9c8e269d9d06af0b3bc00043cb3ee7d
    Wednesday, October 18, 2017 8:40 PM
  • Hi,

    For print issue, you could reinstall the printer driver and the software to check.

    If you often use remote desktop connections, don’t hurry to install the Fall Creators Update. Users report that Remote Desktop Connection crashes when they try to connect to another device that’s not running the Fall Creators Update.

    Considering the Update is released recently, if the issue persists, you could try the built-in "Feedback" tool to submit the issue on your side.

    I will forward this information to the appropriate department through our internal channel. Both the Microsoft Product Team and Development Team take into consideration all suggestions and feedback for future releases.

    Best regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Thursday, October 19, 2017 8:51 AM
  • The work-around for me was to edit the .rdp file and go to the Local Resources tab and un-check Printers.  I don't need to print to my local printer so this solution works for me.
    Friday, October 20, 2017 1:47 PM
  • I can confirm this work-around works.  Even after your initial connection, the setting must persist on the pinned "Recent" menu, so I just unpinned the hosts I want to connect to, use RDP again as if it's the first time I connect to the host, uncheck "printers" on the local resources tab and I'm back in business.  Nice find CRendall :-)
    Saturday, October 21, 2017 1:20 PM
  • Hi JitenVaghela,

    Based on my check, it could be related to your Printer redirect.

    Disable Printer redirect on RDP settings.


    Using gpedit.msc, expand to Computer Configuration - Administrative Templates - Windows Components - Remote Desktop Services - Remote Desktop Session Host - Printer Redirection, then set the policy for "Use remote desktop easy print printer driver first" to DISABLE

    Or you can directly create a value in the registry,

    HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services

    "UseUniversalPrinterDriverFirst" with a reg_dword value 4


    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Terminal Server Client

    DisablePrinterRedirection = 1

    Hope it will be helpful to you

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Wednesday, October 25, 2017 12:32 PM
  • Carl,

    You're TOTALLY mistaken.  With respect, while your registry key may resolve it, your assumption is incorrect.  You stated, "Based on my check, it could be related to your Printer redirect."  That's a DEFAULT in Windows and this crash in the RDP client did NOT happen in ANY previous version of Windows going back to Windows NT 4.0 Terminal Services so this is, in fact, related to defective code in Windows 10 build 1709.  

    That you claim this is fixed in an insider build, and assuming you're correct, that suggests to me that 1) Microsoft has been aware of the problem for some time; 2) they shipped 1709 with a major defect they knew about; 3) they know how to fix it but haven't bothered to; and 4) they know about it but have failed to release a public document admitting to the defect and describing ways to mitigate it (at least none that I've been able to find).

    Tell me how that's not negligence?

    Sincerely,<br/> Brian Bergin<br/> Terabyte Computers, Inc.<br/> <br/> Information posted by me in these forums is provided &quot;As-Is&quot; with no warranties or rights conferred. Use at your own discretion/risk.<br/>

    Thursday, October 26, 2017 3:38 PM
  • Disabling printer redirect works.  The next two, gpedit and adding the UseUniversalPrinterDriverFirst key, didn't work.


    Thursday, October 26, 2017 7:15 PM
  • FYI, RDP from Win 10 to Win 10 crashes with redirect enabled. But Win10 to anything else works fine.
    Friday, October 27, 2017 9:06 PM
  • Hi Brian, 

    We have noticed many issues about RDP crash after upgrade to Windows 10 fall creator update. 

    Solution Carl provide could be the workaround on this issue. 

    Please also feedback this issue in Feedback hub, hope it can be fixed in further update. 

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Monday, October 30, 2017 10:14 AM
  • I'm experiencing the same issue.  I'll wait it out as this isn't critical this week.  Hope we get a fix soon.

    Wednesday, November 1, 2017 2:07 PM
  • I ran into this same issue today when my Windows 10 box updated.  I turned off sharing all local resources and selected use all my screens and have been able to run
    Wednesday, December 27, 2017 8:18 PM
  • My workaround was to disable forwarding remote sound to local (do not play).  Seems one of my third-party sound drivers is causing a problem.  Found this solution here:
    Thursday, September 13, 2018 1:50 PM