Can't connect to Network Printer


  • I just bought a laptop with Vista.  I have  wireless router connected to a wired router.  My two desktops are conneted to the wired router and the laptop is wireless to the wireless router.

    My printer does not have a wireless card, so I have it plugged to one desktop, and I have the other desktop using it as a network printer.

    I can't seem to get the wireless to see the printer.  I have enabled file & print sharing on all computers, and the print spooler service is started on all computers.  When I do "Add a printer" it doesn't see the printer.  I tried doing "Add a network printer" and entering the name as \\computername\printername (where computername is the computer the printer is attached to), but I alternately get these two errors:


     "Windows cannot connect to the printer. The server print spooler service is not running. Please restart the spooler on the server or restart the server machine" or


    "Windows cannot connect to the printer. Makes ure that you have typed the name correctly, and that the printer is connected to network."


    I have not been able to see the desktop computer at all in the network options, but I do see the wired router listed, but no computers connected to the router.

    Can anyone help with this?  I am at my wit's end.                     Dan





    Monday, April 30, 2007 10:55 PM

All replies

  • Dan

    I have exactly the same problem although I haven't seen the first of your error messages.

    I too am at my wits end.

    Please let me know if you find a solution and of course I will do likewise if I get one.

    Help from anyone out there would be greatly appreciated. I can't believe that Dan and I are the only unlucky ones.

    Tuesday, May 01, 2007 11:25 AM

  • Dan

    Found this fixed it for me.

    Tuesday, May 01, 2007 11:59 AM
  • Hey Dan,


    I was encouraged when I found this thread because what you described is exactly the problem I'm having right now (though months after yours!).  When you said it fixed it for you I was elated and immediately went to try it.


    What I got was "network path not found" when I went to name the new port with the "\\computername\printername".  Nothing like this happened to you?  Now I definitely feel like the unlucky one.



    Wednesday, November 21, 2007 9:08 PM
  • I have the same problem.  Path not found....
    Sunday, September 06, 2009 4:55 PM
  • Hi,

    I'm have the same problem. Its for my homegroup network with both computers running Windows 7. I can print from the PC where the printer is connected via USB but I can't print from my laptop through the network.

    The homegroup works fine enough, I can access files through it.

    I thought originally it was Pharos that was upsetting the computer (installed very very poorly and finally days later managed to get every sign of it off the laptop) - but now I get the printer being found but it won't connect!

    I've been though a couple of other threads but none of it seems to work. The file and printer sharing has always been connected (as my brother from his XP computer can print to my printer) and the firewall lets it through.

    Is there any other way? The permissions are set to print for Everyone so its not that either.

    Does anyone know how I can get my laptop access to print???

    Friday, June 18, 2010 7:22 AM
  • "Windows cannot connect to the printer. The server print spooler service is not running. Please restart the spooler on the server or restart the server machine" or

    see the tail end of my thread here, it sounds a LOT like your problems and my own are similar:


    Might be the right hotfix!


    I will be trying this hotfix this week. I have this problem SO bad right now. The only slight difference is that my print server is running Microsoft Storage Server 2003, and all my clients are now windows 7. The problem hits users at seemingly random times, random 5% of the company per day, and all printer made no sense at all! 

    I'll keep you posted as to whether the asyncronous RPC reg key helps, or if your hotfix does.

    There is also something i found that works (for 48 hours straight anyways):

    1. On vista/7 client, go to Devices and Printers and click Add Printer
    2. Then choose Local Printer. I know your printer is shared on a print server, just stick with me here!!
    3. Choose Create New Port and select Local Port...
    4. When it asks you for a port name, type in the UNC ADDRESS of the printer (ie \\printserver1\HPLaser5000n). 
    5. When it asks you for a driver, point it to the right location where you downloaded a clean set of drivers matching your client OS and printer. Or press the Windows Update button.
    6. finish adding the printer. You will notice the name of the printer doesn't have a "...on [printserver1" anymore, BUT it will still print!!
    I have done this for 4 printer pools and for the last 2 days the 1 user i set it up for has had no printing problems. May be total coincidence, but at this point i was willing to try anything. I'm not sure if this constitutes fooling windows 7 into setting up a remote printer as a local printer, and i'm also doubting this will be deployable via GPO or script...but still, i hope it helps.


    Saturday, December 18, 2010 1:48 AM
  • If Windows Vista fails to display the network printer of your choice, then you are advised to skip the installation process and follow the instructions in the `The printer that I want is not listed’ section.

    Upon selecting the browsing option, Windows Vista will display all the current computers logged into the system.

    Select the computer that is attached with the network printer.

    Continue through the wizard until the printer is successfully installed.

    Upon selecting the second option, user is required to type PC name followed by printer name [\\PCName\PrinterName] .

    Alternatively, click the Browse button and select the devices. When made the appropriate selection, continue through the wizard until successful installation.

    If the user has chosen to add a printer via TCP/IP address, the IP address of the printer should be known, else contact the network administrator.

    Upon providing the relevant information, click `Next’ to rename the printer and set it as a default printer.

    Click `Finish’ once the wizard indicates that the installation process is complete.

    get more information and help for Setup Network Printer Vista . Hope this helps you.


    Michel Smith

    Printer Support
    Monday, January 10, 2011 5:29 AM
  • after adding a network printer on my my laptop Compaq 6910p with windows 7, cant print. when i troubleshoot and it gives me an option of restoring the system and i click restore the system, the printer starts to print test pages which i had initially sent while testing the connections, what might be the problem with the laptop since the other PC's on the network can print using the same printer via network. kioli
    Tuesday, February 01, 2011 2:23 PM
  • Thanks Ray, that worked for me too, but I'm not happy with that. It's not suppose to work like that. Come on Microsoft, where's all the MVPs or whatever they're called that are supposed to know how this stuff really works. I'm sick off all the guessing and trial and error we have to engage in as Microsoft users.


    Microsoft, please can we have a proper explanation as to why these things are not working? i understand that there can be many reasons the system can't connect to printer shared on another system, but the fact that this dogey local printer addition seems to work leaves me seething as this proves there are no network issues at play here. 



    Monday, April 25, 2011 4:14 PM
  • Still happens even on Windows 7 SP1.  I just browse the network, find the right machine, right-click and choose "connect" ... bingo!  Thanks a lot, Redmond guys.
    Wednesday, September 28, 2011 5:17 PM
  • Similar problem with Windows 7 until I turned off the firewall, after which both the printers on the network began to print out all the files in the queues.

    It was possible to reset the firewall and have had no further problems since then.

    Tuesday, May 08, 2012 7:05 PM
  • I have the same issue with HPe6520 printer. I've done 3 remote sessions w/HP, they aren't able to fix my issue. I tried w/usb then disconnect the cable, loose my connection. I restarted, pc, printer, router, nothing works. I have a nvg510 router by ATT/Motorola. HP doesn't know what the issue is. This is my 5th printer from HP that something has been wrong with it. I can connect with usb cable but it's just not recognizing my network, ATT says network is fine.
    Sunday, April 06, 2014 5:32 PM
  • Regular add printer dialog would not find the printer.  Advanced Printer setup would find the printer, but immediately fail with error 0x00000002.  The printer worked while using the computer to which it was attached.  Sharing was set up properly.

    What worked for ME:

    Go to YOUR (remote) computer's services, and stop the Print Spooler service and restart it.  (I also first did this on the network computer, but it still didn't work).

    After I did that, it would connect to the printer.

    None of the suggestions above worked.

    Tuesday, April 08, 2014 3:57 PM
  • Have you tried connecting to the printer via TCP/IP? Can you ping the host computer that the printer is attached to?
    Tuesday, April 08, 2014 5:50 PM