August 2019 update caused a boot problem RRS feed

  • Question

  • This August update has up until now caused 4 W7 Pro machines not being able to boot. It goes directly into repair mode, not being able to do a repair. F8 no luck either, goes directly into repair mode.
    Mounting the disk in another machine and checking Windows update log file reveals that it updated and then rebooted. Nothing after that. For good measure I checked for malware.
    Have not found a solution to this yet.
    Really annoying.

    Can anyone help ?


    Just tested EasyRE (Easy Recovery Edition) on 2 machines and they are both up and running again.

    Cost me something like $20

    • Edited by yrjc Friday, August 16, 2019 11:50 AM Found a fix
    Thursday, August 15, 2019 9:26 AM

All replies

  • So far we have 300+ computers at various sites by various manufacturers that are hit by this patch. System restore points seem to have been destroyed by Microsoft and considering how widespread this issue is for us, I have no idea why I'm not seeing more activity online.

    None of these computers have third party antivirus so that's not the cause, they're Microsoft Security Essentials or nothing at all in some protected environments.

    Thursday, August 15, 2019 1:20 PM
    • Proposed as answer by williamgault Thursday, August 15, 2019 2:30 PM
    Thursday, August 15, 2019 2:29 PM
  • Hi,

    We have recevied lots of the same issues of the August 2019 update, and will keep confirming it. If there is any update, I will post here asap.

    For now, it's recommended to uninstall it first:

    1. Boot into WinRE and open command prompt.

    2. Run DISM /Image:C:\ /Get-Packages > packages.txt to get the list of packages.

    (Note: please replace C with the system drive )

    3. Find the August update and it's package identify.

    4. Run DISM /Image:C:\ /Remove-Package /PackageName:<Package Identify you got from the text> to remove it.

    5. Reboot and check the symptom.

    Best regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, August 16, 2019 2:32 AM
  • Hi guys,

    I have been struggling from Thursday Morning to now (Friday 13.00) with this issue and finally found a solution, so I wanted to share it (especially with the poor guy with 300+ machines having the issue on this thread!)

    It might be a different issue for you, but this is what happened to me :

    The problem effectively came from the last two major updates of last Tuesday (13 August 2019) :

    - 2019-08 Security Update for Windows 7 for x64-based Systems (KB4474419)
    - 2019-08 Security Monthly Quality Rollup for Windows 7 for x64-based Systems (KB4512506)

    - AND from the fact that I have two SATA hard drives on my machine (a desktop computer running Windows 7 Pro 64 bits)

    Symptoms :

    When starting the machine, Windows 7 does not even start to boot, and I go immediately into the Repair Mode (with an auto repair mode that does not work, a console pretty useless from which I can't even  access C:, and a few other useless things).

    What I tried first which did NOT work :

    1) First I tried several reboots, hoping that the OS will realize that it can now boot normally (in case some actions where still pending from the updates, perhaps from pending.xml). That did not work.

    2) So I wanted to try the Repair Mode from an installer (DVD or USB) or more complicated stuff, like trying to revert the update by hand with a command line from a DVD/USB with the installer, or perhaps removing pending.xml. So I booted from a DVD with Windows 7 on it, and I could boot from it, but the Repair Tool told me a very weird "The system on this media and the version of windows do not match".

     I was really surprised because I was 100% that the DVD was the one I used years ago to install my Windows 7.

    So I tried from a USB stick with the ISO downloaded from Microsoft. Same issue : can't enter the Repair mode because the "versions do not match". I was 100% sure that it was the same (7, Pro, for x64).

    So I googled the issue and realized that having two Hard Drives on the same machine can cause the issue (and I already had this issue a long time ago). So I thought I would unplug my second one (a non SSD), and boot again from the DVD or USB to do more advanced stuff. So I unplugged it, and first rebooted on the main hard drive to be sure I unplugged the right disk, and oh surprise, this time I had a different screen, another automatic repair mode, which told me at the end something like "Reboot now and if it worked Windows will boot, otherwise you will come back here". I rebooted (still without the second hard drive), and it booted perfectly.

    Conclusion, try this if you have two hard drive in your machine :

    1) Shut down your machine

    2) Unplug your second hard drive if you have one (I have one for large data that I don't want on my small SDD). Let the main drive on which Windows is installed plugged.

    3) Reboot and let the computer enter the automatic repair mode which at the end will reboot automatically

    4) If Windows 7 now starts correctly, then the problem effectively came from these two updates that do not work well if you have a second hard drive plugged on SATA (I have no idea why). You can shut down your machine.

    5) Re plug the second hard drive

    6) Start again the machine

    7) Go to the Windows update setting, untick all the updates from August 2019, and turn off updates for now. (I did try to install them again, hoping that the issue would have been solved by now, and I got the same issue). This is not perfectly safe to do that, but otherwise they will get installed again, and you will have the same issue.

    In the future :

    When Microsoft will have solved the problem (if they do), re-activate the automatic updates from Windows update, and install the (corrected) updates that they will have pushed. Personally, might not try them in the near future (anyway, Windows 7 is only on maintenance mode, and will die from January 2020, so I might never install these last faulty updates).

    Hoping this will help some of you ! Good luck.

    Best regards.

    Friday, August 16, 2019 11:42 AM
  • Hi,

    It is confirmed as a known issue of Aug updates. 

    The current resolution is to uninstall those updates and keep them uninstalled until the next action plan.

    Thanks for your understanding.  

    Best regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, August 21, 2019 2:29 AM
  • I had the same problem (reported here)and used exactly the same software to fix it.
    Wednesday, August 21, 2019 9:00 AM
  • Thanks for this information. Very useful.

    /Get-Packages returns a lot results. PhoenixArizona mentions KB4474419 and KB4512506. Are these the packages I should be removing?

    This is the tail of my package list


    The dates on the last few are very old and one from August does not look like the KB number mentioned.

    Wednesday, August 21, 2019 10:13 AM
  • Wednesday, August 21, 2019 4:47 PM
  • Refer to the FAQ section in https://support.microsoft.com/en-us/help/4472027/2019-sha-2-code-signing-support-requirement-for-windows-and-wsus  to recover from this situation.  Copy pasting the recovery steps below:

    I have installed an image of Windows 7 SP1 or Windows Server 2008 R2 SP1, which includes the SHA-2 support, directly to the disk without running setup and now the system does not boot and I receive error 0xc0000428 (STATUS_INVALID_IMAGE_HASH). How do I make this scenario work?

    If you are seeing error 0xc0000428 with the message “Windows cannot verify the digital signature for this file. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source.” please follow these steps to recover.

    1. Start the operating system using recovery media.
    2. Before installing any additional updates, install KB3133977 using Deployment Image Servicing and Management (DISM) for Windows 7 SP1 and Windows Server 2008 R2 SP1.
    3. Reboot into the recovery media. This restart is required
    4. At the command prompt, run bcdboot.exe. This copies the boot files from the Windows directory and sets up the boot environment. See BCDBoot Command-Line Options for more details.
    5. Restart the operating system. 

    Thursday, August 22, 2019 10:44 PM
  • This solution worked for me so I thought I would share:

    Boot from a Clean Win 7 ISO. Goto repair this pc and then go to the command prompt.
    Type this to revert the changes
    dism.exe /image:c:\ /cleanup-image /revertpendingactions

    • Proposed as answer by s2project Friday, August 30, 2019 5:25 PM
    Friday, August 23, 2019 1:24 AM
  • check and try Below

    * Open CMD in Recovery Console and run Diskpart, list disks check fixed disks are available are not

    Option 1: if disks are available

    Check the drive letter where OS is available. change it to Original Drive letter
    Rename below files

    cd \windows\system32
    ren win*.efi *.old
    ren winload.exe *.old
    ren winresume.exe *.old

    and copy files from c:\windiws\winsxs\amd64_microsoft-windows-b..vironment-os-loader_xxxxxxxxxxxxxx to c:\windows\system32


    Option 2: If Disk are not visible try to boot with Windows 2012 or windows 8, 10. try to copy above files as pption 1 from  and check


    Option 3: If Disks are not visible

    * Down load RAID or Storage drivers ( required iso or in usb)

    * Reboot the PC, Select Load Drivers from image recovery and select drivers and Add

    * Open CMD and run Diskpart, you can see Disks

    * Check and change OS drive letter by remove and assign letter using Disk part

    * run " BCDBOOT c:\windows"


    Tuesday, August 27, 2019 10:52 AM
  • This solution worked for me so I thought I would share:

    Boot from a Clean Win 7 ISO. Goto repair this pc and then go to the command prompt.
    Type this to revert the changes
    dism.exe /image:c:\ /cleanup-image /revertpendingactions

    This issue affected about a dozen or so of our machines.  This command worked!  Thank you so much.

    Friday, August 30, 2019 5:26 PM
  • This is verified that the issue occurred in Win 7 and Server 2008, R2 after August 2019 security updates (KB4512506 and  KB4512486)

    After struggling a lot, we too found the solution which worked with systems having HDD/SSD etc.
    Download latest Win 10 ISO of version 1903.

    The one I have used is (Windows 10 (business editions), version 1903 (updated Aug 2019)

    Create a bootable flash drive using above ISO and boot either in UEFI or Legacy mode, you will have to get inside troubleshoot option and then in command prompt. Inside command prompt you will see X:\Sources>.

    Try typing C: here and if you are inside C drive it means your life is easy after next command.
    Type below command to revert the changes:

    dism.exe  /image:c:\  /cleanup-image /revertpendingactions

    Please take care of the spaces in this command you may get different errors for same. But this is working fine in almost every model of laptop/desktop/server etc.

    Cheers!! If you encounter further issues, discuss it here.

    S Saurabh

    Sunday, September 1, 2019 9:06 AM
  • Hi Saurabh, Thanks for your help

    In many of the machines it has thrown Error 5, though it was successful.

    But in some of the machines Error 2 & Error 3 appeared, still we got stuck in the recovery mode.

    It would be great helpful if you suggest some solution for Error 2 & Error 3.

    Also could you please let us know does this problem reappear in the successful machines after few days ?

    Saturday, September 7, 2019 6:46 AM
  • This is also one of the many issues I'm fighting when updating over 300 CNC's.  If KB4474419 is installed and the machine reboots it will enter an endless boot loop.  One strange thing is, if you unplug the machines network cable it will boot fine.  But as soon as the cable is plugged back in and it gets an IP it instantly reboots.

    So I was able to uninstall each recent update on one of the machines having this issue and once I uninstall KB4474419 it would work again.  This has caused me HOURS and DAYS of troubleshooting, not to mention all the downtime in our production unit.  

    The only saving grace for me is that I do weekly backups so I can restore easily, but unless I disable Windows Updates on 300+ machines it just keeps happening.

    I just really wanted to vent a bit after the day I've had figuring out which update out of, sometimes, 100's that were recently installed was causing this issue.  F' Me.

    Monday, September 30, 2019 7:27 PM