Error 1935 on installation of Bluetooth Windows 7 SP1


  • There is already a question on this but for some reason the thread is locked (!?) without an answer being given.  I am experiencing the following when installing Lenovo's ThinkPad Bluetooth with Enhanced data Rate Software II for Windows 7 (32-bit, 64-bit), Vista (32-bit, 64-bit) - ThinkPad (

    Error 1935: An error occurred during the installation of assembly 'policy.8.0.Microsoft.VC80.CRT,type="win32-policy",version="8.0.50727.42",publicKeyToken="1fc8b3b9a1e18e3b",processorArchitecture="x86".Please refer t...

    Then rolls back actions and I end up with a system that gives me:

    BTTray.exe System Error The Program can't start because btwhidcs.DLL is missing from your computer. Try reinstalling the program to fix this problem.


    Of course re-installing does not help.  The fix suggested in the previous version of this question refers to . However I do not have Visual Studio (and frankly do not see how that is going to solve my Bluetooth installation issue).

    For the record I have Microsoft .NET Framework 4 and Windows 7 SP1.



    A luta continua
    Thursday, March 17, 2011 7:23 AM


All replies

  • Hi Edwin,

    check this:

    Error 1935.An error occurred during the installation of assembly 'Microsoft.VC90.ATL,version

    and run the following tool to fix:;EN-US;946414


    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo:
    Thursday, March 17, 2011 1:47 PM
  • Hi, Edwin

    My problem is just like yours. And i kinda solved it. 

    i experienced exactly the same error pop-up as i was trying to install lenovo's Thinkpad Bluetooth with Enhanced data Rate Software II for Win7 on my T61p Lapto, and the roll-back, 

    also the notification of missing of btwhidcs.DLL as i start the BTTray.exe thread. 

    gone through the same question post you've mentioned, couldn't figure it out.




    HERE's how i solved this:


      UN-INSTALLATION: I run a fully-uninstall TOOL within a Security Software Suite named "Qihu360", which you might haven't heard of, 'cause it is made by a  Chinese company, ( is its official website) to execute a neat un-installation of that Bluetooth Software. This action , i think , deleted the unuseful legacy files and bad register informations the regular uninstall or roll-back doesn't deal with.

     RE-INSTALLATION: then i restarted my laptop, just as the app suggested. and restarted the previously not-working setup.exe i downloaded from lenovo's site. and this time, BOOM! it worked well. didn't roll-back, no error pop-up.


     I'm not so SURE if you can coop with a Chinese software with this chinese UI like me. I used this tool just because i am a Chinese.  You might probably got hold of a comparative, similar TOOL, maybe Macfee!? Norton? I don't know.

     I think the problem we both've encountered might be caused by failed installation or incomplete un-installation of the system. the KEY  is  un-install it first!

     Hope my words do help you,and things go well.



    • Edited by Justin.Z Friday, November 18, 2011 5:20 AM
    Friday, November 18, 2011 5:18 AM
  • Doesn't work. Even tried with the "Aggressive" check box checked.
    Tuesday, June 26, 2012 8:06 PM
  • Doesn't work. Even tried with the "Aggressive" check box checked.
    Tuesday, June 26, 2012 8:06 PM