none
Windows 7 dual physical screens remain blank after remote desktop

    Question

  • Hi Guys,

    I'm running Win7 Enterprise x86 RTM (reasonably patched up) on a Dell Optiplex 755 with an ATI Radeon HD2400Pro PCIe card and the ATI 9.11 Catalyst Drivers/Control Center.

    I'm finding that if I've remoted in (F5 Firepass, RDP session) overnight, then when I get in, in the morning, my dual (HP2035 DVI-D) screens are blank and no ammount of mouse/keyboard bashing will wake them up.  The PC is still pingable and I can still remote desktop in.  At the moment I have to logout using MSTSC and then power down the PC using it's power button (nicely, just a quick press to do a nice shutdown), then power it back up again.

    I suspect it's some conflict between the ATI drivers, power saving turning the monitors off and me physically turning the monitors off when I go home at night.

    Today I've tweaked the power saving options to not turn the monitors off and I'll not physically turn them off when I go home, remote in tonight and see if they still go in the morning.  And if they do, play around with the power saving/monitor power combinations until I can pick the combos that fail/work.

    Has anyone else seen this? or similar?
    Thursday, December 17, 2009 4:26 AM

Answers

  • Hey Brendan,

    I think you might have cracked it.  At least for me it seems to work now.

    What I did:

    1. On my work PC, unplugged the DVI cables from my monitors, swapped the cables over and plugged them back in (this is because monitor #1 was on the right and not set as primary.
    2. Win7 autodetected the change(!) now #1 is on the left and is primary.
    3. Reset my screensaver/power settings to put the monitors to sleep/off.
    4. Updated to the latest ATI drivers (10-7 for Win7 32bit).
    5. Locked my PC (Windows-L)
    6. Physically turned my screens off.
    7. Went home.
    8. RDP'ed from home to my work PC (via TS Gateway).  Note: my home screen resolution is different to my work one.
    9. Disconnected (did not logout) the session from my work PC.
    10. Came to work the next day.
    11. Powered on my screens.
    12. Unlocked the session as normal.
    13. No dramas!

    Can anyone else confirm that this process (or similar) resolves this issue for dual DVI screened ATI powered Win7 machines?

    Note: It's quite possible the driver update helped significantly.  Thanks largely to our corporate build process, 10-7 is first driver I've been able to install successfully since 9-11.

    Hope this helps most of the people with this problem.
    Thanks Brendon for pointing out what looks like the right direction.

    Later'ish
    Craig

    • Marked as answer by Craig Humphrey Wednesday, October 26, 2011 8:43 PM
    Wednesday, August 11, 2010 2:39 AM

All replies

  • Hi,

    Could you please hlep confirm the Desktop Window Manager Session Manager service status?

    Verify the status of the UxSms service.
    =================================
    1. Open the Services console (services.msc).
    2. Double click on Desktop Windows Manager Session Manager.
    3. The service status should display Started and the Startup type should be set to Automatic.

    Please let me know the result.

    Thank you for your cooperation.
    Friday, December 18, 2009 5:35 AM
  • I'm experiencing the same problem for one of my users.  She is running a Dell Vostro 420 running Win 7 Pro x64 with an ATI HD 3450 Card.  She also has dual monitors.  RDP always works, but the background in her RDP session goes black, then when she physically gets in front of her computer, the screens are just black and the KB and mouse are unresponsive.  RDP continues to work fine.  She never shuts off her monitors, but the Power Save is set to performance (display's shut off after 15 minutes, computer never sleeps).

    After rebooting her computer, I checked the Desktop Windows Manager Session Manager and it is running, and set to automatic.  I havn't verified if the service is running while the problem is occuring however.

    Any help is appreciated...
    Friday, December 18, 2009 3:33 PM
  • Hi,

    it's started and is set to Automatic startup.

    Note: having set my power saving to not turn off my screens, the problem has gone away. Even if I physically turn my screens off, connect remotely overnight and then power them on in the morning, they're OK.

    So it looks like the issue is localised to the screens having been powered down by the power management, then turn them off physically, then remote desktop in.

    If I don't remote desktop in, there's no problem.

    Could it be that because the screens have been powered off (power management) and physically turned off (power button), when the remote desktop session ends the OS is unable to detect that the screens are still connected?

    Thanks
    Craig
    Monday, December 21, 2009 10:45 PM
  • I've unmarked this as the answer because while it might be the answer to Tim's issue, it's not the answer to my originally proposed problem.

    [Updated: sorry Tim, editing this answer has deleted the original answer (I've had that happen a couple of times now... grrr...]
    • Marked as answer by Robinson Zhang Wednesday, December 30, 2009 6:27 AM
    • Unmarked as answer by Craig Humphrey Friday, January 08, 2010 3:24 AM
    Monday, December 21, 2009 10:52 PM
  • Same problem with the Vostro 420 running Windows 7 32bit with the AMD Radeon HD3450 video card.  Of interesting note, one monitor is analog (VGA) and the other is digital (DVI).  The analog monitor is set to the default monitor and it stays in "sleep" mode after remote desktop session (the power button glows amber).  The digital monitor displays a black screen, the power button turns blue, and I can mouse over to it and see the cursor on screen.  However, I can not log in and have to reboot. 


     The system display \ screen resolution screen identifies the analog as the 2 monitor and the digital as the 1.  I have 2 set as the primary display.  I'm going to try to set the video drivers to have the digital monitor as the primary display  and test.  Also, I agree that it is a power management issue.  When testing remote desktop before the "Turn off the Display" times out after 15 minutes, everything works.  It is after the display times out that the error occurs.

    Friday, January 08, 2010 4:07 PM
  • Ok.  I think I figured this one out.  The digital monitor (connected DVI and identified as 1) has to be set as the "Main Display". 

    When testing, I unplugged the two monitors physical cables with the machine powered on and logged in.  When I plugged in the DVI, windows auto-detect ding'd but when I plugged in the VGA, nothing.  I had to go into Control Panel\Appearance and Personalization\Display\Screen Resolution and hit "Detect" for it to come back up.  Aha! 

     Now, the problem is a power management feature of Windows 7 for some reason will not recognize a connected analog monitor after turning it off to save power and utilizing a remote desktop session.  Even now, when I log onto the local machine, the digital monitor (DVI) wakes up with the log on screen, but the VGA analog monitor stays sleeping and "amber" until the operating system logs in. 
    Friday, January 08, 2010 4:54 PM
  • I have DELL XPS Studio, dual DVI output and get same problems.

    I'll try the power saver and update if it works.

    BTW, I am also unable to view what was on the secondary  (2) monitor when remoting in to this PC, I can click on icons, but they dont display, and obviously RD does not have the ability to set second monitor up, so basically I am unable to view whatever was on the second screen.

    I think this is a new development, as It used to work OK in November when I first started RDP onto the same PC.....
    Tuesday, January 12, 2010 1:04 AM
  • Wow, cured, turned off the power saving to monitors and used pc remotely. Got home just now, and both dispays have nice blue glow light and fire up fine.

    Also the issue with focus going to a non exisisting second screen when RDP in has gone away.

    Thanks for the advice.
    Tuesday, January 12, 2010 7:07 PM
  • Hi WPecker,

    to view the dual screens over RDP you need the Win7 version of MSTSC (http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=a4895bf6-f022-4b4c-8852-dd28978f72d2) and dual screens on both the remote(?) and local PCs.

    Later'ish
    Craig
    Monday, January 18, 2010 9:45 PM
  • Hi Ronnie,

    please do not mark my response to WPecker as the answer, as it is not the answer to the original question.

    Later'ish
    Craig

    Thursday, April 01, 2010 5:56 AM
  • Exactly the same problem. Windows 7 Pro x64. 2 DVI monitors. Main monitor looks like it is in sleep mode after Remote Desktop. Secondary monitor is ok.

    Installed latest MSTSC on another computer. Didn't help at all. Never had anything like that in Windows XP.

    Tried  to remote from Windows 7 machine. Exactly the same result. Screen is still off.

    Monday, April 19, 2010 5:03 AM
  • As far as I can tell, it's not the remoting machines fault (the machine running mstsc).

    It looks like the way Win7 on the remoted machine (PC you are connecting to) detects monitors, particularly DVI (no one has mentioned any other connection types [VGA, HTMI, display port, etc]), so when the remote connection is terminated, the Win7 PC attempts to re-detect the connected displays, which have been turned off either manually, or by the power settings (which means the GFX card has also turned them off?) and for some reason this isn't enough for the GFX card (driver issue?) to either probe or attempt to wake up, the connected displays.

    I'm wondering if it's due to DVI screens not being detected by Win7 when powered off.  I don't have any VGA (or other connectors) based Win7 PCs, so can't test this.

    Certainly wasn't a problem in WinXP, so possibly something introduced in the Vista/Win7 driver model?

    Note: I'm staying current with my ATI drivers (now at 10.3) and the problem still exists.  Anyone seen this on NVidia or INTEL? If we can narrow it down to a GFX card manufacturer, then we can raise it with them instead of MS.

    Tuesday, April 27, 2010 11:43 PM
  • I had the same problem.  Try this.

    The problem for me was a certain registry key. I compared registry keys on another machine where RDP worked properly and found that HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp had a one key that was different. The fInheritCallback key was set at "0" compared to the working PC that was set to "1". I changed the Windows 7 PC registry key to a "1" also, rebooted and checked to see if it fixed the problem. It did.

    Stu

    Friday, April 30, 2010 5:23 PM
  • All the registry keys that I have checked, both working and not working, have fInheritCallback set to '0'.  I'm using ATI on Win7 x64 with Dual-DVIs.
    Friday, April 30, 2010 9:30 PM
  • Hey Stu,

    Hmm... I think this is a red herring... That key is all about the dial-back number and I see it's not actually used in Terminal Server (http://msdn.microsoft.com/en-us/library/7ce7f717-461b-4f18-9829-6690168c7707(v=PROT.10)#id60) anymore. Unless ATI are using it in some strange way for their driver...

    Given that the current common denominators are: Win7, Dual Screens (anyone having this problem on single DVI/VGA?) and ATI.  It might be time to report this to ATI... I'll see what I can do.

    Later'ish
    Craig

     

    • Edited by Craig Humphrey Sunday, May 09, 2010 11:41 PM One instance of DVI + VGA
    Sunday, May 09, 2010 11:35 PM
  • I have the same problem on two machines both running Windows 7 64bit. They are my work and home machines and I RDP back and forwards between them constantly. Both machines have ATI Video Cards and I have tried various versions of the Catalyst drivers. The issue seems exclusive to ATI Video Cards as I have tested extensively with NVidia and on board cards and have not been able to reproduce the problem.

    The computer is actually working fine if you discount the fact the the main screen will not come on. If you remember all the keystrokes to logon blindly and don't make any types on your password the screen will then fire up OK and you then get the message saying "the catalyst control center is not supported by the driver version of your enabled graphics adapter".

    Agree with Craig on the common denominators. It is definitely an ATI problem though my searches have given me no indication that the problem is acknowledged in any way.

    While the workaround of logging on blindly gets me out of trouble most times, this is an extremely annoying problem. Annoying enough for me to toss all my ATI cards if not resolved soon.

    Wednesday, May 26, 2010 12:39 AM
  • Exact same problem with over 100 machines, all Windows 7 X64.

    --Steve

     

     

    Saturday, May 29, 2010 2:18 PM
  • Hi Steve,

    what's the graphics card/chipset in these machines?

    Thanks
    Craig

    Sunday, May 30, 2010 10:11 PM
  • We are having the same problem here.  We all have Dell Optiplex 745/755/960s.  The common denominator is that they (about 200) have ATI cards, dual monitors and Win 7 x64 Enterprise...

     

    It's sounding like an ATI issue.  Can anyone find an NVIDIA card and test this?

    Monday, June 07, 2010 12:28 PM
  • Same issue -

    HP Compaq 8000 Elite
    64bit Win 7 Pro
    NVIDIA 9400GT

    Driver 8.17.11.9745
    Driver Date 4/3/2010

    Phillips 190VW
    Phillips 221E

    After disconnecting the RDP session ( from another computer ), the aformentioned workstation remains "Black " on both screen.

    CTRL ALT DEL does not help. Only way to recover is to force the system down.

    Nothing out of the norm in event viewer.

    Monday, June 07, 2010 7:08 PM
  • I have the same issue with Win 7 64 Enterprise, DVI connections and an ATI 3400HD card.  Here is what I noticed in my testing of this issue. 

     

    The secondary monitor is blank and the primary monitor is off.  Hit CTRL ALT DEL and type your username.  The tab and type your password and hit enter.  The primary powers up.

     

    My theory (testing tonight) is that this is linked to closing the RD session by clicking the X.  If I log off, I dont seem to have this issue.  I will report back tomorrow.

     

     

    -Dave

    Tuesday, June 08, 2010 12:41 AM
  • OK, so now we have the same problem with both Nvidia and ATI, so it's unlikely to be a driver issue.

    Now to find an easy way to report this to MS, without incurring a charge...

    Tuesday, June 08, 2010 3:58 AM
  • I've been experiencing the same thing with my ATI 4850 HD.

    I will try "Logging off" instead of clicking the X next time to see if that makes a difference.

     

    I've also managed to "resurrect" the host computer by unplugging and replugging the main monitor from the computer. Drastic I know.. but it beats restarting. Though I'm not able to restart the catalyst control center which is slightly problematic for controlling my GPU's fan.

     

    Simon

    Tuesday, June 08, 2010 5:26 AM
  • Exact same problem here. Dual monitors with DVI, nvidia chipset, and x64.  Updating to the latest drivers doesn't make a difference.
    Tuesday, June 08, 2010 4:10 PM
  • I have the same issue with Win 7 64 Enterprise, DVI connections and an ATI 3400HD card.  Here is what I noticed in my testing of this issue. 

     

    The secondary monitor is blank and the primary monitor is off.  Hit CTRL ALT DEL and type your username.  The tab and type your password and hit enter.  The primary powers up.

     

    My theory (testing tonight) is that this is linked to closing the RD session by clicking the X.  If I log off, I dont seem to have this issue.  I will report back tomorrow.

     

     

    -Dave

    Well, that did not work.  I had my monitors set to go to sleep, but not the PC.  Last night I set the PC to go to sleep as well and this morning when I came in both monitors came on.  Testing again tonight, I will post an update.
    Thursday, June 10, 2010 2:22 AM
  • I have the same issue with Win 7 64 Enterprise, DVI connections and an ATI 3400HD card.  Here is what I noticed in my testing of this issue. 

     

    The secondary monitor is blank and the primary monitor is off.  Hit CTRL ALT DEL and type your username.  The tab and type your password and hit enter.  The primary powers up.

     

    My theory (testing tonight) is that this is linked to closing the RD session by clicking the X.  If I log off, I dont seem to have this issue.  I will report back tomorrow.

     

     

    -Dave

    Well, that did not work.  I had my monitors set to go to sleep, but not the PC.  Last night I set the PC to go to sleep as well and this morning when I came in both monitors came on.  Testing again tonight, I will post an update.
    That worked.  I set the sleep on the PC for 5 hours so it wouldn't be asleep when i got home from work.  I have to do some reading on wake on lan.
    Thursday, June 10, 2010 11:08 PM
  • Hi Dave,

    see my results near the top of this thread on just turning off the "turn monitor(s) off after XX" in your Power Settings.

    Thanks
    Craig

    Saturday, June 12, 2010 12:24 PM
  • Hi Robinson,

    given the growing length of this thread, are you able to work this through MS at all?

    [You've been noticably silent since this initial response]

    Thanks
    Craig

    Saturday, June 12, 2010 12:27 PM
  • I know that works, the point is that I want my PC to be able to sleep
    Sunday, June 13, 2010 2:18 AM
  • Hi Dave,

    you can still set the PC to sleep, just not to auto power off the screen(s).

    Later'ish
    Craig

    Monday, June 14, 2010 1:22 AM
  • Thanks,

     

    My method works though.   Use Wake on LAN, set PC and monitors to sleep.  That way, when you arrive in the AM the pc waking seems to refresh the video out.

    Monday, June 14, 2010 1:46 AM
  • Cool, a start I guess. But given that if your PC is asleep you can't RDP to it... :)

    I guess if you're only ever going to connect to the PC < 5 hours after you leave work...

    Have you found a WoL solution? Sounds like something MS could build into the TS GateWay product...

    Monday, June 14, 2010 4:41 AM
  • So no actual fix then?

    Dell Optiplex 780 Dual HDMI (ATI), Dual Dell, W7 x32 Enterprise, same as above with no actual fix.

    Is there another discussion somewhere with a resolution I wonder?

     

    Tried logging in, failed, need to check process and write it down.

    Can not sleep and WOL as corporate FW blocks this.

    have not tried unplugging and re-connecting screens - not feasible.

     

    Is there a real fix?

    Monday, June 14, 2010 8:34 AM
  • Set a screensaver to blank the screen, and turn the monitors off at night?
    Thursday, June 17, 2010 1:29 AM
  • i'm getting similar behavior; wondering if it is the same or a different issue.  I seem to be able to see the login screen fine, but when I login, the screens are all black.  curiously, I still show my cursor arrow.  Dell i7 24gb Ram, quad ati, windows 7 latest. 

     

    I am going to try the power control settings workaround as above, let you know how it goes.

    Monday, June 28, 2010 4:39 PM
  •  

    There's a similar thread about this problem here:

    http://social.technet.microsoft.com/Forums/en-US/w7itprohardware/thread/d9d81430-cf50-458b-b3e8-c1aca5a22084

    I've also noticed this behavior on Win2k8, Radeon 4600, Catalyst v10.5 drivers.

    Thursday, July 01, 2010 6:33 PM
  • I've been lurking on this for awhile now-- but is there any update as fixing this that doesn't require unplugging a monitor or changing power savings mode?

    Our Windows 7 rollout is right on track but we have a growing group of irate users over this issue.

    I'm inwardly hoping there might be some acknowledgement of the issue with Microsoft.

    Monday, July 19, 2010 6:46 PM
  • Hi JMHahn,

    as I see it, there are a few work-arounds currently (in no particular order):

    1. Blindly login, as the screen will reset/appear correctly once you've logged back into the desktop
    2. Unplug and replug the monitors (in particular the primary monitor, where the login prompt appears)
    3. Disable "turn off monitor" in your power saving settings. [Group Policy?]
    4. Set the timeout for "turn off monitor" to something rediculusly long. [Group Policy?]

    I suspect the latter two can be deployed using Group Policy, so you should be able to roll it out to your entire organisation fairly easily.

    I'm surprised that you've got so many users complaining, as it should only be affecting users who use RDP to their desktops, which outside of IT teams and Devs would normally be rare, I would have thought.

    Later'ish
    Craig

     

    Tuesday, July 20, 2010 10:36 PM
  • Craig. Many, many people use VPN and remote desktop to provide a superb and cost effective remote access solution. It is not just techs that use RDP widely.
    Wednesday, July 21, 2010 10:53 PM
  • Yes take a look at the thread Orbital posted. Someone posted a way to at least login that worked for me. (post was on Feb 11th).

    1)  Hit CTRL-ALT-DELETE
    2)  Hit ENTER (I'm sure this will only select your first user account listed)
    3)  Type your password
    4)  Hit ENTER twice.

    I believe I only have to press Enter once after entering my password but this has worked after a few tries. I just installed Windows 7 on my desktop yesterday and this was driving me crazy because I never had this problem on my laptop. I am sure this is a video driver issue but I've tried Dell and ATI drivers.

    Friday, July 23, 2010 2:46 AM
  • Hi Craig,

    Wouldn't luck have it that ours is one of the few corporations that advertised this capability to our users years ago? It's a pretty popular form of "remoting in" that our company promotes. We've been using the #2 above as a work-around to the monitor issue. Not a whole lot we can do until MS comes out with a fix for it.

    Thanks for the followup, everyone.

    JMHahn

    Tuesday, July 27, 2010 4:11 PM
  • Our office is having the same issue. We deployed clean images of Windows 7 - 64bit on Dell Optiplex 980. They are all running ATI HD 3450 video cards. After a remote desktop session and returning to the host computer, the screen no longer displays an image, but monitor light is active(eg. Green=active Orange=asleep)

    Like Craig said earlier, I'm just disabling the monitor from going to sleep as the temporary fix for now.

    Any updates to this would be helpful.

     

    Tuesday, July 27, 2010 11:47 PM
  • I have experienced this as well in a deployment of about ~150 Win7 x64 machines.  Everything is on Dell 745, 755, 760, 780s with ATI cards.  I have a workaround which has been working for about 6 months without issue.

     

    The screen that has the taskbar must be screen #1 when you hit "identify" in display properties.  Doing this along with up to date drivers has fixed this issue on all win 7 computers in my company.  Let me know if this works for anyone else as well.

     

    -Brendan

    Monday, August 02, 2010 10:44 PM
  • Hi,

     

    I have the exact same problem.

     

    So far I've found the only fix is to use a different physical monitor, this should work straight away.

     

    Then play around with the settings for a bit, and switch back to your original second monitor.

     

    Problem solved.

     

    Chris

    Tuesday, August 03, 2010 10:05 AM
  • The screen that has the taskbar must be screen #1 when you hit "identify" in display properties.  Doing this along with up to date drivers has fixed this issue on all win 7 computers in my company.  Let me know if this works for anyone else as well.


    Hmmm... #1 is on the right for me and does not have the taskbar, but only because the cables happened to work out that way.

    I'm going to swap my cables around so that #1 is on the left and is my primary screen and see if it makes any difference.

    Can anyone else confirm if their #1 monitor is NOT their primary? We could be on to something here...

    Wednesday, August 04, 2010 12:05 AM
  • Has anyone tried my suggestion above and found that this works?
    Friday, August 06, 2010 2:18 PM
  • How can we try your suggestion if the user isn't logged in? We would have to login blind first which isn't an option for my firm.

    This issue is preventing our Windows 7 deployment as 2700 users require RDP.

    I found this issue on seems to occur when we RDP at the SAME resolution as the console's and closing the remote session but not logging off.

    The only way I can seem to resolve this is to login blind or

    Unplug the monitor’s DVI cable and plug it back in

    Restart the computer

    Come on Microsoft... This is a HUGE issue for businesses...

     

    Friday, August 06, 2010 8:25 PM
  • I don't think you understood.  BEFORE your screen goes black after an RDP session, make sure your screen that identifies as #1 (in display properties) has the taskbar on it.  Then go and rdp and try to recreate the issue.

     

    -B

    Friday, August 06, 2010 8:44 PM
  • Hey Brendan,

    I think you might have cracked it.  At least for me it seems to work now.

    What I did:

    1. On my work PC, unplugged the DVI cables from my monitors, swapped the cables over and plugged them back in (this is because monitor #1 was on the right and not set as primary.
    2. Win7 autodetected the change(!) now #1 is on the left and is primary.
    3. Reset my screensaver/power settings to put the monitors to sleep/off.
    4. Updated to the latest ATI drivers (10-7 for Win7 32bit).
    5. Locked my PC (Windows-L)
    6. Physically turned my screens off.
    7. Went home.
    8. RDP'ed from home to my work PC (via TS Gateway).  Note: my home screen resolution is different to my work one.
    9. Disconnected (did not logout) the session from my work PC.
    10. Came to work the next day.
    11. Powered on my screens.
    12. Unlocked the session as normal.
    13. No dramas!

    Can anyone else confirm that this process (or similar) resolves this issue for dual DVI screened ATI powered Win7 machines?

    Note: It's quite possible the driver update helped significantly.  Thanks largely to our corporate build process, 10-7 is first driver I've been able to install successfully since 9-11.

    Hope this helps most of the people with this problem.
    Thanks Brendon for pointing out what looks like the right direction.

    Later'ish
    Craig

    • Marked as answer by Craig Humphrey Wednesday, October 26, 2011 8:43 PM
    Wednesday, August 11, 2010 2:39 AM
  • Brendan,

    I followd your instructions. Still no luck :(   Unplugging & plugging the display in the only workaround that works for me.  What a pain in the A$$ for a nice new system & OS!

    Wednesday, August 11, 2010 7:16 PM
  • I'm having this problem with 3 monitors on a Dell Precision T1500.  My main monitor is analog using an adapter.  I have 2 more monitors using a splitter.  The main monitor went black after an RDP session from home, even though the light is on. 

    I tried a hard boot of the PC and it still won't show output on that monitor.  It is the main monitor and it is already identified as #1.  I used the blind login approach and got in, but only my #2 and #3 monitor are showing output.  I used some blind fishing for the display window (since it opened on #1) and eventually grabbed it.  Then I made my #2 monitor the main, and got the task bar back on it. 

    Now no matter what I do I can't get #1 to come on.  I've tried disabling it and renabling it.  I've tried physically unplugging it.  I've disabled it and then unplugged it, and verifed this in the settings, and then plugged it in.  Windows recognizes it fine, and lets me extend the desktop to it but guess what?  Still no output on it.  Just a black screen with a green power light taunting me.

    I have smart cards disabled via the settings.  Still no luck.  I'm going to try unplugging #1, rebooting, using just the 2 & 3 for a bit, and then plug 1 back in (which will become 3 at that point, since 2 and 3 should become 1 and 2).

    This happened before weeks ago and I hate that I can't remember how I fixed it. 

    Tuesday, August 31, 2010 2:14 PM
  • Hot Fix available for this issue!

    Symptoms:

    Consider the following scenarios:

    Scenario one

    ·    On a computer that is running Windows 7 or Windows Server 2008 R2, you enable a screen saver.

    ·    You enable the On resume, display logon screen option for the screen saver.

    ·    In Power Options, you set the Turn off the display option and the Put the computer to sleep option to the same length of time. Additionally, the length of time that you set is longer than the time that you set for the screen saver to trigger.

    ·    The time for the Turn off the display value elapses and the display is turned off automatically.

    Scenario two

    ·    On a portable computer that is running Windows 7 or Windows Server 2008 R2, you enable a screen saver.

    ·    You enable the On resume, display logon screen option for the screen saver.

    ·    After the screen saver starts, you close the lid of the portable computer.

    In both scenarios, the computer is still running. However, you cannot turn on the display by using the keyboard or the mouse. You may be unable to turn on the display until you force the computer to restart.

    Note When you set the Turn off the display option to less than 10 minutes, the Turn off the display option automatically changes to the value of the Put the computer to sleep option.

     

    Cause:

    This problem occurs because of a race condition between the CSRSS thread and the WinLogon thread.

     

    http://support.microsoft.com/kb/976427

     

    • Proposed as answer by TopFuelWeimar Tuesday, September 07, 2010 1:27 PM
    • Unproposed as answer by Craig Humphrey Wednesday, October 26, 2011 8:42 PM
    Tuesday, September 07, 2010 1:27 PM
  • I get the fix but when I run Windows6.1-KB976427-x86.msuI get: The update is not applicable to your computer. Is this only for SP1. Not sure I want to put SP1 on my computer?
    Sunday, September 19, 2010 4:05 PM
  • That hotfix says not applicable for me as well. It's because winlogon.exe is already newer then the hotfix version.
    Thursday, September 23, 2010 3:18 PM
  • I'm seeing the same thing.  I've posted feedback on the KB/hotfix page.

    The KB article talks about both RTM and SP1 versions of the DLLs, but then the hotfix only contains the SP1 version.

    Thursday, September 23, 2010 9:22 PM
  • I have one computer having this problem and the hotfix does not want to install.

     

    Sunday, October 10, 2010 7:39 AM
  • Now to find an easy way to report this to MS, without incurring a charge...

    ROFLMAO! You hit the nail on the head there. I am having a similar issue but you get to a point where it's like "who cares? MS will never see the feedback anyway".

    And even if they did, like when the entire world told them to stick Vista where the sun doesn't shine, they still won't write a single line of code to fix it.


    Just trying to get value-for-money for the $20,000 worth of your products I support...
    Monday, October 11, 2010 3:29 AM
  • I also have this exact issue using a Dell Precision T5500 with ATI 8500 card.

    My main display is on display port so this is not limited to DVI. Actually both my DVI connected screens wake up even though they are black and only display my mouse pointer.

    Will try to power settings solution but it's not ideal.

    Thursday, October 28, 2010 7:50 AM
  • I am seeing this as well.   I have a 3 monitor setup.  When I remote desktop from home at night using 2 monitors my third monitor stops working.  It appears to be in standby.  I can still move my mouse over onto the monitor but I can't see it.  So it's as if the computer thinks that the monitor is there but it isn't displaying anything and will not come out of standby mode.

    Today I saw the problem as well logging in remotely from my laptop (1 monitor).  

    Thursday, December 16, 2010 10:58 PM
  • I can also confirm the same issue on Win server 2008 R2 running on a desktop with an ATI 2400HD Pro.  I can get them working again by simply bringing the device manager up in an rdp session and click "scan for new devices".  It wakes up both monitors.
    Wednesday, January 05, 2011 6:24 PM
  • Same problem here:

    • Windows 7 Enterprise
    • Dell Optiplex 980
    • ATI Radeon HD 3450
    • 2x Dell 2007FP connected via DVI

    To cause the problem I need to leave my computer long enough for the displays to sleep (15 minutes), RDP from elsewhere, and then return to the computer. The second display will wake up (and only have the cursor on it) but the primary remains asleep. I can get it to wake up using the blind login process.

    I tried, all to no avail:

    • manually replacing the default "Generic P&P monitor" monitor drivers with a Dell driver for Vista
    • swapping the plugs the two monitors are plugged into - curiously the plug marked '1' identifies as '2' and vice versa
    • installing the hotfix mentioned earlier in the thread - it was "unavailable at this time"
    Good to hear I'm not alone. Will keep monitoring (no pun intended!) for a solution.
    Tuesday, January 25, 2011 2:44 AM
  • Throw in my hat with the same problem. Running Win7 x64 Ultimate Edition on a Dell Precision 690 with dual monitors, a Samsung and Dell. It has an ATI FirePro V3700 video card that I recently installed, which is when the problem appears to have started. Currently, my workaround is to have a shortcut on the desktop that restarts the PC after I have finished with my RD session. Would be nice to have a fix for this soon as it does not appear to be an isolated problem.
    Tuesday, January 25, 2011 4:39 PM
  • Something I found interesting today. We have users who use their laptops to RDP into their main boxes. All the main boxs run Win7 and have multiple monitors.  This issue was not occuring for one user until I upgraded his laptop from Vista to Win7.  It seems to be a Win7 to Win7 issue.

    Anybody seeing this issue with XP or Vista RDP'ing to Win7 machine?

    Friday, February 04, 2011 7:38 PM
  • Yeah, I'm getting it XP RDPing to Win7
    Friday, February 04, 2011 11:38 PM
  • Just to add to the mix, this failure/misbehaviour often also involves losing theme settings (e.g. glass OFF, sounds OFF).
    Working in C++ reminds me that some things are almost as illogical as Microsoft
    Friday, February 11, 2011 12:38 AM
  • have you tired to RDP from a mac client?

     

     

     

     

    Windows 7 Tutorials
    Friday, February 11, 2011 1:23 AM
  • Hmm... haven't seen this.

    Has anyone else seen a loos of theme?

    The closest I get, and likely it's unrelated, is that my Stream based distributed.net client gets lousey performance after I RDP into my Win7 box (that is running distributed.net). I suspect this is due to the hardware accelleration context changing when you RDP in (e.g. Aero and hardware accelleration get turned off, since they don't make sense (hardware accell) and aren't supported (Aero, yet)

    Sunday, February 13, 2011 10:34 PM
  • my Stream based distributed.net client gets lousey performance after I RDP

    You may be right there. Another cause of this would be that the rig you are remoting to is maxxing out the outgoing connection. In Australia where we have $%^&-all outgoing bandwidth on a home connection this is always a problem. The outgoing gets so clogged that any downloads etc. taking place at the remote end are held up.


    Working in C++ reminds me that some things are almost as illogical as Microsoft
    Tuesday, February 15, 2011 2:48 AM
  • Tee hee... this is not a bandwidth thing.

    My Win7 PC is down in my man cave downstairs and I often RDP from my WinXP laptop, upstairs, over my wireless and wired network.

    "Stream" in this case is ATI/AMDs GPGPU programming language for writing applications that use the graphics cards GPU to do tasks that might normally be handled by the CPU.  Distributed.net uses this to crunch through RC5-72 encryption...

    As an aside: my home bandwidth is 17Mbit/s download 900Kbit/s upload, which is pretty good amongst NZ broadband, even amongst ADSL2+ (which I think has a 24Mbit/s download 1Mbit/s upload limitation).

    • Proposed as answer by b48u Wednesday, October 26, 2011 11:18 AM
    • Unproposed as answer by Craig Humphrey Wednesday, October 26, 2011 8:41 PM
    Tuesday, February 15, 2011 3:48 AM
  • I had the similar problem and the following workaround helped me

    Try pressing Ctrl + Alt + Delete and select one of the options there. It mostly forces your monitor to refresh and there by giving it a life.

    Thursday, March 03, 2011 9:09 AM
  • I think you've missed the point.

    The point is that your primary monitor (where the login icons, etc appear) remains blank and doesn't wake up when you bump the mouse, press a key, press CTRL-ALT-DELETE or anything else, except unplug it's (usually) DVI cable and plug it back in.

    So you can't see the options (or anything else) that might appear when you press CTRL-ALT-DELETE

    Thursday, March 03, 2011 8:17 PM
  • Same problem, Dell Optiplex 755, remoting from home, Win7 to Win2k8R2, ATI Radeon 2400 Pro drivers.

     

    Friday, April 29, 2011 6:49 PM
  • If you are still having problems, this might help.  ATI installs a service in their newer driver releases named something like "ATI External Event..."  We have found that by disabling this service it solves all kinds of odd issues we were having the monitors re-arranging, flipping and rotating, and powering off but not back on.  Give it a shot.

     

    DaveJ

    Friday, June 24, 2011 6:29 PM
  • Worked for me w/ Vista 64 Ultimate.. Thx.
    Wednesday, September 28, 2011 1:02 PM
  • I'm having the same problem running windows vista ultimate with ONE DVI monitor and an nVidia Geforce 8400
    Wednesday, October 19, 2011 2:53 PM
  • Had this problem on my HP Z200 w/Windows 7 Professional and dual monitors.

    Seems to be under control now. Here's what I did:

    1. Swapped the monitor cables.

    2. Updated the display adapter driver.

    3. Changed power options so monitors stays on.

    Many thanks to Brendan Hamilton, Craig Humphrey and others in this thread.


    babu
    • Edited by b48u Wednesday, October 26, 2011 9:25 AM
    Wednesday, October 26, 2011 9:22 AM
  • Thanks guys!

    Making sure screen 1 was the Primary solved this for me.
    I had 2 as primary and 1 to the right of that. Switching those DVI cables made no difference so manually switched the monitors over after I adjust the displays to the right order.

    (This can also be adjusted in the ATI catalyst control center)

    Now when RDPing in only one screen goes black, instead of both.

    Thanks to Brendon and Craig, was bugging me for ages.

    Dan

    Monday, January 09, 2012 8:51 PM
  • All I did was set the RDP client to send Window's control keys to the server, and the simple act of that change caused my dual-displays to come to life when I next connected.  I didn't actually have to send any keys to wake the screens up.

    Ian.

    • Edited by ian kb Thursday, May 24, 2012 8:00 AM
    Thursday, May 24, 2012 7:57 AM
  • Same problem. Windows 7 x64, ATI 5750, monitor 1 (default) - DVI, monitor 2 - VGA.

    After using RDP my monitor 2 displays a black screen.

    To solve this problem i'm used a Catalyst Control Center. I'm just created an AMD Eyefinity group and then deted it. Monitor 2 began work properly.

    Thursday, November 15, 2012 1:28 AM
  • This problem started for me about 3 weeks ago.  I'm on a Dell Latitude E6500 Dual core, win7 x64.  I've been running this system with external dual monitors attached to a port replicator for better than 2 years without any issues.  And "I didn't change anything".

    Same deal... if the power settings kick in and disable the monitor, the main display will not show after "waking".  I can CTRL-ALT-DEL do an invisble login thing, do that a dozen times or so, and eventually get the main display going again.  I assumed it was the external display.

    I'm at my parents place this week and hooked up a spare external monitor to the VGA port on my notebook so that I could have 2 displays (notebook panel and external Analog VGA display).  And low and behold... SAME problem...upon waking my NOTEBOOK display behaved the same way as my external digital (primary) display... a Dozen CTRL-ALT-DEL and fiddling with the extend/disable projector settings and I could get back in.

    I discovered last night that unpluging the Analog display WOULD cause the primary notebook display to immediately paint.

    I saw a post in this long thread about screen savers that triggered a memory though.  3-4 weeks ago, I disabled my screen saver/auto log out setting because I was onsite at a customer doing presentations.  My screensave/auto log out is set at 10 minutes.  My power settings are set at 15.  So my screen saver logged me out BEFORE the power settings kicked in and did the same.  And THAT is what changed.

    I re-enabled my screen saver with logout at 10 minutes, power settings still @ 15 minutes and I have been unable to reproduce the problem since...

    So...if you have this, enable a screen saver with auto logout before the power settings kick and perhaps your blank screen woes will go away...they did for me.


    There's someone in my head and it's not me - Pink Floyd

    Wednesday, November 21, 2012 6:13 PM
  • Distressing that this is still an issue. I was hoping I would just find it was fixed in a service pack one day.

    I've not tried upgrading the ATI drivers, but the workaround I use is as follows:

    - on the PC with the blank screens after RDP - hit WINDOWS-P-P (nb: hold Windows key down for both 'P's)

    - this will change the monitors over to only display on the second monitor.

    - at this point (for me) I can see the login prompt, and hitting WINDOWS-P-P-P gets me back to dual screen with everything working

    YMMV

    Wednesday, December 19, 2012 2:33 AM
  • Thanks a bunch Craig! 

    For the similar problem of can't get my work Desktop PC (running win7) to respond after RDP'd from home at night, your suggestions in step #1 & #2 fixed the problem. Luckily, I didn't have to muck with drivers/etc.

    Regards.

    -DS

    Thursday, October 31, 2013 2:34 PM
  • Hi all,

    I'm having the same issue with my home PC, and as of yet, haven't seen a fix for it from Microsoft.

    I'm currently running an Intel i5 (2nd gen), 16Gb DDR3 RAM, Windows 7 Ultimate 64-bit (fully patched), nVidia GTX460, Asus P8P67-M PRO REV 3 motherboard, dual screens.

    I've often found that when I remote desktop into my PC from my work laptop (which runs Windows 7 Professional) I'll get home later in the day to find that both monitors are powered off - in that the orange standby light is on - and I can't wake them with the mouse or keyboard.

    I've tried turning off the screens' power-saving mode, so the GFX card will never turn off my monitors after, say, 10 minutes, but that had no effect.

    Occasionally, I find that the act of RDP'ing into the machine will cause the screens to go black right away, and the RDP session itself doesn't log into Windows fully. Other times, the RDP session will work fine, but when I'm physically sat back at the machine, the screens are black, but I can still successfully log into the machine again via RDP.

    It's become quite frustrating. Updating video card drivers and Windows itself hasn't helped, and having to unplug the monitors, and plug them in again, to get things working is rather inconvenient (as you may as well work on the physical machine if you have to be there to fanny about with DVI cables!)

    If anyone has any updates on this, that would be great.


    Monday, November 18, 2013 4:21 PM