none
Windows 7 Hangs When Opening a File with Explorer.exe

    General discussion

  • This is a strange bug I found on accident. I accidentally opened a .zip file with Windows Explorer (explorer.exe) and explorer.exe began spawning copies of itself and bringing the CPU usage to 100%. I couldn't kill them all and had to log out to make it stop. I tried this again on a PDF and a TXT file and the same thing happened.

    Has anyone else had this problem?
    I like my coffee black just like my Metal
    Monday, July 06, 2009 8:07 PM

All replies

  • Hi Mvied,

    Do you have a representative file that others could use to attempt to reproduce the behavior?

    Are you running Win7 x86 or x64?
    Tuesday, July 07, 2009 1:33 AM
  • Hi,

    I am using the Evaluation Version, 6.01.7137.

    I have noticed that explorer.exe will always pre-read any driver i open. So when i go to use a external terrabyte, it hangs and hangs.... lags and lags. Im not sure microsoft actually want to make money anymore~! After reading alot of posts of variouse websites, it seems that windows desires to know the full contents of video applications before it executes.....

    Is there a methood to prevent this....also, can anyone from microsoft explain why they would design something this anoying?
    Saturday, July 18, 2009 12:59 AM
  • I know this thread is old, but this bug made it into release.

    In addition to maxing out your processor and filling up your RAM, explorer.exe highjacks that file extension permanently. After associating a file extension with explorer.exe, there is no way to change it back. You can't set it through Control Panel, you can't edit the registry, and I haven't found anything else that will fix it. You will have to re-install Windows 7 in order to fix your file extension.
    I like my coffee black just like my Metal
    Thursday, November 12, 2009 5:38 PM
  • File associations can be changed by going into the search box and starting to type "change the file type associated with a file extension".

    Problems encountered with Explorer such as you describe are often times associated with third-party code that Explorer loads, such as Shell Extensions or AV components. Consider using programs like ShellExView or Autoruns to control what Explorer loads, or Process Explorer and Process Monitor to investigate what Explorer.exe may be doing.
    Saturday, November 14, 2009 3:44 PM
  • Well, I hate to say it but I tried both of those things. I can post screenshots if necessary.

    Also, I tried this on a fresh install of Windows 7, but also have it on my home computer cause I tried it with Jpegs and now I can't change it. Very annoying, lol.

    EDIT: Screenshots!


    This is where you should be able to change the file association, but the button is missing.





    Here is the place where it should be in the Control Panel. Note that the .jpg extension is not there.





    And lastly, here is the 'Open With' menu where you should be able to check the box for 'Always use the selected program to open this kind of file.' But of course, you can't. I even tried to edit the registry to enable the button, but it was enabled. On any other kind of file, nothing is wrong.




    I like my coffee black just like my Metal
    Thursday, November 19, 2009 12:25 AM
  • Any difference if you boot into safe mode, or try a different user account?

    Is there any common software between the two systems?
    Thursday, November 19, 2009 3:59 AM
  • Just an update, a friend of mine somehow figured out how to fix it. He said there's no documentation online, but he figured it out. I have tried it on both machines and it does indeed fix it.

     - Run Registry Editor
     - Browse to \HKEY_USERS\S-1-5-21-(random numbers with dashes)\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\(whatever file extension is broken, i.e. '.jpg')\
     - Delete the folder called 'UserChoice'

    After this, the file extension goes back to it's default association and everything is fine! I never looked in this folder because in other Windows OS's, this is not where file associations were stored.

    Anyhow, thanks to all of this who helped! Hopefully people who run into this bug will be able to solve their problem.

    I like my coffee black just like my Metal
    Thursday, November 19, 2009 6:00 PM
  • Good to hear you were able to get to the bottom of it... Thanks for sharing what worked for you!
    Friday, November 20, 2009 1:54 AM
  • This is a pretty shocking bug and is not 3rd party related as MS would have you believe.

     

    I was desperate not to log off so I executed the following code in C# to rescue my drowing PC, I had 984 explorer instances running, interestingly though it would not break through 1000 even though more were being spawned, some sort of limit was being reached.

     

    foreach (Process p in Process.GetProcessesByName("explorer"))
    { 
      p.Kill();
    }
    
    Process.Start("explorer.exe");
    

     

    I can also confirm that the registry hack fixes this bug. 

    Sunday, January 23, 2011 11:09 PM
  • You can outcome this kind of error by creating a reg file from a text file. first make a new text file: copy the text below. Windows Registry Editor Version 5.00 [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\explore] "MultiSelectModel"="Document" [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\explore\command] "DelegateExecute"="{11dbb47c-a525-400b-9e80-a54615a090c0}" @="%SystemRoot%\\Explorer.exe" then rename the file to error.reg double-click this file and voila the explorer is running again.... Enjoy...
    Wednesday, February 09, 2011 1:43 PM