locked
cannot preview image files (JPG, TIF, etc.) on network shares RRS feed

  • Question

  • Hi folks, Here's one I've been living with for a few years.

    I have associated Paint Shop Pro 7.04 with image file extensions (JPG, TIF, etc.) on my 64-bit Windows 7 Home Premium SP1 notebook (a Gateway P-7811FX) and can preview any image file on either local or removable hard drives just fine (cell phone, USB, c:, etc). (BTW, Windows is up to date as of 8:45PM 1/13/2012.)

    I have a Netgear WGR614v9 wireless router (latest firmware) to which I have a NAS (a Buffalo LS-W1TGL) hard-wired to a router port. Browsing files and basic operation of the network is flawless (eg, I can print from the Gateway to my HP 5550PS, play music files with Windows Media Player on the Gateway stored on the NAS, etc).

    However, when connecting to a virtual network resource (here specifically the y: drive on my NAS) I see the filenames and the icon for PSP associated with the file, but no preview (selecting large icons just make the PSP icon bigger). I can read/write to these drives but cannot preview any image file.  Previewing works fine for non-image files such as word documents, PDF files, or excel spreadsheets stored on the NAS.

    So far it sounds like a no-brainer issue with the old version of PSP, right? Well,wait, there's more...

    Here is the kicker: If I change the extension association to another graphics app such as Windows Paint, I get the same results. I can preview image files on local and removable drives but not the virtual drives.

    This is my third forum folks. Hope the master minds behind the curtain can tell me what's wrong. I am convinced it is something simple (registry entry?) so let's see what you can come up with.

    Puzzled in central Florida, Phil


    Phil Rastocny
    Saturday, January 21, 2012 10:27 AM

Answers

  • A couple of other things to check:

    First, open Folder Options and make sure the "Always show icons, never thumbnails" option is deselected.

     

    Second, open gpedit.msc (only if you have Professional, Enterprise, or Ultimate) and make sure thumbnails are not disabled there.

     

    • Marked as answer by Niki Han Monday, January 30, 2012 3:14 AM
    Monday, January 23, 2012 2:25 PM

All replies

  • Which ports do you use for sharing? Port 445 is the minimum but legacy 137-139 ports enable visibility of shares.

    Regards

    Milos

    Sunday, January 22, 2012 6:13 PM
  • Ok, you're a bit over my head here. Tell me how to check this and I'll get back with you.
    Phil Rastocny
    Sunday, January 22, 2012 6:22 PM
  • For image previews on a network drive, Windows creates a hidden thumbnail file named Thumbs.db.  This is normal behavior on Windows based shares.  If you don't have the Thumbs.db file, you will not be able to preview the files via Windows Explorer.  Other file types such as Word docs, text files, etc don't require the use of the Thumbs.db file.

    What is the underlying file system of your NAS?  I have seen instances where Linux based NAS devices that have the physical drives formatted as ext3, but yet provides shares to Windows' clients via CIFS exhibit similar issues.

    • Proposed as answer by Niki Han Monday, January 23, 2012 6:05 AM
    Monday, January 23, 2012 12:31 AM
  • Looks like it is an XFS filesystem but I have found something else quote interresting.

    As you suspected, browsing the share with Windows Explorer shows the files and the thumbs.db files are in fact missing.

    However, invoking "net use" from an admin CMD window shows the drive status as "unavailable".

    Thoughts?

     


    Phil Rastocny
    Monday, January 23, 2012 1:39 PM
  • A couple of other things to check:

    First, open Folder Options and make sure the "Always show icons, never thumbnails" option is deselected.

     

    Second, open gpedit.msc (only if you have Professional, Enterprise, or Ultimate) and make sure thumbnails are not disabled there.

     

    • Marked as answer by Niki Han Monday, January 30, 2012 3:14 AM
    Monday, January 23, 2012 2:25 PM
  • FOUND THE PROBLEM and you folks got going! It was the tumbs.db file that got me thinking as to where I saw it - or a reference to it.

    I am using AusLogics BoostSpeed to defrag my registry.

    In System Tweaks >  Windows Explorer > Thumbnails, there is an option to "Do not display thumbnails in network folders"

    Automatic Optimization selects this box. Deselecting it got it working. Not sure what it did internally to do this, but it did fix my problem.

    I vaguely recalled this syntax when setting up the application but your suggestions triggered my memory. Thanks! 


    Phil Rastocny
    • Proposed as answer by RobertPearman Tuesday, March 27, 2012 11:13 AM
    Monday, January 30, 2012 3:28 AM