Intermittent network connection drops (Vista Ultimate SP1)




    I am a technition at an office supplies store and have had a number of computers come in with similar issues to the one I am having. This is becoming so common I decided to post about this issue on the forum.


    my network connection is intermittently dropping entierly. It can only be restablished if I:

    -reset my router for factory defaults (massive pain as I use a static IP for specific ports to be forwarded).

    -disable my connection, restart machine, enable connection.

    -reset my static IP and reset my router to factory defaults.

    -release/renew my router IP then reset my computer.


    I should note that every time this problem happens which is a few times a month, all my other computers which includes 3 win XP machines and 1 CentOS 5 Linux Server all retain their connections and do not experience any network issues. all my machines are going through the same router, a linksys WRT350n gigabit w/storage link.


    I have gone through 3 WRT54G and a wired BFSR41v3 (if thats the right model) before using the WRT350N, this same issue has been experienced on just this vista computer on all routers. By all this I conclude the issue is not with the router for the following reasons:

    -network connectivity is retained on all other machines.

    -it does not matter which router is being used, this issue will happen regardless.


    I am using IPv4 since nothing seems to support v6 at an internal IP of because I have about a dozen items that need to be forwarded to various internal IPs. This happens on either of my 2 wiered or my wireless connections which are all onboard on my MOBO. I only keep one connection active at any time and only use one network cable, if I need to switch ports I do so physically then enable the new one, disable the others.



    -I have uninstalled and reinstalled my wiered and wireless network drives.

    -I have updated all my network drivers to the most current versions.

    -I have reset all settings for all network related devices on my machine and the router.

    -I have set the settings back to using static IP and DNS.

    ___DNS is set to the routers IP

    ___secondary DNS is set to the routers active DNS (I do not remember it off hand).

    -I have tested all different routers and even gone direct wired.

    -I do not use ANY firewall software of AV software, they only get in my way.


    keep in mind the network issue only seems to affect the vista machine only.

    Due to the fact the divers have been downgraded, upgraded and restored via the vista driver disk that came with the MOBO this cannot be a hardware issue, the hardware is functioning as at times Ive been connected for 2 or 3 months without an issue, then the issue returns. Additionally I can always access the router, I have total internal network connectivity and can connect to other computers too, just nothing outside the internal network.


    I have discussed this at length with customers and cooworkers who have all, after investigation, experience the -exact- same symptoms I am experiencing on my computer when this is happening. I have exhausted all the solutions I can think of, also the fact that a number of others are reporting identical issues. Therefore I can only conclude the problem appears to be with how Vista handles networks internally.


    Please, I need a solution to this issue, its driving me out of my mind.





    I forgot to mention that I also upgraded the WRT350n firmware, no change, then factory reset firmware to default, again no change to the solution.

    Sunday, April 27, 2008 9:07 PM

All replies

  • Anyone?
    Monday, April 28, 2008 10:05 PM
  • Hello,


    Can you provide more information about this issue? When you observe connection drops on the Vista machine run following commands and paste the output here?


    "ipconfig /all" and "route print"




    Tuesday, April 29, 2008 11:21 PM
  • Will do, when it happens again I will post the results here.
    Tuesday, April 29, 2008 11:43 PM
  •  Pentazer wrote:
    Will do, when it happens again I will post the results here.


    Also can you include information about your linksys router? model,firmware version and when you hit this issue does it have IP Address from ISP etc...



    Wednesday, April 30, 2008 12:07 AM
  • It has not happened yet so I will instead post information about my router to see if that may be part of the issue.
    Saturday, May 10, 2008 6:56 PM
  • I have nearly the exact same problem on Vista home and a brand new HP dv9810us laptop.  The wireless access was fine until SP1 and then I keep getting "Connection has been reset".  The frequency is enough to almost make it unusable and my wife has to keep hitting refresh/try again multiple times.  This problem happend with both IE7 and Firefox with the same frequency and affects establsihed TCP connections.

    I installed wireshark and took a look.  What I saw was the vista laptop issuing a tcp RST to the server.  Everytime the "connect has been reset" occurs there is a TCP RST sent.  This wireless router/ISP combination has 4 other laptops on it with XP, Fedora8, windows 2000 and none have problems except the vista machine. 

    It did work fine until the SP1 update came.

    I only see the machine once per week but next time I will try wired and separate wireless PC card to rule out machine/driver specific issues.
    Tuesday, May 20, 2008 4:54 PM
  • I have a Vista machine at home, a 1 week-old vista machine at work, and two friends with vista laptops.  Every single one of us frequently (a few times a day) loses internet connection with our respecive routers, but maintain local access to the local network.  After a few mins, the connection with the internet is re-established.  I have read many messageboards looking for *someone* who has found a fix.  no luck yet. 

    As was mentioned above, my XP computers NEVER lose their wireless connections when my Vista machine drops the connection.  This is annoying at best.

    I dont have a solution, but you are not alone, and I will be sure to post back should I stumble upon one.
    Thursday, May 22, 2008 4:23 PM

    "Access: Local and Internet" goes to "Local only"

    System will be running fine for many hours, then internet connectivity is lost.

    It may come back shortly, or it may stay down for a long time.

    Connection is through cable ISP, not wireless.


    Lately it has been coming back in about 1-2 minutes, with no action on my part.



    I think we should all write the same Trouble report to Microsoft Help and Support.

    Maybe a flood of tickets will get their attention.


    Free SP1 support is here:



    Saturday, May 31, 2008 3:23 PM

    I reported this issue to Microsoft Vista SP1 Help And Support.

    This is their answer:


    Based on my experience, this issue is probably caused by the ISP, not the client side issue. At this point, I recommend contacting the ISP for more information.


    Monday, June 09, 2008 10:51 PM

    That could be true most of the time but I have vista ultimate and will go local only.  The only way I can get my internet connection (not wireless)  again is to system restore a earlyer point.  Also when i try to go into my router to release the DHCP ( I like to do it from there ) but i will not even let me in.  ipconfig /release, /flushdns, /ipconfig renew has no effect, and nither does unplugging the power to the router and modem. But all other computer connected to the router work perfectly. It's really makeing me mad.  Just got the computer and got vista just because it can do directx 10.  Hope Microsoft fixes the problem



    Based on my experience, this issue is probably caused by the ISP, not the client side issue. At this point, I recommend contacting the ISP for more information.


    Tuesday, June 10, 2008 3:16 AM
  • I am having this issue too.  Microsoft seems to be ignoring it but I have found it around more and more.  Anyone interested in putting together a press release or media release?  I think they are ignoring what seems to be a clear-cut Vista issue. 


    The, its your ISP quote is infuriating after reading tons of posts of people's ISPs being unable to locate the problem on their end.




    Friday, June 20, 2008 4:42 AM
  • I am having the same issue on my Vista PCs. I own a technical services company and we have all experienced this on many different ISPs and many different PCs by all of the big name manufacturers. My customers use a wide variety of routers. The ONLY common factor is the Vista. My peers tell me they too are experiencing the same exact issue.


    It is ridiculous for my technicians to have to spend up to ten minutes of wasted time dealing with a Vista initiated drop from the Internet. I am charging my customers by the hour and I am forced to give discounts and eat the loss of time each time this happens. I thought a couple of my techs might be using the drops as excuses, but I am assured by their supervisors this is not the case.


    I hoped SP1 would fix the issue. It has not. Going back to XP and telling all my business customers not to change yet. Over 16000 PCs under management will not be recommended for upgrade because Vista is disgustingly bad for business. Given one good option over Microsoft and I would be switching everyone and screaming my joy of doing so from the rooftops.


    T. Wilkinson

    Friday, June 20, 2008 5:36 AM
  • I found this on CNET, it is interesting in that he states (offhandedly unfortunately) that his non-microsoft firewall and anti-virus were causing the issues.  Could we add to this list, to see if all of us are using extra programs on top?

    I use zonealarm and Avast!

    We could at least start building a case as to what is happening.

    Friday, June 20, 2008 2:28 PM
  • Uninstalled Zone Alarm and so far no connection drops.  I will continue to monitor to see if ZA was the issue.
    Sunday, June 22, 2008 9:02 PM
  •  Steinjr wrote:
    Uninstalled Zone Alarm and so far no connection drops.  I will continue to monitor to see if ZA was the issue.

    Here is a link to a group regarding this issue.  I hope this helps even one person who has been battling this nightmare.

    Monday, June 23, 2008 4:03 AM
  • Hi,


    I seem to be having similar problems, My config includes an ICS Vista Home Premium, an XP Pro and a 98 SE machine( all wired cat 5e). It seems my internet connection becomes stale or dormant.  Many times I'm not really disconnected but pings take really long times, so long that internet explorer gives up.  I've been trying to pin it down to the ISP... but I haven't been able to do it.  The ISP claims their cable service is perfect.  I've also been hesitant to install Vista SP1 until I have this resolved, this thread seems to confirm that SP1 won't fix it. This problem also exists when I disable and unplug the LAN NIC, so I can't isolate ICS as the problem either...


    It seems that I can't find a consistent way to resestablish the connection either.  Sometimes disabling and enabling either NIC on the ICS machine will reestablish a connection, sometimes an ipconfig /renew or ipconfig /flushdns, sometimes a restart, somtimes I do all of the above including shutting down and disconnecting power on machines and modem...  No pattern...


    BTW - I'm using McAfee security and so I shutdown windows firewall(only on Vista machine), but it seems windows firewall gets turned back on.  I also set my LAN to be private and it keeps getting switched back to public....  Here's a recurring event - 


    >Log Name:      System
    >Source:        Microsoft-Windows-SharedAccess_NAT
    >Date:          6/29/2008 1:06:20 PM
    >Event ID:      31004
    >Task Category: None
    >Level:         Error
    >Keywords:      Classic
    >User:          N/A
    >Computer:      cm1-hall
    >The DNS proxy agent was unable to allocate 0 bytes of memory. This may indicate that the system is low on virtual >memory, or that the memory manager has encountered an internal error.


    The machine is a 6 month old q6600 with 2gb ram that is basically tasked with being the network connection at this time. I also get events complaining about not being able to build the "ipv6 stack".


    From previous posts on this thread I could disable mcafee firewall and turn windows firewall on...  Not really what I want  to do... Does anybody have suggestions.  thanks in advance.

    Sunday, June 29, 2008 11:24 PM
  • Oh Yes!

    I do identify this event as "old hack" above quite frequently in Vista on my Lenovo ThinkPad T61P. Could this be caused by a system with some communications problems?

    Kind regards


    Thursday, July 03, 2008 5:42 AM
  • Same here, 2 different situations:


    Home: Wireless Network drops regularly, replaced wireless routers, checked with ISP, disabled Vista Firewall.


    Office: We are system managers with  600 users. Only 3 System managers have Vista. We use our Notebooks Wired in our domain. About 2 to 3 times a day, all connections drop. We need to restart and sometimes a cold boot to be able to access the network again. This is in a Windows 2003 domain. 2 notebooks are Sony Vaio and one is an HP 8710p, all three originally with Vista pre-installed. Problem was already there when SP1 was released. Installing SP1 has not solved the problem.

    What do we have in common? Windows Vista Business SP1 and McAfee Virusscan Enterprise Workstation Version

    Wednesday, July 09, 2008 8:01 AM
  • I'm having the same issue with vista ultimate sp1.  Dell, about 6 months old, vista preloaded.  All windows updates are loaded.  Updated onboard NIC driver from dell to latest release.  I visit this company once a week under contract and every time I come out this system is down again.  All other computers in the office (all on xp or osx) are working properly.  Every time I simply run a repair on the NIC and the internet comes back up.  Not sure if it stays up for an hour or days but when I make it back the next week its down again.  I can ping locally but can't access anything on the internet until I run the repair.  This system has no antivirus or aftermarket firewalls.  Windows firewall is disabled.  System has been scanned for malware and is clean...probably because nobody can connect to the internet long enough to mess it up Smile

    I'm not letting any of my customers touch vista, its still garbage. 

    System is a dell optiplex 745.  Broadcom onboard gigabit NIC.

    Microsoft?  Any ideas?
    Thursday, July 24, 2008 5:35 PM
  • Are the network cards  by any chance Realtek ones?  I have 2 RTL8169/8110 gigabit ethernet adapters installed and from the box with teh realtek drivers thy worked fine.  Recently they have started exobiting this issue and it seems to have been after i installed a driver update as part of Windows Update.


    Can anyone else confirm the make and modle of the card which is experiencing this intermitten conection issue.


    Regards Cass

    Saturday, August 09, 2008 1:27 AM

    Hi Cass,


    I have been having a similar issue on 2 machines, although lately this has started to settle down.  Both machines were dell's with gigabit adapters, but neither were Realtek.


    Not much help, sorry.



    Tuesday, August 12, 2008 10:17 AM

    Same problem, Vista SP1 ultimate x64 (was happening prior to SP1 as well), all other systems (xps) on the network never lose connection.

    I first noticed it on AT&T's 2wire uverse system and then on Time Warner's High Speed Internet. It usually only happens while using the browser with say facebook apps where you are continuously going from page to page (refreshing).

    The internet connection will drop, then instant messaging. I can keep another connection alive that uses a front end but that is about it.

    I can only get the connection back by restart, nothing else works. This system always is dual boot to XP, I have yet to lose connection with the same setup while in XP, only Vista.


    I do use AVAST but I also use AVAST on XP, again no issues, not until I am running VISTA. I have a linksys wireless / wired router and also had a 2 wire router / modem same issue 2 different ISPS same issue and again only with VISTA running.


    Netsh, ipv6, various other things, altered and put back no effect, no power savings on or active. updated drivers, old drivers, nothing fixes this issue.


    The mere fact that simply restarting the computer brings everything back up leads me to believe that the problem is some sort of stop in VISTA that halts all connections of a specific type once you reach a certain limit, say x # of connections in a specified period of time. I am getting so sick of this that I am considering upgrading back to XP and yes I mean an upgrade this is ridiculous.


    Not to mention the other issue I have with dual screens where my secondary monitor will start to flicker, stutter and then go out, the only fix there appears to be changing from dual view to single monitor only and back again. That one is a pain but doesn''t require a restart.


    Anyhow someone at MS must be able to replicate our common issue and give us a toggle (act like XP here)


    My 2 cents.



    Friday, August 15, 2008 7:48 AM
  • My issue was with a realtek card.  Try installing the drivers from realtek rather than the windows update.  For firewall suspects I had to uninstall my firewall software in order for the connection issues to be fixed.  It was not Vista that was causing issues in my case -and in many of the cases I have seen- so be aware that there are many other factors with the connection.  For the mcafee guys I would uninstall the firewall temporarily and see if that changes your connection issues.  With the realtek driver, try reinstalling it, which is difficult since you need the internet connection.

    In my case it was absolutely the firewall.

    Hope this helps someone.
    Monday, August 25, 2008 4:53 PM
  • I'm on the XPS 1710 using a broadcom nic. The more patches I install teh worst my problem gets.

    I have to reboot about 5 times a day because I lose my network connection. My firewall is disabled and I don't have zone alarm.


    This is driving me crazy.

     HallGS wrote:


    Hi Cass,


    I have been having a similar issue on 2 machines, although lately this has started to settle down.  Both machines were dell's with gigabit adapters, but neither were Realtek.


    Not much help, sorry.



    Monday, August 25, 2008 5:45 PM
  • I have the same problem and it shows up the most obviously when running Cisco Vpn client.  Sometimes you boot Vista and the vpn client runs with no problem.  The next time you can start vista and the vpn client service fails to run and you get 2 errors:


    "The ICS_IPV6 failed to configure IPv6 stack" under shared access


    and under WMI I get :"Event filter with query "Select * FROM_InstanceModificationEvent WITHIN 60 WHERE  TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 99" could not be reactivated in naespace "//./root/CIMV2" because of error 0x80041003. Events cannot be delivered through this filter until the problem is corrected."


    Sometimes I reboot and it fixes it but not always.  Sometimes I restart the WMI and then restart the cisco and it works again, but not always. Sometimes I uninstall the cisco software and reinstall it and it works, but not every time.  I guess this is what's called intermittent.


    This software is running on a HP Presario A900 notebook.  I have used it with no routers, with routers, no firewall, with firewall, every bit of windows security running and none running.  It doesn't seem to effect wether or not it will work.  Seems to me it's an internal Vista problem that Microsoft has to track down.  I don't have any problem running the same software on any of my xp machines.



    Tuesday, September 16, 2008 11:34 AM
  • Good Day:
    I have 25 XP machines which do not lose network access, this is the only pc that is Vista and loses connection to our network. Therefore its not a ISP issue.  I would like some help as well.

    I have Vista Business sp1. Veriton L410 Acer AMD Athlon 64x2 Dual Core Processor, 1GB RAM with 32-bit os.  We connect to a Novell 6.5 Server.

    Plz assist asap.

    Thank you kindly,
    Friday, September 19, 2008 7:22 PM

    [ ... assist asap.]



    I hope you are not holding your breath on this.

    Monday, September 22, 2008 11:06 PM
  • Huge bump I realize, so please don't flame me for this.

    I encountered the same issue but with Windows 7 public beta (b7000). I have a gigabit nVidia as Eth0, connection dropped without a notice, then in event manager found some references to IPv6. I went ahead and disabled the protocol and since I don't have an issue. It's weird though, because the issue appeared usually when one of the hosts connected to this gateway tried to use torrent networks.

    Not the best solution though because now I had to switch every PC connected to this one to IPv4 which was a pain to do on 40+ machines. I'm the guilty though, because I should not use the IPv6 for small networks :|

    Blaming the ISP seemingly is not viable this time.
    Monday, February 23, 2009 6:11 PM
  • Brand new HP wx4600 Workstation; came with Vista Business Downgrade to XP Pro; thought it was about time to give Vista a try and reverted system back to Vista Business; same problem as described with losing Internet connection, several times an hour; tried all the fixes above, but none resolved the problem; I see why HP sells the Workstations Downgraded to XP Pro and went back to that; probably won't visit Vista for another year!
    Monday, March 16, 2009 11:05 PM
  • The problem is clearly with Vista.  It is not hardware, extra software, or the isp's.  I have been running Win 7 beta and rc1 and have had no problems.  I just reinstalled Vista 3 days ago and its happened twice.  I have an Acer laptop and my wife has an HP Pavilion.  I have Vista SP2 and my wife SP1.  It would be nice if Microsoft would actually address this issue instead of pawning it off on everything bu there OS.
    Wednesday, July 08, 2009 2:42 PM
  • I haven't had any problems for almost a year.

    Mine started the same thing when I tried SP2 RC. I also had another issue with losing my default gateway after a re-start so, I uninstalled it and waited for the RTM. A tcp/ip reset fixed the gateway problem but, it looks like the RC did something to cause this connection problem.

    Quick question - can you do a Vista REPAIR with the installation disk like you can in XP?

    If MS can't come up with a fix soon - I might resort to that.
    Wednesday, July 08, 2009 9:03 PM
  • I have had the same problem with Vista for some time with differnet wireless dongles (thinking it was a Vista compatible driver issue) and also a 3G Mobile dongle. Vista will not stay connected but XP does. When Vista loses connection, it still thinks it is connected. Picked up from a different forum it may a a bug in ICS, just tried disabling that and now it is staying connected during the day. Anybody else tried that work around??
    Wednesday, July 15, 2009 9:57 AM
  • I agree with ddg747. I have had this same problem of repeated dropped network connections (includes LAN not just Internet) while using a WiFi connection with my laptop. The error has been described above as "The DNS proxy agent was unable to allocate 0 bytes of memory. This may indicate that the system is low on virtual >memory, or that the memory manager has encountered an internal error". The probable cause is with Vista 64 where ICS (Internet Connection Sharing) is turned ON. It must be turned OFF to rid this bug. Some programs may turn this on. Unless you need ICS on you can also disable it in Services.
    To turn off ICS simply open the Network and Sharing Center from Control Panel. Select "View Status" from your network connection listing. Then select the Properties button and then the Sharing TAB and deselect the ICS check box if it is selected. Make sure the check box underneath it is also deselected.

    To disable ICS in Services simply start Administrative Tools and select Services. Scroll down to "Internet Connection Sharing" and pan over this line to the startup type column where the word "Manual" should be found. Right click and select Properties and in the dialogue box you'll see a drop down box for startup type. Select disable from the list of options.

    I hope this helps some of you. From the sounds of it there may be more than one problem described on this page. But the one commonallity is Vista 64. My laptop is a dual boot with both Vista 64 and 32. Vista 32 (same laptop) doesn't have this problem.

    Sunday, September 06, 2009 9:53 AM
  • Have the same exact issue. Computer will work fine for 1-2 days, then loses wireless connection, will reconnect then drop immediately. Sometimes it will reconnect fast and sometimes will not connect for a day or two at a time. I have already disabled the dhcpbroadcast in regedit and computer still will not hold a connection.

    Asus P5QE Motherboard
    Intel E8200
    Linksys WMP 600N (just replaced WMP300N)
    Gskill 4gb
    Windows Vista Ultimate with all current updates
    Apple Airport Router

    I know for a fact this is not an ISP issue or router issue. I have 2 mac laptops, 2 iphones and a toshiba vista home laptop that connect and will stay connected the entire time. I have not and will not update my toshiba laptop. So this leads me to believe that this is an issue with a current update for vista. Please if anyone can help, I really do not want to format my desktop as I have nearly a TB of information on it and do not have sufficient disks to back up to.

    Thanks in advance.
    Tuesday, September 15, 2009 6:25 AM
  • I have a Dell XPS M1710, running vista home premium. Occasionally, and there's no pattern to this, the local area connection drops - this is a wired connection and gets its IP address from the router via DHCP, not using wireless.

    Right clicking the 'local area connection' icon and selecting disable does not disable it, it does nothing (I would hope that disable | enable would sort it). When I do a disable, the only way to get the network back is to attempt to shutdown, but when it gets to the 'shutdown in progress' screen after logging me off, it hangs forever, and I need to power off the machine by pressing the power button for 5 seconds. Vista then whines about not shutting down properly, thankfully every time so far it has started up again ok.

    The laptop next to me is running xp, and has *never* had this problem. XP machines for the last 6 years I've had the router have never had this problem. How a Microsoft person can dismiss it as an ISP issue is beyond me.

    I am running AVG and no firewall (router has a firewall) and this happened before installing AVG, and after, so AVG is not the problem.

    The laptop itself is a lovely piece of kit, let down by a sad excuse for an operating system. I'm not going to feed any more £ to Microsoft to 'upgrade' to windows 7 I'm afraid, so unless Microsoft can come up with some nice festive cheer and provide a free upgrade to Windows 7, this xmas will be spent upgrading to Ubuntu or OpenSUSE - would rather go through setting up Linux and having a reliable system than not knowing when I'm going to lose the network connection...

    Wednesday, November 11, 2009 9:07 AM
  • I too have had this issue on two Vista PCs.  One was a Vista Ultimate 32 wired, the other an HTPC running Vista Home Premium 32 wireless with an N+ USB wireless dongle.  The wired one worked fine for over a year pre and post-SP1, then all of a sudden it started losing it's internet connection.  The HTPC was setup last April but was just hooked up and run again recently.

    So far I have fixed the issue on both PCs.  My solution was to update the chipset drivers for the motherboards (both were Nvidia chipset boards, the HTPC was a nForce 730i board and the ohter the Ultra 790i) and also the NIC drivers.  The wired PC has worked fine for over a month now since I did that and it's on all the time.  The HTPC was just recently done but prior to that Windows Update wouldn't work and it's downloading the updates now, so I'm cautiously optimistic that it fixed the issue.

    Something to try.
    Monday, November 16, 2009 6:53 AM
  • I too have had this issue on two Vista PCs.  One was a Vista Ultimate 32 wired, the other an HTPC running Vista Home Premium 32 wireless with an N+ USB wireless dongle.  The wired one worked fine for over a year pre and post-SP1, then all of a sudden it started losing it's internet connection.  The HTPC was setup last April but was just hooked up and run again recently.

    So far I have fixed the issue on both PCs.  My solution was to update the chipset drivers for the motherboards (both were Nvidia chipset boards, the HTPC was a nForce 730i board and the ohter the Ultra 790i) and also the NIC drivers.  The wired PC has worked fine for over a month now since I did that and it's on all the time.  The HTPC was just recently done but prior to that Windows Update wouldn't work and it's downloading the updates now, so I'm cautiously optimistic that it fixed the issue.

    Something to try.

    We have a Toshiba Satellite A135-S2266 with Vista Business 32-bit SP2 that had the same problem reported here. We solved the problem by rolling back to the previous Wireless Network Adapter (we used Atheros AR5006EG - version - 28/07/2008 and rolled back to version - 14/07/2007).
    Monday, November 23, 2009 7:49 PM
  • Try disabling realtime protection in Windows Security Essentials

    I had the exact same issue on my Windows 7 64 bit install. After hours of searching to see what was causing the issue, I found that Windows Security Essentials was the problem.

    Internet started working normal again after disabling realtime protection. Since my internet worked just fine after just installing Windows 7, it's probably some update to security essentials that messed some things up.

    Let me know if this solves your issues...
    Wednesday, November 25, 2009 10:39 AM
  • Try disabling realtime protection in Windows Security Essentials

    I had the exact same issue on my Windows 7 64 bit install. After hours of searching to see what was causing the issue, I found that Windows Security Essentials was the problem.

    Internet started working normal again after disabling realtime protection. Since my internet worked just fine after just installing Windows 7, it's probably some update to security essentials that messed some things up.

    Let me know if this solves your issues...
    Did you have the DNS-proxy error and had it fixed by disabling Windows Security Essentials?
    Where is the setting for it? I have a swedish Windows 7, so I'd guess it probably is'nt called the same.
    Monday, December 07, 2009 4:12 PM
  • Same here - Toshiba Satellite, Realtek RTL8102/3 Family PCI-E-FE NIC...but in this case, went forward and installed an updated driver from Windows Update. Useful to have access to a wireless network simultaneously.
    Tuesday, December 15, 2009 4:21 PM
  • After using Google Public DNS for a couple of weeks, I find that the
    incidence of connectivity timeouts is significantly reduced, that is, by at least an order of magnitude.

    For more, see


    Tuesday, December 15, 2009 7:59 PM
  • Apologies if I'm being ignorant here, but I'm new to this forum.  Is there any way to indicate to Microsoft that there are more cases of this issue?  My Lenovo T61 running Windows Vista Ultimate is experiencing this crippling issue.  The network disconnects and reconnects every couple of minutes.  It only recently started doing this.  If I restart the machine the problem goes away for a while.  I think it comes back when I close the lid and the machine goes to sleep.  When I re-open it and the machine wakes up, the problems follow.

    There's nothing special or unusual about my machine.  In fact, that's exactly why I bought a ThinkPad.  I expected that since it is such a corporate workhorse that Lenovo and Microsoft would work hard to guarantee that issues like this got resolved quickly.  Seeing that this issue has been open and unresolved since April of 2008 (more than a year and a half so far), I'm a little worried about the level of commitment from Microsoft.

    I'm running Norton Protection Center, which came with the machine when new.  This problem only started cropping up in the past couple of weeks.  I'm unsure of when the SP1 was installed.
    Saturday, December 19, 2009 5:04 AM
  • Similar issue here with Win7- connection "hickups" every 10-30 minutes or so, but then re-connects immediately.

    I remember an Acer Aspire One (XPsp3) I owned that was _awful_ about this- every 3-10 minutes. I disabled the power management for the adapter and that fixed that problem.

    I'm trying the same in my Win7 environment- disabling "allow Windows to turn this device off to save power." My theory is some kind of message gets sent asking, "Hey adapter, are you being used right now?" I dunno.

    We will see if that works... So far so good, but it's only been a short time.

    Sunday, December 20, 2009 5:56 AM
  • Same problem here. Windows 7 Ultimate.  I don't lose internet connectivity, but I do lose local network connectivity. I have to restart to get back online - lasts for a couple hours than boom, time to restart again.  I think it has to do with Zone Alarm.  I was using Comodo with no problems, but i like Zone Alarm better and am more familiar with its functionality so once they released the free Windows 7 64 bit version I switched and the problem started.  I'd hate to switch back to Comodo but may have to if something doesn't get fixed here pretty quick. There's only so much of this I can take.
    Tuesday, December 22, 2009 8:40 PM
  • I am faced with the same issue on my LENOVO PC with SP1 installed. The TCP <RST> the tcp <reset> bothers me now for months. So we escalated the problem to HP for help. hence I'd like to pass you a e-mail received from Norbert Metzger, a big help on that issue working for the OpenVMS Competency Center EMEA at HP Services Switzerland.


    hello Sepp (thats me)

    here the Network Trace Analysis for the Ethereal Trace File you have sent to me. I have sent it to our "distributed NetBeans Engineering".


    The true cause and origin of the TCP RESETS is still unclear! However it is true that this RESET kills the FTP Controll-Connection ending in a abortive close. The origin is either the VISTA TCP STACK itself or the VISTA Firewall. It could help further isolating the problem if you can switch of the VISTA Firewall. (unfortunately this is against our company policy but we try to achive this in the next days)






    Field Update (25-Feb-2010) by Norbert Metzger:



    Hi Swapnil, (at HP distribute NetBeans Engineering)


    got another Ethereal network trace from the customer (Sepp) showing his remaining FTP problem.


    These unexpected <RESET>s from the VISTA PC aborting the FTP control connection are still around. (araound, after HP has fixed the missing password issue on a atempt to make the NetBeans client able to re-establish the network FTP-connection properly for an ongoing bulk file transfer issued by NetNeans IDE from NetBeans.Org)


    In this trace you can find 3 of them. (Frame 749, 14249 and 24553) The reason for these <RESET>s is still not clear. There is no tcp protocol error before. All frames before are correct. It could be caused by the VISTA tcp stack, or the VISTA firewall on the system.

    If the NetBeans client aborts the FTP control connection, it is using the usual three way handshake with <FIN>, <FIN> <ACK>, <ACK>. It does not do any abortive close using a <RESET> ?


    Unfortunately, the IDE NetBeans Client is still not able to recover correctly from such a aborted FTP control connection. The restart now looks  better. It can provide now the users password. But later, it does not issue a PASV command before the first command (LIST) that needs a data connection. (it could issues a PORT command as well, but the customer selected FTP passive mode). This is causing the data connection to timeout after 74 seconds. During these 74 seconds everything is waiting. After the timeout of the FTP data connection, the NetBeans Client shuts down the FTP control connection normally (<FIN>, <FIN> <ACK>, <ACK>) and  starts a new FTP control connection. This restart works fine, and FTP traffic starts again until the next <RESET> on the FTP control connection comes into play ...


    Then we have another pause of 74 seconds.


    A starter into the network trace:

    Frame   Time            Description

        34  16:12:19.78     FTP activity starts


       749  16:12:20.16     <RESET> from the VISTA system on the FTP control connection

       750                  The FTP server kills the data connection using <RESET>

       751                  The NetBeans Client starts another FTP control connection <SYN>


       767                  The FTP client issues a "list /integ1$dkb3/..." command.

                            Note, this list is in lowercase. Normally FTP commands are in

                            uppercase !

                            Before this list command a PASV or PORT command from the NetBeans

                            client is missing !!!!

                            This will cause the following data connection to timeout.

                            No more FTP traffic for 74 seconds ...

       912  16:13:34.42     The FTP server responds with "425-can't build data connection ..."

       913                  The FTP server responds with "425 device timeout"

       915                  The NetBeans client shut's down the FTP control connection

                            <FIN> <ACK> ...

       918                  The NetBeans client start a new FTP control connection <SYN>

                            This time the FTP connection comes up fine and there is a lot of

                            FTP activity until the next unexpected <RESET> from the VISTA PC

                            is seen on the FTP control connection...


     14249  16:13:50.67     <RESET> from the VISTA system on the FTP control connection

                            now the same NetBeans Client FTP restart problem can be seen

                            again, with the same 74 seconds wait ...


     24553  16:15:13.03     <RESET> from the VISTA system on the FTP control connection

                            now the same NetBeans Client FTP restart problem can be seen

                            again, with the same 74 seconds wait ...



    Despite the problem with the <RESET>s, the NetBeans Client should be able to recover from such a FTP control session disconnect, without introducing a long waiting time.


    The main problem is now the missing PASV command before the "list" command on the restart of the FTP connection.







    Norbert Metzger

    OpenVMS Competency Center EMEA

    HP Services Switzerland




    But NOBODY should forget that we have such pain because either the VISTA TCP STACK or the VISTA Firewall sends this RESET for what ever reason. In any case, sending TCP RESET during an ongoing error free working Filetransfer is just stupid bad behaviour, even more worse then disconnecting a network cable for a moment, a nornmal network can recover from. At least this was possible when we had DECnet and not TCP/IP.

    Josef Stadelmann





    Thursday, April 08, 2010 8:28 AM
  • my conclusion: "nobody from microsoft is able to help on that problem which has come to our system with Vista SP1"



    Monday, April 19, 2010 12:52 PM
  • OMG !!!  Somebody please help !!!  I am a church secretary and we run a datatbase software that requires vista ultimate... we are on a peer-to-peer network; set up basically as a home-network...  the server (where the shared program and files are located) is vista ultimate; three computers are vista home premium and another is vista ultimate.  The Home Premium workstations access the network fine - able to see this shared database program ...  the Vista Ultimate workstation, intermittantly, accesses the network..  most of the time it cannot. However, it always has connectivity with the internet.   I HAVE SPENT COUNTLESS HOURS over the past 9 months trying to solve this problem incorporating the knowledge of IT professionals.

    At any moment I may be able to access this shared program / database and then the next moment its gone - LITERALLY...  when I view the network computers, I get the prompt to enter the user log on and password - although the computer acting as the server does not have network password protection on. (I don't get this with ANY other computer on the network)

    Here's my findings but still can't make it stay connected...

    turned off power-saver management ... worked once

    restart router - may work for a minute - LITERALLY

    restart computer - may work - usually not - only stays connected for a minute

    tonight i turned off IPv6 and immediately had a connection -- lasted only for a minute

    we use Trendmicro (whom I have also spent many hours with their support)  set settings low - for home network - using their firewall (Windows firewall turned off) -  have turned it off COMPLETELY and it still doesn't help...

    User Account Control - OFF

    File Sharing ON

    -------  I am totally at wits end with this ----  it appears to be this pc-password thing (network security) or something with this ip address.....  i read somewhere that a person with same problem had an ip address established with internet but had to correct the IP address in Control Panel... ??????  what is this!

    I AM DESPARATE!  There has got to be a simple solution for this


    Tuesday, June 08, 2010 4:05 AM
  • Driver for adapter is out of date on HP & Microsoft Update Pages. Finally found program that is free to use here is web site for those with local only connection on wireless. Fixed my local only problem. I would just make sure you get only digitally signed drivers they worked best for me.

    Yes I have tried every thing in your post nancygt plus almost every blog and help sites assists I have read for the last month with no luck. Removed all my security & anti virus even used the special removal tools no luck till I found this free Driver Program.  

    Give it a try and Good luck to everyone else with this same problem.

    Thursday, July 22, 2010 8:08 AM
  • The local server in this case is not the problem.  The operating system is also not the problem.  The WindowsLive Hotmail server is experiencing too much in and out traffic causing a generic error notice [really a Windows NT processing slowdown], probably meant to scare everybody?  No, it just means that the authorization process/program needs updating [less memory] so that the WLH server can run at the speed it needs to run at without eating up so many resources, thus slowing down.  No....then tell me to my desk!
    Wednesday, September 01, 2010 1:14 AM
  • Hi,

    I've just encountered such similar issue too. It seems lthe root cause is on the vista machine.

    Kindly refer to below RFC & implement a registry tweak. I would reccomend you to upgrade to windows 7.

    Guowen Su | CCNA, CCIP, MCP, MCSA, MCSE, MCTS, MCITP, CEH | Our Goal? VERY SATISFIED Customers. If you're not...let's talk!!
    • Proposed as answer by Guowen Su Friday, May 06, 2011 5:03 PM
    Friday, May 06, 2011 5:02 PM
  • This is an old KB article, we've all tried this and many other things.


    Windows 7 no help;  the problem persists.

    Obviously, Microsoft has no intention to acknowledge and fix this.


    Window 7 Pro 64-bit

    There is no answer for so long you should not presume to Mark as Answer.
    Friday, May 06, 2011 5:47 PM
  • I must decline to agree sir as on this test platform we are experiencing same issues on all four new seperately booted non RAID Windows ultimate 32/64bit drives of Windows Vista ultimate and Windows 7 ultimate.  We are all experiencing WLHS concerns that are being worked on by professionals whom are aware.  The problem is not in the machine or the ISP here.  It's in your mind and in the WindowsLiveHotmail server which is well known to be experiencing problems which are noted and are being researched by the Hotmail team.  So what's your game?

    Monday, May 09, 2011 2:05 PM
  • All,

    This thread seems to be a blend of network problems, but I may be able to help...  (and sorry for being a "Johny come lately")


    I had some of the same symptoms many of you have, on various platforms I started getting random intermittent NIC connection loss.  Of course, the messages were a bit indirect (Domain can't be found, can load CA certs from web...), but all the problems reported jibed with a fundamental problem: LAN connectivity was lost. 

    The loss seemed to be windowed: The computer would function fine for 35 minutes, then would lose LAN connectivity for 12 minutes, then go back on working for 15 minutes, followed by a 7 minute outage.  This cycle repeated over and over.  The failures started on machines that had no other problems, and had worked fine for years.

    My platforms were mainly Dell servers (PE2850, PE850) and Dell workstations (Precision and Optiplex) running Win Svr 2003 and XP (all with latest updates and SPs).  All the failing machine had Broadcom NetXtreme 57xx gigabit NIC cards.  I did myriad tests to find the problem, but was befuddled.  If I had 2 NICs in the same machine, they would both act the same way, and this smelled like a config/SW issue.  Only replacing the NICs (or the entire PC) fixed the problem. 

    I have a solution which was 100% for me (and which may help others too).  This solution has been mentioned in other support issues in other sites, but since it was not directly mentioned here, I though I would post it.


    I had been reading about issues with Broadcom NICs running the management software and Cisco switches.  There were recommendations of removing the management software or upgrading to a newer version.  Since I really didn't need the features, I removed the management suite.  Since the drivers were bundled with the suite I suspected that my NIC would need a reinstall of the driver.  But it didn't!  After rebooting from the management removal, my hardcoded IP (for my server...) was  Apparently, the management program did a little scorched earth policy upon its removal.  When I re-entered the IP values, the NIC card came right up.  Doing this universally fixed my similar NIC issues.  Go figure!

    Hope it helps,


    Thursday, August 11, 2011 9:21 PM
  • The problem is with Vista. I have both Vista and Ubuntu Linux loaded in the same machine. The wireless network connection is quite stable when running Linux but drops intermittently when using Windows Vista.

    I got some improvement by the following process:

    1) Start > Settings > Control Panel > Power Options (the procedure may differ if you are not using using the classic start menu, but the idea is to start the Power Options)

    2) Select High Performance and click on Change plan settings just below it.

    3) Set the Turn off the display to 20 mins On battery and Never on Plugged in ... instead of 20 mins you can select a suitable time.

    4) Set the Put the computer to sleep to 1 hour On battery and Never on Plugged in ... instead of 1 hour you can select a suitable time.

    5) Now, click on "Change advanced power setting"

    6) Expand "Wireless Adapter Settings" and then expand "Power Saving Mode"

    7) Change both "On Battery" and "Plugged in" to "Medium Power Saving"

    8) Click Apply, OK, etc. then Save changes ...

    9) Close the Power Options window and reconnect to the wifi.

    I think the blokes at Microsoft messed up with the code and at maximum performance setting the adapter goes to sleep when it should stay wide awake.

    I don't know if this will help you, but it has helped me. So give it a try and let me know at [email address redacted for privacy concerns]


    Monday, June 11, 2012 3:28 AM