none
Windows 7 AIK on VM experiments, error 0x80070026

    Question

  • Hi!

    I'm doing some experiments with imagex just to try understand how does this work and how I can benefit  from it.

    The objective is to capture an image with all updates installed and with a few (~20, 30) programs installed.

    Step by step:

    1) Create two VM machines and install an untouched Windows 7 in each. Let's call it A and B
    2) On machine A install windows AIK and on windows B run sysprep, install all software and finish with sysprep shutdown + generalize
    3) On machine A mount virtual hard drive of machine B, then capture it:

    Assumptions:
    -Machine B is now E:\
    -Copied untouched W7 install CD to c:\imagex

    Command 1: imagex /COMPRESS fast /CHECK /VERIFY /CAPTURE E:\ C:\IMAGEX\sources\install.wim "WAIK1" "WAIK2DESC"
    Command 2: oscdimg.exe /b"c:\Program Files\Windows AIK\Tools\PETools\amd64\boot\etfsboot.com" /n /m /o /l"WAIKteste1" c:\IMAGEX c:\test1.iso

    4) Try to install final test1.iso with captured image in a new, clean VM

    But I got an error that is:

    "Windows cannot open the required file D:\Sources\install.wim. Make sure all files required for installation are available, and restart the installation. Error code: 0x80070026"

    ---

    What I've already done:
    - Searched for this error and for tips on search engines.
    - Tried to not use generalize option
    - Mixed up some imagex flags

    So, am I doing something wrong here? Any help is appreciated.

    Wednesday, September 15, 2010 2:48 PM

Answers