Speakers work, but headphones don't


  • Heya,

    I'm running on an EVGA NF68 motherboard with 680i chipset, onboard audio. I had this problem before downloading the most recent Realtek audio drivers, though it has only gotten stranger since then. When my speakers are plugged in sound seems to work fine, they're able to be configured, no issues. But when I plug my headphones into a different audio out port (on the back, next to where the speakers are plugged in), I don't get any sound from them. However, the computer does recognize that they have been plugged in; there's just no sound. I can remove the speakers and plug the headphones into the spot they used to occupy, with the same result. It recognizes that I took an audio device out and put another one in, but yet there's still no sound from the headphones. Prior to my installing the driver the same issues were present, but there was no indication that devices were being switched in/out. I'm positive the issue doesn't stem from the headphones themselves -- plug them into anything else and they're fine.

    I would very much appreciate any possible solution. :)
    Saturday, May 30, 2009 7:13 AM


All replies

  • Check the Speakers Properties of the device (right-click volume icon -> Playback devices -> Speakers: Realtek High Definition Audio -> Properties -> Levels) to see if anything is set low/muted:

    Speakers Properties

    Also post the result of the following command:

    wmic sounddev list brief > C:\sounddev.txt
    • Edited by Ryan Capp Saturday, May 30, 2009 8:25 AM
    Saturday, May 30, 2009 8:08 AM
  • No dice there, everything's maxed.
    Manufacturer         Name                           Status  StatusInfo  
    Realtek Realtek High Definition Audio OK 3
    (Generic USB Audio) USB Audio Device OK 3
    It's also worth noting that when I plugged the headphones into the front port -- it isn't hooked up properly and never got sound, I think I just screwed up the wiring -- the Realtek software opens a box asking "What kind of device did you plug in?", with headphones as one of the options. I don't get that when I use the rear port. But, when I ran Windows XP, I did get that choice when I used the rear port.
    Saturday, May 30, 2009 9:21 PM
  • Try unplugging the speakers from the system and just try the headphones. Maybe the drivers are muting all other ports with one device already in.
    Saturday, May 30, 2009 9:43 PM
  • Nope, nothing. :(
    Saturday, May 30, 2009 11:27 PM
  • What are your advanced settings set to in the Realtek control panel?

    Realtek - Advanced Device Settings

    EDIT: Are the latest drivers you're using the ones directly from Realtek?

    Also, I see they just put up a new driver recently; R2.25.
    Saturday, May 30, 2009 11:44 PM
  • The drivers I was using were from the EVGA website, but installing the newest ones from Realtek doesn't seem to have changed anything.

    These are my advanced settings:

    • Edited by Dodobird11 Sunday, May 31, 2009 3:40 PM
    Sunday, May 31, 2009 2:00 PM