locked
How to allow ftp.exe through Windows 8 firewall? RRS feed

  • Question

  • I had it running on Windows 7 and it worked just fine. But I can't seem to get it to work on Windows 8.

    I allowed an inbound and outbound rule for ftp.exe on _all_ ports.

    The connection itself is established but once I try to send an ASCII file, it goes:


    ftp> lcd d:\temp
    Local directory now D:\temp.
    ftp> send test.txt
    200 PORT command successful
    425 Unable to build data connection: Connection timed out
    ftp> send test.txt
    200 PORT command successful
    425 Unable to build data connection: Connection timed out

    Once I disable the Firewall for public networks, it works immediately. :-(
    Saturday, November 3, 2012 4:43 AM

Answers

  • I use NcFTP (especially NcFTPput) now and it works fine through the Windows 8 firewall - and on a command line.
    • Marked as answer by DJDoena Thursday, December 6, 2012 8:17 AM
    Thursday, December 6, 2012 8:15 AM

All replies

  • Access the following website.

    http://technet.microsoft.com/en-us/library/cc739791(v=ws.10).aspx#BKMK_9

    See: "I cannot get my FTP program to work with Windows Firewall. "


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Monday, November 5, 2012 7:49 AM
  • Unfortunately that didn't help.

    I started the ALG service as described in the article.

    I ran the ntsh command:


    netsh firewall show all
    
    Allowed programs configuration for Domain profile:
    Mode     Traffic direction    Name / Program
    -------------------------------------------------------------------
    Enable   Inbound              ftp.exe / C:\Windows\System32\ftp.exe
    
    Allowed programs configuration for Standard profile:
    Mode     Traffic direction    Name / Program
    -------------------------------------------------------------------
    Enable   Inbound              ftp.exe / C:\Windows\System32\ftp.exe

    And I still get

    ftp> open home.arcor.de
    Connected to home.arcor.de.
    220 gnftpd Server (Arcor DE - Homepageserver) [home1]
    User (home.arcor.de:(none)): <my user>
    331 Password required for <my user>.
    Password:
    230 User <my user> logged in.
    ftp> cd upload
    250 CWD command successful.
    ftp> lcd d:\
    Local directory now D:\.
    ftp> ls
    200 PORT command successful
    425 Unable to build data connection: Connection refused
    ftp> ls
    200 PORT command successful
    425 Unable to build data connection: Connection refused
    ftp>

    :-(




    Monday, November 12, 2012 5:37 PM
  • I use NcFTP (especially NcFTPput) now and it works fine through the Windows 8 firewall - and on a command line.
    • Marked as answer by DJDoena Thursday, December 6, 2012 8:17 AM
    Thursday, December 6, 2012 8:15 AM