Windows 7 Xp Mode-virtual pc Error Message, windows system32 config system


  • I am using windows 7 prof. I was using Windows Xp Mode since last 6 months without any problems, I tried to use system restore option inside windows virtual xp. upon completion of system restore i got the message sayingcould not enable integration features giving me 2 option retry or continue. If i click continue i am getting this message

    windows could not start because the following file missing or corrupt: \windows\system32\config\system

    You can attempt to repair this file by starting windows setup. Using the original Setup CD-ROM

    Select "r" at the first screen of repair.

    I tried CTL+ALT+DEL wile booting up F8 i tried all the option to recover example last good known configration, safe mode etc. all attempts filed comming back to same error message.

    Since I Installed Windows Xp Mode Option from microsoft website I do not have Cd to try to recover.

    I have desktop running xp, so i tried booted through cd seleected R followed Instruction from

    but unable to copy copy c:\windows\repair\system c:\windows\system32\config\system returning error cannot find the specified file. able to copy rest of the instruction.

    If any one could help me to solve this for me.


    Saturday, October 15, 2011 10:32 PM

All replies

  • Hi,


    This problem could be caused by " Windows XP Mode.vsv" file in the path of C:\users\[your user name]\appdata\microsoft\Windows Virtual PC\Virtual Machines. Please backup this file and remove it. Then check the issue again.


    More information about .vsv file, please refer:


    Saves the current state of the virtual machine, merges the undo disk with the parent, and stops the virtual machine from running. Saving state creates a temporary file in the same location as the virtual machine configuration files with a .vsv extension that contains state information. When the virtual machine is restored from the saved state, it returns to the condition that it was in when its state was saved.



    Hope that helps

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by jssmith252 Wednesday, October 19, 2011 2:20 AM
    • Unmarked as answer by jssmith252 Thursday, October 20, 2011 12:59 AM
    Tuesday, October 18, 2011 6:08 AM
  • Thank You For your response, unfortunately It didn't solve My Problems. I did create Another virtual pc Xp Mode. Loaded Program Back, I Don't Have All My custom Programming. That's in The virtual Pc Xp Mode That crashed, months of Programming The Backup Is In Several files in the virtual Pc. Not thinking Xp os would crash. Everything I've Tried, I Still Get, missing Or Corrupt \windows\system32\config\system. Oh, One More Thing, When I Deleted The .vsv File. Then when I open the Corrupt Xp, it does Write a new .vsv File.

    Wednesday, October 19, 2011 12:12 AM

    1.apaga la maquina virtual

    2. enciendela y apreta teclaSupr para entrar en la configuracion de la BIOS VM, ordena el booteo asegurate que este booteando 1º la unidad de cd/dvd

    3. Monta una .iso de windows xp sp3, sino utiliza el mismo disco de tu pc, asegurate de configurar eso en la configuracion de la VM

    4. Inicia la VM, la que arrancara el cd virtual iniciando disco instalacion XP.

    5. Espera a que llegue al menu donde te consulta si deseas instalar o reparar, selecciona reparar con la tecla R

    6.Ingresa los datos que te va pidiendo, ej. unidad donde esta instalad0 el S.O. XP, contraseña de administrador

    7. una vez que llegas al prompt c/:System, teclea: chksdk /r   (con eso verifica fallas en disco en SO)

    8. Una vez terminado, reinicia la maquina virtual e inicializara sin problemas.

    saludos desde chile, SUERTE !! 

    Tuesday, February 28, 2012 1:56 PM
  • As an virtual machine has worked flawlessly for more than a year, then...I experienced the same problem as jssmith252...I drilled down the path you suggested to the "virtual machines" folder, but instead of backing up and deleting the file, I right clicked the folder and used the option to "restore previous virsions"...selected a version of the folder dated for when I was certain the virtual machine was loading well...the utility said it would take an hour to restore the folder to the privious did take the full hour....the problem was fixed and the virtual machine is now working perfectly again...thanks, zhen tan, for your insight into this problem!
    Friday, January 18, 2013 7:35 PM