Devices and Printers does not display icons


  • Using a clean installation of Windows 7 RC1 Build 7100 - I am no longer able to view any icons in the Devices and Printers Control Panel.

    I have toggled on and off UAC.  When printing from an application, the one printer that was set up for before the issue occured is still avaliable to print.

    I thought it might be related to installation of McAfee - and uninstalled but that did not solve the problem.  I have seen some other posts but no solutions as of yet.

    Friday, June 05, 2009 2:52 PM

All replies

  • Valuable Logic,

    Following your uninstall of McAfee, I'd try running a System File Checker scan by entering "sfc /scannow" into a Command Prompt. This will identify and repair and corrupted or missing operating system files. If that doesn't work, you could try loading your Windows 7 install DVD while the computer is running to perform an "in-place upgrade," as if you were upgrading from Windows Vista - this, too, will re-install needed OS components, and sometimes works where SFC fails.

    Friday, June 05, 2009 9:51 PM
  • I'll try those steps - one thing I did notice - I created another user on the workstation - the new user displays all the elements in the Devices and Printers without issue.  It is definily something to do based upon a particular User. 

    This machine is not part of a domain.  The inital User is an Administrator, the second User is was also created as an administrator.

    I did find a post at one point that suggested just copying the files over from the one user to the new user - but that really doesn't fix the issue, or understand what caused it, or what is file is causing the elements to not be displayed.

    I verfied that the User Profile was an Administrator, I even removed it and set it to standard, then changed it back to Adminstrator.

    Anyone know where that Control Panel view is generated from in respect to each individual profile?  Is this just something I'm experiencing or is this an wide issue we'll probably see a fix for soon?


    Saturday, June 06, 2009 4:49 AM
  • As a note to above - from a Command Prompt - I recieve an error stating

    C:\>sfc \scannow

    You must be an administrator running a console session in order to
    use the sfc utility.

    This happens under both users I have created with administrative rights.  Suggestions?

    Saturday, June 06, 2009 4:55 AM
  • You'll need to run an elevated Command Prompt by opening it as an administrator. To do this, right-click on the Command Prompt shortcut and select "Run as administrator."

    Saturday, June 06, 2009 4:33 PM
  • Ran the Utility - no integrity issues found.  Any other suggestions?
    Sunday, June 07, 2009 4:42 PM
  • Doesn't anyone ever respond to these issues?
    Wednesday, June 24, 2009 1:23 AM
  • I haven't gotten a response to problems in other threads, so I wonder if posting here is a waste of time.

    I have the same problem - no printers listed in the Devices and Printers window, but the printers still show up in the apps as available printers.  I ran sfc - no issues.  Nothing but a vanilla new Build 7100 install here.  This problem did not exist in the W7 beta, which I was forced by MS to uninstall.

    Tried creating another Admin account, but it shows the same thing - no printers listed, although three (plus the default junk) are installed.

    I need to delete one of those printers, but without them showing up in the window, I don't see how I can.

    I'm having much more trouble with this RC than I did with the Beta, both running clean on the same (new) hardware.
    Saturday, July 11, 2009 9:06 PM
  • Weeks and months go by with no replies whatsoever to these real problems that people are having.
    Monday, August 03, 2009 10:48 AM
  • I am also having the same problem, but not with a single computer. It's every Win 7 I have on my home network. When I click on "Devices and printers" it just keep going as if it's loading but then never stops. I am not able to remove a printer profile that I have in my list at all because I cannot get to the list. It looks as if you still do not have a good answer to your issue.
    Friday, March 11, 2011 4:38 PM
  • I was having the same problem.  I found the following article:

    In it someone suggests using the printmanagement.msc.  I opened this, click start and type "printmanagement.msc" in the "Search programs and files".  In this management console I navigated down to the printers on my computer and installed my default printer, it was not showing here.  After doing this all of my devices and printers showed up in the Devices and Printers window.  Hope this helps.

    Wednesday, May 18, 2011 4:07 PM
  • Check back for my reply to Valuable Logic, Inc.  Hope that helps.
    Wednesday, May 18, 2011 4:09 PM
  • Ran p

    Ran printmanagement.msc.  Selected  my printer.  Set “List in Directory”. Now all show.

    Sunday, July 15, 2012 1:23 AM