Memory leak in Windows 7 64-bit when writing to a network shared disk.


  • This problem started around Aug 2012.  Access my network drive (NAS Seagate Go Flex Home) was not an issue before.  I could perform network backups, and copy files back and forth with no issues.


    I first detected the problem when my computer starting locking up after attempting a network backup.  I had the backup task running at night.  When login into the computer the next day, I would get out of memory errors.  Task manager would report all 6GB were in use.


    I then just tried to copy files from my local drive to my network drive. The resource monitor shows memory usage going up, but no real change in any of the processes. 

    Once the copy is complete, the memory is not returned. If I copy 26GB from local to the network drive, my memory usage grows from 1.5GB to 3.5GB.


    To get the memory back I I have to reboot the PC.

    The PC is a Dell Alienware Aurara ALX running Windows 7 Home premium edition 64-bit.

    Friday, September 21, 2012 10:52 AM

All replies

  • I seemingly have the same problem.  I've just switched to a NAS for backup, but so far have failed to get one to complete.  Watching the memory in Resource Monitor when the backup is running it just keeps going up until it runs out, at which point the machine becomes unusable (unable even to shutdown).  Would be an extremely serious bug if this affects all network file transfers.
    Friday, September 21, 2012 8:33 PM
  • The same memory leak occurs if you are just copying files from local disk to you network drive via explorer drag and drop.

    Saturday, September 22, 2012 3:49 PM
  • Hi,

    You may take the following steps to find the culprit.

    1. Open Task Manager

    2. Go to the Process table

    3. From the menu bar select View > Select Collumns ...

    4. Add “Handles” and “Memory (Private Working Set)” column to Task Manager.

    5. Then rank the Handles column, Memory (Private Working Set) column.

    6. Check out the processes which are at the top.

    Hope that helps.

    Tracy Cai

    TechNet Community Support

    Monday, September 24, 2012 6:20 AM
  • OK, I tried that while moving around about 50Gb worth of data to the NAS but saw little change in process memory or handles while the physical memory usage went up around 16%.  Given that my PC has 4Gb of RAM, at a rough estimate I would say it's leaking around 10Mb per 1Gb transferred (if I've got the maths correct).  For unrelated reasons (the onboard NIC was only 100Mbps) I've also changed network card between the time I originally noticed the problem and this test, so it's unlikely to be a driver issue.
    Monday, September 24, 2012 6:31 PM
  • Here are the results. I copied about 10GB from my local disk to the network drive.  The memory usilisaion went from 1.5GB up to 2.3GB. But does not drop back down once the file copy (drag and drop) has completed. I am adding screen shots from task manager, and resource monitor from before and after the file copy.

    Task Resource And Manager before and after filecopy to network drive.

    Tuesday, September 25, 2012 2:43 AM
  • Hi,

    I suggest you to test the issue in Clean Boot and Safe Mode.

    Also, try this:

    Paged pool leaks when you map a network drive and then disconnect it frequently in Windows 7 or in Windows Server 2008 R2

    Tracy Cai

    TechNet Community Support

    Tuesday, September 25, 2012 8:34 AM
  • Hi Tracy,

    I ran the same test with a clean boot, and no additional services.  I mapped the network drive, and copy 12Gb of files from local dick to network drive.  The memory leak was still present.  It may be related to Explorer, and svchost.

    See attached screenshots.

    And after the copy

    Wednesday, September 26, 2012 3:04 AM
  • Hi,

    For a test, when the memory leak occurs, end the explorer.exe process and then restart it and see the result. Will it release the memory?

    In the Task Manager, select New Task (Run…) from the File menu.

    The Create New Task dialog box displays. Type “explorer.exe” (without the quotes) in the Open edit box and click OK. The Taskbar, desktop, and other components of Windows are restored.

    Meanwhile, please disable all the third party plug-ins in Explorer.exe via Shellviewer.

    Please Note: The third-party product discussed here is manufactured by a company that is independent of Microsoft. We make no warranty, implied or otherwise, regarding this product's performance or reliability.

    Tracy Cai

    TechNet Community Support

    Wednesday, September 26, 2012 7:28 AM
  • I have exactly the same problem. I am working with SyncBackPro and making a backup to a Lacie Big5. Working with Windows 7 64bit. When the backup is running, it just keeps going up until it runs out, at which point the machine becomes unusable (unable even to shutdown).

    Wednesday, September 26, 2012 11:21 PM
  • Hi Tracy,

    I have made another test this time with a large (about 50GB) file transfer from local to network disk.  Looks like explorer is not the culprit.  Memory usage on the system claims about 5GB.  No processes show a memory increase that would reflect this.  It must be going into the kernel, or drivers (see attached screen shots of results after the transfer).

    It may be time to apply the kb/2647452 fix you suggested earlier in this thread.

    Friday, September 28, 2012 12:43 PM
  • I did actually bite the bullet and try out the hotfix and it has definitely improved things - some of the time.  I tried a few file transfers, and sometimes the memory stayed static and other times it seemed to rise up - not as seriously as before, and I wasn't being particularly scientific in my tests.  Then the acid test - backup with system images turned on.  It definitely got further, there's one image of >200Gb that appears to be complete, but the system started to die while making the second image.  Unfortunately it was unrecoverable by the time I realised what was happening so I couldn't check for any rogue processes.  Still, it seems like an improvement.
    Friday, September 28, 2012 4:31 PM
  • I have installed the hotfix.  The memory leak is less than before, but is still present.  I can copy more data to the network disk before memory leak renders the system unusable.

    Saturday, September 29, 2012 2:43 AM
  • Hi,

    I have the same problem as well. I have 16Gb of memory and there is a leak when copying file to my NAS or internet cloud service.

    The hotfix slows the problem down, as other users have said.

    Is there any update from Microsoft on this issue? When will it get fixed?

    It means I cannot run updates overnight as the PC becomes unresponsive or crashes.

    Monday, October 01, 2012 2:59 PM
  • I am having the exact same issues.  I am trying to backup about 250GB to a Synology NAS drive.  I have run my PC out of memory using both the Synology backup software, and the Win7 backup software.  I have yet to get a successful backup completed.  The only way to recover the PC is a reset w/the power button; you can't even shut down with the start menu.  I can copy files manually to the NAS with no problems (my copy job was about 15GB).

    I can't wait for the fix for this.

    Tuesday, October 02, 2012 3:31 AM
  • I also notice a side-effect of this memory-leak.  Once I rebooted the PC, I had corrupted file records on C drive, which were resolved by running a full chkdisk in C.  The file records were probably corrupted by the logging of the backup software when the PC ran out of memory.  I suggest you run chkdsk on your systems too.
    Tuesday, October 02, 2012 10:08 AM
  • Hi Tracy,

    Are there any additional fixes being developped to address this issue? The hotfix you mentioned previously has helped, but not enough.  Working with a network drive is not really feasable with this issue.

    Friday, October 05, 2012 11:54 AM
  • Bob,

    I have the same problem where it also started some months ago. I noticed Win7 Prof Backup and Restore was locking up after several hours of trying to perform a backup to a Network drive. I did all of the above. I also noticed that I have an enormous amount of iPhone backup files = 2kbyte each. this makes up about 50,000 files of the 100,000 files to be backed up. Not sure if this is contributing to the problem but I'm running out of ideas.

    Monday, October 08, 2012 1:00 AM
  • Hi,

    Do you notice that there is the botton under the Windows Task Manager, it is "Show processes from all users".

    When I check them in the "before status" or "after status", I could see you only show the user of "robert" but not all the processes.  When you click the "Show processes from all users", you can check the changes from System to see which memory is increasing faster of all memories.

    Then, Check this process to see where it belongs to. 


    Annie Gu

    Monday, October 08, 2012 9:30 AM
  • Hi,

    For me, under processes in Task Manager, the image name that the memory belongs to is Systm (NT Kernal & System). The Handles just keep on growing. This is with and without the hotfix mentioned in an earlier post.

    The problem manifests itself most when opening and closing a large number of files when I backup my PC data to a cloud service or copy data from a nework drive (e.g. Synology NAS) to a USB 3 backup drive.

    Monday, October 08, 2012 5:39 PM
  • Hi,

    I have run another test this time with show processes from all users.  Test was copying 8 files total (30GB) from local disk to network drive  (NAS Seagate Go Flex Home).

    Tuesday, October 09, 2012 10:36 PM
  • Hi,

    I can see the svchost.exe is increasing, but I think it is normal because the SMB connection need to use this process when you copying files. But I could not find any other process which is growing faster?

    Could you please list them to check out which process grows fastest?



    Wednesday, October 10, 2012 9:29 AM
  • Annie,

    On my system I only see the System process having a growing number of handles, but there is no single process that grows in terms of memory despite the total memory used growing.

    Wednesday, October 10, 2012 9:39 AM
  • Hi, Maybe you can try to use the RAMMAP ( to capture two snapshot for analysis, to find out where is the memory.  Also, you can try to upgrade the NIC driver, disk driver for a test, since based on my experience, lots of memory leak issue caused by the outdated driver.

    Meanwhile, usually system won't release the memory which doesn't in used immediately, please try to monitor for longer. 

    “Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.”

    Thursday, October 11, 2012 8:30 AM
  • Hi I'll check the rammap.  The last test I ran was started in the morning.  It took about 1 hour to run, and the memory task manager, and reouce monitor captures were done about 6 hours after the start of the file copy to network drive.  (5 hours after completed of the copy).  No action was done on the PC between the end of the copy, and the screen captures.
    Thursday, October 11, 2012 7:48 PM
  • Here are the results of the rammap.  I captured at the start of the copy, and the endm and 7hrs after.  The system was idle during the 6hrs.  The network drives were always mapped, but no applications were running during the 7 hrs after the the copy completed.  As for windows updates, I keep the system updated.  The only updates not yet installed were thoses published this week.

    Friday, October 12, 2012 10:55 AM
  • I just tried a network backup on another Win 7 64 bit PC and same problem - the memory leaks and then the PC becomes unstable.

    The PC has a very different hardware spec, i.e. motherboard, disks etc.

    Microsoft - I know and understand why you seek information via the user forums, but copying 100Gb from one PC to another across a network clearly demonstrates the problem.

    Could someone from Microsoft try it out and report back to the forum? Would only take a couple of hours ....


    Friday, October 12, 2012 4:19 PM
  • I encountered exactly the same problem...

    Both high end ASUS PC (WINDOWS 7 64bit Ultimate, 12 GB RAM, INTEL Network Adapter) and SONY Laptop with Windows 7 64bit Home (4 GB RAM, Gigabit LAN).

    Both Windows Explorer, MS RichCopy, TeraCopy and Extreme Copy fail.

    Files habe different sizes up to 1 GB.

    Target is a Windows file share on the Network (Gigabit, NAS).

    After a few hundred GB the Windows systems get stuck or reboot in uncontrolled manner or one time showed a blue screen and rebootet. In Windows Task Manager the value for promised memory increases up to nearly the size of the physical memory. Defining a large swap file does not improve the situation.

    The problem exists since a few months. Before it worked fine. Must have been introduced by an automatic Microsoft online fix.

    Microsoft, please provide a fix asap ! Thank you.

    Thursday, October 18, 2012 8:12 AM
  • Hi,

    Looking to all those screens.
    Do we all have McAfee as antivirus?

    Thursday, October 18, 2012 11:21 AM
  • Hi,

    Yes I have McAfee and I note on their forums much talk about a memory leak. This is summarised best at:

    The formal response from Mcafee about a memory leak found on the above link is:

    The bottom line is that this is a Microsoft problem caused by their fwpxclnt component not releasing memory consumed in Win 7, SP1 (Windows 8 doesn’t experience this problem). Despite the fact this problem is *caused* by a Microsoft component, we are adjusting our software to compensate.  The change has been made and will be included in the next release of the Core components – I still haven’t heard back which specific version number that will be in, nor do I yet know when it will be released.

    So if this relates to the same problem described in this forum then the fault lies with Microsoft.

    The bad news is that it seems that neither Mcafee or Microsoft has yet to to issue a fix to these issues.

    Thursday, October 18, 2012 5:36 PM
  • Yes, I have/had McAfee as well.  However, having identified it as the cause of some other problems I have now switched to Norton.  Now when I try to make a system image I'm not seeing the same memory leak problems.  So it appears that there are two problems here, one solved by the hotfix and one related to the McAfee issue (which they suggest is also an OS issue).  Fingers crossed there isn't another bug hiding somewhere.
    Saturday, October 20, 2012 11:57 AM
  • HI, I have just switched to Bitdefender and no longer have any issues, noting that I also have installed the hotfix as well.
    Saturday, October 20, 2012 12:30 PM
  • Hi,

    You may take the following steps to find the culprit.

    1. Open Task Manager

    2. Go to the Process table

    3. From the menu bar select View > Select Collumns ...

    4. Add “Handles” and “Memory (Private Working Set)” column to Task Manager.

    5. Then rank the Handles column, Memory (Private Working Set) column.

    6. Check out the processes which are at the top.

    Hope that helps.

    Tracy Cai

    TechNet Community Support

    then what? seeing what is at the top of the list doesn't solve anything especially when you have generic processes like w3wp.exe there? Also, is a handle still the same as 30 years ago? Is each one of those an open file? If so, why does mssearch have over 4,000 files open at a time? and why does Outlook have over 3,000 files open?
    Tuesday, January 08, 2013 6:02 PM