none
HomeGroup

    General discussion

  • I am unable to set up a HomeGroup. Windows starts the wizard, but when I finish my selections of what to share, it says I have to be at a "Home" location in order to set up homegroups.

    This in spite of the connection I'm on already being designated a "Home" connection in the Network & Sharing Center.

    I don't have any other Win7 computers at the moment, I merely tried to set up a HomeGroup out of curiosity. Since I can't submit a feedback report from within Windows 7, I thought I'd mention it here.
     
    Wednesday, January 14, 2009 7:41 AM

All replies

  •   I too am having the same exact problem.  I tried everything, changing the firewall from home to work to public even though the error message says to set up the homegroup you must have the firewall set to home.  I also read that if a homegroup is set up, it will only work between win 7 machines.
    Wednesday, January 14, 2009 12:32 PM
  • I'm also having the same problem. I filed a bug, but not sure if public beta testers are taken seriously enough ;)

    https://connect.microsoft.com/feedback/ViewFeedback.aspx?FeedbackID=397075&SiteID=647

    Wednesday, January 14, 2009 5:53 PM
  •  Out of 3 systems, I only have problems like this on one. For some reason, windows 7 must think it is connected to either "work network" or "public" which it isn't.

    update... I ended up clearing the homegroup on all three systems and started from scratch. The system that I could not create or join on, I went into the registry editor, and in the subkey: "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters\" I added  D-word, DisabledComponents with 0xffffffff to disable all IPv6 components. Restarted the system and did a ipconfig to make sure IPv6 was off. I then went back and changed 0xffffffff to 0 to enable ipv6 again. Afterwards, I was able to join the homegroup although I have another problem. All three systems are connected but when I go to homegroup in windows explorer, my other network locations do not show under homegroup. 

    Homegroup is a nice idea but windows 7 is not ready for it. Windows needs a check feature to make sure permissions, along with everything else is in order before it can be used.
    • Proposed as answer by Delerius Friday, January 16, 2009 9:25 PM
    Friday, January 16, 2009 2:48 PM
  • I have 3 machines with the same problem as well.
    Friday, January 16, 2009 3:13 PM
  • Thanks for your questions, this is a known bug in the OS. We have reported the issue.
    Microsoft MVP - Group Policy
    Monday, January 19, 2009 2:31 PM
    Moderator
  • Thanks. Not to hijack the thread, but I've had problems reporting things like this using the Feedback tool. Is this supposed to work for all testers, or only for members of the private beta on Connect?
    Monday, January 19, 2009 2:34 PM
  • Feedback tool only included in some distributions. So if you downloaded from public beta site, it can't be used.


    Microsoft MVP - Group Policy
    Monday, January 19, 2009 2:50 PM
    Moderator
  • That explains it. It still seems incredible to me that Microsoft doesn't want feedback from people using the public beta (I thought that was the primary purpose of releasing one in the first place), but at least now I don't have to wonder why I can't get it to work.

    I've disabled the feedback tool on my install accordingly.
    Monday, January 19, 2009 3:27 PM
  • if you are having this problem, are you showing error 1001 in event viewer?
    Monday, January 19, 2009 11:10 PM
  • FlowMaN said:

    Feedback tool only included in some distributions. So if you downloaded from public beta site, it can't be used.


    Microsoft MVP - Group Policy


    I'm sorry can you clarify this? I downloaded the BETA and all of my versions have the feedback tool. Does this mean that all the feedback I am sending is not going anywhere?
    Thursday, January 22, 2009 5:04 AM
  • is there at least a work around this network/homegroup problem so i can share files?  it seem i can usually get small files threw, but big ones never make it....
    Friday, January 23, 2009 4:03 AM
  •  Go to Control Panel > All Control Panel Items > Network and Sharing Center. You will see, "view your active networks". Right below that you will see one of the three, Home Network, Work Network or Public.  If you click on the name set it to "Work Network". After you do that you should be able to share files like you did with vista...

    Friday, January 23, 2009 4:10 AM
  • ive tried that, but doesn't seem to help any, and every time i restart it goes back to 'public'.  and when it does decide to stay on work or home, sharing is intermittant at best

     

    when i do switch my local nic to work/home, it usually says 'windows could not set the network settings' but then changes it anyway.

     

    i have two nics, one for the adsl modem, one for the home network, and i use ics.

    Friday, January 23, 2009 5:00 AM
  • Please enable IPv6 protocol on interfaces which connected to your home network. IPv6 is required for Homegroups. :)
    Microsoft MVP - Group Policy
    Friday, January 23, 2009 10:31 AM
    Moderator
  • FlowMaN said:

    Please enable IPv6 protocol on interfaces which connected to your home network. IPv6 is required for Homegroups. :)


    Microsoft MVP - Group Policy


    thanks!  that appears to fixed all the instabilities i had with file and internet sharing on my home network.  in vista i always disabled it as i was using all local ips (192.168.0.x) and did the same in win7.
    Saturday, January 24, 2009 2:33 AM
  • For the record, that did not work for me. I do have IPv6 enabled (I have globally routable IPv6 addresses at home) and no dice.

     

    Saturday, January 24, 2009 5:06 AM
  • The only way that I was able to get HomeGroup working was to reinstall and choose "create a homeGroup" in the setup.  Everything worked and my entire network was discovered.  Note during the attempt to create a HomeGroup after installation, I was still able to establish a Remote Deskto Connection with other computers on the network (W7 to XP pro).
    Saturday, January 24, 2009 4:26 PM
  • although mine is working, i ended up just sharing a driectory.  although it did let me create a homegroup after i enabled ipv6 (only one computer running win7 so far).  the important part is the network is stable now, and i can use it, transfer files over it, and share internet.

     

    one odd thing is when every i restart, the local nic defaults to public, but even though i have told the firewall to block file sharing on public network, the shares still work.

     

    network screen capture
    Saturday, January 24, 2009 4:33 PM
  • that feedback section is, I think, meant to be for feedback about the connect website. I realize people post about w7, but I don't think MS intended it that way. Too bad, because it's a much better place to post bugs (as opposed to ask for help) with options for other users to validate or not, required fields with steps to reproduce the error and so on.
    cyanna
    Sunday, January 25, 2009 2:28 AM
  • The home group is not needed for sharing!

    Where are you supposed to enter the password on the Vista or XP PC who don't have this feature?

    Just enable sharing the same way you did in Vista/xp. And disable IPv6, it slows all internet browsing to a crawl.
    cyanna
    Sunday, January 25, 2009 2:33 AM
  • cyanna said:

    The home group is not needed for sharing!

    Where are you supposed to enter the password on the Vista or XP PC who don't have this feature?

    Just enable sharing the same way you did in Vista/xp. And disable IPv6, it slows all internet browsing to a crawl.
    cyanna


    Of course, the pre-HomeGroup ways of sharing are still available. HomeGroup does not work with prior versions of Windows, nor with non-Windows operating systems (like Mac OS X or Linux.)

     

    Disabling IPv6 is poor advice. The only reason IPv6 would slow things to a crawl is if IPv6 is broken on your LAN, thus causing timeouts followed by a fallback to IPv4. For the majority of users, this doesn't matter either way today as most networks are not currently IPv6-capable, but over the next couple of years, that will likely change.


    Tuesday, January 27, 2009 4:23 PM
  • Please read my post again. IPv6 slows internet browsing, not LAN connections. Despite MS's documentation, in both Vista and W7, as long as IPv6 is enabled the network stack is configured to try and establish an IPv6 connection first. That means that for the majority of users there will be an extra delay as Windows looks for IPv6 connectivity.

    On a LAN you might actually prefer IPv6 because of the improvements in security, better QOS support, more efficient use of bandwith. But these differences will only be noticeable on larger networks with server shares, distributed applications and so on.

     

    Please note that this is not something specifically wrong with Vista or W7. Firefox is also known to have trouble resolving IP addresses with IPv6 enabled (in the browser's configuration I mean). And there's nothing wrong with IPv6 either, it's just not implemented widely enough yet for the benefits to be apparent.


    cyanna
    Tuesday, January 27, 2009 8:41 PM
  • My experience has been that that only occurs if IPv6 is actually configured on the interface. Sometimes, this happens if e.g. a local router gives out IPv6 addresses even though it has no upstream connectivity.

     

    If it occurs in spite of no global IPv6 address being assigned to the computer (e.g. link-local addressses in fe80: space only) then that sounds like a bug.

     

    In my case, I have IPv6 configured (for Internet access too, not just LAN use) and both my browsers (I use Firefox 3.0.5 and IE8RC1) connect instantly. They do lookups for AAAA and A records seemingly simultaneously, and instantly fall back to IPv4 if there is no IPv6 record available.

    Now, in those cases where an AAAA record exists but the IPv6 address it gives is unreachable, that does cause a timeout. But that's expected behavior, and usually indicates a network configuration error somewhere along the way.

    Of course, for a router to give out IPv6 addresses it's unable to route is certainly a network configuration error. :)

    Wednesday, January 28, 2009 4:24 AM
  • I struggled with trying to set up a home group until I ran across this in Windows Help and Spport under What is a homegroup?:

    [This content is preliminary and subject to change.]

    A homegroup makes it easier to share files and printers on a home network. You can share pictures, music, videos, documents, and printers with other people in your homegroup. Other people can't change the files that you share, unless you give them permission to do so.

    Share files and printers easily with a homegroup

    When you set up a homegroup, you select the libraries and devices that you want to share. You can prevent specific files or folders from being shared, and you can share additional libraries and devices later. You can help protect your homegroup with a password, which you can change at any time.

    Using a homegroup is one of the easiest ways to share files and folders on a home network, but there are other ways to do this. For more information, see File sharing essentials.

    Notes

    • Computers must be running Windows 7 to participate in a homegroup.

    • Homegroups are only available on Home networks.

    For more information about homegroups, see Windows HomeGroup: recommended links.


    After reading this I set up a workgroup (which already existed on my other 6 computers) and everything works just fine.  Also, when I installed Windows 7, it detected my Windows Home Server and using the connector software on the server, it setup a connection and an icon for shared files and did backups without a problem.

    So, my solution is, use WORKGROUP and forget HOMEGROUP.  Everything works fine except for my three copies of Vista that still suffer from incompatible software and lack of hardware drivers and now  they are probably lame ducks.  I think Microsoft owes something to everyone that bought Vista and Vista Certified Software and Hardware with exceptions and exclusions in fine print on the bottom or backside of the box.

    Oh, one more hint, set your netork location to WORK for a workgroup or to HOME for a homegroup (see related links in Help and Support).

    Steve1916

    Monday, February 02, 2009 5:22 AM
  • Monday, February 02, 2009 2:41 PM