Configure Static IP, Default Gateway and Subnet Mask in WAIK


  • Hi,

    I want to know how to configure mainly the default gateway and subnet mask in my unattend.xml using WAIK. I know it is donw under TCPIP component but i dont know how to input say for the subnet and for the gateway. Any guidance would be great!


    Michael Vowles

    Thursday, February 09, 2012 12:41 AM

All replies

  • I have since figured this out, read: my problem now is i need technicians to be able to enter this information as we dont have a DHCP server and we are using domain accounts on the machines to be deployed. So the answer file needs to be edited in say audit mode to enter this into the answer file.

    Thursday, February 09, 2012 1:01 AM
  • I have configured a workaround for this problem as well but now the default gateway isn't added to the network settings i looked at the log file under Panther\UnattengGC\setupact which displays:

    012-02-09 17:50:02, Error                        [NETIOUGC.EXE] TCPIP: Failed parsing route prefix '\0': 0x57.
    2012-02-09 17:50:02, Error                        [NETIOUGC.EXE] TCPIP: Consumer 5 REJECTED the value named 'Prefix' (under '0') with status 0x57.
    2012-02-09 17:50:02, Error                        [NETIOUGC.EXE] TCPIP: Error processing values under '0' registry key: 0x57.
    2012-02-09 17:50:02, Error                        [NETIOUGC.EXE] TCPIP: Error while processing the the '0' registry key.
    2012-02-09 17:50:02, Error                        [NETIOUGC.EXE] TCPIP: Failed to add the constructed route table entry to the stack: 0x57.

            <component language="neutral" name="Microsoft-Windows-TCPIP" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" versionScope="nonSxS" xmlns:wcm="" xmlns:xsi="">
                    <interface wcm:action="add">
    					<identifier>Local Area Connection</identifier>
                            <ipaddress wcm:action="add" wcm:keyValue="1"></ipaddress>
                            <route wcm:action="add">
    I'm really starting to run out of ideas on this.

    Thursday, February 09, 2012 11:13 PM
  • I think the  <prefix>\0</prefix> should be  <prefix></prefix>
    Wednesday, October 03, 2012 1:11 PM