none
Error code: 2@01050001 and disk management errors RRS feed

  • Question

  • Actually there are 2 problems but I think they are connected:
    1) While connecting usb-stick to computer I don't get a drive letter for it. Instead there is a error message in log:
    "Failed to open device \Device\Harddisk3\Partition1. Error code: 2@01050001"
    2) I have a ntfs partition on other hard drive which I cannot also access (Does not have a drive letter)

    What I tried so far:
    Under computer management: "Change drive letter.." I get: "The operation failed to complete..is not up to date..try to refresh.."
    Tried to format usb-drive: I get "An unexpected error has occurred. Check error log..restart.."

    Of course I have refreshed it, restarted CM and computer. Keep getting the same errors.

    I also contacted local (Estonian) technical help desk about it. They said, they only offer support to 32bit Vista. Very nice indeed. No one told me that while I was buying VistaSad

    I searched the net for these problems. There are people with same problem, but I did not find any solution for it.

    Would someone please help us with this?

    OS: Vista Home Premium x64 (up to date)
    MB: Abit AN8 32x
    Monday, April 7, 2008 1:23 PM

Answers

All replies

  • Hi,

     

    The error code 0x01050001 means: ERROR_INVALID_FUNCTION, which is just a general information. Could you post the detailed information of the error log with Event ID?

     

    It seems that some system files are corrupted. Make sure your system was not infected by virus.The best resolution, I think, would be to restore the system from a working system restore point.

     

    Thanks.

    Wednesday, April 9, 2008 7:00 AM
  • Hello!

    Restoring to some restore point would not help I think, because I do not remember it ever working. Before I installed my final version I installed Vista on same computer twice (was just playing around) and I remember it working on 1 occasion (I did see the other ntfs partition). So it should work (it's not hardware support problem).
    I ran antivirus scan and PC seems to be clean.
    As for detailed information: Is this enough?

    System


    - Provider



    [ Name] VDS Basic Provider 1.0


    - EventID 9



    [ Qualifiers] 49664



    Level 2



    Task 0



    Keywords 0x80000000000000


    - TimeCreated



    [ SystemTime] 2008-04-10T18:27:18.000Z



    EventRecordID 30793



    Channel System



    Computer cleo



    Security
    - EventData



    \Device\Harddisk3\Partition1



    2@01050001
    Any other information that I can provide You to help me?

    Here is a screenshot from my dev-manager.  There are some unknown devices. 1 is creative gameport (which is not anymore supported as I understand) and the others are partitions on other hard drives.
    Some of them are linux partitions but one is ntfs.
    When I try to update the driver for it it, I get "Generic volume" "The system cannot find the file specified" (screenshot).
    Here is the screenshot from my disk management.
    I ran "sfc /scannow" and it gave me: "Verification 100% complete.Windows Resource Protection found corrupt files but was unable to fix some of them."
    CBS log is here.


    Thursday, April 10, 2008 9:36 PM
  • Hi,


    It looks like an known bug in Windows Vista. Please read the following KBs and install the hotfixes to see if they help.


    Error message when you try to install a new hardware device on a Windows Vista-based computer: "Windows encountered a problem installing the driver software for your device"
    http://support.microsoft.com/kb/940199/en-us


    If you reconnect a removable storage device to a Windows Vista-based computer, Windows Vista cannot find the removable storage device
    http://support.microsoft.com/kb/943986/en-us

     

    Thanks.

    Friday, April 11, 2008 8:37 AM