Age Of Empires 2 Problem


  • "Could not initialize graphics system. Make sure that your video card and driver are compatible with DirectDraw."

    I've tried everything, all the compatibility options, nothing works. I've also tried downloading DX 9. How can i fix this problem?


    My graphics card is a ATI Radeon HD 4200.

    Saturday, December 11, 2010 8:49 PM

All replies

  • Do you use the latest ATI drivers?

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter
    Sunday, December 12, 2010 12:29 AM
  • I think I tried it once, downloading it as I write this, will post if it works, or not.
    Sunday, December 12, 2010 1:55 AM
  • Didn't work. Anything else?
    Sunday, December 12, 2010 2:04 AM
  • Hi,


    To resolve this problem, we could try the following methods to check the result:


    1.    Turn on the Run in 256 colors display setting. The Run in 256 colors display setting is on the Compatibility tab in the program.


    2.    Create a new shortcut:


    1)   Right-click the Age of Empires II or Conquerors shortcut, and then click Delete.

    2)   Go to Age of Empires application folder, right-click the Empires2.exe or Age2_x1.exe file, and then click Create Shortcut . 

    3)   When you are prompted to create the shortcut on the desktop, click Yes. 

    4)   Close all the windows. 

    5)   Right-click the newly-created shortcut, and then click Rename. 

    6)   Type Age of Empires II or Age of Conquerors , and then press ENTER


    3.  Perform a clean boot.


    Meanwhile, I would like to share the following link with you:


    Fixing game performance problems


    Also, you could go to Age of Empires support for further help:


    Age of Empires Solution Center


    Hope it helps.


    Alex Zhao

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, December 15, 2010 9:08 AM
  • I did the steps 1-3 listed (including the clean boot) and still get the error message upon startup of the game.

    Wednesday, December 15, 2010 12:38 PM

    As you can see others have it, too. Read some of the links, maybe they help.

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter
    Wednesday, December 15, 2010 2:30 PM