none
WiFi randomly disconnecting RRS feed

  • Question

  • Good day,

    I have had this new desktop computer for 2 weeks. Ever since I assembled it, I have been experiencing random WiFi disconnections with a frequency of about 2 disconnections per day. After this happens, I have to manually reconnect to the WiFi network.

    I have a laptop, an iPhone and an iPad in my home network, and none of them experience this weird WiFi outage; it only happens to the desktop computer.

    Whenever I get disconnected, the only clue I get is an event 6062 "Lso was triggered" in the systems event viewer.
    My motherboard is a X570 I Aorus Pro Wifi. The chipset driver together with the WiFi adapter driver and the LAN driver were installed after a fresh install of Windows 10 v1903. The drivers are up to date, and Windows 10 is up to date.


    Any idea on what the problem is?

    Tuesday, October 15, 2019 12:47 AM

Answers

  • Ok, guys. I figured it out.

    The "Lso was triggered" event will be logged every time my computer connects to the WiFi network. That is to say, whenever I turn on or reset my computer, it will connect to the WiFi network and hence, log the event.

    Additionally, this event is logged every time my access point changes channel. My access point was configured for auto-channel selection, meaning this variable could change on-the-fly based on interference and usage. This explains why I saw the "Lso was triggered" event logged many times throughout the day even though I seldom shut down or reset my computer. 

    I don't know why my WiFi adapter does this; maybe sub-optimal drivers or a bad access point; but sometimes when the channel changes and this event is logged, my internet connection is dropped for a second or so (very noticeable while gaming).

    The solution was to set a fixed channel in the access point. Problem solved. I have spent over 2 days without any internet connection drop and without the "Lso was triggered" event logged.

    • Marked as answer by RickBauer Friday, October 25, 2019 3:21 PM
    Friday, October 25, 2019 3:21 PM

All replies

  • Run windows network diagnostic tool . Simply right click on the WiFi icon on the taskbar tray and select “Troubleshoot problems” option.

    Uninstall,reinstall and update wireless network card driver.

    Open “Network and Sharing Centre” and click on your wireless connection name. This time click on the “Properties” button under “Activity” section.You will be taken to “Wi-Fi Properties” popup and click on the “Configure” button for your wireless router connection. The next popup will show the network connection properties of your wireless router and disable the option “Allow the computer to turn off this device to save power” under “Power Management” tab.


    S.Sengupta,Microsoft MVP Windows and Devices for IT, Windows Insider MVP

    Tuesday, October 15, 2019 3:58 AM
  • Hello,

    Try to perform Network Reset once:

    1. Open Settings app, click Network & Internet > Status > Network reset link.

    2. Now click on Reset button on next screen.

    3. In confirmation prompt appearing next, click Yes.

    Let us know if this helps!

    Reference: https://www.kapilarya.com/how-to-reset-network-settings-to-default-in-windows-10

    Note: Included link in this reply refers to blog post by a trusted Microsoft MVP.


    Microsoft MVP (Windows and Devices for IT)

    Windows Insider MVP

    Windows Help & Support [www.kapilarya.com]

    Tuesday, October 15, 2019 4:52 AM
  • Hi RickBauer,

    1) If you're using 2.4 GHz bandwidth of WiFi (802.11b or g), try to use 5 GHz (802.11a or ac).
    2.4 GHz is used by many home devices, such as microwave, cordless phone, Bluetooth device, etc. So, 2.4 GHz is weak, or easy to subject to radio wave interference.

    2) Please try to change channel of your WiFi router, or access point.  It will lessen radio wave interference.

    Regards,

    Ashidacchi -- http://hokusosha.com

    Tuesday, October 15, 2019 11:19 PM
  • Hello guys, 

    Thank you for the suggestions. So far I've done the following:
    - I've disabled the "Allow computer to turn off this device to save power" setting as indicated by @S.Sengupta.
    - I checked the network with Microsoft WiFI analyzer. The 2.4ghz was heavily congested whereas the 5ghz band was clean as a whistle; should be able to use any channel in this band. I configured the access point to only work in the 5ghz band with automatic channel selection. 

    That was 2 days ago. Yesterday, I got kicked out of the wireless network and the same "Lso was triggered" event appeared. 

    I just reinstalled the wireless adapter's driver and performed the network reset as indicated by @Kapil.Arya afterwards. 

    Now, I must wait and see. I'll count victory once I'm able to spend 2 days without being kicked out of the network.

    By the way, does anybody know what this "Event 6062 - Lso was triggered" means? I have not found much information online. 

    P.D. I have been having issues with my GPU which I'm also troubleshooting; do you think this might be related since both GPU and wireless adapter are PCIe devices?
    • Edited by RickBauer Wednesday, October 16, 2019 1:46 PM Added information
    Wednesday, October 16, 2019 1:44 PM
  • Since last post, I've only experienced one WiFi incident: I lost connection to the internet for one second while gaming. The "Lso was triggered" was also logged; However, I did not get kicked out of the network, which was usually the problem. 

    I'll blame this one on the Internet provider. I'll update this post once I'm able to spend a few days without any Internet/WiFi incident. 

    Friday, October 18, 2019 12:40 PM
  • Hi ,

    >>I'll blame this one on the Internet provider. I'll update this post once I'm able to spend a few days without any Internet/WiFi incident. 

    If you have any updates during the process, please feel free to post in the forum.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Monday, October 21, 2019 7:35 AM
  • Hi ,

    Just want to confirm the current situations.

    Please feel free to let us know if you need further assistance.                   

    Best Regards,

    Candy



    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Wednesday, October 23, 2019 9:48 AM
  • Hello, 

    The problem persists. About once or twice a day my internet connection drops and I get the "LSO was triggered" event. I've tried the following:
    - Re-installing the WiFi adapter driver
    - Re-installing the chipset driver together with the WiFi and the LAN adapter drivers
    - Updating Windows and drivers
    - Updating the motherboard's BIOS
    - Disabling the "Allow computer to turn off this device for energy saving" feature
    - Disabling the 2.4 band in my access point 
    - Setting both my WiFi adapter and my access point to work in the 802.11ac only mode (as opposed to my WiFi adapter working in 802.11ax and my access point working in 802.11ac)

    I attempted to disable the LSO feature in my WiFi adapter; but my model, the Intel AX200, does not have this option available. 

    Wednesday, October 23, 2019 7:37 PM
  • Ok, guys. I figured it out.

    The "Lso was triggered" event will be logged every time my computer connects to the WiFi network. That is to say, whenever I turn on or reset my computer, it will connect to the WiFi network and hence, log the event.

    Additionally, this event is logged every time my access point changes channel. My access point was configured for auto-channel selection, meaning this variable could change on-the-fly based on interference and usage. This explains why I saw the "Lso was triggered" event logged many times throughout the day even though I seldom shut down or reset my computer. 

    I don't know why my WiFi adapter does this; maybe sub-optimal drivers or a bad access point; but sometimes when the channel changes and this event is logged, my internet connection is dropped for a second or so (very noticeable while gaming).

    The solution was to set a fixed channel in the access point. Problem solved. I have spent over 2 days without any internet connection drop and without the "Lso was triggered" event logged.

    • Marked as answer by RickBauer Friday, October 25, 2019 3:21 PM
    Friday, October 25, 2019 3:21 PM