Webdav not working on Windows 7


  • Hi,

    When I try to map a network drive with webdav folder on Windows 7, I always get an error - Network name cannot be found with error code '0x80070043' . I have already tried things listed on the threads in forum but haven't been able to get webdav working on Windows 7.Things are working fine on Windows XP.

    I have also tried setting BasicAuthLevel in WebClient/Parameter in registry to 2, restarted service and computer but it didn't work.

    Can you please help me in fixing this issue?


    Friday, March 18, 2011 6:07 AM

All replies

  • Can you access the Webdav folder properly?

    I suggest you change the default NTLM authentication level in Windows 7. Locate to the following policy:

    Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\Network security: LAN Manager authentication level

    Please change “Send LM & NTLM - use NTLMv2 session security if negotiated”.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, March 21, 2011 8:08 AM
  • Thanks Arthur for your reply. I tried the LM & NTLM setting as suggested by you but still facing the same issue. I am still getting 'Network name not found' error.

    Any further suggestions would be really appreciated.




    Gaurish Sharma
    Tuesday, March 22, 2011 3:14 PM
  • W7 client is really very flaky for non-MS webdav connections. Moreover, the W7 client only accepts connection on port 80 , using a mapped drive. This is the re-introduction of a bug MS corrected with webfolders :(.
    But forget about webfolders on W7. You might get the "webdav network location" in the left pane but wil not see the folders in the right pane.

    We're waiting for more than two year now for MS to resolve this protectionist move. (protecting sharepoint). It'll take probably a new EU ruling to see any advance on this issue.


    J. Kerstens

    Monday, May 23, 2011 10:35 AM
  • 1) At first i had this problem also "network name not found" and miscellaneous errors when trying to map the webdav as a network drive.

    2) Then i tried to map this:

    and it gave me a username/password prompt. I think i made a typo and after that it threw me a couple errors and i couldn't get the password prompt again.

    3) Using the same address as above i checked the box "connect using a different username..." and entered the correct login info and the mapping went through and now i'm transferring files without problems

    I'm using Windows 7 Enterprise 64-bit

    I really thought there was nothing that could be done after my earlier experiences with Windows and Webdav, and after reading peoples posts on W7/Webdav problems, but fortunately seems i was wrong - unbelievable! :).



    Thursday, May 26, 2011 8:05 PM
  • lol!!!!


    It worked.....


    My problem was : I was able to connect webdav folder but could not open the same.

    In windows browser hierarchy, I was able to see the folders on webdav but cannot go inside them.

    By making changes suggested by Arthur worked and now I am able to open webdav folders.


    Thanks a lot Arthur....

    Wednesday, July 27, 2011 1:23 PM
  • We're experiencing a similar issue with a few hosted SharePoint sites.  In my case, I tried some of the steps recommended here and in particular dennismil's suggestions.  Oddly enough, I don't get any error when I attempt to map the network drive.  However, the drive never appears in Explorer.  net use shows that the drive is mapped, but it in inaccessible either through Explorer or by trying to directly access the drive letter.


    We're using shorcuts to get around the issue.  We found that creating a shortcut to \\\DavWWWRoot\ allows us to access the entire site through Explorer.  It just seems odd that it wont allow the creation of the drive mapping.
    Tuesday, August 09, 2011 12:16 AM
  • I have had this issue repeatedly.

    Sometimes after many attempts mapping a drive I do get prompted for login and the drive is mapped; but the following day 'Network name not found' returns.

    The 'solution' I found was to map using the command line:

    1) Open a command prompt

    2) Type in>net use W: https://etc   (where W: is the drive letter you want to use)

    NOTE: It may not work first time, but usually after less than three attempts it works for me, and you are prompted for username and password.

    Monday, April 06, 2015 11:06 PM