none
USB Ports Now Unknown Devices !!

    Question

  • My daughter didn't need her Windows XP Pro desktop (a Dell Dimension 4600) any more, so I decided to use it in my office at home.  On my workbench, I blew out scads of dust, removed a bunch of useless software, cleaned up the hard drive, ran all the Windows updates (since 2005) including SP3, and installed a few programs that I need.  Everything was working fine until I moved it to my office.  

    Now each time I boot the machine, I get six "Found New Hardware" wizards that can't find a driver for whatever unknown hardware they're looking for.  And I get six "Unknown Device" items listed under "Other Devices" in the Device Manager.  Six?  Just happens to be the number of USB ports on the PC.  All of the USB Controllers and Hubs indicate that they're working fine. 

    If I plug anything into a USB port, it shows up (with the correct name) added to the "Other Devices" list with a yellow exclamation point, and it doesn't work.  If I manually load the driver for the item, it moves from "Other Devices" to the right category, and it begins working, but the other six Unknowns are still listed.  (After reboot, the item I plugged in goes back to the "Other Devices" list.)

    Here's what I've tried so far...

    1. Rolling back to a System Restore point before I made all these changes, and rebooting. 
      -- It didn't make any difference.  Same situation, but without all the other changes.  So I undid the Rollback.

    2. Uninstalling all the offending "Unknown Device" entries in the Device Manager, and rebooting.  
      -- No change.  After rebooting, it just repopulates the list after the "Found Hardware" wizard offers to find the drivers for all six unknowns.

    3. Uninstalling all the offending "Unknown Device" entries AND all the USB controllers and root hubs in the Device Manager, and rebooting.  
      -- No change.  After rebooting, it goes right back to where it was before.

    4. Rebooting into Safe Mode.
      -- It WORKS!  The USB ports work just fine.  No "Unknown Devices" show up.  So that means that some other software that's loading on startup is interfering.  Right? 

    5. With great anticipation, after a normal reboot, using MSConfig, I unchecked all of the non-Microsoft startup programs and services (except my antivirus SW) and rebooted.
      -- Ugh! No change.  I'm not sure which Microsoft programs and services I can uncheck without causing instability, so that's where I am now. 

    Oh, I also spent and hour and 40 minutes in an online chat with Dell today, and they came up with Bupkus.
     
    Any advice would be GREATLY appreciated.  I need to get this thing working agin, so I can get the wife off my back and get something else done! 

    Thanks!

    Tuesday, September 08, 2009 3:30 AM

Answers

  • Select View/Show Hidden Devices from Device Manager.
    There may be a "ghost" install of the device. (incorrect or failed install of the driver).
    http://support.microsoft .com/default.aspx?scid=kb;en-us;298370
    • Marked as answer by Eddie Jim Wednesday, September 09, 2009 4:03 AM
    • Unmarked as answer by Eddie Jim Wednesday, September 09, 2009 4:04 AM
    • Marked as answer by Eddie Jim Wednesday, September 09, 2009 4:08 AM
    Tuesday, September 08, 2009 9:26 AM

All replies

  • Theres a lot more start up locations than appear in the MSCONFIG, try this, download sysinternals autoruns and run it to see what other start ups you have that arent listed there http://technet.microsoft.com/en-us/sysinternals/bb963902.aspx In the options tab click "Hide Signed Windows Entries" and "Verifiy Code Signitures" that will more than likely exclude anything that isnt the problem.
    Tuesday, September 08, 2009 3:53 AM
  • Select View/Show Hidden Devices from Device Manager.
    There may be a "ghost" install of the device. (incorrect or failed install of the driver).
    http://support.microsoft .com/default.aspx?scid=kb;en-us;298370
    • Marked as answer by Eddie Jim Wednesday, September 09, 2009 4:03 AM
    • Unmarked as answer by Eddie Jim Wednesday, September 09, 2009 4:04 AM
    • Marked as answer by Eddie Jim Wednesday, September 09, 2009 4:08 AM
    Tuesday, September 08, 2009 9:26 AM
  • BTW, last night I went through and removed every microsoft service and startup.  The only one that had any effect was "Plug and Play".  Does that make sense?  Does it help anyone figure this out?

    Thanks!
    Tuesday, September 08, 2009 5:30 PM
  • You need to re-enable the plug and play. you have to be careful what default services you disable, heres a good list to start http://rangrez.wordpress.com/2009/08/25/10-windows-xp-services-you-should-never-disable/  but depending on how you use the pc, thats just the start. re-enable the plug and play and that should allow the pc to read the usb. also, you might want to research more on the purpose of each service before you disable it.
    • Proposed as answer by securityguy14 Tuesday, September 08, 2009 11:55 PM
    Tuesday, September 08, 2009 5:48 PM
  • Tried running AutoRuns, but I'm not sure what I'm looking for.  Any ideas?
    Wednesday, September 09, 2009 3:05 AM
  • Tried this.  Plug and Play was already enabled, so I disabled it, rebooted, enabled it, and rebooted again.  No change.
    Wednesday, September 09, 2009 3:06 AM
  • Tried running AutoRuns, but I'm not sure what I'm looking for.  Any ideas?

    your especially looking for anything thats listed under the "image path" tab as "file not found" those are entries in the registry that are set to start, but the system cant find them. also, try downloading "unknown devices" from here
    http://www.halfdone.com/Development/UnknownDevices/  that will give you a lot more information about the entries in device manager than device manager does.
    Wednesday, September 09, 2009 3:27 AM
  • I turned on Show Hidden Devices in Device Manager.  I didn't see any "ghost" installs.  However, the Properties option on the Unknown Devices now showed that they were all tied to the ATI All-In-Wonder video card.  I reinstalled the video card drivers, and the Unknown Devices are gone!!

    Thank you VERY MUCH for your help!

    (BTW, I couldn't get the link you sent to work.)
    Wednesday, September 09, 2009 4:08 AM