none
Change Desktop Fonts From White to Black Text - Windows 7

Answers

  • How do I change the white font display under the desktop icons to black in Windows 7?

    This cannot be changed, unless you use a third party theme.

    The Desktop fonts are dynamic and designed to always be visible. This is necessary because of the varying color of a typical desktop background.

    If you select a black icon and you have a desktop wallpaper that has very dark areas, those black fonts would become completely invisible.

    The default white desktop icons display a 'shadow' around the letters. The visibility of this shadow will appear to change, depending on the background color where the fonts are located. On a darker background you will not see the shadow and on a lighter background the shadow will appear darker. This will make the fonts more visible, regardless of what color the wallpaper may be.

    You can test this effect by moving a desktop icon over a very dark area of the desktop and then moving the same icon over a very light area of the desktop.

    Hope this helps.

    Thank You for testing Windows 7

    Ronnie Vernon MVP
    Tuesday, May 19, 2009 10:38 PM
    Moderator

All replies

  • How do I change the white font display under the desktop icons to black in Windows 7?

    This cannot be changed, unless you use a third party theme.

    The Desktop fonts are dynamic and designed to always be visible. This is necessary because of the varying color of a typical desktop background.

    If you select a black icon and you have a desktop wallpaper that has very dark areas, those black fonts would become completely invisible.

    The default white desktop icons display a 'shadow' around the letters. The visibility of this shadow will appear to change, depending on the background color where the fonts are located. On a darker background you will not see the shadow and on a lighter background the shadow will appear darker. This will make the fonts more visible, regardless of what color the wallpaper may be.

    You can test this effect by moving a desktop icon over a very dark area of the desktop and then moving the same icon over a very light area of the desktop.

    Hope this helps.

    Thank You for testing Windows 7

    Ronnie Vernon MVP
    Tuesday, May 19, 2009 10:38 PM
    Moderator

  • The answer is simple:

    - Start Menu |Control Panel | System : In the System Properties window, under the advanced tab, click on "Settings in the Performance Row.
    - In the Performance Options Windows, scroll down and uncheck the "Use drop shadows for icon labels on the desktop". Click Apply, ok and close the window.
    - Start Menu | Run | desk.cpl
    - in the Display Properties windows, under the Appearance tab, click on Advanced.
    - by default it should be pointing to Desktop if not, select Desktop from the drop down menu and choose a matching color to your desktop image.
    - click Ok, Apply, ok and now your Desktop Fonts should be a dark color in contrast to your light colored background IMAGE.

    Source:
    http://www.msfn.org/board/lofiversion/index.php/t71297.html
    Friday, February 12, 2010 9:17 AM
  • Thank you!  Thank you!  I have been searching on-line for 30-minutes for a solution to this problem.  I like a pale yellow solid color background and I was unable to see the icon titles.  Microsoft is wrong if they think those white shadowed letters show up on a light background.  Your solution worked perfectly!  I now have black letters.  Thank you for taking the time to post a solution. 
    Monday, January 31, 2011 2:13 PM
  • I was able to do the first of the two steps. When I do Start-Run-desk.cpl there is no Appearance Tab and clicking on "Advanced Settings" does not bring up anything like what you describe.

    When you say "it," what are you referring to?  I happily had black lettering on older machine with Windows 7 Ultimate 32-bit. Now I have new machine with Win7 Home Premium 64-bit.

    Friday, March 11, 2011 5:32 PM
  • Sorry but...

    When i try to do that i get as far as the desk.cpl screen.  It shows no "Display Properties" tab [hence no Appearance, and no Advanced, so i never get to the "pointing at desktop" part, whatever that is.

    When i had XP i hated its color picker/adjuster, for its inconsistency and grotesque indirectness.  W7 is even worse.  I want to use Aero [W7's only plus!] but i get white text on white menus.  ARG!!

    W7- prettier than XP but otherwise....

    Thursday, June 27, 2013 3:54 PM
  • To get to the 2nd part, you can go another route: Right click on the desktop, choose "personalize", then select "Windows Color" at the bottom, then select "Advanced appearance settings".

    Then, you will have the "Desktop" first item, - play with its color and the font color will change accordingly.

    Tuesday, July 02, 2013 8:15 PM
  • Another quick option is to change the desktop to a background color, the font color will automatically be contrasting color... once the font color is what you like, then you can set the desktop background to however you had it before.. custom picture, etc. 
    Tuesday, December 09, 2014 3:19 PM
  • and they have removed this feature from Windows 10. now in Windows 10, you cannot set the background color to anything, while not able to change the desktop font color. Why WHY WHYYYYYYYYyyyy please Microsoft! why is it soooooooo forbidden to change the desktop icons' font color??????????

    SO IT IS FORBIDDEN TO USE LIGHT COLORED BACKGROUND!

    Please fix this.

    Tuesday, August 11, 2015 8:21 AM