locked
Network Level Authentication not supported on Windows 7 RRS feed

  • Question

  • I am trying to get NLA to work on our network. We have a server 2012 dc and a server 2008R2 dc and I would like to get NLA to work for the improved security. However, when I try to connect via Win7 pro sp1 (32bit) workstations, I get the error NLA not supported, and when I click on the about link on the Remote Desktop icon, it says NLA is not supported (and Remote Desktop Protocol 8.0 supported) - I have searched for information on this, and all solutions are for XP or Vista. It is supposed to be supported on WIndows 7, but its not on this system. 
    Thursday, May 9, 2013 1:22 PM

Answers

  • Configure Network Level Authentication

    1. Click Start, click Run, type regedit, and then press ENTER.
    2. In the navigation pane, locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    3. In the details pane, right-click Security Packages, and then click Modify.
    4. In the Value data box, type tspkg. Leave any data that is specific to other SSPs, and then click OK.
    5. In the navigation pane, locate and then click the following registry subkey:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders

    6. In the details pane, right-click SecurityProviders, and then click Modify.
    7. In the Value data box, type credssp.dll. Leave any data that is specific to other SSPs, and then click OK.
    8. Restart the computer to check the result.

    You can refer to this article.
    http://technet.microsoft.com/en-us/library/cc732713.aspx


    Niki Han
    TechNet Community Support

    • Marked as answer by Niki Han Thursday, May 16, 2013 2:14 AM
    Friday, May 10, 2013 3:01 AM

All replies

  • Configure Network Level Authentication

    1. Click Start, click Run, type regedit, and then press ENTER.
    2. In the navigation pane, locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    3. In the details pane, right-click Security Packages, and then click Modify.
    4. In the Value data box, type tspkg. Leave any data that is specific to other SSPs, and then click OK.
    5. In the navigation pane, locate and then click the following registry subkey:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders

    6. In the details pane, right-click SecurityProviders, and then click Modify.
    7. In the Value data box, type credssp.dll. Leave any data that is specific to other SSPs, and then click OK.
    8. Restart the computer to check the result.

    You can refer to this article.
    http://technet.microsoft.com/en-us/library/cc732713.aspx


    Niki Han
    TechNet Community Support

    • Marked as answer by Niki Han Thursday, May 16, 2013 2:14 AM
    Friday, May 10, 2013 3:01 AM
  • Thanks, that did the trick. The first key was already correct, but I had to add the second. 
    Thursday, May 23, 2013 2:41 PM