Faulting application TrustedInstaller.exe


  • On my Windows 7 Ultimate x64 machine, I all of the sudden started receiving this message in my Application log constantly:

    EVENT #









    Application Error


    Application Crashing Events





    DATE / TIME  

    6/10/2010 7:01:14 AM


    Faulting application name: TrustedInstaller.exe, version: 6.1.7600.16385, time stamp: 0x4a5bc4b0
    Faulting module name: ntdll.dll, version: 6.1.7600.16385, time stamp: 0x4a5be02b
    Exception code: 0xc00000fd
    Fault offset: 0x0000000000051c53
    Faulting process id: 0xbc8
    Faulting application start time: 0x01cb08949251dbbb
    Faulting application path: C:\Windows\servicing\TrustedInstaller.exe
    Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
    Report Id: dd96826c-7487-11df-abcf-001d09167a33


    Thursday, June 10, 2010 8:55 PM

All replies

  • TrustedInstaller is encountering a stack overflow.  ntdll.dll isn't the cause, it's just the code that's executing when the stack needs to grow but can't grow anymore.

    MSE (Microsoft Security Essentials) can be found at: - no need to visit another site to find the link.   Do you currently have an AV program installed? If so, what?

    Can you use system restore to restore your system to a point in time before the problem began?

    Consider running SFC /SCANNOW from safe mode - see if that helps anything.

    Thursday, June 10, 2010 10:41 PM
  • Hi,

    First of all, do you have ZoneAlarm Security Suit installed? If so, turn off the function "Enable Timing Attack Prevention" under Program Control (Custom) to check the result.

    If it is not in this situation, let us boot into clean boot to troubleshoot this issue.

    This method will help us determine if this issue is caused by a loading program or service. Refer to
    1. Click the Start Button and type "msconfig" (without quotation marks) in the Search Box and press Enter.
    2. Click Continue to verify the permission.
    3. Select the Services tab in the open window. Check the “Hide all Microsoft Services” option and click Disable All.
    4. Switch to the Startup tab and click Disable All.
    5. Click OK to save the settings and select Restart when prompted.
    6. Check whether or not the issue still occurs.

    Note: Temporarily disabling the Startup Group only prevents the startup programs from loading at startup. This shouldn't adversely affect the system or other programs. We can still manually run these programs later.


    Magon Liu - MSFT
    Tuesday, June 15, 2010 6:25 AM
  • Why has this been marked as answered but there is no answer in this thread?

    I ran into the same problem and want to point everyone to


    • Proposed as answer by Stoll Monday, May 23, 2011 1:13 PM
    Wednesday, June 23, 2010 6:17 PM
  • Because the Microsoft moderators love to mark themselves as an answer. Happens more often than not.
    Friday, December 17, 2010 7:32 PM