none
Windows Update setting not respecting GPO RRS feed

  • Question

  • I just wiped my Windows 8.1 computer and installed Windows 10 Enterprise 1511 x64 for the purpose of piloting it and gaining experience with it.  Since we still use SCCM 2007 R3, I'm unable to deploy regular updates to this computer with SCCM because SCCM 2007 R3 only supports Windows 10 Enterprise LTSB 2015.

    Due to this, I created a new Group Policy Object that uses a WMI filter to apply only to Windows 10 clients and has the following settings.  Please note that this GPO is the #7 GPO in terms of precedence at the OU containing my computer.  The 6 higher GPOs do not control Windows Update at all and have no effect in this regard.

    Two other Windows 10 computers in the same OU are picking up the correct update settings.  It seems to affect only my computer.

    Despite this, I'm seeing the following Windows Update settings on my Windows 10 machine:

    As you can see, the Delivery Optimization settings are taking effect correctly, but not the other settings.  I've already tried deleting the GPO and creating it from scratch, but the result is the same.

    How can I fix this?

    Thursday, April 21, 2016 7:22 PM

Answers

  • Hi Scott,

    Follow the article below and check the Windows Update part for registry settings:

    https://technet.microsoft.com/en-us/itpro/windows/manage/disconnect-your-organization-from-microsoft#bkmk-wu

    See if any registry key modified there.

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    I came in to the office today ready to check for the Windows Update registry keys mentioned in your link.  Before doing so, I checked to see if Windows Update on my computer was picking up the GPO settings or it was still holding on to the setting to never check for updates.  It is picking up the GPO settings now.

    I have no idea what the solution was.  I'd run gpupdate /force /boot a bunch of times and rebooted manually several times and none of these fixed the issue last week.  Now it is working randomly.  I don't know...

    Tuesday, April 26, 2016 2:22 PM

All replies

  • Update: I put my computer object in an OU that has group policy inheritance blocked and has zero GPOs linked, ran gpupdate, and then rebooted my computer. It was still holding the undesirable Windows Update settings for some reason.

    I'm not sure what to do next.

    Thursday, April 21, 2016 7:38 PM
  • Hi Scott,

    Follow the article below and check the Windows Update part for registry settings:

    https://technet.microsoft.com/en-us/itpro/windows/manage/disconnect-your-organization-from-microsoft#bkmk-wu

    See if any registry key modified there.

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, April 22, 2016 6:21 AM
    Moderator
  • Hi Scott,

    Follow the article below and check the Windows Update part for registry settings:

    https://technet.microsoft.com/en-us/itpro/windows/manage/disconnect-your-organization-from-microsoft#bkmk-wu

    See if any registry key modified there.

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    I came in to the office today ready to check for the Windows Update registry keys mentioned in your link.  Before doing so, I checked to see if Windows Update on my computer was picking up the GPO settings or it was still holding on to the setting to never check for updates.  It is picking up the GPO settings now.

    I have no idea what the solution was.  I'd run gpupdate /force /boot a bunch of times and rebooted manually several times and none of these fixed the issue last week.  Now it is working randomly.  I don't know...

    Tuesday, April 26, 2016 2:22 PM
  • Hi Scott,

    Thanks for the update.

    Gald to hear that the issue is solved.

    If any further questions, please feel free to ask in TechNet.

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, April 27, 2016 1:49 AM
    Moderator