VPN issue with Miniport PPTP


  • Hi Forum

    So I had a User who could not connect to the VPN, I looked at the hidden devices and noticed that the WAN Miniport (PPTP) was faulty or corrupt and it would not update. I could not uninstall it without a work around and since I have uninstalled it, i can not find a way to get it back. 

    I followed the following to try and resolve the error, and when i thought i was getting somewhere, what ever i do, the WAn Miniport PPTP will NOT install.

    Can someone please help.Thanks

    What i tried to fix this issue:

    Check to see if the WAN Miniport is there or whether it is faulty, go to device manager and then view > show hidden.

    First solution

    If the PPTP miniport is on the PC this should install it:

    Run as admin CMD;

    Netcfg -l %windir%\inf\netrast.inf -c p -i MS_PPTP

    Second Solution

    1. Go to device manager and select "Show Hidden Devices" under the  View menu.  2. Expand Network adapters. You should see the WAN Miniport (PPTP)  3. Try right clicking on it and uninstalling it. More than likely it  won't allow you to. To get around this update the driver to something  "uninstallable" like the MAC Bridge. To do this right click on it and  select update driver. Choose no to look on windows update. Then choose  to specify a location. Next choose dont search. Next unselect show  compatible hardware and find the MAC Bridge under Microsoft. Force it  to install it. After thats done you should be able to uninstall your  new 'MAC Bridge Miniport."  4. Now that it's gone, lets reinstall it. Now get the devcon.exe  package from the link below and extract  it desktop or c:drive.  5. Go to the command prompt (Run it in administrator mode) / console (cmd.exe) and get to the folder with devcon.exe in it.  6. Run this command: devcon.exe install c:\windows\inf\netrasa.inf  MS_PptpMiniport  7. Go back to the device manager. You should see the WAN Miniport  (PPTP) back.

    Third solution:

    Step 1: Uninstall WAN Miniport Devices

    1. Open Device Manager (devmgmt.msc) and on the view menu select Show hidden devices

    2. Under Network adapters, you will see WAN miniport devices (IP, L2TP, Pppoe, PPTP). If you don’t see these, skip to the Step 2 section

    3. Open Registry editor (regedit.exe)

    4. Browse to the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318} and Export this registry subkey

    5. Click each of the registry subkeys under this key. Look up the data value in DriverDesc. Find the subkey that corresponds to the miniport device for example, WAN Miniport (IP).

    6. Right click the subkey (for example 005), and then click delete. Click Yes to confirm deletion

    7. Go into Device Manager and right click the miniport device that corresponds to the subkey that was deleted. Select uninstall and confirm uninstallation

    8. Repeat this process for all miniport devices that you need to uninstall

    Step 2: Reinstall WAN Miniport Devices

    9. Find netrasa.inf in c:\windows\inf

    10. Make a copy of this file (netrasa.bak)

    11. Open netrasa.inf and comment out the following section:


    [ControlFlags]  ExcludeFromSelect =\      SW\{eeab7790-c514-11d1-b42b-00805fc1270e},\      MS_IrdaMiniport,\      MS_IrModemMiniport, \      MS_L2tpMiniport,MS_PptpMiniport,\      MS_PppoeMiniport, \      MS_NdisWanBh,\      MS_NdisWanIp,\      MS_NdisWanIpv6,\      MS_NdisWanNbfIn,MS_NdisWanNbfOut


    [ControlFlags]  ;ExcludeFromSelect =\  ;    SW\{eeab7790-c514-11d1-b42b-00805fc1270e},\  ;    MS_IrdaMiniport,\  ;    MS_IrModemMiniport, \  ;    MS_L2tpMiniport,MS_PptpMiniport,\  ;    MS_PppoeMiniport, \  ;    MS_NdisWanBh,\  ;    MS_NdisWanIp,\  ;    MS_NdisWanIpv6,\  ;    MS_NdisWanNbfIn,MS_NdisWanNbfOut

    12. Start the Add Hardware Wizard from control panel

    13. Select Yes, I have already connected the hardware, then Next

    14. Select Add a new hardware device, then Next 

    15. Select Install the hardware that I manually select from a list (Advanced), then Next

    16. Select Network Adapters, then Next

    17. Select Microsoft in the Manufacturer section and then on the Network Adapter, select the desired WAN Miniport device, then Next and Finish the wizard

    18. Repeat 13 – 18 for each device you are re-installing

    19. After the devices are re-installed, reboot the system

    20. Run netsh int ip reset c:\resetlog.txt and reboot the system again (Resetting the TCP/IP stack)

    21. Check the network connections in device manager and in Network Connection (ncpa.cpl)

    22. Delete c:\windows\inf\netrasa.inf and rename netrasa.bak to netrasa.inf

    Fourth Solution:

    I looked on another PC for the name of the driver for the miniport and attempted to extract and place in the correct folder.

    Download the .sys for the miniport (this one is WAN miniport PPTP) : raspptp.sys
    Place this in folder needed. Varies on different windows.

    Monday, September 10, 2012 3:49 PM

All replies

  • Hi,

    I would like suggest you try to perform an In-Place Upgrade on Windows 7. The link below would guide you

    how to do it.


    TechNet Community Support

    Tuesday, September 11, 2012 3:04 AM
  • Thanks for that information Spencer Xi,

    I was hoping this would be a last thing to attempt, is there no way to get this miniport back? When I try to add it via the Third Solution Step 2, I can see it there but the upgrade/install of the miniport throws up an error saying it couldn't be installed, exactly the same as it did when it was faulty.

    It does not make sense why this is so difficult?


    Tuesday, September 11, 2012 8:32 AM
  • Hi,

    I am not sure whether the network adapter driver contains PPTP, you can try to re-install your network adapter driver(Please download the latest one) for check.

    You had tried all the methods i wanna suggest that's why i hope you to perform an in-place upgrade.

    Thank you for understanding.


    TechNet Community Support

    Tuesday, September 11, 2012 8:56 AM
  • Hi Spencer

    Yes sorry, I tried all the network drivers and the chipset drivers and still got nothing. There seems to be something not right going on.
    I was thinking the only way to resolve this issue was to do the above but was hoping different.

    Thanks again

    Tuesday, September 11, 2012 8:58 AM