none
Unable to disable Windows Store on 1809 RRS feed

  • Question

  • We are rolling out Windows 10 1809 (October 2018 Update) and noticed that the Windows Store is not getting blocked as previous versions of Windows did.

    We have the GPO setting "Turn off Store application" set as "Enabled". This was working fine until the rollout of Windows 10 1809. 

    We also tried to block the Store using AppLocker, but no luck. 

    A reality check of the AppLocker shows other apps getting blocked, but the Windows Store rule does not apply.

    It seems that nothing is blocking the Windows Store.

    Friday, January 4, 2019 6:47 AM

All replies

  • Hi,

     

    Please confirm with your computer edition.

     

    If you are using Windows 10 Pro, Group Policy settings to disable Microsoft Store will not be applied. This is by design.

     

    If you are using Windows 10 Ent or Edu, you could disable Microsoft Store through the following GPO:

     

            Computer Configuration>Administrative Templates>Windows Components>Store>Turn off the Store application
           User Configuration>Administrative Templates>Windows Components>Store>Turn off the Store

     

    For more information, kindly read the offifcial link:

    Title: Can't disable Microsoft Store in Windows 10 Pro through Group Policy

    https://support.microsoft.com/en-sg/help/3135657/can-t-disable-windows-store-in-windows-10-pro-through-group-policy

     

    Hope these are helpful.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, January 4, 2019 9:47 AM
    Moderator
  • Hi Cloris,

    Thanks for the feedback.

    Windows 10 Enterprise is in use. 

    The GPO that you informed is already enabled. The problem is that Windows 10 1809 is not applying the policy.

    I also tested it enabling on both Computer and User configurations with no luck.

    Please keep in mind that we had that enabled already before rolling out 1809. It was working fine on Windows 10 1607. 

    It seems to be a bug on the Windows 10 1809 version.

    Thank you.

    Regards,

    Lucas

    Saturday, January 5, 2019 3:54 AM
  • Hi Lucas,

     

    Please try to change the registry key and DWORD value below.

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WindowsStore

     

    RemoveWindowsStore DWORD=1

     

    Then restart the computer to apply it.

     

    Hope these are helpful.



    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, January 7, 2019 7:04 AM
    Moderator
  • Hi Cloris,

    Thanks for that, but that was already in place. 

    Like I said, it seems to be a bug with the 1809 version.

    How can we get Microsoft to reproduce the situation and acknowledge the problem?

    Regards,

    Lucas

    Monday, January 7, 2019 11:44 PM
  • Hi Lucas,

     

    You could download Feedback Hub app in Microsoft Store and send your feedback to Microsoft.

     

    For more information, please read the official link below:

     

    Title: Send us feedback

    https://support.microsoft.com/en-sg/help/27932/windows-10-send-us-feedback

     

    Hope these are helpful.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, January 8, 2019 2:41 AM
    Moderator
  • Hi,
     
    Am 04.01.2019 um 07:47 schrieb LDSilickas:
    > A reality check of the AppLocker shows other apps getting blocked, but the
    > Windows Store rule does not apply.
     
    Did you create the rule for the Store in the GPO on a GPMC running on 1809?
     
    Probably MS changed the certificate or name of exe
     
    Mark
    --
    Mark Heitbrink
     
    Homepage:  http://www.gruppenrichtlinien.de - deutsch
     
    GET Privacy and DISABLE Telemetry on Windows 10
     
    Tuesday, January 8, 2019 7:33 AM
  • Hi Mark,

    We access the GPMC from different devices and OS's.

    We have a central store for the ADMX templates and these templates are the latest (1809), downloaded from Microsoft website. *PS: I noticed a few issues on the templates coming with the Windows 10 1809. Then I downloaded it from the MS website and most of the issues were gone, but one. See: https://social.technet.microsoft.com/Forums/windowsserver/en-US/cb97affb-9724-457b-a113-32cbd3d53331/searchocradmx-error-after-installing-win101803-admx-templates?forum=winserverGP

    Not sure what you mean about creating the rule. The rule is in GPO, we just tick the box.

    Regards,

    Lucas

    Tuesday, January 8, 2019 11:38 PM
  • Am 09.01.2019 um 00:38 schrieb LDSilickas:
    > Not sure what you mean about creating the rule. The rule is in GPO, we just tick
    > the box.
     
    you tick the box inside GPMC, which is runnig on which OS?
    The list of Apps you can "tick" is created individually, always on the
    client/server where the GPMC is running.
    You will see more/less/different Apps when opening GPMC on server or client.
     
    It is NOT admx. It is like the services list, you only "see" the local
    existing ressources from the machine.
     
    Mark
    --
    Mark Heitbrink
     
    Homepage:  http://www.gruppenrichtlinien.de - deutsch
     
    GET Privacy and DISABLE Telemetry on Windows 10
     
    Wednesday, January 9, 2019 5:51 PM
  • Hi Mark,

    Sorry, I confused your question with the AppLocker subject.

    I used the 1809 machine to configure the AppLocker, otherwise I would not see the "Packaged Apps" options coming up.

    I tried configuring the locker with the Store full name and also using "*store*", but no luck.

    Also, be aware that I successfully was able to lock other apps as a reality test, but does not matter what you do for the Microsoft Store, nothing is blocking it.

    But AppLocker is not my focus on this thread, I want Microsoft to be aware that the option GPO key "Turn off the Store application" is not working on 1809. 

    Despite that option be enabled (which was working finer prior the 1809 version), the Store still allows users to sign in.

    Regards,

    Lucas


    Thursday, January 10, 2019 12:31 AM
  • I can confirm, I'm seeing the same. 1809 will not lock the Windows store even though the correct registry entry is in place. 

    Computer\HKEY_CURRENT_USER\Software\Policies\Microsoft\WindowsStore

    RemoveWindowsStore - DWORD value-1

    Friday, January 25, 2019 9:14 PM
  • Just read this is by design in Windows 10 Pro.....Really?
    Friday, January 25, 2019 9:25 PM
  • i also have the feeling applocker packaged app rules is not working on 1809 too! someone can confirm?
    Friday, February 1, 2019 2:28 PM

  • We just fresh installed a few student PC's with 1809 and I can confirm the same issue exists. :(

    Store policy no longer works but is working fine on the older Windows 10 editions.

    Hopefully someone can provide an answer.

    And I'm not sure I'm reading this link correctly... Are they saying it is by design but not so in Education / Enterprise edition. As this is not the case for me.

    And are they saying it only applies to upgrades? 

    https://support.microsoft.com/en-sg/help/3135657/can-t-disable-windows-store-in-windows-10-pro-through-group-policy


    Symptoms
    On a computer that's running Windows 10 Pro, you upgrade to Windows 10, version 1511 or Windows 10, version 1809. After the upgrade, you notice that the following Group Policy settings to disable Microsoft Store are not applied, and you cannot disable Microsoft Store:

    Computer Configuration>Administrative Templates>Windows Components>Store>Turn off the Store application

    User Configuration>Administrative Templates>Windows Components>Store>Turn off the Store

    Cause
    This behavior is by design. In Windows 10, version 1511 or Windows 10, version 1809, these policies are applicable to users of the Enterprise and Education editions only.


    Update Note:

    Anyone also tried removing Built-in Apps as the Remove-AppxPackage doesn't appear to work either.. :(

    Works fine yet again on older editions.

    Can someone please advise on what edition we can revert to that works as we currently using 1703 for all our staff and reluctant to upgrade to 1809 after spending quite a few hours creating and capturing what now appear to be a useless image to deploy?




    • Edited by SL7330 Friday, February 8, 2019 2:15 AM
    Thursday, February 7, 2019 10:19 PM
  • Hi,

    Thanks for your feedback.

    We are just hoping this is just a bug to be resolved soon and not a machiavellic plan. :)

    Regards,

    Lucas

    Friday, February 8, 2019 12:18 AM
  • Problem appears to be in the version available for download in our portal:

    OS Build 17763.107

    Just confirmed store policy working in OS Build 17763.253

    (KB4480116)
    • Edited by SL7330 Wednesday, February 13, 2019 4:12 AM
    Wednesday, February 13, 2019 2:15 AM
  • We are running Enterprise Edition and Windows store is blocked by GPO that is applying according to RSOP but the store app is loading and is prompting for logon credentials to Azure. As we have azure but no store, they are working. We need to block this.

    lforbes

    Thursday, February 21, 2019 8:10 PM
  • We also upgraded to 1809 on a Windows Enterprise and the Windows Store does not disable the GPO yet. Did you find a solution ?

    D.Gehrig

    Wednesday, March 6, 2019 10:16 AM
  • Just checking this on our systems and we find that on 1809 the store appears to work for 10 seconds or so before switching to the "store is blocked" screen. Not ideal, but it does disable it.

    We're blocking it with the reg key rather than the GPO (to ensure it's blocked before domain join happens), but I wouldn't expect that to make a difference.

    Wednesday, March 6, 2019 11:40 AM
  • We also upgraded to 1809 on a Windows Enterprise and the Windows Store does not disable the GPO yet. Did you find a solution ?

    D.Gehrig

    I also have this issue.  I Just built a fresh 1809 VDI image and applied all windows updates and store updates.  

    My system is the following:

    Edition = Windows 10 Enterprise

    Version = 1809

    OS Build = 17763.379

    I have the following group policy set:

    Computer Configuration/Administrative Templates/Windows Components/Store/Turn off the store application = Enabled. 

    I am running the 1809 group policy templates, and This setting worked perfectly in v1607 and 1709.  it also works on a computer of mine running 1809 enterprise 17763.316, so i know the group policy is valid.  

    Microsoft, PLEASE PLEAASE fix these issues as I am trying to run an enterprise solution in a healthcare organization.  I would love to use LTSB but office 365 won't run on it.  So what are my options?  

    Has anybody else figured out why group policiy is no longer blocking the store?  

    Thursday, March 21, 2019 12:17 AM
  • My group policy is properly setting the registry key to a value of '1' and yet the store still opens.  windows 10 enterprise 1809 build 17763.316.  anybody figure this out yet or get a response from microsoft support?  I need a solution. 
    Thursday, March 21, 2019 12:20 AM
  • Remove the store entirely, maybe? We do our removals directly in the starting materials (using DISM), but you can also do it using powershell after the machine is installed.

    The "Inbox Apps" ISO from VSLC contains the necessary appxbundle files to put back anything that you remove via this route if you need it again on specific PCs.

    If the GPO is no longer working, then leaving the store app present is no longer entirely safe...

    That said, as mentioned above, for us the setting is still working after a fashion - it just takes a few seconds for the store to notice and display the "store is blocked" screen.

    Thursday, March 21, 2019 9:42 AM
  • Just an update to this thread.  I found that the group policy IS applying to the sytem correctly and setting all registry values.  It appears 1809 has some cosmetic bugs.  What i was expecting was when a user clicks on the store for the screen to immediately pop up saying "sorry the store has been disabled by your administrator" like normal.  What was happening in my environment is the store opened and you can search and view all the public apps.  HOWEVER, once you try to actually download or install an app you then get a screen saying group policy is blocking you.  

    From a functinoality perspective everything seems to be blocked, it is just not displaying things the way it should or we are used to.  

    Monday, April 1, 2019 8:22 PM
  • All, while there are good recommendations throughout this thread, we found (and confirmed) another scenario in our organization that can cause this issue.

    In our organization we had the "Turn off Store application" setting set to "Enabled", but was not taking effect at all in Windows 10 *1903*. What we found and confirmed is that a security baseline / hardening GPO was also in play and setting the "Microsoft Store Installer Service" to disabled, and through A/B testing of the service determined that this Windows service is required in order to properly parse and process any Store settings being set by Group Policy.

    In other words: If the Microsoft Store Installer Service is disabled and cannot start, relevant group policies for the store will not take effect. If the service is set back to manual, launching the store calls the service, and the store block takes effect within about 10 seconds (whenever the service starts).

    Moreover, our ability to test and validate the problem was confused by Windows Store caching, which can be accounted for by running WSRESET.exe. Let's say you have the service set to manual, and launch the store, and the block store policy in place - the service will start and block the store. Then, let's say the GPO applies and disables and/or stops the service. If you relaunch the store, the cached block page will still appear as though the policy is still correctly applied, even though the underlying support for the store policies (the Windows service) is now in an incorrect state. It'll take reboots and/or time for the store to suddenly unblock without any clear explanation.

    We are sharing the results back with Microsoft shortly.


    • Edited by KevinM2019 Tuesday, November 19, 2019 3:44 PM
    Tuesday, November 19, 2019 3:40 PM