locked
Windows 10 internet time sync fails RRS feed

  • Question

  • As far as I know my Windows 10 Pro has never managed to sync with any internet time server. I've tried everything I can find and had no success. I need help from someone that knows what they are doing.

    I've checked the services.msc settings but only as far as starting windows time automatically, the log on tab is unclear to me. I've re-registered the .dll and .exe for the time service at an admin command prompt. I just can't get it to work.

    Please help.

    Cliff

    Tuesday, June 13, 2017 5:21 PM

All replies

  • If you open Control Panel (search start for control) then click Clock, Language and Region, then Date and Time. On the Date and Time screen that opens click the Internet Time tab. What does it say it is set to sync with?

    Click Change settings then Update now, does that work?
    Tuesday, June 13, 2017 7:19 PM
  • Hi Cliff, 

    Before we start troubleshooting this issue, it would be a good idea to run the System File Checker. To do so, you have to type sfc /scannow in an elevated CMD and hit Enter. Wait for a while and when the job is completed, restart your Windows computer. 

    Then, register the win32time components again to check the issue:

    To do so, in an elevated command prompt, type these commands one after the other and hit Enter:

    1. net stop w32time
    2. w32tm /unregister
    3. w32tm /register 

    If the issue still persists, please open regedit, navigate to the following registry key:

    HKLM\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControl\services\TapiSrv

    Now in the right pane right-click on ImagePath and select Modify. Here in the Value data box, make sure that the value is:

    %SystemRoot%\System32\svchost.exe -k NetworkService

    Click OK and exit.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, June 14, 2017 9:42 AM
  • Here is a workaround that I use: (not a direct fix)

    Go to:

    https://www.nist.gov/pml/time-and-frequency-division/services/internet-time-service-its

    Locate the download box for NISTIME-32bit.exe

    You can run the file and choose from several NIST Time servers.  The exe file will allow you to change the system time if your windows system will allow the change. The exe file runs the program directly, it is not an installer.

    You can set a shortcut to this program from almost anywhere on your system.

    Cliff1-ct

    • Proposed as answer by IlDavo Tuesday, March 31, 2020 8:15 PM
    Friday, October 25, 2019 4:02 PM
  • I changed my time server via the method on this site: www.windowscentral.com/how-manage-time-servers-windows-10

    My computer is now syncing properly.

    Thursday, January 30, 2020 11:25 PM
  • After trying 5 or 6 other tutorials, this is the only thing that works for me. Thank you. 
    Sunday, February 16, 2020 1:10 AM
  • Please: "this is the only thing that works..." is unhelpful in a thread that has listed more than one remedy.  Please specify exactly what action worked for you!

    For me: Changing values in Control Panel's "Date and Time"->"Internet Time Settings" and then clicking "Update now" only ever produced, "An error occurred while Windows was synchronizing with [servername]" -- no matter which server I specified.

    Stopping, unregistering and re-registering w32tm fixed nothing.

    Downloading and running NISTIME 32 from https://www.nist.gov/pml/time-and-frequency-division/services/internet-time-service-its was the only action that resulted in fully synchronizing my local clock.  I'm glad I have a way to synchronize, but I'm still baffled by my inability to get Windows' own, built-in synchronization service to work!

    Tuesday, March 31, 2020 8:10 PM