none
Possible problem with Windows Live Sign-In Assistant and file sharing (SMB) RRS feed

  • General discussion

  • I have run across an apparent problem with the Windows Live Sign-In assistant.  Lately, I have had several installs of Windows 7 (x86 and x64) break file sharing.  Specifically, I would be sharing folders through SMB/samba with remote computers, logging in using dedicated accounts/passwords.  At some point, the sharing would break and I could figure out no way to fix the problem short of a reinstall.  It didn't dawn on me that my issues began around the time I started installing Live Mail.  Thanks to some other post boards, I found out that installing the Windows Live Sign-In assistant was causing the problem.  After uninstalling the app via add/remove, all was well.  Maybe I didn't have it all set up right, but it has caused me a lot of grief and I thought I'd give a heads up.

    • Changed type Oracle99 Thursday, July 16, 2009 9:24 AM
    Thursday, July 16, 2009 9:23 AM

All replies

  • Heh I wish I'd found this sooner, because I went through the same thing and *just* solved the problem, I was looking for other threads of people who were stuck with the same problem.
    Thursday, July 16, 2009 7:40 PM
  • Thanks for this.

    I was wondering why I couldn't get to my windows 7 printer from a Linux box - removing the windows live sign-in application resolved the issue.


    Now I want to know how/why installing sign-in assistant blocks access?


    Saturday, December 12, 2009 8:09 AM
  • Thanks all.. this was a HUGE help... nothing of use on the Ubuntu site sadly.  I too look forward to learning *why* this helps.
    Monday, December 21, 2009 4:44 AM
  • Sorry for resurrecting an old post, but I have new information regarding this issue.

    The issue with samba/linux not being able to connect to Win7 + Live Sign-in assistant was caused by a bug in samba's security negotiation code that did not anticipate the additional security object introduced by the Live Sign-in assistant.

     

    For reference, please see the following samba bug report:

    https://bugzilla.samba.org/show_bug.cgi?id=7577

     

    According to samba devs, the fix should be queued for next 3.4.x and 3.5.x releases.

    The patch should be pretty easy for other developers to adapt to older samba builds if they cannot upgrade for some reason.

    I'm sure it will take a little while for the linux distros to pick up the patch though.

     

    Regards,

    Dave

     

    Thursday, July 22, 2010 5:26 PM
  • Windows live sign in assistant breaks "non-microsoft" smb client access to windows 7 shares.  I fixed this by uninstalling "windows live sign in assistant", but at least weekly, this "assistant" reinstalls itself, and the problem returns.

    The primary client I have that uses this is a media player.  I can't update the firmware on the media player, so dumping the responsibiliity for the fix on every other non-microsoft entity, and the customer, is not realistic.  Somewhere, within the windows 7 system, I need to be able to check a box that says to use "the old way" for SMB shares, and have it stay that way.

    Also, there's no reason that an add-in, like windows LIVE! ZOMG LIVE!!!1! should break my networking at home, for services that have nothing to do with windows live.  

    Outlook Express had it's issues (especially the difficulty in running down spammers), but at least it didn't break stuff unrelated to the application.  When I get the chance, and a free weekend to pry my data out of it, I'm migrating away from windows live, for good.  I'm not tolerating an application suite that behaves like this.

     

     

    Saturday, December 11, 2010 7:29 PM
  • Fresh openSuse 11.3 install and ran right back into this problem with windows live sign in assistant.  It had been months since I fixed this when setting up an ubuntu system.  It is incredible that this has not been addressed with newer versions of Samba.  OP date is July 16, 2009.  LoL oh well.

    Monday, December 13, 2010 2:31 AM
  • I ran into this problem yesterday while attempting to get my Blu-Ray player to stream content from my W7 computer. Seriously why does an "assistant" break a functioning windows network? Beyond frustrating.
    Sunday, December 19, 2010 8:06 PM
  • Same problems connecting with Ubuntu 9.10 and 10.10 to Windows 7. I had installed for testing purpose the Windows Live Movie Maker on the Windows 7 machine. After that no connection from Ubuntu to Win 7 were possible. So i removed the Movie Maker. Then all works fine !

    Sorry, Microsoft, we are in the year 2011, and this situation is nothing more than morbid !

     

    Sunday, April 3, 2011 1:06 PM
  • This live id sign-in thing is irritating, everytime my main pc updates suddenly XBMC for windows and my xbox cannot access shares. The worst part is whenever I uninstall it it just reinstalls a week or two later, even if i choose the hide update it still seems to get installed.

    Came up with this that so far seems to work, just drops in the install keys so wu thinks it's already installed. I'm hoping this works long term.
    First removed the live id sign-in assistant, reboot.
    Create a reg file call it something like liveidblock.reg and merge it with the registry 

    Windows Registry Editor Version 5.00
    
    [HKEY_CLASSES_ROOT\Installer\Products\CA0B84B9318C4714092474A68857297C]
    "ProductName"="Windows Live ID Sign-in Assistant"
    "PackageCode"="EBAFEAFAE0BF0F842826D9F5199AEE1F"
    "Language"=dword:00000409
    "Version"=dword:07f40c5d
    "Assignment"=dword:00000001
    "AdvertiseFlags"=dword:00000184
    "ProductIcon"="C:\\Windows\\Installer\\{9B48B0AC-C813-4174-9042-476A887592C7}\\prodicon.ico"
    "InstanceType"=dword:00000000
    "AuthorizedLUAApp"=dword:00000000
    "DeploymentFlags"=dword:00000003
    "Clients"=hex(7):3a,00,00,00,00,00
    
    [HKEY_CLASSES_ROOT\Installer\Products\CA0B84B9318C4714092474A68857297C\SourceList]
    "PackageName"="wllogin_64.msi"
    
    [HKEY_CLASSES_ROOT\Installer\Products\CA0B84B9318C4714092474A68857297C\SourceList\Media]
    "1"="IDCRL;"
    
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\CA0B84B9318C4714092474A68857297C]
    "ProductName"="Windows Live ID Sign-in Assistant"
    "PackageCode"="EBAFEAFAE0BF0F842826D9F5199AEE1F"
    "Language"=dword:00000409
    "Version"=dword:07f40c5d
    "Assignment"=dword:00000001
    "AdvertiseFlags"=dword:00000184
    "ProductIcon"="C:\\Windows\\Installer\\{9B48B0AC-C813-4174-9042-476A887592C7}\\prodicon.ico"
    "InstanceType"=dword:00000000
    "AuthorizedLUAApp"=dword:00000000
    "DeploymentFlags"=dword:00000003
    "Clients"=hex(7):3a,00,00,00,00,00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\CA0B84B9318C4714092474A68857297C\SourceList]
    "PackageName"="wllogin_64.msi"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\CA0B84B9318C4714092474A68857297C\SourceList\Media]
    "1"="IDCRL;"
    
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{9B48B0AC-C813-4174-9042-476A887592C7}]
    "AuthorizedCDFPrefix"=""
    "Comments"=""
    "Contact"=""
    "DisplayVersion"="6.500.3165.0"
    "HelpLink"=""
    "HelpTelephone"=""
    "InstallDate"="20110918"
    "InstallLocation"=""
    "InstallSource"="C:\\Windows\\SoftwareDistribution\\Download\\718279e69c573efcf51f8205fddbc417\\img\\"
    "ModifyPath"=hex(2):4d,00,73,00,69,00,45,00,78,00,65,00,63,00,2e,00,65,00,78,\
      00,65,00,20,00,2f,00,58,00,7b,00,39,00,42,00,34,00,38,00,42,00,30,00,41,00,\
      43,00,2d,00,43,00,38,00,31,00,33,00,2d,00,34,00,31,00,37,00,34,00,2d,00,39,\
      00,30,00,34,00,32,00,2d,00,34,00,37,00,36,00,41,00,38,00,38,00,37,00,35,00,\
      39,00,32,00,43,00,37,00,7d,00,00,00
    "NoModify"=dword:00000001
    "Publisher"="Microsoft Corporation"
    "Readme"=""
    "Size"=""
    "EstimatedSize"=dword:00002829
    "UninstallString"=hex(2):4d,00,73,00,69,00,45,00,78,00,65,00,63,00,2e,00,65,00,\
      78,00,65,00,20,00,2f,00,58,00,7b,00,39,00,42,00,34,00,38,00,42,00,30,00,41,\
      00,43,00,2d,00,43,00,38,00,31,00,33,00,2d,00,34,00,31,00,37,00,34,00,2d,00,\
      39,00,30,00,34,00,32,00,2d,00,34,00,37,00,36,00,41,00,38,00,38,00,37,00,35,\
      00,39,00,32,00,43,00,37,00,7d,00,00,00
    "URLInfoAbout"=""
    "URLUpdateInfo"=""
    "VersionMajor"=dword:00000006
    "VersionMinor"=dword:000001f4
    "WindowsInstaller"=dword:00000001
    "Version"=dword:07f40c5d
    "Language"=dword:00000409
    "DisplayName"="Windows Live ID Sign-in Assistant"
    
    

     


    • Edited by PhilFCS1 Saturday, October 8, 2011 3:57 PM
    Saturday, October 8, 2011 3:55 PM