none
All Flash videos freeze in Windows 7

    Question

  • I've had this problem once before but somehow, magically it fixed itself after a restart, but not this time.

    So here's the problem. All flash videos freeze my browsers and I have to force them to close. It does not matter which browser I use (IE, Firefox, Chrome), they all completely freeze up. Note that I'm not saying the video freezes and I can use the browser normally. The ENTIRE browser freezes, the video doesn't load, and I have to force the browser to close.

    I've uninstalled/reinstalled flash 10
    Restarted my computer several times.
    I'm able to play youtube videos just fine on other computers in the house so I know it's not the bandwidth.
    Since this is affecting all browsers on my system, I figure it has to do with the system itself, and therefore making an uninstall/reinstall process of the browsers useless.
    I've ran ccleaner which didn't fix the problem.
    I've ran disk cleaner
    I've ran a spyware scan using Spybot S&D, everything came up clean
    I ran a malware scan using Ad-Aware, came up clean.
    I also ran a virus scan, and everything came up clean.

    I have no idea what to do at this point. So if anyone else has had this problem and fixed it, please provide some insight.
    Monday, March 08, 2010 6:52 PM

Answers

  • I am sorry for that.

    Maybe something is wrong with your registry related to flash player, and cannot be overwrited by reinstallation.
    I recommend you to run System File Checker as a try.
    Click Start button, input cmd in the search box and right-click the command promopt. Click "Run as administrator"
    type the command below, and hit Enter,
    sfc /scannow 

    It will scan the system protected files and replace the corrupted files to the original version.


    Hope it will be all right after your repair install!
    Friday, March 12, 2010 1:11 AM

All replies

  • Hi,

    try new flash 10.1 beta:
    http://labs.adobe.com/downloads/flashplayer10.html

    update also your graphic drivers > newest drivers from Intel, ATi and nVidia support accelerate Flash videos throught graphic card

    Tuesday, March 09, 2010 9:22 AM
  • You have done great.

    The issue may be caused by video card driver failure. Please uninstalled the present video card driver and restart the computer.
    If it cannot be recognized, try upgrading the driver via Windows Update.
    1. Click “Start” button, click “Control Panel”
    2. Select View as “small icons”, click “Device Manager “
    3. Right–click the device which gives you the message, click “Update Driver Software…”
    Also, go to the video card manufactory’s official website to check the driver updates.

    I see a thread with similar problem as yours:
    http://social.answers.microsoft.com/Forums/en-US/InternetExplorer/thread/c0e3d078-2043-4450-8d7a-df9bae08ef22

    Please run Clean Boot and have a test if the method doesn’t work.
       How to Clean Boot:
    1.  Click start, and then input msconfig.exe in search box, press Enter
    2.  Click General tab, click the selective startup, uncheck “Load startup items”
    3. Click Service tab, check “Hide all Microsoft services”, click “Disable All”
    4. Click Apply, and exit the window.
    5. Restart your computer, go to Youtube and play a flash video.
    It can eliminate the conflict caused by of background programs.

    If the issue persists, reset IE 8 as a try.
    1.Exit all programs, including Internet Explorer (if it is running).
    2.Click Start Button, type “ inetcpl.cpl” in the Start Search box, and then press ENTER:
    3.In the Internet Options dialog box, click the Advanced tab.
    4.Under Reset Internet Explorer settings, click Reset. Then click Reset again.
    5.When Internet Explorer finishes resetting the settings, click Close in the Reset Internet Explorer Settings dialog box.
    6.Start Internet Explorer again and check the result.

    Hope it will help you!

    Tuesday, March 09, 2010 10:11 AM
  • I did try the flash 10.1 beta, it crashed my browsers.

    I also did uninstall my current video card drivers and installed the latest drivers, it didn't work. I tried a whole bunch of other "solutions" around the net. I did disable all startup items, and that didn't work either. I didn't bother resetting IE8 since it affected more than just IE, but also firefox and chrome. So as a last resort, I reinstalled Windows 7 from scratch. It's too bad I couldn't figure out what specifically went wrong.
    Thursday, March 11, 2010 7:18 PM
  • I am sorry for that.

    Maybe something is wrong with your registry related to flash player, and cannot be overwrited by reinstallation.
    I recommend you to run System File Checker as a try.
    Click Start button, input cmd in the search box and right-click the command promopt. Click "Run as administrator"
    type the command below, and hit Enter,
    sfc /scannow 

    It will scan the system protected files and replace the corrupted files to the original version.


    Hope it will be all right after your repair install!
    Friday, March 12, 2010 1:11 AM
  • I've had exactly the same problem as you with Windows 7 64-bit.  I have limped along by doing a system restore every time video freezes the browser and have been looking without success for a real solution.  Did reinstalling win 7 from scratch do the trick?

     

    Thanks

     

    gblackbuc

    Saturday, May 01, 2010 1:17 PM
  • I'm having the same, problem, where flash videos are freezing my browser. Usually a reboot or two solves the problem, but today it is just not working. I want to try the System File Checker solution listed above, but when I right click into my command prompt, it doesn't give me the option to "Run as administrator" (just copy, paste, scroll, etc). Any ideas?
    Friday, May 07, 2010 11:31 PM
  • Hi,

     

    can you please new topic make? Thank you!

    Saturday, May 08, 2010 1:32 AM
  • I had the same problem with playing videos on my Windows 7 x86. Whenever I played the video, the browser just used to freeze for some time and till the time i didn't close that tab, the entire system used to slow down. The system ran smoothly until I did the mistake of playing the video. I thought the problem to be of a virus or a spyware, so I went ahead and re-installed the OS. everything went fine till the time I installed flash and played the video. The same problem again. And I realized the problem to be of Flash.

    I have installed windows in bootcamp on the mac and have all the video drivers installed. So I do not think the problem to be that of the video card.

    Does anyone know the reason and/or the solution?

    Thursday, September 09, 2010 4:16 AM