Windows 7 Setup cannot continue due to a corrupted installation file


  • Hello,

    I am trying to upgrade from Vista Home Premium with the Family pack.
    The DVD I am using is definitely ok, I tried with another one with the same result.
    The setup stops and also shows me a cmd window saying "a winpeshl.ini file being present, "but no commands were successfully launched. This is caused by incorrect formatting or an invalid executable name" consult the documentation bla bla...
    It shows X:\$windows.~BT\Windows|system32> and there it stops.
    No automatic rollback is happening.

    I have run chkdsk before, removed all external devices, disabled Norton IS, all without success.
    Luckily I have cloned the Hard drive and can clone back from another one if this happens (so far I tried 4 times!)

    Since the installation files cannot be corrupted, and the formatting is definitely correct, I am wondering what the " invalid executable name" is about.

    Any help is appreciated


    Thanks Su
    Sunday, December 06, 2009 6:00 PM

All replies

  • Can I ask what makes you so sure your installation files are not corrupted? Did you burn it yourself? I've seen this error before when it was burned too fast.

    Sunday, December 06, 2009 8:04 PM
  • Hello cdobbs,

    - tried several original DVDs, all brand new, can copy everything to another drive
    - setup fails on the last step where settings are applied etc. NOT on copying or even expanding the files.

    The error is not in corrupted setup files because:

    Everytime I fail to upgrade, I end up with booting into the possibility of  a rollback that doesn't work and Vista which upon choosing turns into a fresh and healthy Win7.
    I have now tons of logfiles, but don't know which one is the one that tells me what is going wrong.
    For reasons I don't want to discuss here, going with a fresh install is only the very very last option, so I intend to find a solution for this error.
    Thanks Su
    Sunday, December 06, 2009 9:39 PM
  • Sumu86336,
    I would suggest uninstalling the Norton completely and reinstalling the Win 7 version after the upgrade. Your subscription key will work with the new version. Disabling doesn't work.

    Also, have you run the Windows 7 Upgrade Advisor to determine if there are any other application problems?
    Monday, December 07, 2009 11:49 AM
  • Thanks, Nano.

    Been there done that... I am currently looking for a way to examine the logfiles.

    The file locations listed at
    are not existing on my machine.

    Any idea?

    Thanks Su
    Monday, December 07, 2009 5:15 PM
  • Su,
    kb 928901 list locations created during an upgrade with different scenarios/results of the upgrade. Perhaps you have some of those locations.

    Tuesday, December 08, 2009 11:57 AM
  • Su,
    If it is possible, have you tried a different optical drive?  Created a bootable usb thumb drive?  Could be that a read/write error is happening with the optical drive.
    Tuesday, December 08, 2009 12:02 PM