Windows 8.1 Upgrade from Windows 7 Error: "We can't connect right now. Check your Internet connection and try again."


  • I have just purchased a copy of Windows 8.1 Pro, using a student offer and when I try to run the setup executable (which I downloaded from my account Downloads, product keys, and subscription page) everything seems fine. It checks my devices and tells me that a few programs are incompatible. Then when I press next it shows me an error saying:

    "We can't connect right now

     Check your Internet connection and try again."

    I am running on Windows 7, and I have tried running the executable while on 2 different wireless networks, both with the same result. I have tried disabling my antivirus and allowing it through my firewall, but nothing seems to work.

    I would greatly appreciate it if anyone could give me some help with my problem.

    EDIT: I have also tried pinging with command prompt, and it just keeps timing out. I have also gotten a friend who is running 8.1 to ping and it times out for him as well. I can visit in IE and Firefox. Could this be part of the issue?

    Thursday, October 24, 2013 3:34 AM


  • It appears to me that using an invalid product key/code will give the message about being unable to connect as well.  Not just potentially invalid, but the wrong type of code.

    If you are trying to "Upgrade Windows  with only a product key" from

    by choosing the "install Windows 8" link.

    After switching product codes, it worked for me. 

    And then, the trick to download an 8.1 installable using just an 8 install code is complicated.

    It involves

    1. getting the 8 download started with a code that does not give "can not connect to internet" error.
    2. pause and close when it hits 2%.
    3. switch to the 8.1 download (which now no longer asks for a code at all)
    4. download 8.1
    5. make usb media
    6. create an ei.cfg file in sources so that the install wont ask for a code till after it installs (which is good cuz an 8 code will not work with the 8.1 media during the install, but does work after for activation).

    And if you botch it along the way (like I did once) you can get the media maker making blank USB keys.  This is fixed by cleaning out the folder at: C:\%UserProfile%\AppData\Local\Microsoft\WebSetup

    I found Pasul Thurrott's article  and this site: of great help.

    I am now running a USB based 8.1 Pro upgrade on my Win 8 PRO that was having issues running the store upgrade method.

    Thursday, October 24, 2013 10:19 PM

All replies