Windows 8 disconnecting from wireless.


  • I have a somewhat generic WiFi adapter that worked great with Windows 7.

    In Windows 8, after being locked for awhile, the wireless USB adapter will disconnect. Or when I turn on my computer, it will not automatically connect.

    I have re installed the drivers and turned off the option for Windows to put it to sleep.

    Thanks for any input!

    Monday, October 22, 2012 12:54 AM

All replies

    1. Have you try different wireless router? Or install latest router firmware.
    2. Install latest wifi nic driver if you haven’t done it
    3. Try different wifi mode or different wifi security settings.
    4. It could be the security software issue. Try clean boot for a test.

    Or check this post for more help: Limited wireless connection in Windows 8

    Bob Lin, MVP, MCSE & CNE Networking, Internet, Routing, VPN Troubleshooting on

    How to Setup Windows, Network, VPN & Remote Access on

    Monday, October 22, 2012 3:08 PM
  • when I turn on my computer, it will not automatically connect.

    What does the troubleshooter say?   FWIW I have had instances where the troubleshooter was asking for more extreme workarounds than were actually necessary.  E.g. when checking the router (via its admin panel) it could turn out that the DNS wasn't responding properly to it, and that made the troubleshooter think that everything needed to be reset.   In fact, then it was sufficient to make the DNS direct, e.g. via netsh, and the problem symptom was resolved.

    Also, in another post someone introduced me to  TCP supplemental  settings, so now I'm wondering if there are corresponding diagnostics and tuning procedures documented somewhere that would be helpful for dealing with such scenarios?   At the very least I suppose one could try to figure out what was going on using NetMon, get some timing information that way and then play with the parameters this command implies:

    netsh i t se sup ?

    One thing that looking at this a bit more has reminded me of is that I have seen more IPv6 DNS activity with W8 than I see with W7.   I'm not even sure that my router does IPv6.   That's probably an opportunity for some optimization sometime.   ;  )



    Tuesday, October 23, 2012 6:57 AM
  • Hi,

    Please also check the wireless network adapter in Device Manager and disable “Allow the computer to turn off this device to save power” on the Power Management tab.


    Nicholas Li

    TechNet Community Support

    Tuesday, October 23, 2012 9:40 AM
  • I already changed the power settings, as explain in the original post. I also have checked that the latest firmware is installed for both the USB adapter and the router. All my Windows 7 PCs are fully functional, and the USB adapter used to work with 7 as well. I tried it on both 2.4Ghz and 5Ghz bands, as well as mixed. I proceeded to try it on a clean install of Windows 8, to no avail.
    Any other suggestions are more than welcome!
    Tuesday, October 23, 2012 8:35 PM
  • The troubleshooter says my device is working properly, or if I turn on my computer and it doesn't connect, it simply tells me to connect to a wireless access point.
    Tuesday, October 23, 2012 8:36 PM