microsoft gps - pharos gps-360


  • windows does not detect the gps device as a gps device and does not list it in the 'location and other sensors' section in control panel... any idea how to make it show up?
    Wednesday, March 04, 2009 7:42 AM


All replies

  • did you try installing drivers from the manufacturer or from the original cd? ie, MS streets and trips or  Pharos' web site: ?
    Tuesday, April 28, 2009 2:46 PM
  • The pharos GPS device shows both under Vista and Seven as a "Com Port"
    "Microsoft USB GPS Port" to be exact.
    • Proposed as answer by shakeyplace Wednesday, April 29, 2009 6:10 AM
    Wednesday, April 29, 2009 6:10 AM
  • I am having the same problem....   it is giving an error with the USB - Serial controler.   and yes, i tried downloading the drive from pharos.

    Kinda frustrating, since this is on my Samsung Q1 tablet, which I MAINLY use as a GPS...  :(

    Any suggestions?

    Wednesday, June 17, 2009 3:29 AM
  • Update:  Even though I  am using win7 32bit...   I needed to use the pharos 64 bit drivers.  when i did.. it worked.
    Thursday, June 18, 2009 4:01 AM
  • Just as an FYI, I am running RC2 64bit on a Sony Vaio and I plugged in the GPS and it recognized it immediately.   So as Mike said, it may be the 64 bit drivers.
    Friday, June 19, 2009 2:40 PM
  • Well, I have RTM 64bit running on an ASUS.  Gets COM3, light turns on, and it appears fine in Dev Mgr.

    Downloaded Streets & Trips 2010, and it never sees any sat's.  Left for 10 minutes.  Timed out, and asks to disable.
    Saturday, October 17, 2009 5:39 PM
  • Microsoft is pure scum.  They create Plug and Pray and their own devices aren't supported.  They don't provide drivers for products they put their name on.  As I said, pure scum.

    I also find it quite annoying how many Microsoft device drivers and software, provided by Microsoft, fail to be properly signed by Microsoft.

    Tuesday, September 05, 2017 8:44 PM