none
Where can I download a copy of cdrom.sys for Win7? Mine is corrupt.

    Question

  • Need help regarding cdrom.sys. Win7 will not repair the existing file and I can not find one to download with instructions on how to install it.

    Thanks for the help. I'm not an IT pro, but have been using computers, building them and repairing since Commodore 64 days.

    Jim McCants
    Saturday, February 27, 2010 3:58 AM

Answers

  • IF you did an upgrade from Vista, you might have some conflicts. I suggest a clean install in that case.

    IF the system file checker fails, then try an in place upgrade from your DVD.

    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe RaidMax Smilodon, 680W, Asus M2NBP-VM CSM, AMD X2 4200+, 2GB DDR2-800, HD2400 Pro, more details on my site, need a new boot disk, existing one is 5 years old
    • Proposed as answer by Vivian Xing Monday, March 01, 2010 6:37 AM
    • Marked as answer by Vivian Xing Monday, March 08, 2010 3:03 AM
    Sunday, February 28, 2010 12:51 AM

All replies

  • Hi DiamondJim57,
    What is the issue? Do you have an optical drive that is not visible?
    If yes, try this: http://support.microsoft.com/kb/314060

    Use the Vista (Fix it myself) method to manually change the registry settings. Of course, backup your registry before making any changes. Mr. Fix IT may work for you also.

    Alternatively, if you truly have a missing or corrupted file, insert the installation DVD, restart and boot from the DVD, and choose the repair option.
    Saturday, February 27, 2010 11:57 AM
  • Nano - thanks for the advice. Tried your suggestions and to no avail. I've even copied a good cdrom.sys from my backup computer and that still doesn't do the job. Guess Win7 64bit  does not do nice with IDE optical drives. I had forgotten to add that both my drives are IDE.  Both of my drives work fine in the backup with Win7 32bit! Figure that out! Have ordered 2 LiteOn SATA drives for my main system. Everything I've read on the forums is that the 64bit version has no problems with SATA optical drives. They should arrive on Tuesday and I'll post after installing them as to whether I still have problems with Explorer seeing the drives.

    Again, thanks for trying to help.
    Jim

    Saturday, February 27, 2010 3:19 PM
  • Hi Jim,

    open an elevated (with admin rights) command prompt and run:

    sfc.exe /scannow

    André

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Saturday, February 27, 2010 6:44 PM
  • Andre, I've done that also. It looks as though Win7  64bit will not read cdrom.sys without corrupting it. Looking forward to getting SATA drives on Tuesday.
    Thanks!

    Jim
    Saturday, February 27, 2010 8:58 PM
  • IF you did an upgrade from Vista, you might have some conflicts. I suggest a clean install in that case.

    IF the system file checker fails, then try an in place upgrade from your DVD.

    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe RaidMax Smilodon, 680W, Asus M2NBP-VM CSM, AMD X2 4200+, 2GB DDR2-800, HD2400 Pro, more details on my site, need a new boot disk, existing one is 5 years old
    • Proposed as answer by Vivian Xing Monday, March 01, 2010 6:37 AM
    • Marked as answer by Vivian Xing Monday, March 08, 2010 3:03 AM
    Sunday, February 28, 2010 12:51 AM
  • Vegan - thanks for the reply. I installed with a clean install - that included formatting the hard drive before installing win7(64 bit). Nothing has worked. I've taken both drives out of my primary computer and have installed one of them in my backup computer. It has Win7(32 bit) that was installed over Vista(32 bit). It shows in Windows Explorer and works perfectly. 

    This confirms what others have posted on different forums - Win7(64 bit) DOES NOT WORK WELL with IDE optical drives. I have 2 SATA drives arriving from NewEgg tomorrow and will install them in my primary computer. Will post on here tomorrow how well they work after installing.

    Thanks!

    Jim
    Monday, March 01, 2010 5:29 PM
  • Hi Jim,

    Is there any update? Does the system work corrctly?
    Vivian Xing - MSFT
    Friday, March 05, 2010 8:28 AM
  •  

    I had the same problem, here's what worked for me.

     

    http://www.pchell.com/hardware/cd_drive_error_code_39.shtml

    • Proposed as answer by PC-Tech Sunday, August 08, 2010 9:38 PM
    Monday, June 07, 2010 6:10 AM
  • I also had this problem and GX.Ricardo's solution worked.  I had one registry key, "LowerFilters", and when I deleted it and rebooted, cd drive was back.

    Remember to at least export whatever registry keys you are going to change BEFORE you change/delete them.

    Sunday, August 08, 2010 9:45 PM
  • I managed to retrieve the cdrom.sys from the Registry editor

    Friday, February 18, 2011 6:06 PM
  • Went and tried this also, but the Properties folder in the described folder give me an error window that says an error prevents it from being opened; access is denied.

    Thoughts on how to fix this?

    Wednesday, March 16, 2011 5:40 PM
  • The solution listed above worked for me on a Windows 7 machine that couldn't see the default SATA CD/DVD or the USB CD/DVD. I have cut and pasted it below for anyone that comes later when that url goes to no where. I couldn't believe that would work but it does. Amazing and so so nice to have my drives back.

     

    <small>reinstall any CD or DVD recording applications.</small>

    <small>1) Close all open programs 
     </small>

    <small>2) Click on Start, Run, and type REGEDIT and press Enter
    </small>

    <small>3) Click on the plus signs (+) next to the following folders</small>

    • <small>HKEY_LOCAL_MACHINE</small>
    • <small>SYSTEM</small>
    • <small>CurrentControlSet</small>
    • <small>Control</small>
    • <small>Class</small>
    • <small>{4D36E965-E325-11CE-BFC1-08002BE10318}</small>
    <small>4) This folder is the DVD/CD-ROM Drive Class Description in the registry. Look for any of the following names in the right hand column.
    </small>
    • <small>UpperFilters</small>
    • <small>LowerFilters</small>
    • <small>UpperFilters.bak</small>
    • <small>LowerFilters.bak</small>
    <small>5) If  any of the above keys shown in step 4 are listed, right-click on them and choose Delete

    6) After deleting the keys, close the Registry Editor


    7) Reboot your computer
    </small>
    <small>
    8) Open My Computer and check to see if your CD or DVD drives have returned. You may also want to open Device Manager and verify that the yellow exclamation and error code on the CD or DVD drive is gone.
    </small>
    • Proposed as answer by Fateflower Friday, May 20, 2011 9:18 AM
    Wednesday, March 23, 2011 5:10 PM
  • THANK yOu thANk you thaNK YOU! :D This program is free to0!
    Tuesday, April 12, 2011 10:09 AM
  • Hi this didn't not work for me at all tried it and still no results in cd/dvd present in device manger. what else can I do to fix my problem? please help
    Friday, May 06, 2011 6:04 PM
  • DSATWORK --Thank You! Thank You! Thank You!

    I had the code 32 error - Been racking my brain trying to fix this issue...Did exactly was you posted above and wooolalalala!  I got my drive back!

     

     

    Friday, May 20, 2011 9:15 AM
  • Thank You, PC-Tech!
    Friday, May 20, 2011 9:18 AM
  • Helped me!
    Tuesday, June 14, 2011 8:22 PM
  • Its been while since I last burned out a DVD drive, old one was Light-On and it lasted about 2000 burned disks which is not bad. That drive was IDE and it worked fine with Windows 7.

    Currently I am using a SATA drive made by LG only because now that I have a newer MB I have no shortage of SATA ports.

     

    If the drive is not working, its likely a chipset issue.

    I tend to buy new motherboards about every 2-3 years and I use AMD so its not an expensive idea to incrementally upgrade.

    New boards with UEFI are now increasingly on the market so its not a bad idea to consider as new one for Windows 7 and upcoming 8

     


    My MVP is for the Windows Desktop Experience, i.e. Windows XP, Vista and Windows 7 IT

    Remote Assistance is available for a fee.

    I am best with C++ and I am learning C# using Visual Studio 2010

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews

    Tuesday, June 14, 2011 9:06 PM
  • Had same problem, Windows 7 just stopped working my CDROM.SYS with any peripheral CD Drive.  Your solution worked first time...

    Thanks!

    Thursday, December 22, 2011 4:27 AM
  • I have noticed over the last 12 months that some of the ruse malware programs block the CD drive to prevent an easy recovery.

     

    I suggest using a security product like Microsoft Security Essentials, see my IT site home page for links

     


    Windows MVP 2010-11, XP, Vista, 7. Expanding into Windows Server 2008 R2, SQL Server, SharePoint, Cloud, Virtualization etc. etc.

    Hardcore Games, Legendary is the only Way to Play

    Developer | Windows IT | Chess | Economics | Vegan Advocate | PC Reviews

    Thursday, December 22, 2011 11:38 AM
  • XP Security 2012 (The one that renames the OS to match:  Vista Security 2012 for example) replaces/patches the CDROM.sys file on the Windows XP OS since it's always loaded when a computer starts.  This is why Vista does signing...  Although in theory someone can fake it (not likely!).  Not technically a rootkit although just as sneaky!  ;)  I wonder what it does on Vista/7 since those get it as well...  I've not got a working install of 7 to test it with, not that I'd go to the trouble of setting up a second OS on a spare drive or computer just to deliberately infect it.  Virtual machines, either.

     

    The filters list was blank so there wasn't anything interfering.  I had forgotten that I removed cdrom.sys to clean it and didn't copy the (clean) file back off of the CD.  Copying the file from my other computer running Server 2003 worked after disabling and enabling the devices in device manager but I should go find the stupid CD I lost.  Who knows what bugs I just caused!  :P  So your solutions work on Windows 2000, XP, Server 2003, Vista, Server 2008, and 7 I'd imagine.  Thanks for info, everyone!

     

    http://forums.malwarebytes.org/index.php?showtopic=103064

    Sadly, the machine that got infected was of course not running NoScript, so it went right past everything else since it used an escalation exploit.  Update your Java and disable old plugins before doing it!  Happens on roughly the same day as that person.

     

    Tuesday, January 10, 2012 11:20 PM
  • I tried erasing both Upperfilter and Lowerfilter and both my drives are now working. I was told by the "help" desk at PC Tools that it was a hardware problem even after I told them that they were 2 drives, one SATA and one USB and their registry mechanic program could not fix the problem. Thanks again for the REAL HELP!

    Wednesday, June 06, 2012 5:58 PM
  • if you do not have a security program, microsoft security essentials is now on windows update for free, look at the optional updates


    Windows MVP 2011-12, XP, Vista, 7. Expanding into Windows Server 2008 R2, SQL Server, SharePoint, Cloud, Virtualization etc. etc.

    Hardcore Games, Legendary is the only Way to Play

    Developer | Windows IT | Chess | Economics | Vegan Advocate | PC Reviews

    Wednesday, June 06, 2012 6:02 PM