none
Error Code: 0x8007007B, when a KMS client attempts to be actived, which is in WORKGROUP. RRS feed

  • Question

  • _VLMCS._TCP.DOMAIN.COM has been already in the DNS space. Firewall of KMS server has been set as TCP 1688 open.

    Clients's DNS has been pointing to the DNS Serve of domain, but clients not in domain.

    Must I manually assign the KMS Host to the clients? Or the clients in workgroup can by themself discover the KMS host?

    Monday, December 17, 2012 2:34 AM

Answers

  • My apologies.  Yes you must manually register the clients.  You registered your KMS host to the DNS Domain "Domain.com" so its specific to that domain only.  If you had multiple domains you can modify the registry which would then create new SRV RRs for the multiple domains.

    In your case, you have workgroups so you need to point the clients to the KMS host with slmgr.vbs -skms Server1:Port


    Be kind and Mark as Answer if I helped.

    • Proposed as answer by Chris DeCarlo Tuesday, December 18, 2012 7:22 PM
    • Marked as answer by Long Bo Thursday, December 20, 2012 8:56 AM
    Monday, December 17, 2012 6:41 PM

All replies

  • see if this helps you, specifically method 3 and 4:

    kb-929826


    Be kind and Mark as Answer if I helped.


    • Edited by Chris DeCarlo Monday, December 17, 2012 5:50 AM
    • Proposed as answer by Chris DeCarlo Monday, December 17, 2012 5:50 AM
    • Unproposed as answer by Long Bo Monday, December 17, 2012 6:47 AM
    Monday, December 17, 2012 5:49 AM
  • Thanks!

    In fact I have read this KB.

    But in this KB, the question is not answered

    "Must I manually assign the KMS Host to the clients? Or can the clients in workgroup can by themself discover the KMS host using DNS by default?'

    Monday, December 17, 2012 5:55 AM
  • My apologies.  Yes you must manually register the clients.  You registered your KMS host to the DNS Domain "Domain.com" so its specific to that domain only.  If you had multiple domains you can modify the registry which would then create new SRV RRs for the multiple domains.

    In your case, you have workgroups so you need to point the clients to the KMS host with slmgr.vbs -skms Server1:Port


    Be kind and Mark as Answer if I helped.

    • Proposed as answer by Chris DeCarlo Tuesday, December 18, 2012 7:22 PM
    • Marked as answer by Long Bo Thursday, December 20, 2012 8:56 AM
    Monday, December 17, 2012 6:41 PM
  • Thanks!

    I have done some tests, and the results are:

    1. Clients in domain can be aware of the RR _VLMCS._TCP.domain.com

    2.Clients in workgroup must be specified with the KMS HOST with slmgr.vbs -skms Server1:Port

    Thursday, December 20, 2012 9:00 AM