none
Remote Desktop client on Windows 8 drop connection

    Question

  • I've already posted the question at http://answers.microsoft.com/en-us/windows/forum/windows_8-performance/remote-desktop-keeps-dropping-connection/ca049248-20fa-473b-9f42-4239824374f4 but was told this would be a better forum to ask my question.

    I've just upgraded to Windows 8 from Windows 7. The main issue I have with Windows 8 is that the remote desktop client is somehow broken for me. Whenever I use it, it blocks (i.e. I cannot interact with the remote computer) and then I get the pseudo-dialog box stating reconnecting and it will reconnect and I get back the remote access. It does this all the time (about every few minutes). It looks like the client is dropping the connection and automatically re-establishing it.

    Note that when I cannot interact with the remote computer, I can still ping it just fine. So clearly it is not a connection problem. I even have on the same machine a virtual machine machine running Windows XP Pro and in there the remote desktop client from XP never drops the connection, nor blocks.

    Anyone having similar issue or tips on how I could debug this?

    Thanks,

    Manu

    PS: March 23rd 2013: Something that looks to have an impact but which does not solve the problem is that if you have a networked printer, turning it off causes this problem to occur all the time. When that printer is on, the problem still occurs but less frequently. So hopefully it will give some insight to what could be broken in the Windows 8 version of mstsc.exe.
    Tuesday, November 06, 2012 4:11 AM

Answers

  • Thanks for finding this out. I'm putting the link to make it easy: http://support.microsoft.com/kb/2897602

    I'll test this in the next couple of days and if I have no drops whatsover I'll mark this as the answer.

    Update 12/3/2013: It has been more than 10 days and not a single disconnect. I'll mark this as the solution for my particular setup.


    http://www.eiffel.com


    • Marked as answer by manus_eiffel Friday, November 22, 2013 4:14 AM
    • Edited by manus_eiffel Tuesday, December 03, 2013 4:54 PM
    Tuesday, November 19, 2013 5:45 PM

All replies

  • I am having this issue today.  It worked fine last week after I upgraded from 7 Ult to 8 Pro, then today the same symptoms you are describing.  I am connecting using Juniper Client to XP Pro desktop in the office.  the tech at work is able to remote into my desktop machine there without issue. 
    Tuesday, November 06, 2012 5:15 PM
  • Hi,

    How about remove all the redirected item from the MSTSC setting, and try agian? Or logon the remote pc, if any event log duirng the session dorpped?

    To check if any problem the connection, you can also remote logon this Windows 8 from the Windows 7 clent.


    “Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.”

    Thursday, November 08, 2012 1:55 PM
  • If you mean by redirected item such as printer, drives,..., I've already removed them but I'll double check tonight. As for event log, can you tell me where to look exactly?

    As for checking the reverse connection, this is not possible since I'm connecting from home to my work computer and the reverse is not possible as my computer is not reachable from the outside.


    http://www.eiffel.com

    Thursday, November 08, 2012 4:29 PM
  • I am having this same problem, I was able to use Juniper Terminal Client on my Win7 machine to remote into work, as soon as I upgraded to Win8 I experienced this issue. 

    I tried disabling IPv6 per a recommendation, but that did not help.

    Thursday, November 08, 2012 6:50 PM
  • Are any drobo or hyper-V services running in the background? I disabled this for a team member who disconnected every 20-30 seconds (reconnected quickly) and it stopped after I disabled those. Wasn't sure exactly which one it was because of limited time though.
    Thursday, November 08, 2012 10:11 PM
  • I'm clearly not using drobo, nor do I have a need for hyper-V services. If they are enabled by default on Windows 8, then it might be the cause of it. I'll try it out later tonight and report back.

    http://www.eiffel.com

    Thursday, November 08, 2012 10:56 PM
  • Although the hyper-V services are listed none of them are running. So this is not it.

    http://www.eiffel.com

    Friday, November 09, 2012 4:17 PM
  • I have this issue after I upgraded from Windows 7 Ultimate to Windows 8 Pro.

    I'm connecting using a Juniper Client (VPN) to a Windows 2008 server. After some investigate it must be Windows 8 related because Windows 7, Windows Vista or even Linux does not have this problem. I have upgraded my onboard 82576 Intel NIC driver to the lastest available on the Intel website but the problem still occurs.

    Friday, November 16, 2012 6:30 AM
  • I wish someone would help us figuring out how to track this issue down. It has affected my ability to work remotely.


    http://www.eiffel.com

    Friday, November 16, 2012 6:51 AM
  • I really wish someone would post a fix, I have a Hyper VM using Windows 8 PRO, I seen this is 7 and 8 now which is why I just moved to Windows 2008 R2 and the problem goes away. I am using port 3393 and prot forward out side the network, same problem, locally I hit the ip:3393 same thing, drop almost every minute. This is rediculous.

    Mike Caldwell

    Friday, November 16, 2012 6:53 AM
  • I am assuming he means redirecting the RDP port like I do from 3389 to 3393.. Why that would cause an issue I dont know but hope not...

    Mike Caldwell

    Friday, November 16, 2012 6:55 AM
  • I do have the same issue of remote connection being dropped every few minutes. I had a discussion with dell representative as it is a new win8 laptop. They mention it is not a hardware issue. In my case, what I notice is, this happens only if I access my remote desktop connection(mstsc) over my wifi. If I connect my laptop to my local network over ethernet cable, remote desktop connection(mstsc) seem to be working fine with a consistent connection.
    Sunday, November 18, 2012 5:02 PM
  • Good Idea, I'll run a cable from home to work 20 miles away and I should be fine. Anyone else have good idea as to way this is happening?


    Mike Caldwell

    Wednesday, November 21, 2012 1:30 AM
  • I have not experienced this issue anymore after the automatic installation of updates KB2777294 and KB2764462 when connecting to a Windows 2008 server but when I connect to a Windows 7 client the problem still occurs.


    Sunday, December 02, 2012 10:02 PM
  • However the issue has not appeared some days. It is now again, so I don't know what the trigger for this issue is while Windows 7 without any issues can connect to the same Remote Desktop server. It has nothing to do with the Internet connection because I have this issue also on my internal LAN.

    Thursday, December 13, 2012 4:40 PM
  • In my case the following was helpful:

    Disable in the Wireless Adaper Konfiguration the Funktion "Bluetooth(R) AMP"

    Friday, December 21, 2012 7:25 AM
  • It did not change a thing for me. Note that although I have a wireless card it is disabled as I'm using a Ethernet cable to connect to the network.

    http://www.eiffel.com

    Friday, December 21, 2012 4:52 PM
  • Any solutions yet on this, I also have this issue on windows 8 on my new dell laptop, making working remote a hassle.. please help
    Thursday, December 27, 2012 12:04 AM
  • We are also experiencing this issue using Juniper SSL VPN (SA6500 7.3_R2).

    Of note, the problem is less frequent if you remove "Remote Differential Compression" from the Add/Remove Windows Features area, but the RDP drops will still occur. Interesting that others are having this issue using straight RDP - we had originally thought that this was a problem with Juniper TS client.

    Thursday, January 03, 2013 3:01 PM
  • just bought a new dell windows 8 x64 machine to replace my old vista machine. I use juniper TS to connect to my workstation at office which windows XP sp3. it constantly drop connect and reconnect. every a few minute, a pop windows come out saying" your connection has been lost, attempting to reconnect to your session", it will reconnect in a few seconds and all my session still there, i can continue working until next drop and reconnect, and on and on. so annoying and frustrating!

    I still can use my old vista machine to connect to the same office workstation without any problem. I connect my home PC to home route with cable, I also tried home wireless network, same problem.

    anyone can help? thanks a lot

    Thursday, January 03, 2013 3:37 PM
  • Same issue....can't do remote work!! Help!!!

    Sunday, January 06, 2013 9:22 PM
  • Need help it keeps logging In and out dropping connection every 15 or so seconds

    Sunday, January 06, 2013 9:24 PM
  • Same issue here with windows 8 pro/ie10 and Juniper.  Connection establishes, quits after a few seconds, reconnects......repeat.  We need help here please!
    • Edited by Carbonara77 Wednesday, January 09, 2013 2:33 AM
    Monday, January 07, 2013 3:32 AM
  • I've tried disabling "Remote Differential Compression" but it did not seem to make a difference. I wish someone from Microsoft would provide some guidance to debug this things, like proposing to try out a version with extensive diagnostics that could help them solve the issue that many of us are having.

    http://www.eiffel.com

    Monday, January 07, 2013 4:44 AM
  • This started happening to me a couple weeks ago.

    Last week i tried RDT on my wife's Mac computer using firefox to start.  it worked great with zero disconnects.

    I then assumed it was a router problem - since she has wireless and i had ethernet.  tried new ethernet cable - same issue.

    tried wireless adapter - same issue.  

    Everything else internet wise works great with the ethernet or the wireless - a speed/ping test showed a grade of A

    safe to assume it is not the router and/or modem - so it must be something with Windows 8 which I loaded about 2 months ago and never had an issue with remote desktop until about 2 weeks ago.

    Maybe a Windows 8 "update" affected the ability of the PC to stay connected?

    Thoughts?


    Monday, January 07, 2013 5:02 PM
  • I have had the same issue since the beginning of the year on my dell laptop running Windows 8.  Any resolutions?
    Thursday, January 10, 2013 1:37 PM
  • I did a clean install of Windows 8 Pro on 12/31/12 and I've been having this problem from the start, but it seems to be getting progressively worse.  I never had a problem with remote desktop with Vista.  I don't think I'm really losing the connection because when it freezes up, any clicking or typing still registers and will show up after the "reconnect" (which works on the first try every time). Please, for the love of God, don't make me go back to Vista.
    Friday, January 11, 2013 5:43 PM
  • I'm having the same problem with RDP and sites that create a VPN using the Juniper stuff. Is anyone at Microsoft looking at this?

    Ray

    Tuesday, January 15, 2013 12:56 AM
  • Here are a couple of references to the same problem:
    http://forums.juniper.net/t5/SSL-VPN/SA2500-7-1r6-gt-Windows-8-RDP-and-Citrix-Proxy/td-p/167596
    http://kevinmarquette.blogspot.com/2012/10/windows-8-and-juniper-rdp-vpn.html


    Ray

    Tuesday, January 15, 2013 1:29 AM
  • Note that it seems the problem is not necessary related to Juniper. Many of us are having the problem with normal setup: off the shelf router at home and Windows 8 trying to connect some distance Windows machine (doesn't matter which OS it is).

    It would be indeed nice to get someone more knowledgeable to track this down.


    http://www.eiffel.com

    Tuesday, January 15, 2013 7:46 AM
  • I purchased a new HP laptop back in Oct. 2012 with Windows 7 PRO.  At that time I had no issues with RDP.  Like many in this thread we use Junos for authentication, and then have the ability to RDP onto our local workstations within the corporate network.  In early November I decided to take the plunge and upgrade to Wr8 PRO.  At that time I began to experience the same issue everyone has described above.  It appears to only happen when connecting the laptop through a wireless network.  The issue occurs through my wireless home network or any wireless hotel network (I travel frequently).

    I have tried just about everything; new interface drivers, video drivers, hundreds of settings on all devices including the RDP client and still have the issue.  Not only is the problem completely annoying and wastes significant time, it is very disappointing that a fix has not been addressed to date.  There are thousands of posts and blogs out there concerning the same issue – all without a fix.  I am at wits end with the problem and really regret moving to Windows 8.  I am seriously looking at moving back to Windows 7 Pro.

    Tuesday, January 15, 2013 6:52 PM
  • Same story here. I have a Win 7 to Win Pro computer trying to communicate with XP pro. Worked fine for a week and then nothing. Have tried everything almost everyday for two months (I need this for my business). Just went back to my ISP to ping my XP Pro machine which i couldn't do from Win 8 computer and they successfully ping the XP Pro machine. Their solution - get rid of Win 8. Someone MUST have a solution at Microsoft this is ridiculous.

    laumant

    Wednesday, January 16, 2013 6:39 AM
  • I too have the same problem..I am seriously looking to goback to windows older versions(windows xp/windows 7)..

    Microsoft:

    Please release a fix/update for this problem ASAP

    Saturday, January 19, 2013 7:28 AM
  • i have the same problem. W7 x86 worked fine -> W8 Pro X64 installation from scratch, now VPN/RDP connection recycles every minute.

    1) To verify Hardware and Internet access, i installed W7 again (with dual boot) and it works perfect.

    2) I also reinstalled W8 pro without any update, VPN/RDP worked fine, one day later all updates are installed and the VPN/RDP problem started.

    3) I removed both updates KB2777294 and KB2764462 but doesnt solve the problem

    I only use the latest driver from AMD, and Realteak (LAN and sound).

    Recreation Test: --------------------------------------------------------------------

    A) Windows 8 X64 installation from DVD wihtout Updates !!!!   -> No Problem with RDP

    B) Add Realtek and AMD Driver for LAN, Sound. Grafik ->  No Problem with RDP   

    c) now i started with win Update 5 Updates and than PC restart and Test

    c1) after 20 Updates i installed my canon printer using the canon CD. The printer is Wifi attached.

    d) After the next 5 updates the RDP problem exists !!!!!!!

    e) i removed each update and tested again, but the problem doesnt go away. (all updates removed)

    f) To verify that the printer/scanner driver is the source of this problem. I started from scratch but bypassed step c1

    g) All updates installed RDP works perfect.

    conclution: Problem with Canon printer driver from canon CD   (action c1)

    --------------------Test End -----------------------------------

    Now its time to move back to my original "production" installation

    I REMOVED "CANON IJ NETWORK TOOL" "CANON IJ 'SCAN UTILITY" and NOW all my problems are solved !!!!

    RDP WORKS FINE !!!!!!!!!!!!!!!!!!!!!


    Update:

    The problem was that every 32sec my PC send broadcats for scanner discovery.



    • Edited by Killy62 Thursday, January 24, 2013 7:14 AM
    • Proposed as answer by Dan Warfield Thursday, October 24, 2013 12:08 PM
    Monday, January 21, 2013 1:04 PM
  • I am also having this same issue.
    Monday, January 21, 2013 6:02 PM
  • In continuing to try several different things today I clicked on settings, change PC settings, general, and refresh your PC while maintaining data.  It went through several steps, a few reboots, and when it gave me the login screen I tried connecting through the VPN.  The issue mysteriously went away - no more lock-ups.

    Very odd.  Not sure what it did or why it fixed the problem but I am glad it is gone.

    • Proposed as answer by JMF39 Tuesday, January 22, 2013 2:40 PM
    Monday, January 21, 2013 9:57 PM
  • I wanted to note that even though the refresh claims to leave all applications and data in tact, that was not the case for me.  It did fix my issue with VPN / RDP but I had to reinstall all applications including things like Virus scanning and Windows essential / Windows Live. 

    • Proposed as answer by JMF39 Tuesday, January 22, 2013 6:01 PM
    Tuesday, January 22, 2013 2:41 PM
  • My problem was the Canon Wifi Printer/Scanner

    Maybe you have similar Printer problems

    I REMOVED "CANON IJ NETWORK TOOL" "CANON IJ 'SCAN UTILITY" and NOW all my problems are solved !!!!

    RDP WORKS FINE !!!!!!!!!!!!!!!!!!!!!

    It takes one week testing to find this issue

    The problem was that every 32sec my PC send broadcats for scanner discovery.

    • Edited by Killy62 Thursday, January 24, 2013 7:14 AM
    • Proposed as answer by J0shC Tuesday, June 04, 2013 5:04 PM
    Tuesday, January 22, 2013 7:21 PM
  • I did not have a Canon utility
    Tuesday, January 22, 2013 7:43 PM
  • Do you have other Printer installed (like HP or other from there CD or homepage)

    Question is do you use printer driver from external provider (HP, Canon ...)

    Try, remove this driver and test RDP

    MS introduced printer model V4 with Windows 8 (universal model)

    If you use old driver most use printer model V3.

    I have Feedback from an HP installation with the same problem.

    The problem was that every 32sec my PC send broadcats for scanner discovery.

    • Edited by Killy62 Thursday, January 24, 2013 7:13 AM
    Tuesday, January 22, 2013 8:02 PM
  • I have a Brother network printer.  When I went through the refresh it deleted all my print drivers.  After the rebuild I reinstalled the driver and RDP continues to work fine.  Perhaps this is a fix for others on this thread.
    Tuesday, January 22, 2013 8:16 PM
  • Lots of people in this thread have speculated that its Juno, something to do with their VPN software, Something to do with Canon printers/software, but I dont think so. I am experiencing disconnects every couple minutes, sometimes back to back. I Dont have a canon device, I'm not using any type of VPN connection. I am using the same old Win 7 Pro laptop to connect wirelessly to my same old computer that I recently did a clean install of Win 8 Pro (which is connected via ethernet cable). I am going across my home network from the living room (watching the super dark bowl) to my office ~30ft. A little discourging seeing that this thread on Microsofts own forum has been active since Nov 6th with no real input from Microsoft....Anyone...anybody....?

    • Edited by Greg.Baker Monday, February 04, 2013 2:43 AM
    Monday, February 04, 2013 2:32 AM
  • I discovered that as long as I stay away from the Metro tile start page, its more stable. They must have run low on duck tape when they stuck that on Win 8.

    Tuesday, February 05, 2013 3:30 AM
  • This problem has actually become worse with the patches released by Microsoft in the past 2 weeks.  Now, RDP sessions disconnect every 30 seconds every time I connect, and take about as long to reconnect.

    It's stunning to me that Microsoft hasn't even bothered to acknowledge this is an issue, and indicated that it is working on the problem.  Within my company, all 9 of out Win8 beta users have given up on using Windows 8, and have reverted to Win7 Enterprise.  We've also cancelled a planned rollout of Win8 to our 500+ person staff.

    Sunday, February 17, 2013 4:00 PM
  • It's been very frustrating. I think Microsoft is no longer the company it once was... It is a shadow of its former self. I wonder how MSFT employees haven't run into this issue. I have heard reports at my work that windows 8 running on parallels didn't have this issue. Another colleague used windows xp vm on windows 8 to connect and no issues. I really would like MSFT to acknowledge this issue and promise a patch by a certain date. I didn't buy the surface pro tablet for this very reason... It would be useless if I can't reliably remote into my work computer.
    • Edited by Pradipe Monday, February 18, 2013 11:18 PM
    Monday, February 18, 2013 11:17 PM
  • I use juniper client for remote connection to work PC. Had been experiencing 'reconnect' constantly until today. after reading through the posts, i tried few things that might have helped resolve my issue. I removed the wireless printer(Brother), other remote devices like Sonos multimedia devices and HP e printer and Fax. Not sure which one of above fixed it but am a happy man......back to work from Home. 
    Wednesday, February 20, 2013 4:00 AM
  • I had the same problem with the Juniper client. I most cases the Windows 8 RDP doesn't work. Regarding Juniper I have changed the settings to use the Juniper RDP client (Java) instead of the Windows RDP client and from then i haven't disconnection anymore.
    Thursday, February 21, 2013 6:24 AM
  • as was done by JMF39 on January 21 in this thread, I went ahead and did the refresh on my PC.   Now remote desktop works great, I just had it on overnight with no interruption.

    As JMF39 stated in his response - it did delete all non-windows 8 "apps", such as virus scan, microsoft office, quicken, and Turbo Tax among others.  So...if you do the refresh - make sure you have the necessary files backed up.

    I did a full restore from a back-up and the remote desktop still worked fine.  amazing.  I guess it didn't restore the windows 8 bug that was disconnecting the remote desktop 10 times/hour!

    Sunday, February 24, 2013 12:59 PM
  • I did a refresh on my PC as well with no success (Windows 8 Pro). I am also trying to connect with Junos client but experience an RDP client disconnect every 30 seconds or so. I wonder if a Windows Update was applied that caused the issue after the refresh. Does anyone know of a specific Windows Update that might be causing the issue?

    Sunday, February 24, 2013 1:30 PM
  • Same issue here.  This is on an Windows 8 machine upgraded from Windows 7 Home professional.  Other than the upgrade, it was a fresh installation about 2 months ago.  I can definitely make it shut down if I wait several days before logging in via RDP.  It will work after the reboot however.  I saw a post on removing print drivers - I did that and it just shut down again after running less than 12 hours.  This has to be an issue with RDP and Win 8.
    Monday, February 25, 2013 12:42 PM
  • I have an issue with a Windows 8 VDI connecting to a Server 2012 box in a data centre via a VPN. I lose the connection about 10 times a day, sometimes for about 10 seconds but usually around 28 seconds, the screen goes black and then it comes back. The connection bar states that the connection is excellent and UDP is enabled. Another user suffers also, but at different completely times to me. I have had pings running both ways from servers and not a single one is dropped throughout the day, the VPN tunnel has been active all day also. Does anyone have any ideas please? Regards, Dave.
    Tuesday, February 26, 2013 4:46 PM
  • My windows 8 machine (pro, 64 bit, clean install) has begun dropping connection over rdp for approximately 2 weeks.  Approximately every 30 to 60 seconds the connection drops, the rdp hangs for 10 to 15 seconds, a dialog pops up about connection dropping and retrying for 5 to 10 seconds, and the rdp session returns to normal.  This repeats over and over for all rdp sessions.

    The only solution I've found is to run a Windows XP VM (in VMWare player) and use the rdp client from there.  With that I'm back to a rock solid rdp connection.  This proves to me that this issue is absolutely Windows 8 rdp client.  Microsoft please fix this ASAP.  This is critical functionality.

    Friday, March 01, 2013 3:40 PM
  • I am having the same issues as everyone else in this thread... RDP drops connection less than 30 seconds after connection. I am using Juniper. RDP works fine in a Hyper-V XP VM, but the response is slow. 

    I have an X1 carbon touch running Windows 8 64 bit. 

    Because I need this, I tried different combinations this week-end. I found that removing the Hyper-V feature stopped the issue. 

    Just stopping the Hyper-V service does not work, the Hyper-V feature has to be removed! 

    This is not a solution as I need Juniper for one customer and Hyper-V for another customer. 

    Sunday, March 03, 2013 7:53 PM
  • I am also having the same issue. I am running an X1 carbon touch as well. Does anyone at Microsoft actually read this forum? It doesn't seem like they have any solution or guidance. Please fix this issue. 
    Tuesday, March 05, 2013 2:35 AM
  • I am also having the same issue. I am running an X1 carbon touch as well. Does anyone at Microsoft actually read this forum? It doesn't seem like they have any solution or guidance. Please fix this issue. 

    I am also having the connection dropping issue on a new windows 8 64bit computer without a printer installed. I have tried disabling the Bluetooth services but this did not help. Using my old PC with Windows XP and exactly the same configuration I have no problems.

    I connect using tunneling within Putty and then Remote Desktop. This has always worked without any problems until now with Windows 8.

    Is there a was of officially opening a Ticket with Microsoft for this issue as it seems to be quite common?

    Tuesday, March 05, 2013 7:42 AM
  • I think I have found the answer at http://kevinmarquette.blogspot.com/2012/10/windows-8-and-juniper-rdp-vpn.html.

    Here is what Greg Wood says. 

    I've found that the Juniper simply doesn't like UDP that is part of RDP 8. Disable it.

     

    Group Policy:

    Local Computer Policy

    Computer Configuration

    Administrative Templates

    Windows Components

    Remote Desktop Services

    Remote Desktop Connection Client

    Turn Off UDP On Client --> Enabled

     

    Regedit:

    HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\Client\

    Create a dword and assign a value of 1 to:  tofClientDisableUDP dword:00000001

     

    • Proposed as answer by TomForan Monday, March 11, 2013 8:11 PM
    Wednesday, March 06, 2013 2:13 AM
  • I have been having this same problem (RDP disconnecting / reconnecting every 30-60 seconds) since upgrading my laptop from Vista to Windows 8.  The Greg Woods, Group Policy / Regedit solution to disable  UDP seems promising - although perhaps it is not the complete solution.  I made the change on my laptop and have been using RDP for about 15 Minutes.  So far, during that time, I have lost my connection once (after about 6 minutes of working without a problem.)  
    • Edited by Lifterguy Thursday, March 07, 2013 4:14 PM spelling error
    Thursday, March 07, 2013 4:14 PM
  • I thought this fixed me.  I noticed that I did not have problems staying connected from my desktop, but my laptop disconnects whenever I have less than 5 out of 5 bars of wifi signal.

    After adding the registry entry, it stays connected only a little longer.

    Seems like there are more causes than one.

    I also have noticed that it only fails when I am submitting mouse or keyboard input.

    If I just stare at it waiting for it to fail, it is as solid as a rock.


    Enterprise Dev




    • Edited by mcmspark Thursday, March 07, 2013 7:09 PM
    Thursday, March 07, 2013 6:52 PM
  • My Wifi adapter is using the microsoft supplied broadcom wifi adapter Version 5.100.245.20

    Enterprise Dev

    Thursday, March 07, 2013 7:55 PM
  • I noticed in ProcMon that I start to see TCP Retransmit events around the failure

    3:20:42.1385965 PM	IEXPLORE.EXE	6060	TCP Send	127.1.2.3:20219 -> MarksMacBookPro:5475	SUCCESS	Length: 35, startime: 274870, endtime: 274870, seqnum: 0, connid: 0
    3:20:42.6786372 PM	IEXPLORE.EXE	6060	TCP Receive	MarksMacBookPro.neo.rr.com:5476 -> 170.x.x.x:https	SUCCESS	Length: 60, seqnum: 0, connid: 0
    3:20:42.6789602 PM	IEXPLORE.EXE	6060	TCP Receive	MarksMacBookPro:5475 -> 127.1.2.3:20219	SUCCESS	Length: 35, seqnum: 0, connid: 0
    3:20:42.6790457 PM	IEXPLORE.EXE	6060	TCP Send	127.1.2.3:20219 -> MarksMacBookPro:5475	SUCCESS	Length: 35, startime: 274876, endtime: 274876, seqnum: 0, connid: 0
    3:20:43.4275362 PM	IEXPLORE.EXE	6060	TCP Receive	MarksMacBookPro.neo.rr.com:5476 -> 170.x.x.x:https	SUCCESS	Length: 60, seqnum: 0, connid: 0
    3:20:43.4278707 PM	IEXPLORE.EXE	6060	TCP Receive	MarksMacBookPro:5475 -> 127.1.2.3:20219	SUCCESS	Length: 35, seqnum: 0, connid: 0
    3:20:43.4279601 PM	IEXPLORE.EXE	6060	TCP Send	127.1.2.3:20219 -> MarksMacBookPro:5475	SUCCESS	Length: 35, startime: 274883, endtime: 274883, seqnum: 0, connid: 0
    3:20:43.9518975 PM	IEXPLORE.EXE	6060	TCP Receive	MarksMacBookPro.neo.rr.com:5476 -> 170.x.x.x:https	SUCCESS	Length: 60, seqnum: 0, connid: 0
    3:20:43.9522517 PM	IEXPLORE.EXE	6060	TCP Receive	MarksMacBookPro:5475 -> 127.1.2.3:20219	SUCCESS	Length: 35, seqnum: 0, connid: 0
    3:20:43.9523646 PM	IEXPLORE.EXE	6060	TCP Send	127.1.2.3:20219 -> MarksMacBookPro:5475	SUCCESS	Length: 35, startime: 274888, endtime: 274888, seqnum: 0, connid: 0
    3:20:44.4888492 PM	IEXPLORE.EXE	6060	TCP Receive	MarksMacBookPro.neo.rr.com:5476 -> 170.x.x.x:https	SUCCESS	Length: 60, seqnum: 0, connid: 0
    3:20:44.4891721 PM	IEXPLORE.EXE	6060	TCP Receive	MarksMacBookPro:5475 -> 127.1.2.3:20219	SUCCESS	Length: 35, seqnum: 0, connid: 0
    3:20:44.4892555 PM	IEXPLORE.EXE	6060	TCP Send	127.1.2.3:20219 -> MarksMacBookPro:5475	SUCCESS	Length: 35, startime: 274894, endtime: 274894, seqnum: 0, connid: 0
    3:20:45.0159565 PM	IEXPLORE.EXE	6060	TCP Receive	MarksMacBookPro.neo.rr.com:5476 -> 170.x.x.x:https	SUCCESS	Length: 60, seqnum: 0, connid: 0
    3:20:45.3181651 PM	IEXPLORE.EXE	6060	TCP Retransmit	127.1.2.3:20219 -> MarksMacBookPro:5475	SUCCESS	Length: 0, seqnum: 0, connid: 0
    3:20:45.5399029 PM	IEXPLORE.EXE	6060	TCP Receive	MarksMacBookPro.neo.rr.com:5476 -> 170.x.x.x:https	SUCCESS	Length: 60, seqnum: 0, connid: 0
    3:20:45.9216985 PM	IEXPLORE.EXE	6060	TCP Retransmit	127.1.2.3:20219 -> MarksMacBookPro:5475	SUCCESS	Length: 0, seqnum: 0, connid: 0
    3:20:46.0832350 PM	IEXPLORE.EXE	6060	TCP Receive	MarksMacBookPro.neo.rr.com:5476 -> 170.x.x.x:https	SUCCESS	Length: 60, seqnum: 0, connid: 0
    3:20:46.6061283 PM	IEXPLORE.EXE	6060	TCP Receive	MarksMacBookPro.neo.rr.com:5476 -> 170.x.x.x:https	SUCCESS	Length: 60, seqnum: 0, connid: 0
    3:20:46.6988294 PM	IEXPLORE.EXE	6060	Thread Exit		SUCCESS	Thread ID: 192, User Time: 0.0312002, Kernel Time: 0.0780005
    3:20:47.1171960 PM	IEXPLORE.EXE	6060	TCP Retransmit	127.1.2.3:20219 -> MarksMacBookPro:5475	SUCCESS	Length: 0, seqnum: 0, connid: 0
    



    Enterprise Dev


    • Edited by mcmspark Thursday, March 07, 2013 8:58 PM Remove server IP Address
    Thursday, March 07, 2013 8:25 PM
  • I wish to thank you, your solution led me to a similar solution.

    I had a Scanner Canon on my PC with win 7, after rebuild the PC with Win 8 I used the scanner with Windows Fax.
    I didn't install canon software.
    Then after joining a domain i removed phisically the scanner (there are other scanners in the domain).
    Connecting remote desktop to Win2008 R2 Virtual Machine no problem.
    Connecting  remote desktop to Win 2012 phisical machine no problem.

    Connecting remote desktop to win 2012 server vitual machine the problem start, while other connection are still functioning properly.

    Removed Windows Fax from Windows 8 everything is OK.
    I thing the root of the problem was the same of yours.

    Anyway your solution worked in a similar environment.

    Saturday, March 09, 2013 1:15 PM
  • Same issue here.
    Monday, March 11, 2013 6:58 PM
  • Same issue connecting from a win8 machine to a win8 machine.

    Removing the Cannon printer and driver stopped it from disconnecting.

    Tuesday, March 12, 2013 6:04 AM
  • I tried the group policy changes and then removed my network printer and the disconnections stopped. So I changed back the group policy changes and rebooted. Still good. Then I re-added my network printer but told it to reinstall the driver. Still good.

    So I rebooted and tried again and the disconnections started again. BUT..... my printer was turned off. When I turned on the printer, the disconnections stopped.

    Maybe it's because of some type of "keepalive" or heartbeat that is being used with networked printers. Maybe the need to be on otherwise all remote connections get restarted. 

    Thanks.

    • Marked as answer by manus_eiffel Wednesday, March 20, 2013 4:57 AM
    • Unmarked as answer by manus_eiffel Tuesday, April 23, 2013 2:31 AM
    Tuesday, March 12, 2013 11:50 AM
  • I think I have found the answer at http://kevinmarquette.blogspot.com/2012/10/windows-8-and-juniper-rdp-vpn.html.

    Here is what Greg Wood says. 

    I've found that the Juniper simply doesn't like UDP that is part of RDP 8. Disable it.

    Group Policy:

    Local Computer Policy

    Computer Configuration

    Administrative Templates

    Windows Components

    Remote Desktop Services

    Remote Desktop Connection Client

    Turn Off UDP On Client --> Enabled

    Regedit:

    HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\Client\

    Create a dword and assign a value of 1 to:  tofClientDisableUDP dword:00000001


    This was the solution for me, I had the same issue with 2 Windows 8 PCs when connected to a Juniper SA2500 SLL VPN, RDP would freeze up and reconnect making it extremely annoying to try to get anything done - Issue is resolved by setting the policy as shown above.
    Tuesday, March 12, 2013 6:12 PM
  • had WIndows 8 installed in vmware ESXi and had the same problem with RDP disconnecting. After cahnging my IP setting in Windows 8 from fixed to DHCP everything worked fien again.
    Thursday, March 14, 2013 8:51 PM
  • Same issue here after moving from Win7 to Win8 (fresh install)

    I can remote in fine using another workstation (on the same network) using Win7.

    Tried disabling IPv6, UDP in RDP through GP and Registry

    I don't have a Canon printer...

    Are others still having this issue or did one of the above resolve it?

    Edit!: (Solution found "for me at least")

    I checked and my networked HP printer was turned off.

    After turning it on, my RDP connection was stable without any disconnects.

    This leads me to believe (my issue at least) was due to the Network Printer "polling" issue mentioned earlier.

    I disabled all my previous changes, re-enabling IPv6, UDP in RDP through GP and the Registry and can confirm my issue is still resolved. (Again further supporting the issue is related to how network printers are handled in Win8).

    • Edited by Faetyl Sunday, March 17, 2013 4:36 PM
    • Marked as answer by manus_eiffel Wednesday, March 20, 2013 4:46 AM
    • Unmarked as answer by manus_eiffel Tuesday, April 23, 2013 2:31 AM
    Sunday, March 17, 2013 4:17 PM
  • That was it, I just needed keep the damn printer on!!!

    I cannot believe it. 

    To verify tonight, I turned it on, and was able to work 30 minutes!!! Then I turned it off, within 30 seconds it dropped the connection. 

    And this is in spite of having disabled all redirects.

    I've marked your answer as the answer even though it is still dropping the connection but now it is more like once or twice a day.


    http://www.eiffel.com


    Wednesday, March 20, 2013 4:55 AM
  • Same here. My RDP over Juniper was keeping reconnecting every 20 seconds. The problem was resolved when I started to keep my HP network printer powered on.


    Fabrice

    Thursday, March 21, 2013 12:45 PM
  • That was it, I just needed keep the damn printer on!!!

    I cannot believe it. 

    To verify tonight, I turned it on, and was able to work 30 minutes!!! Then I turned it off, within 30 seconds it dropped the connection. 

    And this is in spite of having disabled all redirects.

    I've marked your answer as the answer as it is solving the issue I originally posted.


    http://www.eiffel.com

    Note that although I can now work, I still get that behavior once or twice a day even with the printer is on. So either the printer is not answering quick enough the to RDP client or this is something else.

    Manu


    http://www.eiffel.com

    Saturday, March 23, 2013 4:25 AM
  • I wanted to add my experience to this thread in case it helps anyone. I had the exact issue: Windows 8 RDP (in my case Juniper SSL RDP) would disconnect constantly. With this thread I traced the problem to three separate/related causes:

    1. My Canon all-in-one printer software - not the driver, ironically, the part that manages transmitting scanned images (solved)

    2. Bluetooth headphones (not solved)

    3. Spotify (not solved)

    So, the solution for the Canon stuff: I removed it, but I still want to be able to use my printer (duh) so I started installing one component at a time to see what really caused the issue. The printer driver is fine, but when I added the scanner piece is when this started to happen again. I traced the problem to the executable CNMNSST.exe, "Canon IJ Network Scanner Selector EX." This apparently polls for the printer/scanner on my wireless network, and in so doing causes the RDP connection to drop.

    Canon installs this .exe and adds it to Startup Items, so it's running all the time - but not as a service, just as a process. I want this function when I want it, so I performed these steps to mitigate:

    1. Task Manager > Startup > Disable "Canon IJ Network Scanner Selector EX."

    2. PowerShell > Stop-Process -Name CNMNSST 

    That will kill the problem process and RDP works.

    If I need to scan, I use:

    PowerShell > Start-Process CNMNSST.exe

    Scan things

    PowerShell > Stop-Process -Name CNMNSST

    It's dumb, and annoying, but works.

    Monday, March 25, 2013 2:24 PM
  • Just wanted to add my experience. I found the same issue after installing a video sharing software for my iPad. After reading this thread I disinstalled "Bonjour" that came along with that software, and the RDP (again juniper) connection is not dropping anymore! However I think Microsoft must fix this. Cig

    Sorry after further testing it still doesn't work.

    • Edited by Ciglione Monday, April 08, 2013 7:53 PM
    Saturday, March 30, 2013 3:09 PM
  • I am having this same problem, I was able to use Juniper Terminal Client on my Win7 machine to remote into work, as soon as I upgraded to Win8 I experienced this issue. 

    I tried disabling IPv6 per a recommendation, but that did not help.

    Hi - we have experienced this issue for sometime now...

    Here is a solution that I came up with: 


    Go to Control Panel/Programs/"Turn Windows features on or off" and uncheck:

    • Windows Location Provider

     

    Now reboot and you should not experience drops.

    For best performance, always keep your LAN/WiFi drivers updated straight from the manufacturer's site.

     

    We tested this on 3 different Ultrabooks and all 3 did not drop after implementing the fix.

    You will lose location support for apps, but that is not nearly as important as RDP for me.

    All other settings are default such as IPv6 enabled, UDP for RDP 8 Client, Remote Differential Compression, etc.

    Of note - For VPN access, we are using the Juniper SA 6500 on 7.4_R1 and also on 7.1_r5 with the same results.











    • Proposed as answer by TechNetz Monday, April 08, 2013 11:27 AM
    • Edited by TechNetz Monday, April 08, 2013 11:38 AM
    Sunday, April 07, 2013 7:50 PM
  • I uninstalled McAfee anti-virus from my machine, and was able to work remotely without an issue.

    • Proposed as answer by D_Ganju Monday, April 08, 2013 3:06 AM
    Monday, April 08, 2013 3:05 AM
  • I uninstalled McAfee anti-virus from my machine, and was able to work remotely without an issue.

    I think there should be more than one reason for unstable RDP connection.

    I've tried all the other proposed solution that are suited for my Windows 8 configuration, but this is the only one that seems to work for me!

    After I uninstalled McAfee Intenet Security I stayed connected for more than one hour and a half this evening without any issue.

    Thanks!

    Monday, April 08, 2013 9:11 PM
  • I got this issue resolved on my machine, here is what seemed to have done it:

    Setup:

    - Dell XPS 8500, Win 8 64bit, Juniper Host Checker software

    Issue:

    - RDP connection to my work machine kept getting "lost" but would connect back on 1 of 20 attempts always

    Steps Taken:

    - Uninstalled Lexmark S415 Wireless Printer software completely.

    - Uninstalled McAfee which came with machine from Dell

    - Rebooted desktop

    - Installed Lexmark drivers from CD but choose CUSTOM INSTALL and unchecked driver for wireless network

    Result

    - RDP connection has not been lost for almost 2 hours now

    THANK YOU everyone who contributed to this conversation. I would not have been able to get this issue resolved without your responses.

    Friday, April 12, 2013 4:52 PM
  • Hi,

    I encountered the same problem, and solved it by disabling (unchecking) both the Link-Layer Topology Discovery Mapper I/O Driver & Responder, in the respective Network Adapter (wired and/or wireless) Properties.

    • Proposed as answer by ewieder1 Tuesday, April 23, 2013 10:43 AM
    Tuesday, April 23, 2013 10:43 AM
  • Hi,

    I encountered the same problem, and solved it by disabling (unchecking) both the Link-Layer Topology Discovery Mapper I/O Driver & Responder, in the respective Network Adapter (wired and/or wireless) Properties.

    Unless there are some details left out, doing the above does not fix the issue for me.

    http://www.eiffel.com

    Thursday, April 25, 2013 4:47 AM
  • The same problem is discussed in Juniper forum and it seems there's a Juniper update that solves it

    http://forums.juniper.net/t5/SSL-VPN/SA2500-7-1r6-gt-Windows-8-RDP-and-Citrix-Proxy/td-p/167596/page/5

    Saturday, May 04, 2013 8:50 PM
  • Dell | SonicWALL | Aventail : MSTSC.exe sessions over SSL VPN connections dropping every few seconds.

    When im trying to connect from a windows 8 machine to a windows 7 machine over the SSL VPN into the office the connection stops and tries to reconnect every 20 seconds.

    We are seeing the problem and I have tried to turn off the "Windows Location Provider" But still its not working. 

    Has anyone had a solution to this problem yet?

    Monday, May 13, 2013 12:56 PM
  • Dell | SonicWALL | Aventail : MSTSC.exe sessions over SSL VPN connections dropping every few seconds.

    When im trying to connect from a windows 8 machine to a windows 7 machine over the SSL VPN into the office the connection stops and tries to reconnect every 20 seconds.

    We are seeing the problem and I have tried to turn off the "Windows Location Provider" But still its not working. 

    Has anyone had a solution to this problem yet?

    It has been 6 months and no answers but clearly it happens to those who have either a networked printer or using some Juniper products.

    http://www.eiffel.com

    Thursday, May 16, 2013 10:46 PM
  • Hi guys....


    same  issue  also for  me,    rdp Client  from  a  Windows 8 Enterprise  laptop  to a  same  Os ,  but   a Dell Precision Workstation dual Xeon


    so in fact


    when i try  to  connect from  notebook  to  this Wks ,  connection  Drop  after  just  10 seconds,  all times,   was  really  irritating for me  cause  i need to use  the wks only  via RDP


    so  i Think  , after a lot of   try ,   i have  finally  solved  this   issue  modifying on the  Win 8  Enterprise   Dell  Workstation


    -  disabling  UDP  protocol  for  Terminal Services and  leave   to use  just  only  TCP  connection  via Local  GPO    on the  Wks  Win 8 System


    - disabling  continuously network discovery


    -  Forcing  the  only  TCP protocol  for  Rdp Connection  

    Now  i can  stay  connected  on my   Dell Wks  via  RDP   without  no more  connection   drop   issue.

     

    i hope  can  be useful   and ,   give   some feedback  ; )


    Thx


    Simone

    Sunday, May 19, 2013 5:30 PM
  • This may help someone - I did a fresh install of windows.  RDC worked fine.  Installed a Cannon printer and received WNDW 8 updates.  RDC had issues staying connected.  Uninstalled Cannon printer from system.  RDC is now working nicely.

    This solution is nice - but eventually I would like to be able to print from WNDW 8.  Does anyone have an idea how to install Cannon printer and not break RDC connections?

    Thanks,

    John

    Friday, May 24, 2013 12:44 PM
  • I think I have found the answer at http://kevinmarquette.blogspot.com/2012/10/windows-8-and-juniper-rdp-vpn.html.

    Here is what Greg Wood says. 

    I've found that the Juniper simply doesn't like UDP that is part of RDP 8. Disable it.

     

    Group Policy:

    Local Computer Policy

    Computer Configuration

    Administrative Templates

    Windows Components

    Remote Desktop Services

    Remote Desktop Connection Client

    Turn Off UDP On Client --> Enabled

     

    Regedit:

    HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\Client\

    Create a dword and assign a value of 1 to:  tofClientDisableUDP dword:00000001

     

    This solved it for me as well, however in Registry options mentioned should be fClientDisableUDP and not tofClientDisableUDP.
    Sunday, May 26, 2013 6:20 PM
  • My problem was the Canon Wifi Printer/Scanner

    Maybe you have similar Printer problems

    I REMOVED "CANON IJ NETWORK TOOL" "CANON IJ 'SCAN UTILITY" and NOW all my problems are solved !!!!

    RDP WORKS FINE !!!!!!!!!!!!!!!!!!!!!

    It takes one week testing to find this issue

    The problem was that every 32sec my PC send broadcats for scanner discovery.

    My Windows 8 Pro install was showing the same disconnect issues every short period of time.  It's a MacBook Pro (2007) running Windows 8 on a Bootcamp partition, incidentally.  I had connected to a network shared HP Photosmart C3180 printer and had set it as the default printer.  When I removed it, the RDP disconnects stopped happening.  Interestingly, it seems the problem is most frequent when either the printer or its attached computer is turned off.  So, if you have a network-shared printer you have installed as a printer you use, remove it if you are seeing RDP sessions disconnecting/timing out and then immediately reconnecting.


    Tuesday, June 04, 2013 5:25 PM
  • Open issue since last year! Still no help from Microsoft..... Whats up with that? 
    • Edited by ZackinMA Wednesday, June 26, 2013 12:45 PM cuz I want to
    Tuesday, June 25, 2013 8:59 PM
  • Try this guys. I had the same problem. Looks like the standby powers the wireless adapter off. It was working fine for my before so my guess is that an update might have re-ticked the "Allow computer to turn off device to save power option"

    Hope this helps someone!

    http://www.ppartyka.com/2012/12/tutorial-windows-8-laptop-keeps.html

    Friday, June 28, 2013 12:07 AM
  • After reading your March 23rd post it got me to thinking.  I only started having the issue after I purchased a new Brother wireless printer.  I first un-installed the printer but this did not resolve the remote desktop disconnect issue.  I then stopped the print spooler services and no longer had the issue.  I stayed connected for 10 + minutes with dropping\freezing.  Now the challenge will be to find the underlying issue.  I need the ability to print so I can't leave my print spooler service stopped.  I didn't have this issue with Windows XP. Maybe Microsoft will issue a fix.    

    Friday, July 05, 2013 2:11 AM
  • I have been playing around with the windows services.

    I stopped the IIS services and the RDP services and the print spooler service. I have not had a problem with disconnection from Juniper VPN. I will play with it some more to see which service will break it and report back.

    Update: I reactivated the print spooler service on windows 8 and it looks like that is causing my problem with keeping a connection with Juniper VPN RDP.
    • Edited by jeremypetz Tuesday, July 09, 2013 2:34 AM update
    Tuesday, July 09, 2013 12:16 AM
  • The below method has worked for me. I did not have to mess with any services or printer drivers.

    1. Navigate to C:\Users\<user>\AppData\Roaming\Juniper Networks\Juniper Terminal Services Client

    2. Right click and open the properties for dsTermServ.exe

    3. On the compatibility tab, select to execute the program in Windows 7 compatibility mode.

    4. Select to execute the program as administrator. Apply and OK.

    5. Log out of any Juniper remote sessions and restart the browser. The issue should be fixed.

    For those still having problems, try using WindowsXP mode in compatibitly settings.


    Monday, July 15, 2013 2:21 PM
  • Thank you for your suggestion, however, it does not work for me. So far I've tried-

    1. changing the compatibility mode to W7 and XP

    2. regedit'ing HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\Client
    fClientDisableUDP dword:00000001

    3. uninstalling printer drivers

    4. uninstalling cannon scanners

    5. turning off the printer spooler

    NONE OF THE ABOVE HAS WORKED.  My Juniper / RDP connection drops after about 20 seconds.

    Does anyone have any other suggestions?


    Wednesday, July 24, 2013 12:25 PM
  • I have this experience as well. Also, I have observed that when transferring large files from remote desktop to host computer over RDC, 1 out of 5 attempts get successful. I used to work with same setup with a different laptop running Windows 7, and I had never faced these issues. (guessing) Either this is due to network driver, NDIS 6.3 implementation or something to do with Windows 8's system-wide low-energy consumption policy for devices which results in disconnection.

    Hopefully Windows network team would be notified with these issues along with the others in this forum. Right now, networking capabilities of 8 and 8.1 preview looks very futile and fragile.


    - a citizen of Microsoft Developer Network.

    Wednesday, July 24, 2013 10:55 PM
  • Thank you for your suggestion, however, it does not work for me. So far I've tried-

    1. changing the compatibility mode to W7 and XP

    2. regedit'ing HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\Client
    fClientDisableUDP dword:00000001

    3. uninstalling printer drivers

    4. uninstalling cannon scanners

    5. turning off the printer spooler

    NONE OF THE ABOVE HAS WORKED.  My Juniper / RDP connection drops after about 20 seconds.

    Does anyone have any other suggestions?



    Same here, none of the suggestions have worked for me so far. I need to do home office on my old Windows XP laptop, that's ridiculous..
    • Proposed as answer by Spud63 Sunday, September 15, 2013 7:16 PM
    Saturday, August 03, 2013 10:50 AM
  • Was totally dreading working from home today because of this problem and, of course, it started dropping like crazy first thing!  I've tried a hundred things to fix this in the past but none worked.  Today, the first thing I tried was to disabled the Windows Firewall.  It's been stable since (for the last hour or so)!

    Could it be this simple?  And if this fixes it, what's the cause?

    Monday, August 12, 2013 2:56 PM
  • I was having a similar problem but I'm using Firepass.  After reading this thread I started going through my adapter settings and I found a setting that allows the computer to put the adapter to sleep to save power (Adapter Properties/Power Management Tab).  Once I disabled it my problem seems to have gone away.  I've been working for over half an hour without an issue now.
    Thursday, August 15, 2013 6:33 PM
  • I had the same problem. Using f5 FirePass to connect to a remote windows server. It works fine on a Windows 7, but connection is lost repeatedly on my Windows 8 (Lenovo Yoga). The problem is so bad that it has been impossible to do any work on the remote server.

    I read through all the answers and tried the following simple steps, testing after each if things did improve:

    1. I disabled the location services. Result: no improvement
    2. I then disabled the "remote differential compression" thing: Result: no improvement
    3. I then removed the HP Printer app from the Metro interface. Result: no improvement
    4. I then removed two printers (one HP and one Epson) and the Fax printer from the Control Panel. Result: it works fine!

    I can't say this is the permanent solution for me, but now at least I have been working without interruption for 30 minutes already, while the rule before has been more like 15 seconds before losing the connection. 

    I guess this might be worthwhile trying out for the rest of you as well.

    Tuesday, August 20, 2013 8:46 PM
  • Hi MortenBj,

    I have a Lenovo Ideapad Yoga 13 with the same problem. I am using Windows 8's built-in Remote desktop connection software.

    Not sure if you are aware, but there have been several problems with the wifi card in the yoga, google "yoga 13 wifi issues" if you want to take a look.

    In my case, surfing seems unaffected, but the RDC is horrible. I bought a new wireless router for working from home, which solved my problem there, but it seems that the yoga is not compatible with all wireless routers.

    Thansks for the suggestions on solving this issue. I will try it.

    Thursday, August 29, 2013 8:40 AM
  • I've been dealing with this issue for a while as well.  After I moved to Win 8 originally, all was well with RPD.  But then in December for no apparent reason, seemingly, it started the periodic drops.

    So after reading through this thread tonight and seeing the comment regarding the Canon Scan utility, I thought the same thing as another person who replied - I don't have any Canon stuff installed.

    But then I started thinking, my wife got a new printer in December - a Epson wifi type and I installed the software on my machine even though it's not my primary printer (it's our only color printer).  So tonight I was on RDP and drop, reconnect, drop, reconnect...  Then I uninstalled the Epson software and viola, all is well with RDP again.

    It just goes to show you, it's always something...

    Sunday, September 01, 2013 7:44 AM
  • I have had this exact issue. Rdp from Win8 to a Win7 machine would ultimately end in disconnections frequently within 5 seconds. The resolution for me was to disable sound redirection. This could be that I'm using my Surface vs a full PC. It is very reproducible for me.

    Thursday, September 12, 2013 2:07 AM
  • For me I noticed this happening within the last couple of days.  I bought a new NETGEAR router this past weekend and that router came with software called NETGEAR GENIE.  I manually closed that program and I now have a consistent VPN connection.  I would check to see if any extra fluff software running with your router is causing this issue and see if you can close it down.  After closing the router software (and keep it closed), try your vpn connection again.  Good Luck.  
    Thursday, September 12, 2013 11:57 PM
  • I have struggled with this problem for months ,but after reading the posts I decided to look at my printers. I have 2 networked printers connected to the windows 8 machine, one of them is nearly always off. I tried to connect the rdp and the connection kept dropping. I then switched both network printers on and it now doesn't drop at all. If I turn one of the printers off again , the connection drops after about 30 seconds. Hope this helps.
    Sunday, September 15, 2013 7:13 PM
  • Have you tried turning on any networked printers?
    Sunday, September 15, 2013 7:17 PM
  • Have you tried turning. The networked printers on? It seem to work for me.
    Sunday, September 15, 2013 7:18 PM
  • I am having this same problem, I was able to use Juniper Terminal Client on my Win7 machine to remote into work, as soon as I upgraded to Win8 I experienced this issue. 

    I tried disabling IPv6 per a recommendation, but that did not help.

    Hi - we have experienced this issue for sometime now...

    Here is a solution that I came up with: 


    Go to Control Panel/Programs/"Turn Windows features on or off" and uncheck:

    • Windows Location Provider

     

    Now reboot and you should not experience drops.

    For best performance, always keep your LAN/WiFi drivers updated straight from the manufacturer's site.

     

    We tested this on 3 different Ultrabooks and all 3 did not drop after implementing the fix.

    You will lose location support for apps, but that is not nearly as important as RDP for me.

    All other settings are default such as IPv6 enabled, UDP for RDP 8 Client, Remote Differential Compression, etc.

    Of note - For VPN access, we are using the Juniper SA 6500 on 7.4_R1 and also on 7.1_r5 with the same results.











    Just wanted to post a thumbs up on this one.  I tried most of the other fixes posted here (changing compatibility mode of Juniper exe, disabling UDP, various printer suggestions), which all had no effect for me. But disabling location services finally made my connection stable.  Was getting disconnects every 15-20 secs or so connecting my Win8 Pro desktop machine to a Win7 box over juniper sam.  Thanks TechNetz.
    • Edited by Schuffer Sunday, September 15, 2013 10:13 PM
    Sunday, September 15, 2013 10:12 PM
  • I had this same problem and solved it another way.  I contacted my IT person at work and they told me the Remote Connection is VERY sensitive to "latency" and that might be why it is disconnecting so frequently.  I was having the disconnect and reconnection 1 of 20 issue.  It would always reconnect but made it very frustrating to work. 

    I am using the 5Ghz band on my Linksys (Cisco) router.  It was using the dual channel 40Mhz bandwidth.  He suggested I change it to single channel which is the 20Mhz bandwidth.  I did that and never had a problem or a disconnect again.  For the Linksys router you go to the router settings using 192.168.1.1 and then go to WiFi properties.  I'm sure every brand of router has this.  Might be something to try if you are still having this problem and are using the 5Ghz band on your wireless router.

    Friday, September 20, 2013 1:53 AM
  • This worked for me.. Using Juniper Client on Windows 8 Pro to connect to remote Win7 PC 
    Thursday, October 24, 2013 12:07 PM
  • I found the "UDP Checksum Offload" feature in the Advanced settings of my Local Area Connection (a Realtek adapter) was set to "Rx & Tx Enabled". By switching this to "Disabled", my RDP sessions from my Windows 8 client to Windows Server 2012 stopped experiencing the connection drops, black screens, and lack of screen updates.
    Thursday, October 24, 2013 3:46 PM
  • Just want to see that after more than one year and the Windows 8.1 release, this issue hasn't been solved :-(

    Like everyone here I've tried many things and none solve the problem.

    Clearly having a networked printer is at play for many but even though in my case I have one, when I take my laptop to my office, then I experienced no drops whatsoever. The difference between the two sitations:

    1) At home: Printer is on/off (doesn't matter) and I connect to my office computer via a SSH tunnel

    2) At work: Printer is obviously not present and I connect to my office computer directly as I'm on the same network

    Hopefully someone from Microsoft will finally read that post and contact a few people here that have the problem to figure out what could be wrong in this new release of the Remote Desktop Client. It is really too bad that it is impossible to try the Windows 7 or earlier version of the client to compare things.


    http://www.eiffel.com

    Saturday, November 02, 2013 6:28 AM
  • Here is what I have discovered:

    I have done the items above

    1. turn off "Remote Differential Compression API Support"

    2. turn off "Windows Location Provider"

    3. Edit the registry to disable UDP as above.

    None worked. Downloaded Netmon and traced the network traffic. AH-HA!

    Seems my Windows 8.1 PC would send out an ARP request for my network printer (that was off) it took about 6 seconds to complete (or time out?) before any more network traffic would go.

    Is the ARP request something that is single threaded somehow allowing the RDP session to time out?

    I AM NOT a network professional (I just play one on TV).
    Tuesday, November 12, 2013 4:50 AM
  • A hotfix came out on 11/13 that appears to fix this issue for me. The KB number is 2897602.


    Tuesday, November 19, 2013 4:11 PM
  • Thanks for finding this out. I'm putting the link to make it easy: http://support.microsoft.com/kb/2897602

    I'll test this in the next couple of days and if I have no drops whatsover I'll mark this as the answer.

    Update 12/3/2013: It has been more than 10 days and not a single disconnect. I'll mark this as the solution for my particular setup.


    http://www.eiffel.com


    • Marked as answer by manus_eiffel Friday, November 22, 2013 4:14 AM
    • Edited by manus_eiffel Tuesday, December 03, 2013 4:54 PM
    Tuesday, November 19, 2013 5:45 PM
  • Wow... I just happened to come back to this thread today on the oft chance I thought maybe someone has found a fix... weird. Will reply with results from this hotfix.
    Tuesday, November 19, 2013 6:32 PM
  • Still getting dropped in my situation after hotfix.
    Tuesday, November 19, 2013 8:03 PM
  • After lots of frustration I was so happy to find this thread!  I ran the Hotfix and no more issues with my connection dropping.  However - now my Canon wireless printer doesn't work.  Has anyone had success getting both to work at the same time?
    Wednesday, January 01, 2014 11:45 PM
  • I too have applied the Hotfix and it seems to have fixed the issue with my system.

    My HP printer still works while using Juniper/RDP.

    I'm good.

    Friday, January 03, 2014 8:20 PM
  • Thank you, 

    Following the steps above resolved the problem for me.

    Wednesday, January 15, 2014 3:14 AM
  • I also applied the fix and it hasn't resolved the issue. The issues started when I had to switch to a different NIC, rdp to server 2012 drops every 40-60 seconds. Sigh.
    <menu id="menuid" type="context"><menuitem icon="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQBAMAAADt3eJSAAAAMFBMVEX////4+Pf38eb/5br/257Z3OHX1tX/wmW4u7v/rTCSkpJzc3NBQUEcHBwODg4AAAB/HwUdAAAAAXRSTlMAQObYZgAAAAlwSFlzAAAOwwAADsMBx2+oZAAAAItJREFUeJxjYWDoCeLbGs/AwsBRzMAQBWKIMuxkt1d4wMLAf8ZD9pHDAhaGK2YRYQwMQCnG1c4CYAZX8J39gSBGy7/WvWCGwv8FeWApBsakRIaAhSwMBwK6BRmUy1gYZjcIbVfvf8TicidTtzrsMwPL/pK/69yVpfJZ/vaUpTHcygXq+tuu9O8BAwMA0z4ovkizRgYAAAAASUVORK5CYII%3D" label="Search Amazon.com"></menuitem></menu>
    Saturday, March 29, 2014 4:29 AM
  • I am having the same problem when logged into RWW into server computer have done a lot of testing.

    Seems to be in my case between windows 7 64 bit ie 11.0.9600.17041 logged into RWW on server 2012 essentials and remote desktop to server. Every 2.13 minutes it will disconnect and reconnect same on all three sony viao laptops using the same OS, other machines tested were windows 7 32 bit desktops from the same internet connections.

    1. windows 7 32-bit from TWC New York City to OOL Long Island solid as a rock.

    2. Windows 7 32-bit from OOL Long Island to OOL Long Island solid as a rock.

         Windows 7 64-bit same location as above (2) Reconnects every 2.13 min most software is the same inc anti-virus.

    3. seems to be Windows 7 64-bit on lap tops

    all three locations I tested have network printers that does not seem to play a part.

    It is very distracting.

    • Proposed as answer by Mon789 Tuesday, June 10, 2014 12:57 PM
    Sunday, April 27, 2014 2:47 PM
  • I ran into a similar issue on a Win7 machine running off bootcamp on a Mac Mini. The PC will no longer update Windows, so installing a patch fix is not an option. I was able to workaround this issue by disabling all shared resources via RDP: clipboard, printers, drives, audio.
    Monday, May 16, 2016 5:17 AM
  • I realize this is an old chain, but I had a very recent issue with RDP from our network (a win 8 box) to 2 servers in our DMZ.  RDP would cut out every 40 to 60 seconds making it just about unusable.  Each time you get the reconnecting screen flashing.  Then you can use it for a few more seconds until it cuts out again.  In the Security log we would see a log off event for eventid 4634.  The odd thing would be that the Logon Type would show 3 rather than 10.  If we moved the machine the same subnet then no issue.  Anyway the problem turned out to be something on our SonicWall App Control feature.  For some reason on Windows 8/2012 versions of RDP, it was somehow intercepting the traffic.  Adding exclusions appear to resolve the problem.  The very strange thing is we have other web servers (same OS, different patch level) that are in the DMZ which we not excluded in Sonicwall but work fine.  So for many issuing RDP drops, it could very well be AV/IPS systems. 
    Friday, December 09, 2016 2:16 PM