none
Active Directory Users and Computers MMC Snap-In

    Question

  • Has anyone else got Active Directory Users and Computers MMC Snap-In to work in Windows 7 Beta?  Has there been any changes made to Active Directory Administration?  I have taken the following steps with no luck.

    Action: Download RSAT for Windows 7 Beta ( http://www.microsoft.com/downloads/details.aspx?FamilyID=82516c35-c7dc-4652-b2ea-2df99ea83dbb&displaylang=en)
    Result: Installed fine but no Users and Computers Snap-In

    Action: Install Windows 2003 Adminpak.msi and manually registered all .DLL files.
    Result: Active Directory items listed but when added give error
    (MMC cannot initialize the snap-in.
    Name: <unknown>
    CLSID: {E355E538-1C2E-11D0-8C37-00C04FD8FE93}

      Thanks!

    Monday, January 26, 2009 6:17 PM

Answers

All replies

  • I'm getting the same thing.  It would be nice to test/use/learn Win 7 fulltime in my work environment but without atleast AD Users and Computers, this isn't possible. :(
    Tuesday, January 27, 2009 3:17 PM
  • Thanks for your reply.  I am using Windows 7 full time at the office and this is the only piece that does not work.  Anyone else have an idea?  Thanks!
    Tuesday, January 27, 2009 6:38 PM
  • I've tried all the suggestions I could find for getting the admin tools installed on Vista with no luck. 
    Tuesday, January 27, 2009 8:10 PM
  • We still use XP for our workstations so I have not had a need to load the Admin Pack on Vista.  I seem to remember reading that Active Directory management would be handled differently in Windows Server 2008 R2.  Maybe they are waiting to complete that piece and include it in Windows 7.  I am still very impressed with Windows 7 beta even without this functionality.  

    Wednesday, January 28, 2009 3:32 PM
  • Got it fixed! Thanks to Yukka http://www.techspot.com/vb/showthread.php?p=714749&posted=1#post714749

    First load the Windows 7 Beta Admin Tools http://www.microsoft.com/downloads/details.aspx?FamilyID=82516c35-c7dc-4652-b2ea-2df99ea83dbb&displaylang=en

    Then go to Control Panel > Programs and Features > Turn Windows features on or off.  Now select "Remote Server Admin Tools".  You have to expand each component and check the ones you want.  Once that runs you can add the in the MMC snap in.  Good luck!

    • Marked as answer by Jeremy8778 Wednesday, January 28, 2009 8:32 PM
    Wednesday, January 28, 2009 8:31 PM
  • Hi Guys,

      I logged a similar post earlier http://social.technet.microsoft.com/Forums/en-US/w7itproappcompat/thread/a0b24e31-0290-415b-8448-c367bde3e2c9

    I need to use he users & computer snapin to add computer accounts with GUIDs. I got RASAT installed & added the features but couldnt get up users & computers mmc to be able to add a computer account/guid.

     Did you install RASAT enable features & install the 2003 admin pack or is there the users & computers snapin in RASAT?

    Wednesday, January 28, 2009 9:03 PM
  • I uninstalled the 2003 Admin Tools before adding the features.  When you go to add the features you must select each component that you need under Remote Server Administration Tools.  So the path should be "Remote Server Administration Tools > Role Administration Tools > AD DS Tools > Active Directory Administration Center".  Personally I checked ALL options but I think that is the one you need.  I am able to add computer accounts from the MMC snap-in.  Hope this helps.
    Wednesday, January 28, 2009 10:18 PM
  •  
      when you create a computer acount do you get the option to enter a GUID?
    Wednesday, January 28, 2009 10:22 PM
  • No, sorry I did not read your question thoroughly.  I've never had to add a need to add a GUID when creating a computer accn.  The Beta Admin Tools now do everything for me that Server 2003 did.  If you had that option in 2003 you could try runing them together and see.
    Wednesday, January 28, 2009 11:21 PM
  •  Jeremy8778,

      Installed RSAT & added the feature for users & computer snapin. unfortunatley as you said when adding a computer account it dosent give you the option to enter a GUID line in 2003 admin tools.

     

    back to the drawing board.

    Thursday, January 29, 2009 9:10 AM
  • Hi All,

    Has there been a fix out for this yet?

    Monday, May 25, 2009 12:09 PM
  • Hi All,

    Has there been a fix out for this yet?


    Hi All,

    Just so that all is informed. I have install windows 7 rc x64 and i need the admin tools to work. 

    Let me know when there is a fix.
    Monday, May 25, 2009 12:19 PM
  • Hi,

    I got this to work SHOT GUYS!!
    Monday, May 25, 2009 2:30 PM
  • Thanks, sorted out my problem nicely :o)
    Thursday, June 18, 2009 10:52 AM
  • Thursday, August 13, 2009 1:55 PM
    Moderator
  • Hi Matt, I tried to install both of those (tried the AMD64 first, since I am running Win7 64 bit), and neither one worked. I get the error "the update is not applicable to your computer." Any thing else I can try?


    Thanks
    Friday, August 14, 2009 1:45 PM
  • Hi Matt, I tried to install both of those (tried the AMD64 first, since I am running Win7 64 bit), and neither one worked. I get the error "the update is not applicable to your computer." Any thing else I can try?


    Thanks

    Same here, anyone have any idea?

    Thanks
    Monday, September 14, 2009 11:41 PM
  • 64 bit seems to be the problem. Looks like its a 32 bit tool. I'm running across a lot of tools that don't work for 64 bit win7. this is the first Microsoft tool though. Even Cisco doesn't like Win7 x64. Oh well.
    Wednesday, November 11, 2009 9:14 PM
  • Thank you!! Works great with the non-beta version of Remote Server Tools linked below.
    Tuesday, June 08, 2010 9:26 PM
  • i am on Windows 7 64bit

    after trying to install the RSAT i got the next error ( the update is not applicable to your computer).

    any suggestions?

    thank you

    Monday, December 20, 2010 9:50 AM
  • 1.)  Download Remote Server Administration Tools for Windows 7 with Service Pack 1 (SP1)
    http://www.microsoft.com/en-us/download/details.aspx?id=7887  <<<<  --- download  Windows6.1-KB958830-x86-RefreshPkg.msu  version

    2.)  Install RSAT

    3.)  Click Start, click Control Panel, and then click Programs.  In the Programs and Features area, click Turn Windows features on or off.

    4.)  Check Role Administration Tools >> AD DS Tools >> Active Directory Administrative Center


    Add AD Snap-in to MMC
    1.)  Go to Run
    2.)  Type MMC then enter
    3.)  Click File >>>  Add/Remove Snap-in
    4.)  Select Active Directory Users and Computers
    5.)  Click ADD
    6.)  Click OK

    Wednesday, May 23, 2012 2:52 PM