none
Windows 7 Professional using a Windows 2003 print server to map printers RRS feed

  • Question

  • I am testing Win 7 in our network, I can install a network printer (HP Laserjet 3700 64bit driver) directly to the computer via TCP/IP. If I install the same driver on the 2003 R2 server (by adding the driver under sharing and additional drivers) it will not work, I get an Operation Failed with error 0x00000bcb.

    Win 7 will be useless if I cannot connect it to the network for printing using a print server.

    Thank you in advance,

    Bill
    Tuesday, December 1, 2009 1:46 PM

Answers

  • Firstly please make sure that the printer is properly shared. Then you need follow the steps below to install the printer.

    1. Click Start, click Control Panel and double click Devices and Printers.
    2. Click Add a Printer.
    3. Select "Add a local printer".
    4. Select "Create a new port". Choose "Local Port" as the type of the port.

    5. In the box "Enter a port name", type the address as the following format.

    \\[IP address of the host computer]\[The Share Name of the printer]

    Then click Next.

    6. Follow the instruction to finish the installation. During installing, choose the correct driver in the driver list.

    If the issue persists, please let us know if the computers are in domain or a workgroup. If they are not in domain, please follow the steps below to change the NTLM authentication level.

    Network security: LAN Manager authentication level

    To change the policy, open gpedit.msc from Start Search box, locate to:

    Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\Network security: LAN Manager authentication level

    Change the value to “Send LM & NTLM - use NTLMv2 session security if negotiated”.

    If your system is Windows 7 Home Premium, you may change it from Registry.

    1. Launch regedit from Start Search box.
    2. Find the following branch.
     
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

    3. Create a DWORD key under Lsa and set:

    Name: LmCompatibilityLevel
    Value: 1

    4. Restart.

    If the issue persists, please let us know if file sharing works properly.


    Arthur Xie - MSFT
    Wednesday, December 2, 2009 8:58 AM
    Moderator

All replies

  • Bill,

    Check if the windows spooler service is running.
    Open an administrative command prompt and type the following command.
    Net start spooler

    Does it says that the spooler service is already started?
    If the spooler service is not started you can try agian to install the print driver.

    P.S.: You can better ask this question in a windows 2003 R2 forum.
    Those forums have more experts in windows 2003 R2 server problems.

    Kind Regards
    DFT
    IM me - TWiTTer: @DFTER
    Tuesday, December 1, 2009 3:14 PM
  • Firstly please make sure that the printer is properly shared. Then you need follow the steps below to install the printer.

    1. Click Start, click Control Panel and double click Devices and Printers.
    2. Click Add a Printer.
    3. Select "Add a local printer".
    4. Select "Create a new port". Choose "Local Port" as the type of the port.

    5. In the box "Enter a port name", type the address as the following format.

    \\[IP address of the host computer]\[The Share Name of the printer]

    Then click Next.

    6. Follow the instruction to finish the installation. During installing, choose the correct driver in the driver list.

    If the issue persists, please let us know if the computers are in domain or a workgroup. If they are not in domain, please follow the steps below to change the NTLM authentication level.

    Network security: LAN Manager authentication level

    To change the policy, open gpedit.msc from Start Search box, locate to:

    Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\Network security: LAN Manager authentication level

    Change the value to “Send LM & NTLM - use NTLMv2 session security if negotiated”.

    If your system is Windows 7 Home Premium, you may change it from Registry.

    1. Launch regedit from Start Search box.
    2. Find the following branch.
     
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

    3. Create a DWORD key under Lsa and set:

    Name: LmCompatibilityLevel
    Value: 1

    4. Restart.

    If the issue persists, please let us know if file sharing works properly.


    Arthur Xie - MSFT
    Wednesday, December 2, 2009 8:58 AM
    Moderator

  • I also received this error when trying add a printer to my 64-bit Windows 7 PC. The printer is shared on my 2003 Server Print Server(32-bit).
    To resolve this issue I had to remove the other printer on the Win7 PC that was using a similar driver(in this case the HP Universal Print Driver), then delete the driver, by going into server properties(click on a printer and you will see it on the toolbar) on the Windows 7 PC.

    Thanks,
    Joey
    Monday, January 25, 2010 1:33 AM
  • it is already set to "“Send LM & NTLM - use NTLMv2 session security if negotiated" and the issue is still happening
    Monday, August 23, 2010 1:34 PM
  • I have the same problem. One month back, the printer (HP DeskJet D4260) was ready and OK. Now it stop printing and cannot be added.

    The printer is installed on PC with WinXP Pro a nd I want to install it on Win server 2008. When system installing driver, it stop with error 0x00000bcb. I think that it's problem with driver. but i know that it was OK one month back :-( I tried all, editing registry,Send LM a NTLM, reinstalling spoolsv.exe,deleting all drivers from C:\windows\system 32\spool.... and nothing help me.

    Monday, November 15, 2010 11:33 AM
  • On the print server go into the properties for the printer, then to the "Advanced" tab. Change the Print Processor to "WinPrint" and the Default data type to "RAW."
    Thursday, January 6, 2011 4:32 PM
  • SCENARIO: Print Server Windows Server 2003 R2, station Windows 7 with 64-bit and HP LaserJet P4015n


    PROBLEM: Windows 7 64-bit stations can not add HP LaserJet P4015n from print server Windows Server 2003 R2 showing the error 0x000007e

    SOLUTION: In the print server, delete the registry key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Printers\[PrinterName]\CopyFiles\BIDI"

    CAUSE: The station of user was trying to access a path that the 64-bit operating systems do not recognize as valid: "spool\drivers\w32x86\3". This path is set in the printer settings on the Print Server.

    • Proposed as answer by Gareth_Hiatt Thursday, January 30, 2014 7:26 PM
    Wednesday, April 6, 2011 11:41 AM
  • I found that I had a Web Ex printer installed locally that used the ( HP Universal Print Driver) that was causing my issue. I removed it and then I was able to install the driver correctly. Now my printer is install and working.
    • Proposed as answer by JustinRush Friday, May 27, 2011 1:22 PM
    Thursday, May 5, 2011 7:02 PM
  • I've solved by updating the drivers
    Thursday, November 8, 2012 10:40 AM
  • This solved my similar issue. Thanks much!
    Thursday, January 30, 2014 7:26 PM
  • This worked for me!  I simply removed all of the existing printers...and boom...was able to connect to the printers I was previously unable to connect to.

    Thanks!

    Thursday, June 4, 2015 7:01 PM