none
ATI Radeon 9600 series

    Question

  • Hello,

    I just instelled Windows 7 and I think its great. Although its not perfect yet, since I can't find any drivers for ATI Radeon 9600. I have tried the drivers for OP: XP and Vista, but they haven't worked properly.

    I've already read some of the related threads:
    http://social.technet.microsoft.com/Forums/en-US/w7itprohardware/thread/db5d38b8-6771-465b-a64f-2cb368cb304e   etc.
    Sadly, the links provided haven't fixed my problem.

    The device description for my graphics card:
    ATI Radeon 9600 (RV350)

    I am really looking forward to your reply since I don't want to do a format and install the older XP version.
    Tõnis
    Sunday, May 31, 2009 8:25 AM

Answers

  • ,
    a) I forced Windows to do another search for updates and it said that everything is up to date.

    b) Unfortunately the .cab file couldn't be extracted by even the newest WinZip.
    It gave the error:

    "This archive has an invalid directory, is empty, or contains only a partial file continued from a previous volume. If it is a multi-volume archive, open the previous volume"

    You can use several freeware or trial utilitie to extract cab files, winrar, universal extractor to name a couple, just explorer may have trouble with the long address, filename combo, shorten the name before you extract...
    Wednesday, June 03, 2009 7:08 PM

All replies

  • As I understand you, Windows Update did not find the drivers for you during the installation process. That is strange because there ARE drivers for the Radeon 9600 (8.561.4) on the update site (http://catalog.update.microsoft.com/v7/site/Search.aspx?q=ati%20radeon%209600).
    You could a) force Windows to do another search for driver updates (be it from Control Panel -> Windows Update, be it from Device Manager). If that doesn't work, you can b) manually download the drivers from the catalog site. I'm a bit unsure how to install them because their format changed lately from a former executable (that was easy) to a compressed file (*.cab). I could check that but I'm unwilling to experiment with my fine running system. You could just extract the *.cab and point Windows (Device Manager -> Graphics Card -> Update Driver) to the correspondent folder but the *.cab contains no "Setup.exe" to do that for you..
    Mob. AMD64 3000+, 1 G RAM, Mob. ATIRadeon9700, 20x DVDRW, C:XPSP3 (55G),D:WIN7 (25G),F:DATA (250G)
    Sunday, May 31, 2009 8:46 AM
  • Hello Sanmartin,

    a) I forced Windows to do another search for updates and it said that everything is up to date.

    b) Unfortunately the .cab file couldn't be extracted by even the newest WinZip.
    It gave the error:

    "This archive has an invalid directory, is empty, or contains only a partial file continued from a previous volume. If it is a multi-volume archive, open the previous volume"
    Sunday, May 31, 2009 10:08 AM
  • I just realized that the drivers are THERE, but they just aren't working properly.
    When I tried to enable OpenGl video mode, then the program crashed.


    The error which I recieved said:
    "The specified video mode is not supported".
    Sunday, May 31, 2009 10:29 AM
  • I believe I heard from someone else that all these beta (pre-release) drivers from ATI have problems with OpenGL.
    Mob. AMD64 3000+, 1 G RAM, Mob. ATIRadeon9700, 20x DVDRW, C:XPSP3 (55G),D:WIN7 (25G),F:DATA (250G)
    Sunday, May 31, 2009 11:00 AM
  • ,
    a) I forced Windows to do another search for updates and it said that everything is up to date.

    b) Unfortunately the .cab file couldn't be extracted by even the newest WinZip.
    It gave the error:

    "This archive has an invalid directory, is empty, or contains only a partial file continued from a previous volume. If it is a multi-volume archive, open the previous volume"

    You can use several freeware or trial utilitie to extract cab files, winrar, universal extractor to name a couple, just explorer may have trouble with the long address, filename combo, shorten the name before you extract...
    Wednesday, June 03, 2009 7:08 PM