none
Drive isn`t accessible, Permission denied

    Question

  • Hello!
    I have w7 7100 build about 2 week, and some days ago i`ve got "Permission denied" when i try open folder on my CF-card through USB-card reader. Firstly I think it was NTFS permission on flash (formatted with NTFS in winXP), but it happen even FAT32 formatted flash.. In win-explorer I see "Removable device G:" instead of "Flash512", and i cannot change any permission on Flash.. In win-xp same flash card work fine. May be there some politics on whole USB-device? Comp mostly does not connected to Internet, and havent LAN connections, so haven`t GPO..

    Thank`s
    Legat
    Wednesday, July 22, 2009 1:12 PM

Answers

  • Hi all! 

    I partially solved my problem. "Meine Dumkopf". It was because NOD4.0 "blocked acces to usb devices" ticked. Untick - and I granted access to device. It is strange but in system logs or NOD log I haven`t any notes about that.

    With best wishes!


    Legat
    • Marked as answer by Asoik Monday, July 27, 2009 5:32 AM
    Monday, July 27, 2009 5:32 AM

All replies

  • Hi,

     

    You mentioned “it happen even FAT32 formatted flash”, please let me know whether all flash drives formatted in Windows XP? If so, I also suspect this is a permission issue. The problem is that the ownership of those files/folders belongs to the user account on the XP system. Please try to take ownership of files/folders to test the issue.

     

    1. Please navigate to the target file/folder.

    2. Right-click on the file/folder and choose Properties.

    3. Click the "Security" tab and see if your current user is listed in the "Group or user names" list. If not, please click Edit-> Add button, type the name of your current user in the "Enter the object names to select " box, then click "OK" to add this group.

    4. Select the user from the list and then check the "Allow" checkbox next to "Full Control".

    5. Click the Advanced button and click the "Owner" tab. Then, press "Edit" button.

    6. Select current user from the list and check the "Replace owner on subcontainers and objects" checkbox.

    7. Click "OK" to save changes and wait for Windows 7 to transfer the ownership of all the objects on the partition.

    8. Click OK again to save changes and exit the Properties window.

    9. Test the issue again.

     

    Does it work?

     

    Thanks.

     

    • Proposed as answer by Jen Mehrer Thursday, July 23, 2009 7:47 PM
    Thursday, July 23, 2009 9:01 AM
  • Hello Robinson,
    I was having an issue with the C:/Documents and Settings folder having a padlock next to it and getting an error that the "Location was not Available" Access Denied.  I followed your steps and I am now able to get into that folder without an errors.
    Thanks for providing the steps!

    Best regards,

    Jen Mehrer
    Partner Online Technical Community
    -----------------------------------------------------------------------------------------
    We hope you get value from our new forums platform! Tell us what you think:
    http://social.microsoft.com/Forums/en-US/partnerfdbk/threads
    ------------------------------------------------------------------------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights
    Thursday, July 23, 2009 7:47 PM
  • Thanks for attention, Robinson!

    I know problem with NTFS ownership in "other" systems than native, and it was firstly that i try. :) But.. I`ve select drive from disk management/properties of USB drive/permission/ take ownership for admin group (where is myself)  with full grants and got "Acces denied". I cannot see any user on tab "security" and cannot change any of security properties. Yes, all flash drive initially formatted in XP, and currently works fine, except W7. But i don`t understand what kind of security applly on fat32 drives? It possible?

    If w7 booting with already inserted  USBcard i can see its  volume name, but if try to remove/insert the same card on live w7 (not matter NTFS or FAT32) i see only "Removable device". Thus i think permission for drive (ie card reader), not for card applied?

    In XP something like this may be achieved through regedit and editing "Start" parameter

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\USBSTOR]
    "Type"=dword:00000001
    "Start"=dword:00000003

    Legat
    Friday, July 24, 2009 7:18 AM
  • Hi all! 

    I partially solved my problem. "Meine Dumkopf". It was because NOD4.0 "blocked acces to usb devices" ticked. Untick - and I granted access to device. It is strange but in system logs or NOD log I haven`t any notes about that.

    With best wishes!


    Legat
    • Marked as answer by Asoik Monday, July 27, 2009 5:32 AM
    Monday, July 27, 2009 5:32 AM
  • Hi all!

    I partially solved my problem. "Meine Dumkopf". It was because NOD4.0 "blocked acces to usb devices" ticked. Untick - and I granted access to device. It is strange but in system logs or NOD log I haven`t any notes about that.

    With best thanks!

     


    Legat
    Monday, July 27, 2009 5:55 AM