locked
Cisco AnyConnect VPN and Windows 8

    Question

  • I've tried and tried to make the AnyConnect client v2.5.3054 work on Windows 8 but I cannot seem to get it to get past "Checking for product updates...". It will initially connect. It will shows the correct groups. I can log in with an "incorrect" password and it will fail. When I log in with the correct password it will get to checking for updates and fail with the following error.

    AnyConnect was not able to establish a connection to the specified secure gateway. Please try connecting again.


    Thanks,
    Bobby Cannon
    BobbyCannon.com


    • Edited by Bobby J Cannon Thursday, April 19, 2012 2:51 AM added version
    Thursday, April 19, 2012 2:47 AM

Answers

  • OK, I finally got it working. I installed and used the v3 software but the server used a self signed certificate. Here what you have to do to get it to work. 

    1. Start IE running as "Administrator".
    2. Visit the site of the VPN.
    3. Click the red X certificate button on the address bar.
    4. Click the install certificate button.
    5. Install the certificate to the "Trusted Root Certificate Authorities".

    NOTE: Be aware that if the certificate is assigned to an IP that you must use the IP rather than the DNS name.

    Everything started working once I added the certificate to trusted and used the IP rather than the DNS name.


    Thanks,
    Bobby Cannon
    BobbyCannon.com

    Friday, April 20, 2012 6:33 PM

All replies

  • I asked @AnyConnect and they suggested that I should be using the v3 client on Windows 8 CP. Now I just gotta get me a copy.

    Thanks,
    Bobby Cannon
    BobbyCannon.com

    Thursday, April 19, 2012 1:47 PM
  • I asked @AnyConnect and they suggested that I should be using the v3 client on Windows 8 CP. Now I just gotta get me a copy.

    Thanks,
    Bobby Cannon
    BobbyCannon.com

    Well I just got the v3 software and it's still doesn't work. It may have something to do with our hosted server settings? Not sure yet. The v3 software works great on W7. Which makes me think that it should also work on W8.

    Thanks,
    Bobby Cannon
    BobbyCannon.com


    Friday, April 20, 2012 6:08 PM
  • OK, I finally got it working. I installed and used the v3 software but the server used a self signed certificate. Here what you have to do to get it to work. 

    1. Start IE running as "Administrator".
    2. Visit the site of the VPN.
    3. Click the red X certificate button on the address bar.
    4. Click the install certificate button.
    5. Install the certificate to the "Trusted Root Certificate Authorities".

    NOTE: Be aware that if the certificate is assigned to an IP that you must use the IP rather than the DNS name.

    Everything started working once I added the certificate to trusted and used the IP rather than the DNS name.


    Thanks,
    Bobby Cannon
    BobbyCannon.com

    Friday, April 20, 2012 6:33 PM
  • Bobby,

    I've searched the web and your problem seems most similar to mine.  I (like many others) have installed Win 8 (RP).  I cannot get Cisco AnyConnect v3 to work.

    When I try to connect I get the exact same story as you.  I have tried your solution (the certificates have been added to local and user stores with IP and DNS.  However each time I try VPN I still get the same errors.

    One quick question: after installing the certificates, when I return to the web page should I still get the Certificate error?  Seems like I shouldn't if all goes well, but I still get the error, so maybe I have not installed them correctly.

    Any ideas?

    Thanks,

    Sam

    Friday, June 15, 2012 1:40 AM
  • What store did you install the certificate in? You should install it into the "Trusted Root Certification Authorities". Then use the same IP or DNS name that the certificate is "issued to".

    Thanks,
    Bobby Cannon
    BobbyCannon.com

    Friday, June 15, 2012 12:52 PM
  • Yes, that is what I had done.  Apparently for our system there was an additional step, installing a RootCA as well.  Thanks to your tip of pointing me toward certificates, I was able to continue troubleshooting.  Now it is fixed.

    Thanks for your time and support,

    Sam

    Friday, June 15, 2012 3:01 PM
  • Where did you get the v3 software from?  We use Anyconnect here at work...would love to have VPN access again, rather than having to go through Citrix apps

    Thanks
    john


    John Wildes | Hitachi Data Systems | Director - Microsoft Technologies | Converged Platforms

    Tuesday, June 19, 2012 10:03 PM
  • @johnwildes I contacted CISCO via Twitter. They got me a download link and I was able to get the new client.

    Thanks,
    Bobby Cannon
    BobbyCannon.com

    Tuesday, June 26, 2012 8:44 PM
  • Installing the correct certificates solved my problems as well!

    Thanks!


    F.M.


    Wednesday, July 18, 2012 8:23 AM
  • I have installed the certificates as said above, and the certificate is an ip, however I still cannot connect to my company vpn, it seems the certificate ip is a company local ip address, any solution please?
    Wednesday, August 08, 2012 12:20 PM
  • It works for me. Thanks!
    Tuesday, August 21, 2012 2:25 PM
  • Where does one find the "rootCA"?   I can't do step #2 (Visit site of VPN) as there is no site at my vpn domain.    Bigger question - why does this work FINE on Windows 7 and not at all on Windows 8?
    Monday, August 27, 2012 9:45 PM
  • Found this in a Cisco forum:

    To utilize AnyConnect for VPN on Windows 8, please use 3.0MR8 or 3.1. No special workarounds are required for these versions.

     

    Best Regards,

     

    Pete Davis

    AnyConnect Team

    Cisco Systems, Inc.

    ac-mobile-feedback@cisco.com

    https://supportforums.cisco.com/thread/2138573

    Just need to upgrade your version of anyconnect or have your company do it. 


    DJ Grijalva | MCITP: EMA 2007/2010 SPA 2010 | www.persistentcerebro.com

    Friday, August 31, 2012 9:47 PM
  • Bobby, you kick ass, thank you. I totally missed that the cert was issued to the IP...

    Now to go find the latest version to crowbar into the ASA...

    Sunday, September 02, 2012 6:37 PM
  • Great Bobby, that worked for me, for reference I had to:

    • Trust the certificate for the IP address not the host name
    • Update the displayname registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\vpnva to remove the beginning junk part of the displayname (up to the %)
    • Connect via the ip, not the host name

    Hope that helps

    Steve

    Monday, September 10, 2012 10:56 PM
  • Doing this fixed my issue, thanks.

    Update the displayname registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\vpnva to remove the beginning junk part of the displayname (up to the %)

    Tuesday, October 23, 2012 2:43 AM
  • Doing this fixed my issue, thanks.

    Update the displayname registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\vpnva to remove the beginning junk part of the displayname (up to the %)

    This worked for me as well.  I'm using version 2.5.3041 and just installed Windows 8 this morning.
    Friday, October 26, 2012 5:21 PM
  • Yesterday I've upgraded my Windows 7 to 8. Windows 8 Pro.

    Installed AnyConnect 3.0.2052 - nothing helps. :(

    Are there other ways?

    Sunday, October 28, 2012 7:28 PM
  • Doing this fixed my issue, thanks.

    Update the displayname registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\vpnva to remove the beginning junk part of the displayname (up to the %)

    This fixed it for me too ... Thanks!
    Wednesday, November 14, 2012 8:13 AM
  • I have updated the displayname registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\vpnva to remove the beginning junk part of the displayname (up to the %). I have installed the certificate in the trusted root certificates.  I am unable to download Anyconnect version 3.0 or 3.1 & I am still receiving error message "Unable to establish VPN" error message on Windows 8.

    Any help will be appreciated...

    thanks,

    Thursday, November 22, 2012 12:13 AM
  • It has worked now.  Once I entered our VPN site address with domain name then it worked..

    It is very strange...

    thanks..

    Thursday, November 22, 2012 12:42 AM
  • It has worked now.  Once I entered our VPN site address with domain name then it worked..

    It is very strange...

    thanks..

         This worked for me as well.  I'm using version 2.5.3041 with Windows 8.

         I think I needed flashing RED for the following warning... from Bobby Cannon
    "NOTE: Be aware that if the certificate is assigned to an IP that you must use the IP rather than the DNS name.
    Everything started working once I added the certificate to trusted and used the IP rather than the DNS name."

         For me this was true in reverse,  if the VPN certificate has a DNS name  eg webvpn.yourcompany.com  then 
         with  AnyConnect you need to use webvpn.yourcompany.com and not an IP address.

         Thanks all.

         Shane

         1) Changed the displayname   ( still not working )

         2) Installed the certificate in the "Trusted Root Certificate Authorities". (Still not working)

         3) Used AnyConnect   with  dnsname and not IP address (Worked fine)

    • Edited by shanexz Sunday, December 02, 2012 10:54 PM
    Sunday, December 02, 2012 10:09 PM
  • Our admin told me that they would not support Windows 8 remote access. Since I upgraded from 7 to 8 at home, trying to use AnyConnect 2.5.2019 doesn't work. Is there a way out of this ? Trying to download any version from Cisco site ask me for a username only admin has. Since I HAVE to use VPN to access all my files on the network, do you have a way out of this ? Thanks
    Thursday, December 20, 2012 11:51 PM
  • I found you must check that all 3 of the following have been done to get Cisco AnyConnect to work on Windows 8:

    1. Make sure to Disable the Internet Connection Sharing Service (You may not need to do this)
    a. Run: Search, Apps -> services.msc
    b. Scroll down to Internet Connection Sharing (ICS), right-click mouse over it, select Properties
    c. Set Startup type: Disabled
    d. Click OK

    2. Registry tweak
    a. Run: Search, Apps -> regedit, go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\vpnva
    b. Change "DisplayName" to exactly this (inside the quotes):
        "Cisco AnyConnect VPN Virtual Miniport Adapter for Windows x64"
    (It’ll already be there but have a bunch of junk characters before "Cisco AnyConnect VPN Virtual Miniport Adapater for Windows x64"; remove the junk characters so it only says what is above in quotes)

    2. Install certificates (You may not need to do this)
    a. Open IE as Administrator (shift+click icon or shortcut -> Run as Administrator)
    b. Go to your VPN URL, and accept the certificate warnings.
    c. Once it shows the red “x” certificate error button, click it and then click View Certificates.
    d. Click Install Certificate
    e. Specify Local machine and click Next
    f. Select "Place all certificates in the following store"
    g. Click browse and choose "Trusted Root Certificate Authorities". Click OK
    h. Click Next, click Finish
    i. Click the red “x” certificate error button again and then click View Certificates.
    j. Click Certificate Path
    k. Click the root certificate which should be at the very top of the list and click view certificate
    l. Click Install Certificate
    m. Specify Local machine and click Next
    n. Select "Place all certificates in the following store"
    o. Click browse and choose "Trusted Root Certificate Authorities". Click OK
    p. Click Next, click Finish

    • Proposed as answer by hbwong Wednesday, January 02, 2013 8:06 PM
    Wednesday, January 02, 2013 8:05 PM
  • I can't thank you enough for posting those steps.  I didn't need the step for installing certificates, but I did perform the first two and it worked!
    Friday, January 04, 2013 2:48 PM
  • Thank you all of you guys! By doing the regedit thing now i have my anyconnect vpn working in w8. I DID NOT have to do the followings:

    • use ip instead of domain
    • install de certificates

    Kind regards,

    Sunday, January 06, 2013 10:36 PM
  • Any other suggestions? Following these steps did not fix my problem. I am still unable to connect.

    Wednesday, January 09, 2013 4:06 AM
  • Excellent! That sorted it out or me.

    Everything had been working fine for months.

    I had just installed ICS and my VPN stopped working and I had no idea why!

    Thanks!!!!

    Mark

    Monday, January 14, 2013 11:27 AM
  • If those steps don't work for you, try running the Cisco AnyConnect program as an Administrator.  I accepted the certificate in my browser, but it still wasn't allowing me to connect using the VPN through the taskbar.  When I ran the application as an Administrator, I was able to install the certificate and it resolved my issue.
    Saturday, January 19, 2013 4:20 PM
  • Sunday, January 20, 2013 7:51 AM
  • im having trouble as well. im using a surface pro. I downloaded 3.1.01065 and installed it. no solution listed here resolved the error. it stated that there wasn't a certificate available to authenticate.

    works perfectly on my win 7 laptop right next to my surface. so I contacted cisco support. so far the tech cant figure it out either.

    so for now I am stuck.

    I have to admit that I think this all has to do with enhanced windows security because my router

    s certificate is self signed and windows 8 seems to hate that.

    I also tried loading firefox and making it my default browser and then loading my cert as an exception. obviously no luck.

    if anyone has more insight feel free to reply

    thanks

    • Proposed as answer by mfranks Thursday, April 25, 2013 4:30 PM
    Thursday, February 14, 2013 4:01 AM
  • Hello All,

    I amlooking for Cisco Anyconnect software for my Nokia Lumia 620 (Windows 8) Phone.

    Please give me link to download software and procedure to install on my phone

    Really appreciated your response

    Thanks & Regards,

    Satya

    Monday, March 25, 2013 5:26 PM
  • Thank you very much for this summary of actions to take.

    This, together with the link to AnyConnect VPN V3 from Mack007  below (January 20) helped me solve the same issue.

    I was initially able to connect the VPN with the updated version but couldn't remote connect to any PC until I went through these 3 steps.

    I did step 1 at last since I had found the other 2 on other forums, and it was the final item that made it work.

    Thanks again!

    Saturday, April 06, 2013 11:49 PM
  • I finally was able to run the program successfully on my Surface Pro by starting the program in "Run As Administrator" mode - by right-clicking the icon on my Start Screen and using the IP address not the DNS name.  Also, I am using 3.1.1065 of the AnyConnect Client.  Hope this helps.
    Thursday, April 25, 2013 4:38 PM
  • It was a mix of all of the above but I did finally get it to work on Windows 8 - very much appreciate the input everyone had above.

    Thank you!

    Tuesday, April 30, 2013 7:56 PM
  • The ONLY way I got it to finally work was with version 3.1. THANKS Mack007!!!
    Monday, May 13, 2013 1:18 PM