Windows 8 limited connectivity and invalid IP address configuration


  • I am having issues with connecting to any network on Windows 8. Since the first network that I tried to connect was a WPA Enterprise wireless network, I thought the problem could be IEEE 802.11w incompatibility. I installed/uninstalled tens of Windows 7 drivers but didn't fix my problem.

    Then I created a simple ad-hoc network and tried to connect to that network. I found out that the ip address is not valid and the range is through, a range that has been reserved especially for Microsoft.  Normally this happens when a DHCP server isn't available. Due to the simplicity of the network, I figured out that it has to be something with TCP. Since with upgrades sometimes winsock or the TCP/IP stack gets corrupted. I tried to reset them, so I ran following commands:

    netsh winsock reset catalog (reset winsock entries)
    netsh int ip reset reset.log hit (reset TCP/IP stack)

    I restarted my machine and tried again, but it failed.

    I am really confused and don't know what else I can do.

    I upgraded my Windows 7 to Windows 8 Pro Build 9200. My machine is a HP Pavlion dv7 and the network cards are Intel® Centrino® Wireless-N 1030 and Realtek PCIe GBE Family Controller.

    Friday, November 16, 2012 3:29 AM


  • As I mentioned in my first post. I upgraded my Windows 7 to Windows 8 and I chose the "Keep Windows Settings Personal Files And Applications" option during the upgrade process. Everything was seamless and amazing. All applications were there and working but the network. 

    After countless hours of working on this issue and getting some help from Microsoft support, the problem remained unsolved. The Microsoft technician believes that due to the packet loss or any other unpredicted issue, the update process wasn't successful and some core elements of Windows are corrupted. I agree with the corrupted widows element part, but I think that the Upgrade procedure of Windows 8 while choosing to keep your settings and apps is not perfect yet. At least it failed for me and I don't think it is caused by packet loss, because the transmission of data is over tcp/ip and it is technically impossible to loose any packet. Second, as I followed the process of upgrade, I observed that all files were downloaded first and it went through all files to check if everything is received and uncompressed properly. Anyway, I ended up reinstalling Window8 again, but this time I only kept my personal files. After the fresh installation everything was working perfectly.

    • Marked as answer by P3dr4mP Sunday, November 18, 2012 3:35 AM
    • Edited by P3dr4mP Sunday, November 18, 2012 3:38 AM
    Sunday, November 18, 2012 3:35 AM