none
Error message trying to start Windows defender

    Question

  • Hi,
    I'm running win 7 home premium 64 bit, Avast anti-virus, malwarebytes anti malware and superantispyware but having a problem with windows defender. I noticed it was not working, although it has been in the past, so I tried to enable it but get this message:
    "This program is blocked by group policy. For more information contact your system administrator. (Error code: 0x800704ec)"
    Any help appreciated.
    • Moved by Lisa M-Microsoft Support Monday, April 19, 2010 10:46 PM (From:Windows 7 Security, Privacy, and User Accounts)
    Tuesday, April 13, 2010 5:18 AM

All replies

  • Hello Trumpy9404 – Welcome to Microsoft Answers Community.  

    I recommend you open Local Group Policy Editor (LGPE), from run
    by typing gpedit.msc and bypassing UAC. Once LGPE is open, under
    the Computer Configuration expand Administrative Templates and
    expand Windows Components and select Windows Defender and
    on the right-side you’ll see a list with settings, check those.

    I hope you find this information useful and if you need any further assistance,
    please feel free to contact me and let me know.

    I hope this information was helpful…

    Have a nice day…

    Best regards,
    Fisnik


    Itknowledge24.com
    • Proposed as answer by Dericslab Thursday, November 16, 2017 10:36 AM
    Tuesday, April 13, 2010 5:40 AM
  • Thanks for your reply,

    I type in gpedit.msc and get a page which has only libraries, homegroup, computer, custom and internet icons displayed. Have clicked everywhere searching for LGPE, comp config, admin templates etc but to no avail. Am I missing something.  I have gone into services via control panel to ensure windows defender is not disabled.

    Still lost I'm sorry
    • Proposed as answer by riggityed Thursday, June 03, 2010 10:12 PM
    Thursday, April 15, 2010 2:26 AM
  • Hi,

     

    I would like to suggest you try to disable third party antivirus program and test the issue in Clean Boot.

     

    If the issue persists, I also would like to suggest you perform the following steps to check the result.

     

    Delete All Group Policy Registry keys

    ========================

    1. Click “Start”, type “regedit.exe” (without quotation marks) into “Search” box and press Enter.

    2. Locate the following key:

     

    [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft]

     

    Right click on "Microsoft", click "Export"; please name the file as "RegBackup" (without quotation marks) and then save it to the C:\ drive as a backup.

     

    Note: In case we need to undo the modification, we can double click this RegBackup.reg file to restore the registry key.

     

    3. Highlight Microsoft and click "Delete".

    4. Please repeat the above steps for the following registry keys.

     

    [HKEY_CURRENT_USER\Software\Policies\Microsoft]

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy Objects]

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies

     

    Note: if some keys do not exist, please ignore them.

     

    3. Exit the Registry Editor.

     

    Does it work?

     

    Regards, 


    Arthur Li - MSFT
    Tuesday, April 20, 2010 1:02 AM
    Moderator
  • Hi Arthur and thanks for your input.

    I tried the clean boot method but no result.  Being a little worried about fiddling with the regedit scenario, I thought maybe delete windows defender and reinstall but it's not in control panel/programs and features.......I'm pretty sure it was there before. It is a complete mystery to me.

    Thursday, April 22, 2010 3:43 AM
  • Hi,

     

    You may try to run Services.msc, disable and restart Windows Defender service to check the issue.

     

    Regards,


    Arthur Li - MSFT
    Thursday, April 22, 2010 6:57 AM
    Moderator
  • Hi Arthur,

    Have tried that several times. I downloaded WD and tried to reinstall it but get the message that it is already installed. Hmmmm, I'm lost

    Thursday, April 22, 2010 9:48 PM
  • Hi,

     

    You cannot uninstall and reinstall Windows Defender. If you want to repair Windows Defender, I would like to suggest you perform an In-Place upgrade.

     

    In-place Upgrade

    ============

    1. Start the computer.

    2. Insert the Windows 7 DVD in the computer's DVD drive.

    3. Use one of the following procedures, as appropriate:

     

    a. If Windows automatically detects the DVD, the Install now screen appears. Click Install now.

    b. If Windows does not automatically detect the DVD, follow these steps:

       b1. Click Start, click Run, type Drive:\setup.exe, and then click OK. Note Drive is the drive letter of the computer's DVD drive.

       b2. Click Install now.

     

    4. When you reach the Which type of installation to you want? screen, click Upgrade to upgrade the current operating system to Windows 7.

     

    Regards,

     


    Arthur Li - MSFT
    Friday, April 23, 2010 1:40 AM
    Moderator
  • Hi Arthur,

    No luck,

    I went through the whole circus of "upgrading" but it's still the same. In fact now I have problems with programs and of course all updates have been lost. Think I'll do a format and clean install, seems all I can do. Thanks very much for your help anyway.

    Friday, April 23, 2010 4:21 AM
  • Hi,

     

    Just a reminder, please backup all the important files to avoid data loss before formatting and reinstalling Windows 7.

     

    Regards,


    Arthur Li - MSFT
    Monday, April 26, 2010 9:16 AM
    Moderator
  • I had the exact same problem as the original poster. The solution by Arthur_Li to delete the certain registry keys worked.
    Tuesday, April 27, 2010 7:52 PM
  • thak you so much    i did the "Delete All Group Policy Registry keys" and it worked ..  my question now is the stuff i deleated .... will it cause conflict with anything?
    Wednesday, May 19, 2010 12:54 PM
  • You should use only one antivirus at a time. Delete all the other antivirus. If you have two antivirus software, it will cause conflict with each other.
    Friday, May 21, 2010 10:44 AM
  • I have figured out to how to get windows defender to work with the error code in affect! Go to start menu, search, run, regedit.exe, hkey_local_machine\software\policies\microsoft\windows defender. Look to your right in the same window and you will see DisableAntiSpy... right click on that then left click modify make the value data zero. min the window go to control panel click windows defender it will ask to turn back on, then click it to. it will say the same error code then close the error code window and there is your windows defender!!!! You will have to leave the value data at zero though!! If that works close the regedit.exe window. I wouldnt recommend messing with anything else in the regedit un less your brave sobe carefull and always back up before you venture in any pcu operation!!

    Till next time Riggityred!

    Thursday, June 03, 2010 10:12 PM
  • Ok....so I tried this....and I do not even have windows defender in this location. I was able to search it within regedit and found it in a location with a tonne of numbers preceding it, however it doesnt mention DisableAntiSpy....any other suggestions?
    Thursday, March 01, 2012 2:56 PM
  • This solution posted by "riggityed" worked for me, nothing else did.

    Thank You very much.

    JHS


    • Edited by jhsparky Sunday, April 22, 2012 12:37 AM
    Sunday, April 22, 2012 12:37 AM
  • hello Mr Arthur_li,

    the registry policy delete method working

    thank u
    • Edited by imDHIL Tuesday, August 25, 2015 10:03 AM t
    Tuesday, August 25, 2015 10:03 AM
  • Thanks. It worked!
    Wednesday, October 07, 2015 9:41 AM
  • Delete All Group Policy Registry keys

    1. Click “Start”, type “regedit.exe” (without quotation marks) into “Search” box and press Enter.

    2. Locate the following key:

     

    [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft]

    I just had this error too with Windows 7 64bit after a junkware infection.

    I ran other fixes and scripts that didn't do anything.

    What did work was setting this registry key from 1 to 0:

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows Defender\DisableAntiSpyware

    Instant fix. I set to back to 1 and Defender wouldn't load.

    I set it to 0 then it ran okay.

    I just ended up deleting that key anyway.

    • Proposed as answer by Sikor7 Sunday, January 29, 2017 2:37 AM
    Friday, November 06, 2015 9:50 PM
  • I made an account just to say it has worked me. Yes. This is 6 years later and I hope whomever you are. You're still contributing to help solve computer problems. Thank you again.
    Thursday, January 28, 2016 4:36 AM
  • Hi there!

    Thank you so much! I fixed this now!!\

    Voted for you !


    Saturday, June 18, 2016 9:04 AM
  • Delete All Group Policy Registry keys

    1. Click “Start”, type “regedit.exe” (without quotation marks) into “Search” box and press Enter.

    2. Locate the following key:

     

    [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft]

    I just had this error too with Windows 7 64bit after a junkware infection.

    I ran other fixes and scripts that didn't do anything.

    What did work was setting this registry key from 1 to 0:

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows Defender\DisableAntiSpyware

    Instant fix. I set to back to 1 and Defender wouldn't load.

    I set it to 0 then it ran okay.

    I just ended up deleting that key anyway.


    Saturday, June 18, 2016 9:04 AM
  • Thank you very much! This fixed my problem right away.

    Sunday, December 11, 2016 8:11 PM
  • Delete All Group Policy Registry keys

    1. Click “Start”, type “regedit.exe” (without quotation marks) into “Search” box and press Enter.

    2. Locate the following key:

     

    [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft]

    I just had this error too with Windows 7 64bit after a junkware infection.

    I ran other fixes and scripts that didn't do anything.

    What did work was setting this registry key from 1 to 0:

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows Defender\DisableAntiSpyware

    Instant fix. I set to back to 1 and Defender wouldn't load.

    I set it to 0 then it ran okay.

    I just ended up deleting that key anyway.

    THIS does it!  New format from original disc did not let me run Defender.  Changed value from 1 to 0 and Defender cranked right up.  Thank you!


    Sunday, January 29, 2017 2:40 AM
  • THANKS, IT'S HELPFUL FOR ME........
    Wednesday, March 08, 2017 11:24 AM
  • tnks, it worked. appreciate.
    Saturday, March 18, 2017 11:36 PM
  • It actually works if you do exactly what he said. I had the same problem with my windows 7 pro and now I don't.

    1. press start

    2. go into all programs

    3. go to accessories

    4. click on run

    5. type in gpedit.msc

    6. Once LGPE is open, go to the Computer Configuration

    7. look for Administrative Templates and click the arrow on the left

    8. look for Windows Components and click the arrow on the left

    9. look for Windows Defenderand click it

    10.on the right-side you’ll see a list with settings

    11. it should read as follows:

    enabled

    enabled

    enabled

    disabled

    disabled

    disabled

    enabled (click advanced).

    If your settings are not set to this order, you will continue to get your error.

    • Proposed as answer by mohmd.nagy Wednesday, June 07, 2017 10:26 AM
    Wednesday, May 24, 2017 3:53 AM
  • Thanks Boss!!! It worked.

    I am happy.

    Saturday, June 03, 2017 6:13 AM
  • This worked for me, thank you
    Wednesday, June 07, 2017 10:26 AM
  • Followed the steps explicitly but got this message, "Cannot edit DisableAntiSpyware.  Error writing the value's new content."
    Wednesday, July 19, 2017 9:44 PM
  • thankyou very much.this was really helpful.worked very well for me, thanks again

    Wednesday, August 02, 2017 4:08 PM
  • You're the Man!

    Saturday, August 12, 2017 12:17 PM